GNU Image Manipulation Program

Uživatelská příručka

Právní upozornění

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled GNU Free Documentation License.


Obsah

Předmluva
1. GIMP User Manual Authors and Contributors
I. Getting Started
1. Úvod
1. Vítá vás GIMP
1.1. Autoři
1.2. Systém nápovědy pro GIMP
1.3. Funkce a vlastnosti
2. What's new in GIMP 2.10.18?
2. Fire up GIMP
1. Použití GIMP
1.1. Známé platformy
1.2. Jazykové verze
1.3. Parametry na příkazové řádce
2. První spuštění Gimpu
2.1. Konečně…
3. First Steps with Wilber
1. Základní myšlenky Gimpu
2. Hlavní okna GIMPu
2.1. Panel nástrojů
2.2. Okno obrázku
2.3. Dokování dialogů
3. Undoing
3.1. Nevratné operace
4. Common Tasks
4.1. Intention
4.2. Change the Size of an Image for the screen
4.3. Change the Size of an Image for print
4.4. Compressing Images
4.5. Crop An Image
4.6. Find Info About Your Image
4.7. Change the Mode
4.8. Flip An Image
4.9. Rotate An Image
4.10. Separating an Object From Its Background
5. How to Draw Straight Lines
5.1. Intention
5.2. Příklady
4. What to do if you are stuck
1. Introduction
2. Obvyklé případy nekomunikativnosti GIMPu
2.1. Existuje plovoucí výběr
2.2. Výběr je skrytý
2.3. You are acting outside the selection
2.4. Aktivní kreslící plocha není viditelná
2.5. Aktivní kreslící plocha je průhledná
2.6. Snažíte se pracovat mimo vrstvu
2.7. You are trying to act on a layer group
2.8. The image is in indexed color mode.
2.9. No visible effect when trying to use a brush, eraser or other tool
2.10. Eraser and brushes no longer work
2.11. Eraser does not make area transparent
2.12. Unexpected colors when trying to use a brush or eraser
3. How to fix missing windows and dialogs
3.1. All tool windows are missing
3.2. Tool options dialog is missing
3.3. Some of the tool icons are missing
II. Ze zelenáče profesionálem
5. Getting Images into GIMP
1. Typy obrázků
2. Creating new Files
3. Otevírání souborů
3.1. Otevřít soubor
3.2. Otevřít umístění
3.3. Otevřít nedávný
3.4. Using External Programs
3.5. File Manager
3.6. Drag and Drop
3.7. Copy and Paste
3.8. Image Browser
6. Getting Images out of GIMP
1. Files
1.1. Save / Export Images
1.2. File Formats
2. Příprava obrázků pro web
2.1. Images with an Optimal Size/Quality Ratio
2.2. Vyšší komprese obrázků
2.3. Saving Images with Transparency
7. Painting with GIMP
1. Výběr
1.1. In GIMP, you can feather the edges of a selection. Brushes can also have feathered edges.
1.2. Making a Selection Partially Transparent
2. Creating and Using Selections
2.1. Moving a Selection
2.2. Adding or subtracting selections
3. The QuickMask
3.1. Overview
3.2. Vlastnosti
4. Using QuickMask Mode
5. Cesty
5.1. Path Creation
5.2. Path Properties
5.3. Paths and Selections
5.4. Transformace cest
5.5. Vykreslení cesty
5.6. Paths and Text
5.7. Paths and SVG files
6. Brushes
7. Přidávání nových stop
8. GIH dialog
9. Changing brush size
9.1. How to change the size of a brush
9.2. Creating a brush quickly
10. Přechody
11. Patterns
12. Palety
12.1. Mapa barev
13. Presets
14. Drawing Simple Objects
14.1. Drawing a Straight Line
14.2. Creating a Basic Shape
8. Combining Images
1. Introduction to Layers
1.1. Layer Properties
2. Režim
3. Vytváření nových vrstev
4. Layer Groups
9. Text Management
1. Text Management
1.1. Text Area
1.2. Managing Text Layer
1.3. Text Toolbox
1.4. Text Context Menu
2. Nástroj text
2.1. Embellishing Text
2.2. Adding Fonts
2.3. Font Problems
10. Enhancing Photographs
1. Práce s digitálními fotografiemi
1.1. Introduction
1.2. Vylepšení kompozice
1.3. Vylepšení barev
1.4. Úprava ostrosti
1.5. Odstranění nečistot
1.6. Tisk fotografií
11. Color Management with GIMP
1. Color Management in GIMP
1.1. Problems of a non Color Managed Workflow
1.2. Introduction to a Color Managed Workflow
12. Enrich my GIMP
1. Předvolby
1.1. Introduction
1.2. System Resources
1.3. Relative colorimetric
1.4. Image Import and Export
1.5. Tool Options
1.6. Nový obrázek
1.7. Výchozí mřížka obrázku
1.8. Rozhraní
1.9. Téma
1.10. Icon Theme
1.11. Toolbox
1.12. Dialog Defaults
1.13. Systém nápovědy
1.14. Display
1.15. Správa oken
1.16. Image Windows
1.17. Vzhled okna obrázku
1.18. Formát titulku a stavové lišty obrázku
1.19. Image Window Snapping Behavior
1.20. Vstupní zařízení
1.21. Vstupní ovladače
1.22. Adresáře
1.23. Adresáře s daty
2. Mřížka a vodítka
2.1. Mřížka obrázku
2.2. Guides
3. Vykreslení mřížky
4. Jak nastavit vyrovnávací paměť dlaždic
5. Creating Shortcuts to Menu Functions
6. Customize Splash-Screen
13. Skriptování
1. Plugins
1.1. Introduction
1.2. Používání zásuvných modulů
1.3. Instalace nových zásuvných modulů
1.4. Psaní vlastních zásuvných modulů
2. Používání Script-Fu skriptů
2.1. Script-Fu?
2.2. Installing Script-Fu scripts
2.3. Do's and Don'ts
2.4. Different Kinds Of Script-Fus
2.5. Image-Dependent Scripts
3. Zasvěcení do Script-Fu
3.1. První krůčky s jazykem Scheme
3.2. Proměnné a funkce
3.3. Seznamy, seznamy a zase seznamy
3.4. Váš první Script-Fu skript
3.5. Vytvoření střev skriptu
3.6. Rozšíření skriptu Text Box
3.7. Your script and its working
III. Popis funkcí GIMPu
14. Tools
1. Panel nástrojů
1.1. Introduction
1.2. Tool Icons
1.3. Oblast barev a indikační oblast
1.4. Tool Options
2. Nástroje pro výběr
2.1. Common Features
2.2. Rectangle Selection
2.3. Nástroj výběr eliptických oblastí
2.4. Free Selection (Lasso)
2.5. Přibližný výběr (Kouzelná hůlka)
2.6. Výběr podle barvy
2.7. Intelligent Scissors
2.8. Výběr popředí
3. Paint Tools
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. Plechovka
3.5. Gradient
3.6. Tužka
3.7. Nástroj Štětec
3.8. MyPaint Brush
3.9. Guma
3.10. Rozprašovač
3.11. Nástroj Inkoust
3.12. Nástroj Klonovat
3.13. Léčení
3.14. Perspektivní klonování
3.15. Blur/Sharpen
3.16. Rozmazání
3.17. Zesvětlení / Ztmavení
4. Transform Tools
4.1. Common Features
4.2. Zarovnat
4.3. Nástroj Přesun
4.4. Nástroj Ořez
4.5. Rotate
4.6. Škála
4.7. Naklonit
4.8. Perspektiva
4.9. 3D Transform
4.10. Unified Transform
4.11. Handle Transform
4.12. Flip
4.13. The Cage Tool
4.14. Warp Transform
5. Other
5.1. Overview
5.2. Cesty
5.3. Barevná pipeta
5.4. Zoom
5.5. Nástroj Měřidlo
5.6. Nástroj text
5.7. Operace GEGL
15. Dialogy
1. Úvod do dialogů
2. Image Structure Related Dialogs
2.1. Dialog vrstvy
2.2. Dialog Kanály
2.3. Dialog Cesty
2.4. Dialog Mapa barev
2.5. Histogram Dialog
2.6. Dialog Navigace
2.7. Dialog Historie vracení
3. Image-content Related Dialogs
3.1. FG/BG Color Dialog
3.2. Dialog Stopy
3.3. Dialog Vzorky
3.4. Dialog Přechody
3.5. Palety
3.6. Tagging
3.7. Dialog Písma
4. Image Management Related Dialogs
4.1. Dialog Buffery
4.2. Dialog obrázky
4.3. Dialog Historie dokumentů
4.4. Šablony
5. Miscellaneous Dialogs
5.1. Tool Presets Dialog
5.2. Tool Preset Editor
5.3. Device Status Dialog
5.4. Chybová konzole
5.5. Dashboard
5.6. Save File
5.7. Exportovat soubor
5.8. Sample Points Dialog
5.9. Pointer Dialog
5.10. Symmetry Painting dialog
16. Nabídky
1. Introduction to Menus
1.1. The Image Menu Bar
1.2. Context Menus
1.3. Tear-off menus
1.4. Tab menus
2. Soubor
2.1. Overview
2.2. New…
2.3. Vytvořit
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Otevřít nedávný
2.8. Uložit
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export… and Overwrite…
2.13. Export As…
2.14. Create Template…
2.15. Vytisknout
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Zavřít
2.20. Zavřít
2.21. Ukončit
3. Upravit
3.1. Soubor
3.2. Undo
3.3. Znovu
3.4. Historie vracení
3.5. Vyjmout
3.6. Kopírovat
3.7. Kopírovat viditelné
3.8. Vložit
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Paste as
3.13. Buffer
3.14. Vymazat
3.15. Vyplnit barvou popředí
3.16. Vyplnit barvou pozadí
3.17. Vyplnit vzorkem
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Vykreslit výběr
3.21. Vykreslit cestu
3.22. Předvolby
3.23. Klávesové zkratky
3.24. Moduly
3.25. Units
4. Výběr
4.1. Selection
4.2. Vše
4.3. None
4.4. Invertovat
4.5. Float
4.6. Podle barvy
4.7. Z cesty
4.8. Editor výběru
4.9. Prolnutí
4.10. Sharpen
4.11. Zmenšit
4.12. Zvětšit...
4.13. Obvod
4.14. Remove Holes
4.15. Distort
4.16. Zaoblený obdélník
4.17. Přepnout rychlou masku
4.18. Uložit do kanálu
4.19. Do cesty
5. Zobrazení
5.1. Zobrazení
5.2. Nový pohled
5.3. Show All
5.4. Bod na bod
5.5. Zoom
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Okno dle obrázku
5.9. Přes celou obrazovku
5.10. Navigační okno
5.11. Display Filters
5.12. Relative colorimetric
5.13. Show Selection
5.14. Zobrazovat hranici vrstvy
5.15. Show Canvas Boundary
5.16. Zobrazovat vodítka
5.17. Zobrazovat mřížku
5.18. Show Sample Points
5.19. Chytat na vodítka
5.20. Chytat ke mřížce
5.21. Snap to Canvas
5.22. Snap to Active Path
5.23. Padding Color
5.24. Zobrazovat lištu nabídky
5.25. Zobrazovat pravítka
5.26. Zobrazovat rolovací lišty
5.27. Zobrazovat stavovou lištu
6. Obrázek
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB
6.5. Odstíny šedi
6.6. Indexovaný režim
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transformovat
6.15. Překlápění
6.16. Rotace
6.17. Velikost plátna
6.18. Fit Canvas to Layers
6.19. Fit Canvas to Selection
6.20. Velikost tisku
6.21. Velikost obrázku
6.22. Crop Image
6.23. Slice Using Guides
6.24. Horlivé ořezávání
6.25. Sloučit viditelné vrstvy
6.26. Zploštit obrázek
6.27. Align Visible Layers…
6.28. Guides
6.29. New Guide
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Remove all guides
6.33. Configure Grid…
6.34. Informační okno
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. The Layer Menu
7.1. Vrstvy
7.2. Nová vrstva
7.3. New From Visible
7.4. New Layer Group
7.5. Duplikovat vrstvu
7.6. Ukotvit vrstvu
7.7. Merge Down
7.8. Merge Layer Group
7.9. Delete Layer
7.10. The Text Commands of the Layer Menu
7.11. Zahodit informace o textu
7.12. Stack Submenu
7.13. Select Previous Layer
7.14. Select Next Layer
7.15. Select Top Layer
7.16. Select Bottom Layer
7.17. Raise Layer
7.18. Lower Layer
7.19. Layer to Top
7.20. Layer to Bottom
7.21. The Reverse Layer Order command
7.22. Maska
7.23. Přidat masku vrstvy
7.24. Apply Layer Mask
7.25. Delete Layer Mask
7.26. Show Layer Mask
7.27. Edit Layer Mask
7.28. Disable Layer Mask
7.29. Mask to Selection
7.30. Add Layer Mask to Selection
7.31. Subtract Layer Mask from Selection
7.32. Intersect Layer Mask with Selection
7.33. The Transparency Submenu of the Layer menu
7.34. Přidat alfa kanál
7.35. Remove Alpha Channel
7.36. Barva do alfy
7.37. Částečně zploštit
7.38. Práh alfy
7.39. Alfa do výběru
7.40. Přidat k výběru
7.41. Ubrat z výběru
7.42. Průnik s výběrem
7.43. The Transform Submenu
7.44. Flip Horizontally
7.45. Flip Vertically
7.46. Rotate 90° clockwise
7.47. Rotate 90° counter-clockwise
7.48. Rotate 180°
7.49. Arbitrary Rotation
7.50. Offset
7.51. Layer Boundary Size
7.52. Layer to Image Size
7.53. Velikost vrstvy
7.54. Ořezat vrstvu
8. The Colors Menu
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturation
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invertovat
8.13. Linear Invert
8.14. Inverze hodnoty
8.15. The Auto Submenu
8.16. Ekvalizovat
8.17. White Balance
8.18. Roztáhnout kontrast
8.19. Stretch HSV
8.20. Vylepšit barvy
8.21. Color Enhance (legacy)
8.22. The Components Submenu
8.23. Filtry
8.24. Extract Component
8.25. Mono Mixer
8.26. Komponovat
8.27. Dekomponovat
8.28. TODO
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. The Map Submenu
8.33. Přerovnat barevnou mapu.
8.34. Set Colormap
8.35. Filtry
8.36. Záměna barev
8.37. Rotace barevné mapy
8.38. Mapování z přechodu
8.39. Mapování z palety
8.40. Vzor vybarvení
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. TODO
8.47. HSV
8.48. Průměr okraje
8.49. Analýza barevné krychle
8.50. Export Histogram
8.51. Plynulá paleta
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. Nástroje
9.1. Nástroje
10. Filtry
10.1. Filtry
10.2. Zopakovat
10.3. Znovu zobrazit poslední
10.4. Přenastavit všechny filtry
10.5. The Python-Fu Submenu
10.6. Script-Fu
11. Windows Menu
12. Nápověda
12.1. Introduction to the Help Menu
12.2. Help
12.3. Kontextová nápověda
12.4. Tip dne
12.5. O aplikaci
12.6. Prohlížeč zásuvných modulů
12.7. Prohlížeč procedur
12.8. GIMP online
17. Filtry
1. Introduction
2. Common Features
3. Filtry rozostření
3.1. Introduction
3.2. Focus Blur
3.3. Gaussovo rozostření
3.4. Lens Blur
3.5. Mean Curvature Blur
3.6. Median Blur
3.7. Pixelizace
3.8. Selektivní Gaussovo rozostření
3.9. Variable Blur
3.10. Circular Motion Blur
3.11. Linear Motion Blur
3.12. Zoom Motion Blur
3.13. Dlaždicovatelné rozostření
4. Filtry vylepšení
4.1. Introduction
4.2. Vyhlazování
4.3. Odstranit prokládání
4.4. High Pass
4.5. Noise Reduction
4.6. Odstranění červených očí
4.7. Symmetric Nearest Neighbor
4.8. Sharpen (Unsharp Mask)
4.9. Vyčištění
4.10. Odstranit pruhy
4.11. NL filtr
4.12. Wavelet Decompose
5. Filtry zkreslení
5.1. Introduction
5.2. Apply Lens
5.3. Reliéf
5.4. Rytina
5.5. Zkreslení objektivu
5.6. Kaleidoscope
5.7. Mozaika
5.8. Novinový tisk
5.9. Polar Coordinates
5.10. Rozvlnit
5.11. Shift
5.12. Spherize
5.13. Rozšířit hodnotu
5.14. Video
5.15. Vlny
5.16. Vír a zaškrcení
5.17. Vítr
5.18. Zkřivit
5.19. Emboss (legacy)
5.20. Zkroucení stránky
6. Filtry efekty se světlem
6.1. Introduction
6.2. Bloom
6.3. SuperNova
6.4. Efekt odlesku
6.5. Záře z přechodu
6.6. Světelné efekty
6.7. Jiskřit
6.8. Drop Shadow
6.9. Long Shadow
6.10. Vignette
6.11. Drop Shadow (legacy)
6.12. Perspektiva
6.13. Xach-Effect
7. Filtry šum
7.1. Introduction
7.2. CIE lch Noise
7.3. HSV šum
7.4. Výpadky
7.5. Vybrat
7.6. Roztřepení RGB
7.7. Roztřepení
7.8. Rozprostřít
8. Filtry detekce hran
8.1. Introduction
8.2. Rozdíl gaussovských rozostření
8.3. Hrana
8.4. Laplaceova metoda
8.5. Neón
8.6. Sobelova metoda
8.7. Image Gradient
9. Obecné filtry
9.1. Introduction
9.2. Konvoluční matice
9.3. Distance Map
9.4. GEGL graph
9.5. Normal Map
9.6. Dilatovat
9.7. Erodovat
10. Filtry kombinace
10.1. Introduction
10.2. Sloučení hloubky
10.3. Filmstrip
11. Filtry umění
11.1. Introduction
11.2. Použít plátno
11.3. Komiks
11.4. Kubismus
11.5. Glass Tile
11.6. Olejomalba
11.7. Fotokopie
11.8. Simple Linear Iterative Clustering (SLIC)
11.9. Jemná záře
11.10. Waterpixels
11.11. Cartoon (legacy)
11.12. Clothify
11.13. GIMPresionista
11.14. Oilify (legacy)
11.15. Predator
11.16. Softglow (legacy)
11.17. Van Gogh (LIC)
11.18. Weave
12. Decor Filters
12.1. Introduction
12.2. Add Bevel
12.3. Add Border
12.4. Filters
12.5. Fog
12.6. Filters
12.7. Filters
12.8. Round Corners
12.9. Slide
12.10. Stencil Carve
12.11. Stencil Chrome
13. Map Filters
13.1. Introduction
13.2. Mapa vyvýšení
13.3. Vytlačení
13.4. Fraktální trasování
13.5. Iluze
13.6. Little Planet
13.7. Panorama Projection
13.8. Recursive Transform
13.9. Papírová dlaždice
13.10. Tile Seamless
13.11. Fractal Trace (legacy)
13.12. Map Object
13.13. URI
14. Filtry vykreslení
14.1. Introduction
14.2. Plamen
14.3. Fractal Explorer
14.4. IFS fraktál
14.5. Cell Noise
14.6. Perlin Noise
14.7. Plazma
14.8. Simplex Noise
14.9. Pevný šum
14.10. Difference Clouds
14.11. Bayer Matrix
14.12. Šachovnice
14.13. Difrakční obrazce
14.14. Grid
14.15. Linear Sinusoid
14.16. Bludiště
14.17. Filtry
14.18. Spiral
14.19. Checkerboard (legacy)
14.20. CML Explorer
14.21. Grid (legacy)
14.22. Skládačka
14.23. filtry
14.24. Spyrogimp
14.25. Circuit
14.26. Gfig
14.27. Lava
14.28. Line Nova
14.29. Návrhář koulí
15. Web Filters
15.1. Introduction
15.2. ImageMap
15.3. Částečně zploštit
15.4. Rozřezat
16. Animation Filters
16.1. Introduction
16.2. Nástroj mísení
16.3. Burn-In
16.4. Rozvlňuji
16.5. Spinning Globe
16.6. Vlny
16.7. Optimalizovat
16.8. Playback
I. Keys and Mouse Reference
Nabídka obrázku Soubor — Key reference for the File menu
Úpravy — Key reference for Edit menu
Vybrat — Key reference for Select menu
Zobrazit — Key reference for View menu
Image — Key reference for Image menu
Vrstvy — Key reference for Layer menu
Tools — Key reference for the Tools menu
Filtry — Key reference for Filters menu
Windows — Key reference for Windows menu
Help — Key reference for Help menu
Zoom tool — Key reference for the Zoom tool
Glossary
Bibliografie
A. Historie Gimpu
1. Úplné začátky
2. Úsvit GIMPu
3. Ten, který změnil svět
4. Verze 2.0
5. Co je v GIMPu nového?
6. Co je v GIMPu nového?
7. What's New in GIMP 2.6?
8. What's New in GIMP 2.8?
9. What's new in GIMP 2.10?
B. Hlášení chyb a žádosti o zlepšení
1. Ujistěte se, že se jedná o chybu
2. Hlášení chyby
C. How to Contribute
1. Prerequisites
1.1. Join our mailing list
1.2. Create a Local Working Copy of Code
1.3. Installing your sandbox
1.4. The gimp-help folder
2. Workflow
2.1. Writing
2.2. Validating
2.3. Images
2.4. Create HTML Files
2.5. Sending your files
3. Annexes
4. Working under Windows
4.1. Adapting Cygwin to use with GIMP documentation tools
D. Tone Mapping and Shadow Recovery Using GIMP’s ‘Colors/Exposure’
1. High bit depth GIMP’s floating point “Colors/Exposure”: much better than Curves for lightening the shadows and midtones of an image without blowing the highlights
2. A step-by-step example showing how to recover shadow information using high bit depth GIMP’s floating point “Colors/Exposure”
3. Use Notes
4. Conclusion
E. GNU Free Documentation License
1. PREAMBLE
2. APPLICABILITY AND DEFINITIONS
3. VERBATIM COPYING
4. COPYING IN QUANTITY
5. MODIFICATIONS
6. COMBINING DOCUMENTS
7. COLLECTIONS OF DOCUMENTS
8. AGGREGATION WITH INDEPENDENT WORKS
9. TRANSLATION
10. TERMINATION
11. FUTURE REVISIONS OF THIS LICENSE
12. ADDENDUM: How to use this License for your documents
F. Eeek! Nápověda chybí!
Rejstřík