Kapitola 10. Enhancing Photographs

Obsah

1. Práce s digitálními fotografiemi
1.1. Introduction
1.2. Vylepšení kompozice
1.3. Vylepšení barev
1.4. Úprava ostrosti
1.5. Odstranění nečistot
1.6. Tisk fotografií

1. Práce s digitálními fotografiemi

1.1. Introduction

Jedním z nejčastějších využití GIMPu je úprava nedokonalých digitálních fotografií – lehce přeexponovaných či podexponovaných, nevhodně natočených nebo dokonce rozostřených. Na takové problémy má GIMP lék. Smyslem této kapitoly je představit nástroje vhodné k řešení takových problémů. Nenajdete zde podrobné tutoriály, většinou je totiž snadnější naučit se tyto nástroje ovládat pokusy a hrou, než o nich dlouze číst. (Navíc je každý nástroj podrobně popsán ve své vlastní části manuálu.) Nenajdete zde ani nic o zvláštních efektech, které můžete na fotografii pomocí GIMPu vytvořit. Než začnete číst tuto kapitolu, měli byste znát základy práce s GIMPem, ale rozhodně nemusíte být žádní experti. Ti tu ostatně těžko najdou něco nového. A nestyďte se experimentovat – díky skvělé funkci zpět můžete téměř jakoukoliv chybu napravit stisknutím Ctrl+Z.

Nejčastější problémy, které je potřeba na fotografii řešit, jsou následující: špatná kompozice, špatné barvy, neostrost a různé artefakty a nechtěné objekty v obraze.

1.2. Vylepšení kompozice

1.2.1. Natočení obrazu

It is easy, when taking a picture, to hold the camera not quite perfectly vertical, resulting in a picture where things are tilted at an angle. In GIMP, the way to fix this is to use the Rotate tool. Activate this by clicking its icon in the Toolbox, or by pressing the Shift+R while inside the image. Make sure the Tool Options are visible, and at the top, make sure for Transform: that the left button (Transform Layer) is selected. If you then click the mouse inside the image and drag it, you will see a grid appear that rotates as you drag. When the grid looks right, click Rotate or press Enter, and the image will be rotated.

Jenže tímto způsobem často nedocílíte napoprvé dokonalého výsledku, pouze zlepšení. Můžete natočení provést ještě jednou a výsledek tak doladit, ale to má značnou nevýhodu. Při každé rotaci dochází k určitému rozostření obrazu, protože jednotlivé pixely mění vzájemnou polohu oproti originálnímu obrazu a obraz se převzorkuje. Při jedné rotaci je to téměř nepostřehnutelné, ale dvě následné rotace způsobí dvojnásobné rozostření. Je zbytečné obraz rozostřovat více, než je nutné, a proto je lepším řešením vrátit první rotaci a udělat ji znovu a přesněji.

Naštěstí je to v GIMPu možné provést ještě jednodušeji. Ve Volbách nástroje Rotovat zvolte v položce Směr rotace možnost Zpět (korektivní). Pokud použijete tuto volbu, nenatáčejte síť tak, abyste chybu kompenzovali (tedy vůči chybě v opačném směru), ale naopak natočte síť tak, aby přesně lícovala s chybně natočeným obrázkem. Pokud si to neumíte představit, vyzkoušejte to, zjistíte jak je to snadné.

[Poznámka] Poznámka

Since GIMP 2.2, there is an option to preview the results of transformations, instead of just seeing a grid. This makes it easier to get things right on the first try.

Když obrázek natočíte, objeví se v rozích nehezké trojúhelníkovité „díry“. Opravit je můžete použitím pozadí, které je vyplní nenápadnou neutrální barvou, případně se je můžete pokusit zaretušovat. Nejlepším řešením ovšem často bývá ořez obrázku. Čím silnější bylo natočení, tím je nutný větší ořez. Proto je vůbec nejlepší pořádně držet fotoaparát.

1.2.2. Ořezávání

Fotograf má možnost volit záběr již při snímání obrázku, ale často nemá nad volbou záběru takovou kontrolu, jakou by si přál (např. kvůli pevnému formátu snímku). Výsledkem jsou fotografie, které lze vylepšit ořezem. Dojem ze snímku lze často vylepšit umístěním nejdůležitějších částí a objektů na klíčová místa fotografie. Pravidlo třetin, které je dobré znát, i když se ho není nutné držet vždy, říká, že nejlépe působí objekty umístěné v jedné třetině fotografie (na výšku i na šířku).

To crop an image, activate the Crop tool in the Toolbox, or by pressing Shift+C while inside the image. With the tool active, clicking and dragging in the image will sweep out a crop rectangle. When everything is perfect, hit Enter. Note: if Delete cropped pixels in Crop Tool Options is disabled, the cropped part will not be removed from the image, only the visible image area will be adjusted.

1.3. Vylepšení barev

1.3.1. Automatické nástroje

Navzdory sofistikované elektronice moderních fotoaparátů jsou digitální fotografie často pře- nebo podexponované nebo mají barevný závoj. GIMP obsahuje řadu nástrojů pro nápravu barevnosti, od těch automatických, ovládaných jediným kliknutím, až po pokročilé nástroje s řadou nastavitelných parametrů. Začneme těmi nejjednoduššími.

GIMP nabízí pět automatických nástrojů pro korekci barevnosti. Ne vždy dosáhnou požadovaného výsledku, ale lze je vyzkoušet během okamžiku a poskytnou vám přínejmenším určitou představu o možném směru úprav. Kromě automatické úpravy úrovní je najdete v nabídce okna obrázku VrstvaBarvyAutomaticky.

O každém z nástrojů si něco povíme:

Normalizovat

Tento nástroj (ve skutečnosti se jedná o zásuvný modul) je užitečný při nápravě nedostatečné expozice: upraví rovnoměrně celý obrázek tak, aby nejtmavší části byly co nejtmavší a nejsvětlejší co nejsvětlejší. Nevýhodou je, že barevnou korekci plně určují nejsvětlejší a nejtmavší pixely v obrázku, takže přítomnost jediného černého a bílého pixelu znemožní efektivní normalizaci.

Ekvalizovat

Velmi mocný nástroj, který se snaží barvy v obrázku rovnoměrně rozložit po celém rozsahu možných intenzit. V některých případech je výsledek fantastický, jen těžko dosažitelný jiným způsobem. Častěji je ale výsledek podivný. Vyzkoušet to však můžete za okamžik.

Vylepšit barvy

Tento nástroj zvýší sytost barev, aniž by ovlivnil jejich odstín nebo jas. Funguje pouze v režimu RGB nebo indexovaných barev, ale nikoliv ve stupních šedi.

Roztáhnout kontrast

Funguje podobně jako Normalizovat, ale pracuje s červeným, modrým a zeleným kanálem nezávisle. Obvykle tak dosáhne omezení barevného závoje.

Stretch HSV

Does the same as Stretch Contrast but works in HSV color space, rather than RGB color space. It preserves the Hue.

White balance

This may enhance images with poor white or black by removing little used colors and stretch the remaining range as much as possible.

Úrovně automaticky

Automatické úpravy úrovní dosáhnete vyvoláním nástroje Úrovně ( NástrojeNástroje barevÚrovně v nabídce obrázku) a kliknutím na tlačítko Automaticky v jeho dialogu. V okně obrázku uvidíte náhled, pokud ho chcete zachovat, stiskněte tlačítko Budiž. Tlačítkem Zrušit úpravu zrušíte.

Pokud je v obrázku bod, který má být zcela bílý, a bod, který má být zcela černý, můžete použít nástroj Úrovně v poloautomatickém režimu, který často velmi dobře vylepší jas i barvy v celém obrázku. Nejprve vyvolejte nástroj Úrovně, tak jak bylo popsáno výše. Nyní si všimněte tří tlačítek s ikonami kapátek v pravé dolní části dialogu. Levé tlačítko, pokud nad ním podržíte myš, zobrazí nápovědu Vyberte černý bod. Klikněte na tlačítko a pak klikněte v obrázku na místo, které má být černé – skutečně zcela, úplně černočerné, nikoliv pouze tmavé. Obrázek se změní. Pak klikněte na pravé tlačítko ( Vyberte bílý bod ) a následně na místo v obrázku, které má být dokonale bílé. Obrázek se opět změní. Pokud jste s výsledkem spokojení, klikněte na Budiž. V opačném případě zvolte Zrušit.

Výše uvedené úpravy jsou automatické; pokud žádná z nich nedosáhne toho, co si představujete, je na čase vyzkoušet některý z interaktivních nástrojů pro úpravu barevnosti. Všechny, kromě jednoho, jsou dostupné přes Nástroje->Nástroje barev v nabídce obrázku Pokud vyberete nástroj pro úpravy barevnosti z Panelu nástrojů, klikněte kamkoliv do obrázku abyste ho aktivovali a otevřel se jeho dialog.

1.3.2. Problémy s expozicí

Nejjednodušší je použít nástroj (FIXLINK) Jas-Kontrast. Je ze všech nejméně silný, ale v mnoha případech je dostačující. Je použitelný na podexponované a přeexponované obrázky, barevný závoj opravit neumí. Nástroj se ovládá dvěma posuvníky, Jas a Kontrast. Pokud je zaškrtnuta volba Náhled, uvidíte hned všechny změny přímo v obrázku. Pohybujte posuvníky a jakmile jste s výsledkem spokojeni, stiskněte Budiž. Pokud nemůžete dosáhnout uspokojivých výsledků, klikněte na Zrušit a obrázek se vrátí do původního stavu.

Pokročilejší, a jen trochu složitější, způsob, jak napravit špatnou expozici je použití nástroje Úrovně. Dialog tohoto nástroje vypadá velmi složitě, ale pro nápravu expozice si stačí všímat části označené jako Vstupní úrovně. zvláště tří trojúhelníkovitých šoupátek pod histogramem. Návod k použití naleznete v části (FIXLINK) Nástroj Úrovně, ale nejjednodušší způsob, jak se s ním naučit pracovat, je zkoušet pohybovat zmíněnými šoupátky a sledovat, jak to ovlivňuje obrázek. (Musíte mít zaškrtnutou volbu Náhled.)

Velmi mocný nástroj pro korekci expozice jsou Křivky. Umožňuje pomocí kliknutí a tažení upravovat kontrolní body na křivce, která představuje funkci převodu vstupních úrovní jasu na výstupní úrovně jasu. Nástroj Křivky umožňuje replikovat funkci nástrojů Jas/Kontrast i Úrovně a přidává další možnosti. Návod k použití tohoto nástroje naleznete v části (FIXLINK)Nástroj Křivky, ale nejjednodušší je prostě si ho vyzkoušet a experimentovat.

Jedním z nejmocnějších způsobů úpravy jasu a kontrastu, který je vhodný pro náročnou práci a expertní uživatele, je vytvoření nové vrstvy nad vrstvou upravovanou, a nastavení režimu této nové vrstvy na Násobit. Nová vrstva pak slouží jako vrstva určující zisk vrstvy pod ní. Bílá znamená maximální zisk a černá nulový zisk. Malováním na tuto vrstvu tak můžete přesně určit zisk v jednotlivých částech obrázku. Měli byste ale malovat pouze s plynulými a pozvolnými přechody, jinak v obrázku vzniknou nepěkné hrany a artefakty. Pokud nechcete způsobit barevný posun obrázku, malujte pouze odstíny šedi.

Režim Násobit není jediným vhodným režimem pro kontrolu zisku. Režim Násobit může oblasti obrázku pouze ztmavovat, ne však zesvětlovat. Je proto užitečný na přeexponované obrázky. Režim Dělit má efekt opačný, umožňuje zesvětlení, nikolv však zmavení částí obrázku. Chcete-li maximalizovat množství viditelných detailů v celém obrázku, použijte následující trik:

  1. Zduplikujte vrstvu (vytvořte nad ní novou).

  2. Odbarvěte novou vrstvu.

  3. Na výsledek aplikujte Gaussovo rozostření s velkým poloměrem (100 nebo více).

  4. Nastavte režim vrstvy na Dělit.

  5. Sílu korekce ovládejte změnou krytí vrstvy či pomocí nástrojů Jas/Kontrast, Úrovně či Křivky na nové vrstvě.

  6. Jste-li s výsledkem spokojeni, spojte původní a kontrolní vrstvu pomocí Sloučit dolů.

Kromě režimů Násobení a Dělení lze využít i další režimy kombinace vsrtev, jako je Dodge, Burn nebo Soft Light. Může se však stát, že strávíte hraním si s těmito parametry celé hodiny, aniž si všimnete kolik času uběhlo. Čím více máte možností, tím těžší může být rozhodnout se.

1.3.3. Úprava odstínu a sytosti

Pokud má váš obrázek barevný závoj, je podle našich zkušeností nejjednodušší opravit jej nástrojem Úrovně - upravit samostatně úrovně jednotlivých barevných kanálů. Pokud tudy cesta nevede, zkuste nástroj Vyvážení barev či Křivky, jejich použití je však náročnější.

Někdy je těžké poznat, zda jsou barvy upraveny správně. Dobrou a objektivní technikou je nalézt bod v obrázku, který má být buď bílý nebo šedý. Aktivujte nástroj Barevná pipeta (ikona kapátka v panelu nástrojů) a klikněte na zmíněný bod. Otevře se dialog výběru barev. Pokud jsou barvy správně nastaveny, měly by být červená, zelená a modrá složka stejné. Pokud si rovny nejsou, uvidíte jakou úpravu je třeba provést. Tato technika, je-li správně použita, dovoluje upravit barevnost obrázku i barvoslepým.

Pokud je obrázek vybledlý (což se může snadno stát, pokud fotíte v ostrém světle), zkuste nástroj Odstín/Sytost. Ten poskytuje tři posuvníky: pro odstín, světlost a sytost. Zvýšení sytosti pravděpodobně pomůže. Současně ale bývá užitečné upravit i světlost. ( Světlost má podobný význam jako Jas v nástroji Jas/Kontrast, je lae tvořena jinou kombinací červené, zelené a modré složky.) Nástroj Odstín/Sytost umožňuje upravovat omezený rozsah barev (pomocí tlačítek v horní části dialogu), pokud však chcete dosáhnout přirozeně vypadajícího výsledku, je většinou dobré se této možnosti vyhnout.

[Tip] Tip

I když obrázek nevypadá vybledlý, může zvýšení sytosti zlepšit jeho účinek. Veteráni éry klasického filmu tomuto triku občas říkají Fujifikace, podle filmu Fujichrome, který je známý vysoce barevně sytými zvětšeninami.

Pokud fotografujete ve slabém světle, je někdy problém opačný: přílišná sytost obrázku. V takovém případě je nástroj Odstín/Sytost také užitečný, použijte jej ke snížení sytosti.

1.4. Úprava ostrosti

1.4.1. Oprava rozostření

Pokud není fotoaparát správně zaostřen nebo pokud se během snímání obrázků pohne, vznikne rozostřený obrázek. Pokud je hodně rozostřený, nelze s tím nic dělat, ale pokud je rrozostřen jen mírně, mělo by jej být možné opravit.

The most generally useful technique for sharpening a fuzzy image is called the Sharpen (Unsharp Mask. In spite of the rather confusing name, which derives from its origins as a technique used by film developers, its result is to make the image sharper, not unsharp. It is a plug-in, and you can access it as Filters->Enhance->Sharpen (Unsharp Mask) in the image menu. There are two parameters, Radius and Amount. The default values often work pretty well, so you should try them first. Increasing either the radius or the amount increases the strength of the effect. Don't get carried away, though: if you make the unsharp mask too strong, it will amplify noise in the image and also give rise to visible artifacts where there are sharp edges.

[Tip] Tip

Sometimes using Sharpen (Unsharp Mask) can cause color distortion where there are strong contrasts in an image. When this happens, you can often get better results by decomposing the image into separate Hue-Saturation-Value (HSV) layers, and running Sharpen (Unsharp Mask) on the Value layer only, then recomposing. This works because the human eye has much finer resolution for brightness than for color. See the sections on Decompose and Compose for more information.

In some situations, you may be able to get useful results by selectively sharpening specific parts of an image using the Blur or Sharpen tool from the Toolbox, in "Sharpen" mode. This allows you to increase the sharpness in areas by painting over them with any paintbrush. You should be restrained about this, though, or the results will not look very natural: sharpening increases the apparent sharpness of edges in the image, but also amplifies noise.

1.4.2. Odstranění zrnitosti

When you take pictures in low-light conditions or with a very fast exposure time, the camera does not get enough data to make good estimates of the true color at each pixel, and consequently the resulting image looks grainy. You can smooth out the graininess by blurring the image, but then you will also lose sharpness. There are a couple of approaches that may give better results. Probably the best, if the graininess is not too bad, is to use the filter called Selective Blur, setting the blurring radius to 1 or 2 pixels. The other approach is to use the Despeckle filter. This has a nice preview, so you can play with the settings and try to find some that give good results. When graininess is really bad, though, it is often very difficult to fix by anything except heroic measures (i.e., retouching with paint tools).

1.4.3. Zjemnění

Odstranění rušivých objektů v obraze

1.5. Odstranění nečistot

Odstranění objektů

1.5.1. Another tool looking very much as the clone tool, but smarter, is the healing tool which also takes the area around the destination into account when cloning. A typical usage is removal of wrinkles and other minor errors in images.

A good tool for removing dust and other types of lens grunge is the Despeckle filter, accessed as Filters->Enhance->Despeckle from the image menu. Very important: to use this filter effectively, you must begin by making a small selection containing the artifact and a small area around it. The selection must be small enough so that the artifact pixels are statistically distinguishable from the other pixels inside the selection. If you try to run despeckle on the whole image, you will hardly ever get anything useful. Once you have created a reasonable selection, activate Despeckle, and watch the preview as you adjust the parameters. If you are lucky, you will be able to find a setting that removes the junk while minimally affecting the area around it. The more the junk stands out from the area around it, the better your results are likely to be. If it isn't working for you, it might be worthwhile to cancel the filter, create a different selection, and then try again.

Odstranění červených očí

1.5.2. Red-eyes

The most useful method for removing unwanted clutter from an image is the Clone tool, which allows you to paint over one part of an image using pixel data taken from another part (or even from a different image). The trick to using the clone tool effectively is to be able to find a different part of the image that can be used to copy over the unwanted part: if the area surrounding the unwanted object is very different from the rest of the image, you won't have much luck. For example, if you have a lovely beach scene, with a nasty human walking across the beach who you would like to teleport away, you will probably be able to find an empty part of the beach that looks similar to the part he is walking across, and use it to clone over him. It is quite astonishing how natural the results can look when this technique works well.

Soubory

Jaký formát souboru použít pro uložení výsledku? Máte změnit velikost výsledku? Odpovědi závisí na účelu, ke kterému chcete obrázek použít.

In some cases you may be able to get good results by simply cutting out the offending object from the image, and then using a plug-in called Resynthesizer to fill in the void. This plug-in is not included with the main GIMP distribution, but it can be obtained from the author's web site [PLUGIN-RESYNTH]. As with many things, your mileage may vary.

1.5.3. Pokud chcete obrázek vytisknout, neměli byste jej zmenšovat (kromě případného oříznutí). Důvodem je to, že tiskárny pracují v mnohem vyšším rozlišení než běžné monitory: zatímco typický monitor používá rozlišení kolem 100 pixelů na palec, u běžné tiskárny to bývá 600-1400 bodů na palec. Obrázek o rozlišení 3000 × 5000 pixelů proto vypadá na monitoru obrovský, je-li však vytištěn při 600 dpi (bodů na palec), jeho rozměry budou 12,7 × 21,2 cm. Obvykle také není žádný důvod proč obrázek zvětšovat, skutečné rozlišení (detaily) obrázku tím nezvýšíte) a lze to případně provést až při tisku. Co se týče souborového formátu, ve většině případů postačuje JPEG s kvalitou nastavenou na 75 až 85. Ve vzácných případech, kdy obrázek obsahuje velké plochy téměř jednolité barvy, může být nutné nastavit ještě vyšší kvalitu či použít neztrátový formát jako např. TIFF.

Pokud chcete obrázek umístit na web nebo poslat elektronickou poštou, je zapotřebí minimalizovat velikost souboru. Nejprve zmenšete obrázek tak, aby byly ještě dobře patrné důležité detaily (pamatujte že různí lidé používají monitory různě velké a s různým rozlišením). Pak uložte obrázek ve formátu JPEG. V dialogu při ukládání zvolte volbu Náhled v okně obrázku FIXME

From version 2.4, GIMP incorporated a special remove red eye filter. Make a selection with one of the selection tools of the red part of the eye and then choose the Remove Red Eye filter. Perhaps you have to fiddle around a bit with the threshold slider to get the right color.

1.6. Tisk fotografií

1.6.1. Files

Printing your photos

  • FIXME

  • If you intend to print the image on paper, you should avoid shrinking the image, except by cropping it. The reason is that printers are capable of achieving much higher resolutions than video monitors — 600 to 1400 dpi (dots per inch, the physical density) for typical printers, as compared to 72 to 100 pixels per inch for monitors. A 3000 x 5000-pixel image looks huge on a monitor, but it only comes to about 5 inches by 8 inches on paper at 600 ppi. There is usually no good reason to expand the image either: you can't increase the true resolution that way, and it can always be scaled up at the time it is printed. As for the file format, it will usually be fine to use JPEG at a quality level of 75 to 85. In rare cases, where there are large swaths of nearly uniform color, you may need to set the quality level even higher or use a lossless format such as TIFF instead.

  • ICC-Profile [WKPD-ICC]

  • CMYK [WKPD-CMYK]

Gamut [WKPD-GAMUT]

1.6.2. that a screen resolution is roughly within a range from 75 up to 100 dpi; a printer resolution is about 10x higher (or more) than a screen one; printed image size depends on available pixels and resolution; so actual printed size doesn't correspond inevitably to what is displayed on screen nor available sheet size.

As in most applications, in GIMP, printing needs to go to main menu FilePrint. However it is very useful to keep in mind some elementary concepts to prevent some unpleasant surprises when looking at result, or to cure them if that occurs. You must always remember:

  • Moderní digitální fotoaparáty zapisují do souboru s obrázkem i údaje o nastavení fotoaparátu a dalších okolnostech v okamžiku pořízení snímku. Tyto údaje jsou v souborech JPEG či TIFF uložena ve strukturovaném formátu zvaném EXIF. GIMP, pokud byl správným způsobem sestaven (funkce závisí na knihovně libexif), umožňuje tato data v JPEG souborech zachovat. Pokud je v GIMPu otevřen obrázek obsahující EXIF údaje, upraven a znovu uložen ve formátu JPEG, údaje EXIF zůstanou beze změny zachovány. To sice není ideální způsob, kterým by měl grafický editor s EXIF daty pracovat, ale je to lepší, než je prostě smazat, jak to dělaly starší verze GIMPu.

    • Pokud si chcete údaje EXIF prohlédnout, stáhněte si z registru zásuvný modul Exif Browser . Pokud ho budete schopni na vašem systému sestavit a nainstalovat, vyvoláte ho z nabídky obrázku: Filtry->Obecné->Exif Browser. (Pokud potřebujete pomoci s instalací zásuvných modulů, přečtěte si část (FIXLINK)Instalace nových zásuvných modulů.)

    • CMYK [WKPD-CMYK]

    • Gamut [WKPD-GAMUT]

  • that a screen resolution is roughly within a range from 75 up to 100 dpi; a printer resolution is about 10x higher (or more) than a screen one; printed image size depends on available pixels and resolution; so actual printed size doesn't correspond inevitably to what is displayed on screen nor available sheet size.

Consequently, before any printing it is relevant to go to: ImagePrint size and choose here your convenient output size in print size box adjusting either sizes or resolution. The symbol shows that the both values are linked. You can dissociate x and y resolution by clicking on that symbol, but it is risky! Probably this possibility is open because printers are built with different x vs. y resolutions. Nevertheless if you unlinked them you can be very surprised! You can try this in special effects.

Last recommendation: think of checking your margins as well as centering. It would be a pity if a too much large margin cuts off some part of your image or if an inappropriate centering damages your work especially if you use a special photo paper.

1.6.3. EXIF Data

Modern digital cameras, when you take a picture, add information to the data file about the camera settings and the circumstances under which the picture was taken. This data is included in JPEG or TIFF files in a structured format called EXIF. For JPEG files, GIMP is capable of maintaining EXIF data, if it is built appropriately: it depends on a library called libexif, which may not be available on all systems. If GIMP is built with EXIF support enabled, then loading a JPEG file with EXIF data, and resaving the resulting image in JPEG format, will cause the EXIF data to be preserved unchanged. This is not, strictly speaking, the right way for an image editor to handle EXIF data, but it is better than simply removing it, which is what earlier versions of GIMP did.

If you would like to see the contents of the EXIF data, you can use the metadata-viewer plug-in. you can access it as Image->Metadata->View metadata from the menu.