第16章 メニュー

目次

1. メニューのあらまし
1.1. 画像ウィンドウのメニューバー
1.2. 脈絡メニュー
1.3. 切り取り可能なメニュー
1.4. タブメニュー
2. ファイルメニュー
2.1. 概観
2.2. New…
2.3. 画像の作成
2.4. Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. 最近開いたファイル
2.8. 保存
2.9. Save as…
2.10. Save a Copy…
2.11. 復帰
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. 印刷...
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. 閉じる
2.20. すべて閉じる
2.21. 終了
3. 編集メニュー
3.1. 編集メニューの項目
3.2. … を元に戻す
3.3. … をやり直す
3.4. 作業履歴
3.5. 切り取り
3.6. コピー
3.7. 可視部分のコピー
3.8. 貼り付け
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. クリップボードから生成
3.13. バッファー操作
3.14. 消去
3.15. 描画色で塗りつぶす
3.16. 背景色で塗りつぶす
3.17. パターンで塗りつぶす
3.18. Fill Selection Outline
3.19. Fill Path
3.20. 選択範囲の境界線を描画...
3.21. パスの境界線を描画...
3.22. 設定
3.23. キーボードショートカット
3.24. モジュール
3.25. 単位の定義
4. 選択メニュー
4.1. 選択メニューのあらまし
4.2. すべて選択
4.3. 選択を解除
4.4. 選択範囲の反転
4.5. 選択範囲のフロート化
4.6. 色域を選択
4.7. パスを選択範囲に
4.8. 選択範囲エディター
4.9. 境界をぼかす...
4.10. 境界を明確化
4.11. 選択範囲の縮小...
4.12. 選択範囲の拡大...
4.13. 縁取り選択...
4.14. Remove Holes
4.15. 選択範囲を歪める...
4.16. 角を丸める...
4.17. クイックマスクモード
4.18. チャンネルに保存
4.19. 選択範囲をパスに
5. 表示メニュー
5.1. 表示メニューのあらまし
5.2. 新しいビュー
5.3. ピクセル等倍
5.4. 表示倍率
5.5. Flip and Rotate (0°)
5.6. ウインドウサイズを合わせる
5.7. フルスクリーン
5.8. ナビゲーションウィンドウ
5.9. ディスプレイフィルター...
5.10. 色管理
5.11. 選択範囲境界線の表示
5.12. レイヤー境界線の表示
5.13. ガイドの表示
5.14. グリッドの表示
5.15. サンプルポイントの表示
5.16. ガイドにスナップ
5.17. グリッドにスナップ
5.18. キャンバス境界にスナップ
5.19. アクティブなパスにスナップ
5.20. キャンバス周りの色
5.21. メニューバーの表示
5.22. ルーラーの表示
5.23. スクロールバーの表示
5.24. ステータスバーの表示
6. 画像メニュー
6.1. 概観
6.2. 複製
6.3. モード
6.4. RGB
6.5. グレースケール
6.6. インデックス...
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. 変形
6.15. 水平反転; 垂直反転
6.16. 回転
6.17. キャンバスサイズの変更...
6.18. キャンバスをレイヤーに合わせる
6.19. キャンバスを選択範囲に合わせる
6.20. 印刷サイズ...
6.21. 画像の拡大・縮小...
6.22. Crop Image
6.23. Slice Using Guides
6.24. 最小枠で切り抜き
6.25. 可視レイヤーの統合...
6.26. 画像の統合
6.27. Align Visible Layers…
6.28. ガイド
6.29. 新規ガイド...
6.30. 新規ガイド (パーセントで)
6.31. 選択範囲から新規ガイド
6.32. すべてのガイドを削除
6.33. Configure Grid…
6.34. 画像の情報
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. レイヤーメニュー
7.1. レイヤーメニューのあらまし
7.2. 新しいレイヤーの追加...
7.3. 新しいレイヤーグループ...
7.4. 可視部分をレイヤーに
7.5. レイヤーの複製
7.6. レイヤーの固定
7.7. 下のレイヤーと統合
7.8. レイヤーの削除
7.9. レイヤーメニューのテキスト用コマンド
7.10. 文字情報の破棄
7.11. 重なりサブメニュー
7.12. 前面レイヤーを選択
7.13. 背面レイヤーを選択
7.14. 最前面レイヤーの選択
7.15. 最背面レイヤーの選択
7.16. レイヤーを前面へ
7.17. レイヤーを背面へ
7.18. レイヤーを最前面へ
7.19. レイヤーを最背面へ
7.20. レイヤー順序を反転
7.21. レイヤーマスクサブメニュー
7.22. レイヤーマスクの追加...
7.23. レイヤーマスクの適用
7.24. レイヤーマスクの削除
7.25. レイヤーマスクの表示
7.26. レイヤーマスクの編集
7.27. レイヤーマスクの無効化
7.28. マスクを選択範囲に
7.29. 選択範囲に加える
7.30. 選択範囲から引く
7.31. 選択範囲との交わり
7.32. 透明部分サブメニュー
7.33. アルファチャンネルの追加
7.34. アルファチャンネルの削除
7.35. 色を透明度に...
7.36. 半統合
7.37. アルファチャンネルしきい値...
7.38. 不透明部分を選択範囲に
7.39. 選択範囲に加える
7.40. 選択範囲から引く
7.41. 選択範囲との交わり
7.42. 変形サブメニュー
7.43. 水平反転
7.44. 垂直反転
7.45. 時計回りに 90 度回転
7.46. 反時計回りに 90 度回転
7.47. 180 度回転
7.48. 任意の回転...
7.49. オフセット...
7.50. レイヤーサイズの変更...
7.51. レイヤーをキャンバスに合わせる
7.52. レイヤーの拡大・縮小...
7.53. レイヤーの切り抜き
8. メニュー
8.1. メニューのあらまし
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. 彩度
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. 階調の反転
8.13. Linear Invert
8.14. 明度の反転
8.15. 自動補正サブメニュー
8.16. 平滑化
8.17. ホワイトバランス
8.18. コントラスト伸長
8.19. HSV 伸長
8.20. 色強調
8.21. Color Enhance (legacy)
8.22. 色要素サブメニュー
8.23. チャンネルミキサー...
8.24. チャンネル合成...
8.25. Extract Component
8.26. Mono Mixer
8.27. チャンネル分解
8.28. 再合成
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. カラーマッピングサブメニュー
8.33. インデックスカラーの並べ替え...
8.34. カラーマップを変更...
8.35. エイリアンマップ...
8.36. 色交換...
8.37. カラーマップ回転...
8.38. グラデーションマップ
8.39. パレットマップ
8.40. サンプル色付け...
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. 色の情報サブメニュー
8.47. ヒストグラム
8.48. 境界の平均色...
8.49. 色立体分析...
8.50. Export Histogram
8.51. パレット生成...
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. ツールメニュー
9.1. ツールメニューのあらまし
10. フィルターメニュー
10.1. フィルターメニューのあらまし
10.2. … の再適用
10.3. … の再表示
10.4. すべてのフィルターのリセット
10.5. Python-Fuサブメニュー
10.6. Script-Fuサブメニュー
11. ウィンドウメニュー
12. ヘルプメニュー
12.1. ヘルプメニューのあらまし
12.2. ヘルプ
12.3. 状況適応ヘルプ
12.4. 今日の技
12.5. このアプリケーションについて
12.6. プラグインブラウザー
12.7. プロシージャーブラウザー
12.8. GIMP 関連のウェブサイト

1. メニューのあらまし

GIMP にはいたるところにメニューがあります。 この章の目的は、 画像ウィンドウのメニューで呼び出せるコマンドの解説です。 画像メニューは画像ウィンドウのメニューバーをクリックするか、 キャンバスを 第2ボタン でクリックすると開きます。 そのほかダイアログに付属する脈絡メニューやそのメニュー項目は、 個々のダイアログの説明 のなかで解説しています。

1.1. 画像ウィンドウのメニューバー

Script-Fu や Python-Fu のスクリプトを追加したり動画プラグインなどを GIMP に導入した場合、 このメニューバーに新たに別のメニューが加わることもあります。

1.2. 脈絡メニュー

GIMP のインターフェースはその特定部位をマウスの 第2ボタン でクリックするといろいろな機能が入っている脈絡メニューが開きます。 脈絡メニューが出てくる部分はつぎのとおりです。

  • 画像ウィンドウのキャンバス内を 第2ボタン でクリックすると画像ウィンドウのメニューが呼び出せます。 メニューバーを隠してフルスクリーンモードで作業しているときはこの方法が便利です。

  • レイヤーダイアログのレイヤーやチャンネルダイアログのチャンネルなどは 第2ボタン でクリックするとそのダイアログの脈絡メニューが呼び出せます。

  • 画像ウィンドウの左上のメニューボタンをクリックしたり、 F10 キーを押してもメニューが呼び出せます。

  • タイトルバーを 第2ボタン でクリックするとメニューか何かの機能が呼び出されますが、 これは GIMP に属したものではなく、 お使いのコンピューターのウィンドウマネージャーの機能です。

1.3. 切り取り可能なメニュー

GIMP の一部のメニューには面白い特徴が備わっています。 各ダイアログの脈絡メニューや画像ウィンドウメニューのサブメニュー ( の印がサブメニューのあるメニュー項目の右端についていることで判る) はもちろん、 キャンバスを 第2ボタン でクリックすると出てくる親メニューは、 呼び出すとその上辺に破線 (切り取り線) がつきます。 この破線をクリックするとこのメニューは切り離され補助ウィンドウになります。

図16.1 ウィンドウサブメニューとその切り離されたサブメニュー

ウィンドウサブメニューとその切り離されたサブメニュー
ウィンドウサブメニューとその切り離されたサブメニュー

切り取られたメニューは実質的に独立しています。 これは常設になり、 現在活性化している画像にその機能が適用されます。 画像がすべて閉じられてもそのメニューは残ります。 このウィンドウ化したメニューを閉じるには再び破線をクリックするか、 お使いのコンピューターのウィンドウマネージャーのウィンドウを閉じる機能 (よくある例はタイトルバーの端の×印をクリック) を利用します。

この切り取りメニューはシングルウィンドウモードでも作成できますが、 メニュー項目をクリックした途端に主ウィンドウが手前に出てきて切り取りメニューを隠してしまうのでマルチウィンドウモードほどには使い勝手がよくありません。

1.4. タブメニュー

下図に示したようなメニューは画像ウィンドウのメニューバーにつながっておらず、 補完を目的に設けられています。

ドッキング可能 なダイアログはいずれも下図に示すようなタブメニューボタンがついています。 このボタンをクリックするとこのタブに特に関連が深い操作のメニューが現われ、 その最初に位置するサブメニューがダイアログの脈絡メニューです。

図16.2 ドッキング可能なダイアログ

ドッキング可能なダイアログ

ダイアログのタブメニューボタンを強調

ドッキング可能なダイアログ

タブメニュー


タブメニューの扱い方については 「タブメニュー」 をご覧ください。