5.4. 表示倍率

図16.48 表示メニューの表示倍率サブメニュー

表示メニューの表示倍率サブメニュー

表示倍率 サブメニューには画像ウィンドウ内の画像の表示倍率を変えるいろいろな (ズーム) コマンドが入っています。 画像を大きく表示 (ズームイン) すると高い精度の作業がしやすくなりますから画素 (ピクセル) 単位の画像加工や精密な選択に向いています。 その一方で画像を小さく表示 (ズームアウト) すれば画像の全体像の印象をつかんだり、 一部の変更が画像全体に及ぼす効果をはかり易くなります。 ちなみに表示倍率の変更は画像データに影響がなく表示方法だけが変わるので、 取り消し操作の対象外です。

[ティップ] ティップ

このサブメニューが提供する項目によらず、 他にも画像ウィンドウの ( ステータスバー を表示させておれば) 底部にあるズームボタンで定倍率を引き出しメニューから選んだり直接倍率を入力する方法があります。

表示倍率を扱う設定は ナビゲーションダイアログ 上でも可能です。 画像の一部に焦点を合わせて表示倍率を変更できる ズーム ツールもあります。

5.4.1. サブメニューへの入り方

  • 画像ウィンドウのメニューより 表示表示倍率。 ちなみに表示メニュー上では表示倍率がメニュー項目の名前の横で 表示倍率 (現在 100%) のように表されます。

5.4.2. 表示倍率サブメニューの目次

これより表示倍率サブメニューのいろいろなコマンドについて説明します。 既定のキーボードショートカットがあれば合わせて紹介します。

表示倍率を戻す

(初期設定のショートカット: `) このコマンドは表示倍率を直前の値に戻します。 直前の倍率は 表示倍率を 100パーセントに戻す のようにメニュー項目上でも表示されています。 ただしもし一度たりともまだその画像の表示倍率を変更していなかった場合にはこのメニュー項目は灰色無効で利用できません。

縮小表示

(初期設定のショートカット: -) 縮小表示コマンドは実行するたびに表示倍率をおよそ 30% ずつ下げます。 最小倍率は 0.39% です。

拡大表示

(初期設定のショートカット: +) 拡大表示コマンドは実行するたびに表示倍率をおよそ 30% ずつ上げます。 最大倍率は 25600% です。

[注記] 注記

拡大表示コマンドのキーボードショートカットは非常によく使われそうな操作なのにプラス記号は英語版のキーボードだと[日本語版も同じく] Shift キーも押さなくてはならず、 問題のある初期設定です。 (ヨーロッパでよく使われるキーボードにはあてはまりません。) 他のキーボードショートカットに替えたいときは動的なキーボードショートカット割り当てを利用するとよいでしょう。 詳しくは 設定 ダイアログの ユーザーインターフェースのページの説明をご覧ください。

ウインドウ内に全体を表示

(初期設定のショートカット: Shift+Ctrl+J) このコマンドは画像の全体像が現在のウィンドウにすっぽり収まるようにしつつ目一杯大きな倍率で表示します。 大抵は上下もしくは左右に隙間が空きますが、 4 辺すべてがこの外周不活性区域で囲まれることはありません。

Fill Window

このコマンドは外周不活性区域が塞がる大きさまで画像の表示倍率を上げます。 つまり縦横いずれかの方向では画像がウィンドウの大きさとぴったり合いますがもう一方の方向では画像がウィンドウの枠をはみ出します。

Zoom to Selection

This command zooms the image so that the selection fits the smallest dimension of the image window.

A:B (X %)

これらのコマンドで整数比の定倍率が選べます。 各メニュー項目の名前は表示倍率の比と百分率を示しています。 ちなみにこれらの定倍率はいずれもキーボードショートカットがついているので覚えておくとよいでしょう。 現在の倍率はメニュー項目に大きな黒丸が表示されます。

その他 (X %)...

このコマンドはダイアログを開きますので任意の表示倍率を指定してください。 指定できる範囲は 1:256 (0.39%) から 256:1 (25600%) です。

[ティップ] ティップ

画素単位の精密な描画を行うときは 「新しいビュー」 コマンドを利用するとよいでしょう。 新たに開いたウィンドウで標準の表示倍率の画像を見ながら作業すれば画像に起きた変化が別の視点で同時に読み取れます。