11. ウィンドウメニュー

このメニューから GIMP のウィンドウダイアログを操作できます。

ウィンドウメニューは新登場のシングルウィンドウモードからすればいささかふさわしからぬ名前です。 とはいえ少なくともここに並ぶ機能がいずれも複数と単一の両モードに大きく関わっていることは確かです。 メニューの内容は画像とドックの有無やそれらの名前に従って表示が変化します。

図16.250 ウィンドウメニューの目次

ウィンドウメニューの目次

画像が何も開かれていないとき

ウィンドウメニューの目次

開いた画像があるとき


  1. 最近閉じたドック サブメニューは最近閉じられたドックのリストです。 それぞれメニュー項目を選べばドックを開き元通りにダイアログを復元します。 ただしダイアログがひとつだけのドックは閉じてもここに記録されませんのでご注意ください。

    ダイアログとその合体 でドックについて詳しく述べています。

  2. ドッキング可能なダイアログ サブメニューはタブ状にまとめたり上下左右に繋ぎ合わせたりしてドック化できる常設ダイアログの目録です。 詳しくは 「ダイアログとその合体」 をご覧ください。

  3. ツールボックス: このメニュー項目やショートカット Ctrl+B はツールボックスを表示します。 [場合によりマルチウィンドウモードで]隠れていたツールボックスを (ツールオプションダイアログなどをドッキングしておればそのドックも一緒に) 表側に浮き出します。

  4. メニューの中段は縮小見本画像つきで画像の名前が一覧表となっている現在開いている画像のリストです。 いずれもクリックするかショートカット (Alt キーと数字キーの組み合わせ) でその画像が活性化します。

  5. メニューには現在開かれているドックのリストもあります。 ドックの名前は、 タブ化したドックをアクティブなダイアログの名前で代表し、 ドックが繋ぎ合わされておればそれらの名前を上下連結に-記号、 左右連結に|記号を用いて区切って並べてメニューに表示します。 メニュー項目を選ぶとそのドックが表に現れます。

  6. ドックを隠す (ショートカット Tab) コマンドはマルチウィンドウモードではすべてのドックウィンドウとツールボックスを、 シングルウィンドウモードでは画像ウィンドウの左と右いずれのドックをも隠し、 画像ウィンドウだけを残します。 この状態は GIMP を再起動しても保持されており、 マルチウィンドウモードであればドックを隠した状態で起動しますが、 シングルウィンドウモードで起動したときはこの項目にチェックが入っているにもかかわらずドックを隠さずウィンドウを開いてしまいます。

  7. シングルウィンドウモード コマンドを有効にすると GIMP は単一ウィンドウモードに替わります。 この指定は次回の起動時も有効です。 シングルウィンドウモード をご覧ください。