Kapitel 16. Menyer

Innehållsförteckning

1. Introduktion till menyer
1.1. Bildmenyraden
1.2. Snabbvalsmenyer
1.3. Löstagbara menyer
1.4. Flikmenyer
2. Arkiv-menyn
2.1. Översikt
2.2. New…
2.3. Skapa
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. Spara
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Skriv ut
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Stäng
2.20. Stäng alla
2.21. Avsluta
3. Redigera-menyn
3.1. Edit Menu Entries
3.2. Ångra
3.3. Gör om
3.4. Ångringshistorik
3.5. Klipp ut
3.6. Kopiera
3.7. Kopiera synlig
3.8. Klistra in
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Paste as
3.13. Buffert
3.14. Töm
3.15. Fyll med förgrundsfärg
3.16. Fyll med bakgrundsfärg
3.17. Fyll med mönster
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Stroke Selection
3.21. Stroke Path
3.22. The Preferences Command
3.23. Tangentbordsgenvägar
3.24. Modules
3.25. Enheter
4. Markera-menyn
4.1. Introduktion till Markera-menyn
4.2. Markera allt
4.3. None
4.4. Invertera
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Spara till kanal
4.19. To Path
5. Visa-menyn
5.1. Introduction to the View Menu
5.2. Ny vy
5.3. Show All
5.4. Punkt för punkt
5.5. Zooma
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Shrink Wrap
5.9. Helskärm
5.10. Navigeringsfönster
5.11. Visningsfilter
5.12. Färghantering
5.13. Visa markering
5.14. Show Layer Boundary
5.15. Visa hjälplinjer
5.16. Visa rutnät
5.17. Visa samplingspunkter
5.18. Fäst mot hjälplinjer
5.19. Fäst mot rutnät
5.20. Snap to Canvas
5.21. Snap to Active Path
5.22. Padding Color
5.23. Visa menyrad
5.24. Visa linjaler
5.25. Visa rullningslister
5.26. Visa statusrad
6. Bild-menyn
6.1. Overview
6.2. Duplicate
6.3. Läge
6.4. RGB-läge
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transformera
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Canvas Size
6.18. Fit Canvas to Layers
6.19. Fit Canvas to Selection
6.20. Print Size
6.21. Skala bild
6.22. Crop Image
6.23. Slice Using Guides
6.24. Zealous Crop
6.25. Sammanfoga synliga lager
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Hjälplinjer
6.29. Ny hjälplinje
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Ta bort alla hjälplinjer
6.33. Configure Grid…
6.34. Bildegenskaper
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Lager-menyn
7.1. Introduction to the Layer Menu
7.2. Nytt lager
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Förankra lager
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Förkasta textinformation
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Välj nästa lager
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Höj lager
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Lägg till lagermask
7.23. Tillämpa lagermask
7.24. Ta bort lagermask
7.25. Visa lagermask
7.26. Redigera lagermask
7.27. Inaktivera lagermask
7.28. Mask till markering
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Lägg till alfakanal
7.34. Ta bort alfakanal
7.35. Färg till alfa
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Beskär lager
8. Färg-menyn
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Mättnad
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invertera
8.13. Linear Invert
8.14. Value Invert
8.15. The Auto Submenu
8.16. Jämna ut
8.17. Vitbalans
8.18. Sträck ut kontrast
8.19. Sträck ut NMI
8.20. Förbättra färger
8.21. Förbättra färger (föråldrad)
8.22. The Components Submenu
8.23. Channel Mixer
8.24. Extract Component
8.25. Mono Mixer
8.26. Compose
8.27. Decompose
8.28. Recompose
8.29. Färg till grå
8.30. Avmätta
8.31. Sepia
8.32. The Map Submenu
8.33. Rearrange Colormap
8.34. Set Colormap
8.35. Alien Map
8.36. Color Exchange
8.37. Rotate Colors
8.38. Gradient Map
8.39. Palette Map
8.40. Sample Colorize
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Belasta
8.45. Retinex
8.46. The Info Submenu
8.47. Histogram
8.48. Kantmedelvärde
8.49. Färgkubsanalys
8.50. Exportera histogram
8.51. Utjämnad palett
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. Verktyg-menyn
9.1. Introduktion till Verktyg-menyn
10. Filter-menyn
10.1. Introduction to the Filters Menu
10.2. Upprepa senaste
10.3. Re-show Last
10.4. Reset All Filters
10.5. The Python-Fu Submenu
10.6. Undermenyn Script-Fu
11. Fönster-menyn
12. Hjälp-menyn
12.1. Introduktion till Hjälp-menyn
12.2. Hjälp
12.3. Sammanhangshjälp
12.4. Dagens tips
12.5. Om
12.6. Insticksbläddrare
12.7. Procedurbläddrare
12.8. GIMP på nätet

1. Introduktion till menyer

Det finns många platser i GIMP där du kan hitta menyer. Syftet med detta kapitel är att förklara alla kommandon som är tillgängliga från bildmenyraden och bildmenyn som du kan komma till genom att högerklicka på ritytan. Alla snabbvalsmenyer och menyobjekten för de övriga dialogerna beskrivs någon annanstans i kapitlet som beskriver den dialogen.

1.1. Bildmenyraden

Denna menyrad kan innehålla andra poster om du har lagt till script-fu, python-fu eller videoklipp till din GIMP.

1.2. Snabbvalsmenyer

Om du högerklickar på vissa delar av GIMP-gränssnittet öppnas en snabbvalsmeny, vilken leder till en rad olika funktioner. Några ställen där du kan komma åt snabbvalsmenyer är:

  • Genom att klicka på ett bildfönster visas bildmenyn. Detta är användbart när du arbetar i helskärmsläge utan menyrad.

  • Om du klickar på ett lager i dialogrutan Lager eller på en kanal i dialogrutan Kanaler visas funktioner för det valda lagret eller kanalen.

  • Högerklick på bildmenyraden har samma effekt som att vänsterklicka.

  • Högerklick på namnlisten visar funktioner som inte hör till GIMP, utan till fönsterhanteringsprogrammet för din dator.

1.3. Löstagbara menyer

Det finns en intressant egenskap i samband med några av menyerna i GIMP. Dessa är alla menyerna från bildmenyn som du når genom att högerklicka på ritytan samt deras undermenyer. (Du kan se att ett menyobjekt leder till en undermeny eftersom det finns en -ikon bredvid det.) När du öppnar någon av dessa menyer finns det en streckad linje överst i den (löskopplingslinje). Genom att klicka på den här streckade linjen lösgör du menyn under den och den blir ett separat fönster.

Figur 16.1. Undermenyn fönster och dess löstagbara undermeny

Undermenyn ”fönster” och dess löstagbara undermeny
Undermenyn ”fönster” och dess löstagbara undermeny

Löstagbara menyer är egentligen självständiga. De är alltid synliga, deras funktioner gäller alltid för den aktuella bilden, och de är kvar när alla bilder är stängda. Du kan stänga en löstagbar undermeny genom att återigen klicka på den streckade linjen eller stänga fönstret från fönsterhanteraren på din dator (ofta genom att klicka på en X-ikon i fönstrets övre högra hörn).

Dessa löstagbara undermenyer skapas också i läget med ett enda programfönster, men är av mindre intresse eftersom de döljs av fönstret så snart du klickar på det.

1.4. Flikmenyer

Följande menytyper är inte relaterade till bildmenyraden, men för helhetens skull:

Varje dockningsbar dialogruta innehåller en flikmenyknapp, som den som markerats nedan. Genom att trycka på den här flikmenyknappen öppnas en särskild meny med flikrelaterade åtgärder, med ett objekt överst som öppnar dialogrutans snabbvalsmeny.

Figur 16.2. Dockningsbar dialogruta.

Dockningsbar dialogruta.

Ett dialogfönster med flikmenyknappen markerad.

Dockningsbar dialogruta.

Flikmenyn.


Se Avsnitt 2.3.2, ”Flikmeny” för att lära dig mer om flikmenyer.