Глава 16. Меню

Содержание

1. Введение в меню
1.1. The Image Menu Bar
1.2. Контектные меню
1.3. Отрываемые меню
1.4. Меню вкладок
2. Меню «Файл»
2.1. Обзор
2.2. Создать…
2.3. Создать
2.4. Открыть…
2.5. Открыть как слои…
2.6. Открыть из сети…
2.7. Недавние файлы
2.8. Сохранить
2.9. Сохранить как…
2.10. Сохранить копию…
2.11. Восстановить
2.12. Экспортировать…
2.13. Экспортировать как…
2.14. Создать шаблон…
2.15. Печать
2.16. Послать по почте
2.17. Скопировать расположение файла
2.18. Показать в менеджере файлов
2.19. Закрыть
2.20. Закрыть все
2.21. Выход
3. Меню «Правка»
3.1. Пункты меню «Правка»
3.2. Отменить
3.3. Повторить
3.4. История действий
3.5. Вырезать
3.6. Копировать
3.7. Копировать видимое
3.8. Вставить
3.9. Вставить в выделение
3.10. Вставить на место
3.11. Вставить в выделение на место
3.12. Вставить как
3.13. Буфер
3.14. Очистить
3.15. Залить цветом переднего плана
3.16. Залить цветом фона
3.17. Залить текстурой
3.18. Залить выделение
3.19. Залить контур
3.20. Обвести выделение
3.21. Обвести контур
3.22. Команда «Настройки»
3.23. Комбинации клавиш
3.24. Модули
3.25. Единицы измерения
4. Меню «Выделение»
4.1. Введение в меню «Выделение»
4.2. Выделить всё
4.3. Снять выделение
4.4. Инвертировать
4.5. Сделать плавающим
4.6. По цвету
4.7. Из контура
4.8. Редактор выделения
4.9. Растушевать
4.10. Убрать растушёвку
4.11. Уменьшить
4.12. Увеличить
4.13. Граница
4.14. Удаление дыр
4.15. Исказить
4.16. Закруглить прямоугольник
4.17. Переключить быструю маску
4.18. Сохранить в канал
4.19. В контур
5. Меню «Вид»
5.1. Введение в меню «Вид»
5.2. Новое окно
5.3. Точка к точке
5.4. Масштаб
5.5. Зеркалирование и вращение (0°)
5.6. Сократить окно по изображению
5.7. Во весь экран
5.8. Окно навигации
5.9. Экранные фильтры
5.10. Управление цветом
5.11. Показывать выделение
5.12. Показывать границы слоя
5.13. Показывать направляющие
5.14. Показывать сетку
5.15. Показывать образцовые точки
5.16. Прилипать к направляющим
5.17. Прилипать к сетке
5.18. Прилипать к краям холста
5.19. Прилипать к активному контуру
5.20. Цвет заполнителя
5.21. Показывать панель меню
5.22. Показывать линейки
5.23. Показывать полосы прокрутки
5.24. Показывать строку состояния
6. Меню «Изображение»
6.1. Обзор
6.2. Создать копию
6.3. Режим
6.4. Режим RGB
6.5. Режим оттенков серого
6.6. Индексированный режим
6.7. Точность
6.8. Управление цветом
6.9. Включить управление цветом
6.10. Назначить цветовой профиль
6.11. Преобразовать в цветовой профиль
6.12. Освободить цветовой профиль
6.13. Сохранить цветовой профиль в файл
6.14. Преобразования
6.15. Отразить по горизонтали; Отразить по вертикали
6.16. Вращение
6.17. Размер холста
6.18. Холст по размеру слоёв
6.19. Холст в выделение
6.20. Размер при печати
6.21. Размер изображения
6.22. Обрезать изображение
6.23. Гильотина
6.24. Усердное кадрирование
6.25. Объединить видимые слои
6.26. Свести изображение
6.27. Выровнять видимые слои…
6.28. Направляющие
6.29. Создать направляющую
6.30. Направляющая (в %)
6.31. Направляющие из выделения
6.32. Удалить направляющие
6.33. Настроить сетку…
6.34. Свойства изображения
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Меню «Слой»
7.1. Введение в меню «Слой»
7.2. Создать слой
7.3. Создать группу слоёв
7.4. Создать из видимого
7.5. Создать копию слоя
7.6. Прикрепить слой
7.7. Объединить с предыдущим
7.8. Удалить слой
7.9. Команды меню «Слой» для текста
7.10. Удалить текстовую информацию
7.11. Вложенное меню «Стопка слоёв»
7.12. Перейти на предыдущий слой
7.13. Перейти на следующий слой
7.14. Перейти на верхний слой
7.15. Перейти на нижний слой
7.16. Поднять слой
7.17. Опустить слой
7.18. Сделать слой верхним
7.19. Сделать слой нижним
7.20. Команда «Обратный порядок слоёв»
7.21. Вложенное меню «Маска»
7.22. Добавить маску слоя
7.23. Применить маску слоя
7.24. Удалить маску слоя
7.25. Показать маску слоя
7.26. Изменить маску слоя
7.27. Скрыть маску слоя
7.28. Маска в выделение
7.29. Добавить к выделению
7.30. Вычесть из выделения
7.31. Пересечь с выделением
7.32. Вложенное меню «Прозрачность» в меню «Слой»
7.33. Добавить альфа-канал
7.34. Удалить альфа-канал
7.35. Цвет в альфа-канал
7.36. Полусведение
7.37. Порог альфа-канала
7.38. Альфа-канал в выделение
7.39. Добавить к выделению
7.40. Вычесть из выделения
7.41. Пересечь с выделением
7.42. Вложенное меню «Преобразования»
7.43. Отразить по горизонтали
7.44. Отразить по вертикали
7.45. Повернуть на 90° по часовой стрелке
7.46. Повернуть на 90° против часовой стрелки
7.47. Повернуть на 180°
7.48. Произвольное вращение
7.49. Сместить
7.50. Границы слоя
7.51. Слой к размеру изображения
7.52. Размер слоя
7.53. Откадрировать слой
8. Меню «Цвет»
8.1. Введение в меню «Цвет»
8.2. Цветовой баланс
8.3. Цветовая температура
8.4. Тон-цветность
8.5. Тон-насыщенность
8.6. Насыщенность
8.7. Экспозиция
8.8. Свет-тени
8.9. Яркость-контраст
8.10. Уровни
8.11. Кривые
8.12. Инвертировать
8.13. Линейная инверсия
8.14. Инверсия значения
8.15. Вложенное меню «Авто»
8.16. Выравнивание
8.17. Баланс белого
8.18. Растянуть контраст
8.19. Растянуть в HSV
8.20. Усиление цвета
8.21. Усиление цвета (устар.)
8.22. Вложенное меню «Составляющие»
8.23. Микшер каналов
8.24. Собрать
8.25. Извлечь составляющие
8.26. Монохромный микшер каналов
8.27. Разобрать
8.28. Собрать заново
8.29. Цвет в серый
8.30. Обесцвечивание
8.31. Сепия
8.32. Вложенное меню «Проекция»
8.33. Перераспределить цветовую карту
8.34. Настроить цветовую карту
8.35. Чужое отображение
8.36. Замена цвета
8.37. Вращение цветовой карты
8.38. Отображение градиента
8.39. Отображение палитры
8.40. Окраска по образцу
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. Вложенное меню «Информация»
8.47. Диалог гистограммы
8.48. Средний цвет рамки
8.49. Анализ изображения
8.50. Экспорт гистограммы
8.51. Гладкая палитра
8.52. Порог
8.53. Тонирование
8.54. Постеризация
8.55. Цвет в канал альфа…
8.56. Подмешивание шума
8.57. Обрезка RGB
8.58. «Горячие» цвета…
9. Меню «Инструменты»
9.1. Введение в меню «Инструменты»
10. Меню «Фильтры»
10.1. Введение в меню «Фильтры»
10.2. Повторить последний
10.3. Показать последний
10.4. Перезагрузить все фильтры
10.5. Вложенное меню «Python-Fu»
10.6. Вложенное меню «Script-Fu»
11. «Windows» Menu
12. Меню «Справка»
12.1. Введение в меню «Справка»
12.2. Справка
12.3. Контекстная справка
12.4. Совет дня
12.5. О программе
12.6. Браузер дополнений
12.7. Браузер процедур
12.8. GIMP в Интернете

1. Введение в меню

В GIMP много мест, где можно найти меню. Цель этой главы - объяснить все команды, доступные через меню окна изображения и меню изображения, доступное нажатием правой кнопки мышки на холсте. Все контекстные меню и пункты меню для диалогов описаны в главах, описывающие эти диалоги.

1.1. The Image Menu Bar

This menu bar may contain other entries if you have added script-fus, python-fus or videos to your GIMP.

1.2. Контектные меню

Если вы нажмёте правую кнопку мышки на определённых местах GIMP, появится «контекстное меню», дающее доступ к разным функциям. Вот некоторые места с контекстными меню:

  • При нажатии на окно изображения появляется меню изображения. Это полезно при работе в полноэкранном режиме, без планки меню.

  • При нажатии на слой в диалоге слоёв, или на канале в диалоге каналов появляется меню для выделенного слоя или канала.

  • Нажатие правой кнопки мышки на планке меню изображения равносильно нажатию левой кнопки мышки.

  • При нажатии правой кнопки мышки на титульной планке появляется меню, принадлежащее не GIMP, а оконному управляющему компьютера.

1.3. Отрываемые меню

Существует интересная особенность некоторых меню в GIMP. Это любые подменю контекстного меню изображения, появляющегося при нажатии правой кнопки мышки на окне изображения. Пункты меню, содержащие подменю, имеют пиктограмму справа от текта. Вверху таких меню находится пунктирная линия (линия отрыва). При нажатии на эту линию, подменю отсоединяется от меню и становится отдельным окном.

Рисунок 16.1. Подменю «окна» и его отсоединённое подменю

Подменю окна и его отсоединённое подменю
Подменю окна и его отсоединённое подменю

Отсоединённые подменю из окна изображения независимы. Они всегда видимы, их функции всегда прилагаемы к активному изображению, и они остаются, когда все изображения закрываются. Закрыть отсоединённые меню можно, нажав на пунктирную линию второй раз или закрыв окно в оконном управляющем, обычно с помощью пиктограммы Х в правом верхнем углу окна.

These tear-off submenus are also created in single-window mode, but are of less interest since they are masked by the window as soon as you click on it.

1.4. Меню вкладок

Следующие типы меню не относятся к планке меню изображения, но описаны для полноты:

У каждого стыкуемого диалога есть кнопка меню закладки, как показано выше. При нажатии на эту кнопку появляется особое меню для операций с закладками, первый пункт которого открывает контекстное меню диалога.

Рисунок 16.2. Стыкуемый диалог

Стыкуемый диалог

Окно диалога с выделенной кнопкой меню закладки.

Стыкуемый диалог

Меню вкладки


Обратитесь к главе Раздел 2.3.2, «Меню вкладок» за дополнительной информацией о меню закладки.