Capitolo 16. Menu

Indice

1. Introduzione ai menu
1.1. La barra del menu dell'immagine
1.2. I menu contestuali
1.3. Menu staccabili
1.4. Menu scheda
2. Il menu «File»
2.1. Panoramica
2.2. Nuovo...
2.3. Crea
2.4. Apri...
2.5. Apri come livelli...
2.6. Apri posizione...
2.7. Apri recenti
2.8. Salva
2.9. Salva come...
2.10. Salva una copia...
2.11. Ricarica
2.12. Esporta...
2.13. Esporta come...
2.14. Crea un modello...
2.15. Stampa
2.16. Spedisci per email
2.17. Copia posizione immagine
2.18. Mostra nel gestore file
2.19. Chiudi
2.20. Chiudi tutto
2.21. Esci
3. Il menu «Modifica»
3.1. Le voci del menu «modifica»
3.2. Annulla
3.3. Ripeti
3.4. Cronologia annullamenti
3.5. Taglia
3.6. Copia
3.7. Copia il visibile
3.8. Incolla
3.9. Incolla nella selezione
3.10. Incolla sul posto
3.11. Incolla nella selezione sul posto
3.12. Incolla come
3.13. Buffer
3.14. Cancella
3.15. Riempi con il colore di primopiano
3.16. Riempi con il colore di sfondo
3.17. Riempi con il motivo
3.18. Riempi contorno selezione
3.19. Riempi tracciato
3.20. Delinea selezione
3.21. Delinea tracciato
3.22. Il comando «preferenze»
3.23. Tasti scorciatoia
3.24. Moduli
3.25. Unità
4. Il menu «Seleziona»
4.1. Introduzione al menu «Seleziona»
4.2. Tutto
4.3. Niente
4.4. Inverti
4.5. Fluttuante
4.6. Per colore
4.7. Dal tracciato
4.8. Editor della selezione
4.9. Sfumata
4.10. Definita
4.11. Riduci
4.12. Allarga
4.13. Bordo
4.14. Rimuovi buchi
4.15. Distorci
4.16. Rettangolo arrotondato
4.17. Commuta maschera veloce
4.18. Salva nel canale
4.19. A tracciato
5. Il menu «Visualizza»
5.1. Introduzione al menu«Visualizza»
5.2. Nuova vista
5.3. Punto per punto
5.4. Zoom
5.5. Rifletti e ruota (0°)
5.6. Adatta la finestra all'immagine
5.7. A tutto schermo
5.8. Finestra di navigazione
5.9. Mostra filtri
5.10. Gestione del colore
5.11. Selezione
5.12. Limiti del livello
5.13. Mostra le guide
5.14. Mostra la griglia
5.15. Punti di campionamento
5.16. Guide magnetiche
5.17. Griglia magnetica
5.18. Superficie magnetica
5.19. Tracciato attivo magnetico
5.20. Colore di riempimento
5.21. Barra dei menu
5.22. Righelli
5.23. Mostra le barre di scorrimento
5.24. Barra di stato
6. Il menu «Immagine»
6.1. Panoramica
6.2. Duplica
6.3. Modalità
6.4. Modalità RGB
6.5. Modalità a scala di grigi
6.6. Modalità indicizzata
6.7. Precisione
6.8. Gestione del colore
6.9. Abilita gestione del colore
6.10. Assegna il profilo colore
6.11. Converti al profilo colore
6.12. Abbandona il profilo colore
6.13. Salva il profilo colore su file
6.14. Trasforma
6.15. Rifletti orizzontalmente; Rifletti verticalmente
6.16. Rotazione
6.17. Dividi usando le guide
6.18. Dimensione superficie
6.19. Imposta la superficie ai livelli
6.20. Imposta la superficie alla selezione
6.21. Dimensione di stampa
6.22. Scala immagine
6.23. Ritaglia immagine
6.24. Ritaglio preciso
6.25. Fondi livelli visibili
6.26. Appiattisci immagine
6.27. Allinea livelli visibili...
6.28. Guide
6.29. Nuova guida
6.30. Nuova guida (in percentuale)
6.31. Nuove guide dalla selezione
6.32. Rimuovi tutte le guide
6.33. Configura griglia...
6.34. Proprietà dell'immagine
7. Il menu «Livello»
7.1. Introduzione al menu «Livello»
7.2. Nuovo livello
7.3. Nuovo gruppo di livelli
7.4. Nuovo dal visibile
7.5. Duplica livello
7.6. Àncora livello
7.7. Fondi in basso
7.8. Elimina livello
7.9. I comandi testo del menu Livelli
7.10. Abbandona informazioni sul testo
7.11. Sottomenu «Pila»
7.12. Seleziona il livello precedente
7.13. Seleziona il livello successivo
7.14. Seleziona il livello in cima
7.15. Seleziona il livello di fondo
7.16. Alza il livello
7.17. Abbassa il livello
7.18. Alza il livello fino in cima
7.19. Abbassa il livello fino in fondo
7.20. Il comando «inverti l'ordine dei livelli»
7.21. Il sottomenu «maschera»
7.22. Aggiungi maschera di livello
7.23. Applica maschera di livello
7.24. Elimina maschera di livello
7.25. Mostra maschera di livello
7.26. Modifica maschera di livello
7.27. Disabilita maschera di livello
7.28. Maschera a selezione
7.29. Aggiungi la maschera di livello alla selezione
7.30. Sottrai la maschera di livello dalla selezione
7.31. Interseca la maschera di livello con la selezione
7.32. Il sottomenu «Trasparenza» del menu «Livello»
7.33. Aggiungi canale alfa
7.34. Rimuovi canale alfa
7.35. Colore ad alfa
7.36. Semi-appiattisci
7.37. Soglia alfa
7.38. Alfa a selezione
7.39. Aggiungi il canale alfa alla selezione
7.40. Sottrai dalla selezione
7.41. Interseca il canale alfa con la selezione
7.42. Il sottomenu «Trasforma»
7.43. Rifletti orizzontalmente
7.44. Rifletti verticalmente
7.45. Ruota di 90° in senso orario
7.46. Ruota di 90° in senso antioriario
7.47. Ruota di 180°
7.48. Rotazione arbitraria
7.49. Scostamento
7.50. Dimensione margini del livello
7.51. Livello a dimensione immagine
7.52. Scala livello
7.53. Ritaglia livello
8. Il menu «Colori»
8.1. Introduzione al menu «Colori»
8.2. Bilanciamento colore
8.3. Temperatura colore
8.4. Tonalità crominanza
8.5. Tonalità-saturazione
8.6. Saturazione
8.7. Esposizione
8.8. Ombre-alteluci
8.9. Luminosità-contrasto
8.10. Livelli
8.11. Curve
8.12. Inverti
8.13. Inverti lineare
8.14. Inverti valore
8.15. Il sottomenu «Auto»
8.16. Equalizza
8.17. Bilanciamento del bianco
8.18. Ampliamento contrasto
8.19. Ampliamento HSV
8.20. Aumento del colore
8.21. Aumento del colore (tradizionale)
8.22. Il sottomenu «Componenti»
8.23. Mixer canali
8.24. Componi
8.25. Estrai componente
8.26. Mixer mono
8.27. Scomponi
8.28. Ricomponi
8.29. Da colore a grigio
8.30. Desatura
8.31. Seppia
8.32. Il sottomenu «mappa»
8.33. Reimposta la mappa colori
8.34. Imposta mappa colori
8.35. Mappa aliena
8.36. Scambio colore
8.37. Ruota colori
8.38. Mappa gradiente
8.39. Mappa tavolozza
8.40. Colorazione a campione
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. Il sottomenu «Info»
8.47. Istogramma
8.48. Media del bordo
8.49. Analisi cubocolori
8.50. Esporta istogramma
8.51. Sfuma tavolozza
8.52. Soglia
8.53. Colorizza
8.54. Posterizza
8.55. Colore ad alfa...
8.56. Dither
8.57. Ritaglio RGB
8.58. Bollenti...
9. Il menu «Strumenti»
9.1. Introduzione al menu «Strumenti»
10. Il menu «Filtri»
10.1. Introduzione al menu «Filtri»
10.2. Ripeti l'ultimo
10.3. Ri-mostra l'ultima
10.4. Reimposta tutti i filtri
10.5. Il sottomenu «Python-Fu»
10.6. Il sottomenu «Script-Fu»
11. Il menu «Finestre»
12. Il menu «Aiuto»
12.1. Introduzione al menu «Aiuto»
12.2. Aiuto
12.3. Contenuti dell'aiuto
12.4. Suggerimenti del giorno
12.5. Informazioni
12.6. Navigatore Plug-In
12.7. Il navigatore delle procedure
12.8. GIMP online

1. Introduzione ai menu

I menu in GIMP sono presenti un po' ovunque; lo scopo di questo capitolo è di spiegare tutti i comandi accessibili dai menu della barra degli strumenti e dalla finestra immagine. Tutti gli altri menu contestuali e le voci di menu corrispondenti, sono descritti nei capitoli dedicati alle finestre relative.

1.1. La barra del menu dell'immagine

Questa barra del menu può contenere altre voci se si sono aggiunti degli script-fu, python-fu o video alla propria copia di GIMP.

1.2. I menu contestuali

Se si esegue un clic con il tasto destro del mouse in certe parti dell'interfaccia di GIMP, si apre un «menu contestale», che conduce ad una moltitudine di funzioni. Alcune posizioni dalle quali è possibile raggiungere dei menu contestuali sono:

  • Facendo clic su di una finestra immagine si mette in mostra il menu immagine. Quest'operazione è utile quando si sta lavorando in modalità a pieno schermo, senza la barra dei menu.

  • Facendo clic su un livello nella finestra di dialogo dei livelli o su un canale nella finestra di dialogo dei canali, si mette in evidenza le funzioni disponibili per il livello o per il canale selezionato.

  • Facendo clic destro sulla barra del menu immagine ha lo stesso effetto che fare clic con il tasto sinistro del mouse.

  • Facendo clic destro sulla barra del titolo vengono mostrate funzioni che non appartengono all'applicazione GIMP, ma che fanno parte dei comandi comuni forniti dal gestore delle finestre attualmente in uso (per esempio GNOME, KDE o Explorer).

1.3. Menu staccabili

C'è una proprietà interessante associata ad alcuni menu di GIMP. Essa riguarda qualsiasi menu o sottomenu appartenente alla barra del menu del pannello degli strumenti e i menu o sottomenu contestuali all'immagine, cioè ottenibili con il clic destro del mouse sulla finestra immagine (si può capire se una voce di menu porta da un sottomenu quando c'è un'icona " accanto ad essa). Quando si porta in primo piano uno di questi menu, c'è una linea tratteggiata in cima ad esso. Facendo clic su questa linea, è possibile staccare il menu presente sotto di essa trasformandolo in una finestra separata.

Figura 16.1. Il sottomenu «finestre» e la sua versione staccata

Il sottomenu finestre e la sua versione staccata
Il sottomenu finestre e la sua versione staccata

I sottomenu staccati sono indipendenti. Essi sono sempre visibili, le loro funzioni si applicano sempre all'immagine corrente e sono persistenti anche quando tutte le immagini sono chiuse. Per chiudere un sottomenu staccato basta fare clic nuovamente sulla linea tratteggiata o chiudere la finestra usando la gestione delle finestre dell'ambiente grafico corrente (spesso facendo clic su un'icona a forma di X presente nell'angolo in alto a destra della finestra).

Questi sottomenu staccabili vengono creati anche in modalità finestra singola, ma sono meno interessanti dato che sono mascherati dalla finestra non appena si fa clic su di essa.

1.4. Menu scheda

Il seguente tipo di menu non è correlato alla barra del menu immagine ma per completezza:

Ogni finestra di dialogo agganciabile contiene un pulsante menu scheda, come evidenziato sotto. Premendo questo pulsante si apre uno speciale menu che elenca una serie di operazioni relative alle schede, con la prima voce che apre nel menu contestuale della finestra di dialogo.

Figura 16.2. Una finestra di dialogo agganciabile.

Una finestra di dialogo agganciabile.

Una finestra di dialogo con il pulsante del menu scheda evidenziato.

Una finestra di dialogo agganciabile.

Il menu scheda.


Vedere Sezione 2.3.2, «Menu scheda» per ulteriori informazioni sui menu scheda.