Luku 16. Valikot

Sisällys

1. Esittely valikkoihin
1.1. Kuvavalikkopalkki
1.2. Kontekstivalikot
1.3. Repäisyvalikko
1.4. Välilehtivalikot
2. Tiedosto valikko
2.1. Yleiskatsaus
2.2. Uusi...
2.3. Luo
2.4. File Open…
2.5. Avaa tasoina
2.6. Avaa sijainti...
2.7. Avaa uusin
2.8. Tallenna
2.9. Tallenna nimellä...
2.10. Tallenna kopio...
2.11. Palauta
2.12. Vie...
2.13. Vie nimellä...
2.14. Luo malli..
2.15. Tulosta
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Sulje
2.20. Sulje kaikki
2.21. Lopeta
3. Muokkaa valikko
3.1. muokkaa valikon kohdat
3.2. Peru
3.3. Uudelleen
3.4. Perumishistoria
3.5. Leikkaa
3.6. Kopioi
3.7. Kopioi näkyvä
3.8. Liitä
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Liitä määräten
3.13. Leike
3.14. Tyhjennä
3.15. Täytä edustavärillä
3.16. Täytä taustavärillä
3.17. Täytä kuviolla
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Piirrä valinta
3.21. Piirrä polku
3.22. Asetukset komento
3.23. Näppäimistön pikavalinnat
3.24. Moduulit
3.25. Yksiköt
4. Valitse valikko
4.1. Esittely Valitse valikkon
4.2. Valitse Kaikki
4.3. Ei mitään
4.4. Käännä
4.5. Leijuta
4.6. Värin perusteella
4.7. Polulta
4.8. Valintaeditori
4.9. Lyhennä
4.10. Terävöitä
4.11. Kutista
4.12. Kasvata
4.13. Reuna
4.14. Remove Holes
4.15. Vääristä
4.16. Pyöristetty Suorakulmio
4.17. Vaihda pikamaski
4.18. Tallenna kanavalle
4.19. Polulle
5. Näytä valikko
5.1. Johdatus Näkymävalikkoon
5.2. Uusi näkymä
5.3. Show All
5.4. Piste pisteeltä
5.5. Suurenna
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Pienennä ikkuna
5.9. Kokoruutu
5.10. Navigointi-ikkuna
5.11. Näytä suotimet
5.12. Värinhallinta
5.13. Näytä valinta
5.14. Näytä tason rajat
5.15. Näytä apulinjat
5.16. Näytä ruudukko
5.17. Näytä näytepisteet
5.18. Tartu apulinjoihin
5.19. Kiinnitä ruudukkoon
5.20. Kiinnitä kankaaseen
5.21. Kiinnitä aktiiviseen polkuun
5.22. Täyteväri
5.23. Näytä valikkopalkki
5.24. Näytä viivaimet
5.25. Näytä vierityspalkit
5.26. Näytä Valikkopalkki
6. Kuva valikko
6.1. Yleisnäkymä (Overview)
6.2. Kahdenna
6.3. Tila
6.4. RGB-tila
6.5. Harmaasävytila
6.6. Indeksoitu tila
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Kääntö (transform)
6.15. Peilaa vaakasuunnassa; peilaa pystysuunnassa
6.16. Kääntö
6.17. Kankaan koko
6.18. Sovita kangas tasoihin
6.19. Sovita kangas valintaan
6.20. Tulostuskoko
6.21. Skaalaa kuvaa
6.22. Crop Image
6.23. Slice Using Guides
6.24. Tiukka automaattinen rajaus (Zealous crop)
6.25. Yhdistä näkyvät tasot
6.26. Yhdistä kuva (flatten image)
6.27. Kohdista näkyvät tasot...
6.28. Apulinjat
6.29. Uusi apulinja
6.30. Uusi apulinja (prosentin mukaan)
6.31. Uusi apulinja valinnasta
6.32. Poista kaikki apulinjat
6.33. Määritä ruudukko...
6.34. Kuvan ominaisuudet
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Taso valikko
7.1. Introduction to the Layer Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop Layer
8. Värit valikko
8.1. Esittely Värit valikkoon
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Kylläisyys
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Käännä
8.13. Linear Invert
8.14. Arvon kääntäminen
8.15. Automaatti alivalikko
8.16. Equalize
8.17. White Balance
8.18. Stretch Contrast
8.19. Stretch HSV
8.20. Color Enhance
8.21. Color Enhance (legacy)
8.22. Komponentit alivalikko
8.23. Channel Mixer
8.24. Extract Component
8.25. Mono Mixer
8.26. Compose
8.27. Decompose
8.28. Recompose
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. Kartta Alivalikko
8.33. Rearrange Colormap
8.34. Set Colormap
8.35. Alien Map
8.36. Color Exchange
8.37. Rotate Colors
8.38. Gradient Map
8.39. Palette Map
8.40. Sample Colorize
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. Info alivalikko
8.47. Histogram
8.48. Border Average
8.49. Colorcube Analysis
8.50. Export Histogram
8.51. Smooth Palette
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Väristä alfaan...
8.56. Dither
8.57. RGB Clip
8.58. Kuuma...
9. Työkalut valikko
9.1. Esittely Työkalu valikkoon
10. Suotimet valikko
10.1. Introduction to the Filters Menu
10.2. Toista edellinen
10.3. Re-show Last
10.4. Reset All Filters
10.5. The Python-Fu Submenu
10.6. The Script-Fu Submenu
11. Ikkunat valikko
12. Ohje valikko
12.1. Esittely Ohje valikkoon
12.2. Ohje
12.3. Kontekstiohje
12.4. Päivän vihje
12.5. Tietoja GIMP:stä
12.6. Liitännäisselain
12.7. Proseduuriselain
12.8. GIMP verkossa

1. Esittely valikkoihin

GIMP:ssä on monia paikkoja, mistä voit löytää valikkoja. Tämän luvun tavoitteena on selittää kaikki komennot, joihin pääsee käsiksi kuvan valikkopalkista ja kuvavalikosta, jonka saat esille oikealla painikkeella kankaan päällä. Kaikki kontekstivalikot ja valikonkohdat muille valintaikkunoille ovat kuvattuna muissa luvuissa, jotka kuvaavat valintaikkunoita itsessään.

1.1. Kuvavalikkopalkki

Tämä valikkopalkki sisältää muita merkintöjä, jos ole lisännyt script-fu:ita, python-fu:ita tai videoita GIMP:iisi.

1.2. Kontekstivalikot

Jos painat oikeaa painiketta tietyissä kohdissa GIMP:n käyttöliittymää, niin kontekstivalikko aukeaa, joka johtaa useisiin eri toimintoihin. Joitain paikkoja, joista pääset käsiksi kontekstivalikoihin ovat:

  • Painamalla kuvaikkunaa avaat kuvavalikon. Tämä on hyödyllistä, kun työskentelet kokoruudun tilassa ilman valikkopalkkia.

  • Painamalla tasoa tasojen-valintaikkunassa tai kanavaa kanavien-valintaikkunassa avaat toiminnot valitulle tasolle tai kanavalle.

  • Oikealla painikkeella kuvan valikkopalkissa on sama vaikutus kuin vasemmalla painikkeella.

  • Oikealla painikkeella otsikkopalkissa avaat toiminnot, jotka eivät kuulu GIMP:iin, vaan ikkunanhallintaohjelmaan tietokoneellasi.

1.3. Repäisyvalikko

On olemassa mielenkiintoinen ominaisuus, joka liittyy osaan GIMP:n valikoista. Se sisältää valikot kuvan kontekstivalikosta, jotka saat esille oikealla painikkeella kankaalla ja millä tahansa sen alivalikoista. (Voit nähdä, että valikon kohta johtaa alivalikkoon, koska sen vieressä on kuvake.) Kun tuot minkä tahansa näistä valikoista esille, niin huomaat pisteviivan sen yläreunassa (repäisyviiva). Painamalla tätä pisteviivaa irrotat valikon sen alle ja siitä tulee erillinen ikkuna.

Kuva 16.1. ikkunat alivalikko ja sen repäisyalivalikko

”ikkunat” alivalikko ja sen repäisyalivalikko
”ikkunat” alivalikko ja sen repäisyalivalikko

Repäisyvalikot ovat itse asiassa itsenäisiä. Ne ovat aina näkyvissä, niiden toiminnot liittyvät nykyiseen kuvaa ja ne säilyvät kun kaikki kuvista suljetaan. Voit sulkea repäisyalivalikon painamalla pisteviivaa uudestaan tai sulkemalla ikkunan ikkunanhallitsijasta tietokoneellasi (usein painamalla X-kuvaketta ikkunan oikeassa yläkulmassa).

Nämä repäisyalivalikot luodaan myös yhden ikkunan tilassa, mutta ne eivät ole niin mielenkiintoisia, koska ikkuna naamioi ne heti kun painat sitä.

1.4. Välilehtivalikot

Seuraavan tyyppinen valikko ei liity kuvan valikkopalkkiin, mutta yhdenmukaisuuden takia:

Jokainen telakoitava valintaikkuna sisältää välilehtivalikon painikkeen, kuten korostettuna alla. Painamalla välilehtivalikon painiketta avaat erikoisvalikon välilehteen liittyvistä toiminnoista, joilla on merkintä ylhäällä, joka avaa valintaikkunan kontekstivalikon.

Kuva 16.2. Telakoitava valintaikkuna

Telakoitava valintaikkuna

Valintaikkuna, jossa välilehtivalikon painike on korostettu.

Telakoitava valintaikkuna

Välilehtivalikko


Katso Kohta 2.3.2, ”Välilehti-valikko” saadaksesi enemmän tietoa välilehtivalikoista