Capítulo 16. Menus

Índice

1. Introdução aos menus
1.1. A barra de menu de imagem
1.2. Menus de contexto
1.3. Submenus destacáveis
1.4. Abas de menus
2. O menu Arquivo
2.1. Visão geral
2.2. New…
2.3. Criar
2.4. Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Abrir recente
2.8. Salvar
2.9. Save as…
2.10. Save a Copy…
2.11. Reverter
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Impressão
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Fechar
2.20. Fechar tudo
2.21. Sair
3. O menu Editar
3.1. Entradas do menu Editar
3.2. Desfazer
3.3. Refazer
3.4. Histórico do desfazer
3.5. Cortar
3.6. Copiar
3.7. Copiar como é visto
3.8. Colar
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Colar como
3.13. Buffer
3.14. Limpar
3.15. Preencher com cor de frente
3.16. Preencher com cor de fundo
3.17. Preencher com textura
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Contornar seleção
3.21. Contornar vetor
3.22. O comando Preferências
3.23. Atalhos de teclado
3.24. Módulos
3.25. Unidades
4. O menu Selecionar
4.1. Introdução ao menu Selecionar
4.2. Selecionar tudo
4.3. Nada
4.4. Inverter
4.5. Flutuar
4.6. Por Cor
4.7. Do vetor
4.8. Editor de seleções
4.9. Enevoar
4.10. Tornar nítida
4.11. Encolher
4.12. Aumentar
4.13. Criar borda
4.14. Remove Holes
4.15. Distorcer
4.16. Retângulo arredondado
4.17. Ligar/desligar máscara rápida
4.18. Salvar para canal
4.19. Para vetor
5. O menu visualizar
5.1. Introdução ao menu de Visualização
5.2. Nova visualização
5.3. Um ponto por pixel
5.4. Zoom
5.5. Flip and Rotate (0°)
5.6. Arrumar janela
5.7. Tela cheia
5.8. Janela de navegação
5.9. Filtros para a tela
5.10. Gerenciamento de cores
5.11. Exibir seleção
5.12. Exibir limites de camada
5.13. Exibir as guias
5.14. Exibir grade
5.15. Exibir pontos de amostragem
5.16. Atrair para as guias
5.17. Atrair para a grade
5.18. Atrair para a borda da tela
5.19. Atrair para o vetor ativo
5.20. Cor de preenchimento
5.21. Exibir barra de menu
5.22. Exibir réguas
5.23. Exibir barras de rolagem
5.24. Exibir barra de estado
6. O menu Imagem
6.1. Visão geral
6.2. Duplicar
6.3. Modo
6.4. Modo RGB
6.5. Modo de tons de cinza
6.6. modo indexado
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transformar
6.15. Espelhar horizontalmente; Espelhar verticalmente
6.16. Rotação
6.17. Tamanho da tela de pintura
6.18. Ajustar tela às camadas
6.19. Ajustar tela à seleção
6.20. Tamanho para impressão
6.21. Redimensionar imagem
6.22. Crop Image
6.23. Slice Using Guides
6.24. Cortar com cuidado
6.25. Combinar camadas visíveis
6.26. Achatar imagem
6.27. Align Visible Layers…
6.28. Guias
6.29. Nova guia
6.30. Nova guia (por percentagem)
6.31. Novas guias a partir da seleção
6.32. Remover todas as guias
6.33. Configure Grid…
6.34. Propriedades da imagem
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. O menu Camada
7.1. Introdução ao Menu Camada
7.2. Nova Camada
7.3. Novo grupo de camadas
7.4. Foto do que é visto
7.5. Duplicar camada
7.6. Ancorar camada
7.7. Combinar abaixo
7.8. Remover camada
7.9. Os comandos de texto do menu Camada
7.10. Descartar informações de texto
7.11. Submenu Pilha
7.12. Selecionar camada anterior
7.13. Seleciona a próxima camada
7.14. Selecionar camada do topo
7.15. Selecionar a camada do fundo
7.16. Subir camada
7.17. Abaixar camada
7.18. Camada para o topo
7.19. Camada para o fundo
7.20. O comando Reverter ordem das camadas
7.21. O Submenu Máscara
7.22. Adicionar máscara à camada
7.23. Aplicar máscara à camada
7.24. Remover máscara da camada
7.25. Exibir máscara da camada
7.26. Editar máscara da camada
7.27. Desabilitar a máscara da camada
7.28. Máscara para seleção
7.29. Adicionar a Máscara de camada à seleção
7.30. Subtrair máscara da camada da seleção
7.31. Intersecção da máscara de camada com a seleção
7.32. O Submenu Transparência do menu Camada
7.33. Adicionar canal alfa
7.34. Remover canal alfa
7.35. Cor para alfa
7.36. Semi-achatar
7.37. Limiar o alfa
7.38. Alfa para a seleção
7.39. Adicionar canal Alfa à seleção
7.40. Subtrair da seleção
7.41. Interseção do Canal Alfa com a Seleção
7.42. O Submenu Transformar
7.43. Espelhar horizontalmente
7.44. Espelhar verticalmente
7.45. Rotacionado 90° no sentido horário
7.46. Rotacionar 90° anti-horário
7.47. Rotacionar 180°
7.48. Rotação livre
7.49. Deslocamento
7.50. Tamanho dos limites da camada
7.51. Camada para o tamanho da imagem
7.52. Redimensionar camada
7.53. Cortar camada
8. O menu Cores
8.1. Introdução ao menu de Cores
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturação
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Inverter
8.13. Linear Invert
8.14. Inverter valores
8.15. O submenu Automático
8.16. Equalizar
8.17. Equilibrio de branco
8.18. Esticar contraste
8.19. Esticar HSV
8.20. Realce de cor
8.21. Color Enhance (legacy)
8.22. O submenu Componentes
8.23. Misturador de Canais
8.24. Compor
8.25. Extract Component
8.26. Mono Mixer
8.27. Decompor
8.28. Recompor
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. O submenu Mapear
8.33. Rearranja o mapa de cores
8.34. Especifica o mapa de cores
8.35. Mapeamento alien
8.36. Troca de cores
8.37. Rotaciona cores
8.38. Mapear com degradê
8.39. Mapear com paleta
8.40. Colorizar a partir de amostra
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. O submenu Informação
8.47. Histograma
8.48. Média da borda
8.49. Análise do cubo de cores
8.50. Export Histogram
8.51. Paleta suave
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. O menu Ferramentas
9.1. Introdução ao menu Ferramentas
10. O menu Filtros
10.1. Introdução ao Menu Filtros
10.2. Repetir último
10.3. Exibir novamente o último
10.4. Reiniciar todos os Filtros
10.5. O Submenu Python-Fu
10.6. O Submenu Script-Fu
11. Menu Janelas
12. O menu Ajuda
12.1. Introdução ao menu Ajuda
12.2. Ajuda
12.3. Ajuda por contexto
12.4. Dica do dia
12.5. Sobre
12.6. Navegador de plug-ins
12.7. O navegador de procedimentos
12.8. GIMP online

1. Introdução aos menus

Existem diversos lugares no GIMP em você pode encontrar menus. O objetivo desse capítulo é descrever todos os comandos que são acessíveis a partir da barra de menu da janela de imagem e do menu de imagem que aparece ao clicar com o botão direito na tela. Todos os menus de contexto e menus de outros diálogos são descritos nos demais capítulos, que são focados em descrever os diálogos em si.

1.1. A barra de menu de imagem

Essa barra de menu pode conter outras entradas caso você tenha adicionado extensões e filtros ao seu GIMP, tais como scripts feitos em script-fu ou Python ou a extensão de vídeos (GAP).

1.2. Menus de contexto

Se você clicar com o botão direito em certas partes da interface do GIMP, aparece um menu de contexto, que pode apresentar várias funções. Alguns lugares onde você pode acessar os menus contextuais são:

  • Ao clicar sobre a janela de imagem, aparece o menu de imagem. Isso é útil ao se trabalhar no modo de janela cheia, sem a barra de menus. Esse menu é uma cópia do menu na barra da janela de imagens.

  • Ao clicar sobre uma camada na janela de camadas ou em um canal na janela de canais exibe funções para a camada ou canal selecionado.

  • Clicar com o botão direito do mouse na barra de menu da janela de imagem tem o mesmo efeito que clicar com o botão esquerdo.

  • Clicar com o botão direito do mouse na barra de título mostra funções que não pertencem ao GIMP, mas ao programa gerenciador de janelas de do seu computador.

1.3. Submenus destacáveis

Existe uma propriedade interessante associada com alguns dos menus do GIMP. Aqui estão alguns dos menus de imagem de contexto que você consegue obter ao clicar com o botão direito sobre a tela ou sobre qualquer um dos submenus. (Você pode entender que o item de menu leva a um submenu quando existe um ícone próximo a ele.) Quando você abre qualquer um desses menus, existe uma linha pontilhada no topo do menu (linha de separação). Ao clicar sobre essa linha pontilhada, você destaca o menu abaixo deste e ele se torna uma janela em separado.

Figura 16.1. O submenu janelas e seu submenu destacável

O submenu janelas e seu submenu destacável
O submenu janelas e seu submenu destacável

Os menus separáveis são realmente independentes. Eles são sempre visíveis, e suas funções sempre se aplicam a imagem atual, e eles continuam abertos quando todas as imagens são fechadas. Você pode fechar um submenu separável ao clicar sobre a linha pontilhada novamente ou fechando a janela pelo gerenciador de janelas do seu computador (geralmente ao se clicar no ícone de X no canto superior direito da janela).

Esses submenus destacáveis também podem ser criados no modo de janela única, mas são muito menos interessantes já que ficam atrás da janela principal uma vez que você clica nela.

1.4. Abas de menus

O seguinte tipo de menu não está relacionado à barra de menu da janela de imagem, mas para é importante mencionar:

Toda janela encaixável contém um botão de menu das guias (abas), como destacado abaixo. Pressionar o botão de menu das guiasabre um menu especial de operações relacionadas aos diálogos de encaixe, com uma entrada no topo que abre o menu de contexto do diálogo de encaixe visível.

Figura 16.2. Um diálogo de encaixe

Um diálogo de encaixe

Uma janela de diálogo com o botão de aba de menu destacado.

Um diálogo de encaixe

O menu de guias


Veja Seção 2.3.2, “Menu das Abas (guias)” para aprender mais sobre menus de guias