Глава 14. Инструменты

Содержание

1. Панель инструментов
1.1. Введение
1.2. Значки инструментов
1.3. Область цвета и указателей
1.4. Параметры инструмента
2. Инструменты выделения
2.1. Общие свойства
2.2. Прямоугольное выделение
2.3. Эллиптическое выделение
2.4. Свободное выделение (Лассо)
2.5. Выделение смежных областей (Волшебная палочка)
2.6. Выделение по цвету
2.7. Умные ножницы
2.8. Выделение переднего плана
3. Инструменты рисования
3.1. Общие свойства
3.2. Динамика
3.3. Кистевые инструменты (Карандаш, Кисть, Аэрограф)
3.4. Плоская заливка
3.5. Градиент
3.6. Карандаш
3.7. Кисть
3.8. Кисть MyPaint
3.9. Ластик
3.10. Аэрограф
3.11. Перо
3.12. Штамп
3.13. Лечебная кисть
3.14. Штамп по перспективе
3.15. Размывание/Резкость
3.16. Размазывание
3.17. Осветление/Затемнение
4. Инструменты преобразования
4.1. Общие свойства
4.2. Выравнивание
4.3. Перемещение
4.4. Кадрирование
4.5. Вращение
4.6. Масштаб
4.7. Наклон
4.8. Перспектива
4.9. Трансформации
4.10. Преобразование по точкам
4.11. Отражение
4.12. Инструмент преобразования по рамке
4.13. Искажения
5. Другие
5.1. Общая информация
5.2. Контуры
5.3. Пипетка
5.4. Лупа
5.5. Измеритель
5.6. Текст
5.7. Операция GEGL

1. Панель инструментов

1.1. Введение

GIMP предоставляет большой набор инструментов для быстрого выполнения таких простых задач как создание выделений или контуров. Здесь детально описаны инструменты, находящиеся на панели инструментов программы.

(Если вам интересно, на языке GIMP «инструмент» — способ работы над изображением, который требует доступ к его видимой части либо для того, чтобы показать, что вы хотите сделать, перемещая указатель, либо для того, чтобы показать результаты уже внесенных изменений. Но если вы предпочтете считать инструмент пилой, а изображение — деревом, особого вреда от этого не будет.)

[Замечание] Замечание

Более подробно панель инструментов и её элементы рассмотрены в главе Основные окна: Панель инструментов.

В программе GIMP есть множество инструментов, с помощью которых можно выполнять самые разнообразные задачи. Все эти инструменты можно разделить на четыре категории:

  • Инструменты выделения, которые определяют или изменяют область в изображении, над которой будут работать другие инструменты;

  • Инструменты рисования, которые меняют цвета в какой-то отдельной области изображения;

  • Инструменты преобразования, которые изменяют геометрию изображения;

  • Другие инструменты, которые не попадают ни в одну из трёх других категорий.

1.2. Значки инструментов

With GIMP-2.10.18, tool icons can be grouped, and this option is enabled by default. The group icon displayed is the first icon in the group. Right click on the group icon to display the list of tools in the group.

You can get the former display back unchecking the Use tool groups option in Раздел 1.10, «Панель инструментов».

Рисунок 14.1. Значки инструментов на панели инструментов

Значки инструментов на панели инструментов

«Use tool groups» option unchecked. The default order of tools in the toolbox is different since GIMP-2.10.8; you can customize it in the Interface>Toolbox page of the Preferences.


Большинство инструментов активируется щелчком по соответствующему значку на панели инструментов. Доступ к некоторым (в частности, инструментам цветокоррекции, однако, возможен лишь через меню Цвет или ИнструментыЦвет. Каждый инструмент можно активировать через меню Инструменты, а также через клавиатуру при помощи клавиатурной комбинации.

In the default setup, created when GIMP is first installed, not all tools show icons in the Toolbox: the Color tools are omitted. You can customize the set of tools that are shown in the Toolbox in the Interface > Toolbox page of the Preferences.

There are two reasons you might want to do this: first, if you only rarely use a tool, it might be easier to find the tools you want if the distracting icon is removed; second, if you use the Color tools a lot, you might find it convenient to have icons for them easily available. In any case, regardless of the Toolbox, you can always access any tool at any time using the Tools menu from an image menubar.

Форма курсора меняется на значок активного инструмента, когда он находится внутри окна изображения (если в диалоге Параметры на вкладке Окно изображения включено Курсоры мышиРежим курсораЗначок инструмента).

1.3. Область цвета и указателей

Рисунок 14.2. Область цвета и указателей на панели инструментов

Область цвета и указателей на панели инструментов

1.3.1. Область цвета

Рисунок 14.3. Активные цвета на панели инструментов

Активные цвета на панели инструментов

Область цвета

Эта область показывает основную палитру GIMP, состоящую из двух цветов - переднего плана и фона. Эти цвета используются для рисования, заливки и других операций. Нажатие на любой из них покажет диалог выбора цвета.

Цвета по умолчанию

Нажатие на этот символ сбрасывает цвета переднего плана и фона на чёрный и белый соответственно. Нажатие клавиши D имеет тот же результат.

Поменять местами цвета ПП и фона

Нажатие на маленькую кривую со стрелками на концах или клавиши X меняет местами цвет переднего плана и фона.

[Подсказка] Подсказка

Один из этих цветов можно передвинуть прямо на слой. Тогда цвет заполнит весь слой.

1.3.2. Область индикатора инструментов

Рисунок 14.4. Активные кисть, текстура и градиент на панели инструментов

Активные кисть, текстура и градиент на панели инструментов

Эта часть панели инструментов показывает активную кисть, шаблон и градиент. Нажатие на любом из них покажет соответствующий диалог с параметрами.

1.3.3. Область активного изображения

Рисунок 14.5. Активное изображение на панели инструментов

Активное изображение на панели инструментов

Миниатюра активного изображения может быть показана в этой области, если выбран параметр «Показывать активное изображение» в ПравкаПараметрыПанель инструментов. При двойном щелчке на миниатюре открывается диалог «Изображения». Кроме того, перетаскивание этой миниатюры в файловый менеджер, поддерживающий XDS[9], приводит к сохранению активного изображения в открытую там папку.

1.4. Параметры инструмента

Рисунок 14.6. Диалог параметров инструмента

Диалог параметров инструмента

Диалог параметров инструмента «Аэрограф»


Если у вас используемое по умолчанию расположение диалогов, при активации инструмента палитра «Параметры инструмента» появится под панелью инструментов. Если эта палитра у вас скрыта, стоит вернуть ее на место: очень трудно эффективно использовать инструменты, не имея возможности быстро изменить параметры их работы.

[Подсказка] Подсказка

Параметры инструментов по умолчанию показываются под панелью инструментов. Если вы каким-то образом потеряете эту панель, ее можно получить обратно через меню ОкнаПанелиПараметры инструментов, а затем перенести под панель инструментов. За справкой обратитесь к разделу Диалоги и панели.

У каждого инструмента есть свой определённый набор параметров. Выбранные пользователем значения этих параметров сохраняются на протяжении сеанса до тех пор, пока пользователь не изменит эти значения. Фактически, параметры инструментов сохраняются и между сеансами. Сохранение параметров инструмента с прошлого рабочего сеанса может иногда ощущаться как неприятное недоразумение: инструмент вдёт себя очень странно, пока пользователь не вспомнит, что во время прошлого рабочего сеанса, две недели назад, был использован какой-то редко используемый параметр.

В самой нижней части диалога параметров инструмента расположены четыре кнопки:

Сохранить параметры в

Эта кнопка позволяет сохранить значения параметров текущего инструмента для последующего их восстановления. Она запускает Раздел 5.1, «Диалог профилей инструментов», в котором можно дать имя новому профилю. Во время восстановления параметров показываются только сохранённые профили активного инструмента, так что нет нужды беспокоиться о том, чтобы указывать название инструмента вместе с присвоением имени профиля.

Восстановить параметры

С помощью этой кнопки можно восстановить набор значений параметров активного инструмента, ранее сохранённый в профиле. Если для активного инструмента никогда не сохранялись профили, то эта кнопку будет недоступна для нажатия. В противном случае, после её нажатия будет запущено меню с названиями всех сохранённых профилей: выбор элемента меню применяет сохранённые в нём параметры.

Удалить параметры

С помощью этой кнопки можно удалить набор значений параметров активного инструмента, ранее сохранённый в профиле. Если для активного инструмента никогда не сохранялись профили, то на этой кнопке будет просто повторяться название инструмента. В противном случае, после её нажатия будет запущено меню с названиями всех сохранённых профилей: выбранный профиль будет удалён.

Сбросить параметры

Эта кнопка восстановит значения параметров как они были по умолчанию.

Новые бегунки

Option sliders have changed with GIMP-2.10.18: Sliders typically used in GEGL-based filters and tools’ options now have a compact style by default: they take a lot less space vertically and have a vastly improved behavior. You can use multiple modifiers with either left-click or mouse wheel scrolling:

  • Left-click + drag changes a value with a default increment.

  • Shift + left-click + drag (or right-click + drag) changes a value with a smaller step .

  • Ctrl + left-click + drag changes a value with a larger step.

Here is the full reference:

Как только примерное значение было установлено, его можно более точно настроить с помощью двух маленьких кнопок со стрелками справа от бегунка.

Область значения в области бегунка работает по принципу текстового редактора: там можно изменить значение или напрямую ввести новое.

For some options, you can drag the pointer outside the tool dialog. For example with the size slider, you can get the maximum value (10000) so.

Mouse Scroll-Wheel actions on canvas

При работе с инструментами можно использовать колёсико мыши вместе с клавишами-модификаторами, что даёт возможность удобной настройки параметров выбранного инструмента:

  • Alt + колёсико мыши: увеличить/уменьшить непрозрачность

  • Shift + Основная клавиша + колёсико мыши: увеличить/уменьшить соотношение сторон

  • Shift + Alt + колёсико мыши: увеличить/уменьшить угол

  • Основная клавиша + Alt + колёсико мыши: увеличить/уменьшить размер

  • Shift + Основная клавиша + Alt + колёсико мыши: увеличить/уменьшить интервал

Внимание: основной клавишей обычно бывает Ctrl или Cmd, в зависимости от платформы



[9] см. [XDS].