第14章 ツール

目次

1. ツールボックス
1.1. あらまし
1.2. ツールアイコン
1.3. 色と標識の区画
1.4. ツールオプション
2. 選択ツール
2.1. 共通機能
2.2. 矩形選択
2.3. 楕円選択
2.4. 自由選択 (なげなわ)
2.5. ファジー選択 (魔法の杖; 自動選択)
2.6. 色域選択
2.7. 電脳はさみ
2.8. 前景抽出選択
3. 描画ツール
3.1. 共通機能
3.2. 動的特性
3.3. ブラシツール (鉛筆、 絵筆、 エアブラシ)
3.4. 塗りつぶし
3.5. グラデーション
3.6. 鉛筆で描画
3.7. ブラシで描画
3.8. MyPaint Brush
3.9. 消しゴム
3.10. エアブラシ
3.11. インクで描画
3.12. スタンプで描画 (クローン)
3.13. 修復ブラシ
3.14. 遠近スタンプで描画
3.15. ぼかし/シャープ
3.16. にじみ
3.17. 暗室
4. 変形ツール
4.1. 共通機能
4.2. 整列
4.3. 移動
4.4. 切り抜き
4.5. 回転
4.6. 拡大・縮小
4.7. 剪断変形
4.8. 遠近法
4.9. 鏡像反転
4.10. ケージ変形
4.11. Unified Transform
4.12. Warp Transform
4.13. Handle Transform
5. その他のツール
5.1. 概観
5.2. パス
5.3. スポイト (カラーピッカー)
5.4. ズーム (伸縮表示)
5.5. 定規
5.6. テキスト
5.7. GEGL 操作

1. ツールボックス

1.1. あらまし

GIMP には充実したツールボックスがあり、 選択範囲をとったりパスをひいたりするような基本的な操作を素早くこなせます。 ここでは GIMP のツールボックスに載っているたくさんのツールについて吟味します。

(知識欲旺盛な方向け: GIMP の用語法ではツールとはディスプレイ表示を通して画像を扱う方法のうち、 マウスポインターを画面上で動かして意図を示す必要のあるものと、 加工の効果を見ながら行えるものを指します。 しかしツールをのこぎりに、 画像を一種の材木と捉えて考えてみても、 話はそんなにひどくはならないと思います。)

[注記] 注記

ツールボックスの概観とその内容については、 主なウィンドウ - ツールボックス をご覧ください。

GIMP は様々な用途に対応する多種多様なツールを具えています。 ツールを分類するとつぎの 5 つの範疇に振り分けられます。

  • 画像を加工する前にその対象となる部分を指定し調整するための 選択ツール

  • 画像を部分的に着色し、 あるいは色を変える 描画ツール

  • 画像を幾何学的に変形する 変形ツール

  • Other tools, which don't fall into the other three categories.

1.2. ツールアイコン

図14.1 ツールボックス上に並ぶツールアイコン

ツールボックス上に並ぶツールアイコン

ほとんどのツールはツールボックスのアイコンをクリックすれば起用できます。 初期設定では、 一部のツールはメニューを通してのみ起用できます。 呼び出し方は画像ウィンドウのメニューより ツール色ツール と辿ったところ、 もしくは メニューに限られます。) 結局のところ、 どんなツールも ツール メニューから起用できますし、 いずれも呼び出しにキーボードショートカットで呼びだせます。

GIMP を初めてインストールした時点での初期設定では、 すべてのツールがツールボックス上でアイコン化されているわけではありません。 色ツールは省かれています。 ツールボックスに載せるツールの選定は画像ウィンドウのメニューより 編集設定 と辿ると現れる GIMP の設定 ダイアログのツールボックスのページで指定できます。 ここで調整すると助かる理由は 2 つあるでしょう。 第一に、 ツールを頻繁には使わないけれど、 イザというときアイコンを見付けやすいように目障りなアイコンは片付けておきたいとき、 第二に、 カラーツールを頻繁に使うので、 すぐに利用しやすいと都合がよいとき。 どちらにしても、 ツールボックスの内容にかかわらず ツール メニューを通せばいつでもどんなツールも呼びだせます。

カーソルの形状は画像上で様々に変化し、 現在起用しているツールが何かを示しています。 この設定は 設定 ダイアログの画像ウィンドウのページで マウスポインターポインターのモードツールアイコン を指定している場合に限ります。

1.3. 色と標識の区画

図14.2 ツールボックスの色と標識の区画

ツールボックスの色と標識の区画

1.3.1. 色の区画

図14.3 ツールボックスが示す現在の色

ツールボックスが示す現在の色

色の区画

この区画は描画色と背景色の 2 色だけの、 GIMP の基本的なパレットであり、 描いたり塗ったりいろいろな用途に使われます。 2 色のどちらもクリックすれば描画色を/背景色を変更ダイアログが開かれてその色を変更できます。

描画色と背景色をリセット

この小さな白黒のしるしを押すと、 予想どおり描画色と背景色がそれぞれ白と黒にリセットされます。 D キーを押しても同じ効果があります。

描画色と背景色の交換

小さな曲がった両頭の矢印をクリックすると描画色と背景色が交換されます。 X キーを押しても同じ効果があります。

[ティップ] ティップ

これらの色見本をクリックしてレイヤー上までドラッグして放ってみましょう。 するとレイヤー全体が塗りつぶされます。

1.3.2. ツールの標識の区画

図14.4 ツールボックスが示す現在のブラシ、 パターン、 グラデーション

ツールボックスが示す現在のブラシ、 パターン、 グラデーション

ツールボックスのこの部分では現在使われているブラシ、 パターン、 グラデーションが表示されています。 いずれもクリックすればその選択を変更できます。

1.3.3. 現在の画像の区画

図14.5 ツールボックス上に示された現在活性化している画像

ツールボックス上に示された現在活性化している画像

設定 ダイアログのツールボックスのページで アクティブな画像 オプションを有効にしておれば、 この区画に現在活性化している画像の縮尺見本画像 (サムネイル) が表示されます。 この縮尺見本をクリックすれば画像ダイアログが開かれます。 このダイアログは複数の画像を開いているときに重宝なものです。 この見本画像をクリックして XDS[14] 可能なファイルマネージャーまでドラッグして放つと、 その画像を直に保存できます。

1.4. ツールオプション

図14.6 ツールオプションダイアログ

ツールオプションダイアログ

エアブラシツールのツールオプションダイアログ


ほとんど皆がしているような設定にしておれば、 ツールを起用したときにツールボックスの下にツールオプションダイアログが現れます。 違う設定をされていた方もおそらくそうなるようにせざるを得なくなるでしょう。 オプションを操作できない状態でツールを使いこなすのは大変難しいことです。

[ティップ] ティップ

初期設定ではツールオプションがツールボックスの下に現れるようになっています。 不意にそれを閉じてしまった場合は、 次の方法で戻せます。 画像ウィンドウのメニューより ウィンドウドッキング可能なダイアログツールオプション と辿ればツールオプションダイアログが現れますから、 あとはツールボックスの下に連接すれば良いです。 その方法は ダイアログとその合体 の節にあります。

ツールはそれぞれに定められるオプションがあります。 選んだオプションは変更するまでは作業中もひきつづき有効です。 具体的には、 前の作業で使ったオプションが次の作業にひきつがれるのです。 このような作業間のツールオプションの継続性はしばしば迷惑な事態をひきおこします。 あるツールが非常に奇妙な動作をするのですが、 理由がなかなか判りません。 ようやく気付いたのは、 2 週間前の作業でこのツールのオプションに並はずれた値を設定していたことだった、 などという事態です。

ツールオプションダイアログの底部には 4 つのボタンがあります。

オプションをファイルに保存...

このボタンは現在使用中のツールの設定を後で使えるように保存します。 「ツールプリセットダイアログ」 ダイアログが現れますので、 新しいプリセットにつけたい名前をここに記入します。 あとで保存しておいたオプションを呼び戻すときには、 現在使用しているツールに関わりのあるプリセットだけが並びますので、 ファイルに与える名前にはツール名を明記しなくても大丈夫です。

オプションをファイルから読み込む...

このボタンは保存してあったプリセットを現在使用中のツールに読み込ませます。 まだ一件もプリセットを保存していない場合、 このボタンは灰色無効になります。 逆に有効になっているときクリックすると、 保存されているすべてのオプションの名前が並ぶメニューが出てきます。 メニューからひとつを選ぶと設定に反映されます。

保存したオプションの削除...

このボタンは保存してあった現在使用中のツールに関連のあるプリセットを削除します。 まだ一件も現在使用中のツールのプリセットを保存していない場合、 このボタンは単にツール名を繰り返します。 逆に有効になっているときクリックすると、 保存されているすべてのプリセットの名前が並ぶメニューが出てきます。 選んだプリセットが削除されます。

このツールオプションをリセット; Shift すべてのツールオプションをリセット

このボタンは現在使用中のツールもしくはすべてのツールに初期設定値を読み込ませます。

新しくなったスライダー

オプションで使われているスライダーが GIMP 2.8 から新しくなりました。 見た目にはわかりませんがスライダーは枠内で上下ふたつの領域に別れています。

図14.7 ツールオプションダイアログの新しくなったスライダー

ツールオプションダイアログの新しくなったスライダー

スライダー枠内の上半分で上向き矢印の姿になったポインター

ツールオプションダイアログの新しくなったスライダー

スライダー枠内の下半分で水平両頭矢印の姿になったポインター


  • スライダー枠内の上半分では. ポインターの姿が上向き矢印になっており、 クリックするとスライダーはその位置に値を変更します。 (何も目安がなく、 大雑把な方法です。) クリックしてドラッグする操作は大幅な値の変更に適しています。

  • スライダー枠内の下半分では. 両頭矢印でクリックしても何も起こりません。 クリックしてドラッグすると値は少しづつ変動します。

ポインターを動かして凡その値を定めたあと、 スライダー右端の小さな上下矢印ボタンをクリックしても精密に数値を決定できます。

スライダー枠内は数値記入欄にもなります。 数値を書き込んだり貼り付ければ値を直ちに設定できます。

オプションによってはツールダイアログの外にまでポインターをドラッグすることもありえます。 たとえば最大値が 1 万となっているサイズのスライダーのように、 かなり大きな値を指定するためドラッグ操作で画面の右端までポインターを移動することもあるでしょう。

Mouse Scroll-Wheel actions

When using tools, you can use the mouse scroll-wheel, in combination with various modifiers, to do useful things with the tool options of the selected tool:

  • Alt + Mouse-wheel:  increase/decrease opacity

  • Shift + Primary + Mouse-wheel:  increase/decrease aspect ratio

  • Shift + Alt + Mouse-wheel:  increase/decrease angle

  • Primary + Alt + Mouse-wheel:  increase/decrease size

  • Shift + Primary + Alt + Mouse-wheel:  increase/decrease spacing

Note: the Primary modifier is usually Ctrl or Cmd, depending on your platform.



[14] [XDS] をご覧ください。 X Window System™ 上の規格です。