2. 主なウィンドウ

GIMP 2.8 からユーザーインターフェースが

の 2 通りを選べるようになりました。

When you open GIMP for the first time, it opens in single-window mode by default. You can enable multi-window mode unchecking Windows>Single-Window Mode) option in the image menu bar. After quitting GIMP, GIMP will start in the mode you have selected next time.

マルチウィンドウモード

図3.2 マルチウィンドウモードの様子を示すスクリーンショット

マルチウィンドウモードの様子を示すスクリーンショット

上図は GIMP の最も基本的な構成のスクリーンショットです。 通常はこれらで充分です。

You can notice two panels, left and right, and an image window in middle. A second image is partially masked. The left panel collects Toolbox and Tool Options dialog together. The right panel collects Layers, Channels, Paths, Undo History dialogs together in a multi-tab dock, and Brushes, Patterns, Gradients, Fonts, History, Paint dynamics editor, Palette editor dialogs together in another multi-tab dock.

  1. ツールボックス: (道具箱) ここにはツールを起用できるアイコンボタンがずらりと並んでいます。 初期設定ではその下に描画色と背景色を示す区画があります。 さらにその下の区画で現在のブラシ/パターン/グラデーションの状況や活性画像縮小見本をアイコン化した表示が、 編集設定 と辿ると開かれる 設定 ダイアログのツールボックスのページでそれぞれに表示/非表示を設定できます。

  2. ツールオプション: ツールボックスの下に合体しているのがツールオプションを調整するダイアログです。 現在手にとっているツールの詳細が現れています。 (この例では移動ツール)

  3. 画像ウィンドウ: GIMP は開いた画像をそれぞれひとつづつウィンドウで表示します。 つまり同時に複数の画像を開けますが、 その枚数はシステムの (メモリー) 資源に制限されます。 GIMP で何か意味のあることをするのなら、 まずは少なくともひとつの画像ウィンドウを開いておく必要があります。 画像ウィンドウには GIMP の中心的コマンド群 (ファイル メニュー、 編集 メニュー、 選択 メニュー …) からなるメニューがあり、 これはウィンドウ内を 第2ボタンでクリックしても呼びだせます。

    画像ウィンドウはその寸法より大きな画像も表示できます。 この場合GIMP はウィンドウ内に画像の全体像を収めるため倍率を落として縮小表示します。 表示倍率を 100% に変えると、 画像の見たい部分を繰り寄せられるようスクロールバーが現れます。

  4. レイヤー, チャンネル, パス, 作業履歴: のドック。 ちなみにそれぞれのダイアログはドック内ではタブ化されます。 この図ではレイヤータブが開かれています。 レイヤーダイアログウィンドウには、 いま手掛けている画像のレイヤー構造が表示されており、 ここでいろいろと操作できるようになっています。 基本的にレイヤーを使わずにできる作業も少しはありますが、 ちょっと GIMP に慣れてきたらもうレイヤーダイアログなしにはやっていけないと思うことでしょう。

  5. ブラシ/パターン/グラデーション: レイヤーダイアログの下に合体しているのはブラシ (穂先) とパターン (文様) とグラデーションを調節するダイアログ (のタブ) です。

ダイアログとドックの管理操作方法については 「ダイアログとその合体」 で説明しています。

シングルウィンドウモード

図3.3 シングルウィンドウモードの様子を示すスクリーンショット

シングルウィンドウモードの様子を示すスクリーンショット

上記マルチウィンドウモードと内容は同じものですが、 管理操作方法が異なっています。

  • Left and right panels are fixed; you can't move them. But you can decrease or increase their width by dragging the moving pointer that appears when the mouse pointer overflies the right border of the left pane. If you want to keep the left pane narrow, please use the slider at the bottom of the tool options to pan across the options display.

    If you reduce the width of a multi-tab dock, there may be not enough place for all tabs;then arrow-heads appear allowing you to scroll through tabs.

    マルチウィンドウモードの場合と同じく Tab キーを使ってパネルをいっぺんに隠せます。

  • 画像ウィンドウは両側パネル間の全域を占めます。

    When several images are open, a new bar appears above the image window, with a tab for every image. You can navigate between images by clicking on tabs or either using Ctrl+Page Up or Page Down or Alt+Number. Number is tab number; you must use the number keys of the upper line of your keyboard, not that of keypad (Alt-shift necessary for some national keyboards).

ここでは最低限のものしか出ていません。 GIMP では目的にあわせて十数種ものダイアログがありますが、 それが必要なときに開いて、 用が済んだら閉じればよいのです。 要領のいいユーザーは普段ツールボックス (とツールオプション) とレイヤーダイアログを出したままにしています。 ツールボックスは GIMP を使うほとんどの作業の要です。 ツールオプション区画はこの例ではツールボックスに合体させていますが、 もともと別のダイアログです。 しかし要領のいいユーザーはだいたいいつもこの形にしています。 ツールがどう調整されているか見ないで使いこなすのは無理なことですから。 レイヤーダイアログは画像を複数のレイヤーで扱う場合にのみ必要なものですが、 GIMP を使いはじめるとまもなくこれも ほぼ常備 品となることでしょう。 そしてもちろん、 加工中の画像を画面に出しておかねば何もできません。 作品を保存していないまま画像ウィンドウを閉じようとすると GIMP はこのファイルを閉じるのかどうか尋ねてきます。

[注記] 注記

GIMP のダイアログを消してしまっても ウィンドウ最近閉じたドック と進めば簡単に配置を復元できます。 ウィンドウ メニューは少なくとも 1 つの画像を開いている場合のみ利用可能です。 タブをドックに追加したりドックから外したり消したりするには、 ダイアログの右上角の をクリックします。 出てきたタブメニューで タブの追加タブを閉じるタブの切り放し のいずれかを選びます。

この先の節ではスクリーンショットに出てきたウィンドウのそれぞれの部品をひとつひとつ見てゆき、 それらの名前や役割を説明します。 ひととおり目を通したあとで GIMP 画像の基本構造を解説した章を押さえれば、 GIMP の多様な基本操作は充分マスターできています。 その後はこのてびきの残りを読んでいろいろ遊んでみたり (試したり) しながら、 数えきれないほどの巧妙かつ高度な技を身に付けてゆきましょう。 さあ楽しもう!

2.1. ツールボックス

図3.4 ツールボックスのスクリーンショット

ツールボックスのスクリーンショット

ツールボックスは GIMP の心臓部です。 さて図にでているものを順に素早く見てゆきましょう。

[ティップ] ティップ

ツールボックスも GIMP の各所と同じく、 なにかの部品の上でポイントしたままちょっと待つとそれについてのメッセージが書かれたツールチップが現れます。 ついでにショートカットキーもよくツールチップに表示されます。 ほとんどの部品はその上にマウスポインターを置いたまま F1 キーを押せば関連するヘルプが立ち上がるようになっています。

初期設定ではこの場所に現在の描画色と背景色の色見本だけが表示されています。 現在のブラシやパターンやグラデーションの状態を示す各アイコンや、 活性画像の縮小見本アイコンをここに表示させるには、 画像ウィンドウのメニューより 編集設定 と辿って GIMP の設定 ダイアログを開き、 ツールボックスのページでそれぞれ指定します。

  1. ツールアイコン: ここに並ぶアイコンは、 画像の一部を選択したり、 色付けしたり、 変形したりといった様々な目的にあわせたツールをそれぞれ表しています。 「ツールボックス」 の節ではツールの使い方が大まかに述べてありますが、 ツール の章全体ではそれぞれのツールについて体系的に説明しています。

  2. 描画色/背景色: このふたつの色見本は現在の描画色および背景色を表していて、 GIMP の数多くの操作に関連しています。 それぞれの色は色見本をクリックすると出てくる…色を変更ダイアログで別の色に変えられます。 右上の両矢印アイコンをクリックすれば描画色と背景色を交換でき、 左下隅の白黒アイコンをクリックすると描画色は黒、 背景色は白にリセットされます。

  3. Brush/Pattern/Gradient: The symbols here show you GIMP's current selections for: the Paintbrush, used by all tools that allow you to paint on the image (painting includes operations like erasing and smudging, by the way); for the Pattern, which is used in filling selected areas of an image; and for the Gradient, which comes into play whenever an operation requires a smoothly varying range of colors. Clicking on any of these symbols brings up a dialog window that allows you to change it.

  4. 活性画像: GIMP では同時に複数の画像を扱えますが、 どの時点でもそのうちのただ一枚だけが活性画像 (アクティブな画像) です。 今の活性画像をアイコン化したものがここに表示されます。 これをクリックすると現在開かれているすべての画像をリストにしたダイアログが出てきて、 どれかの画像をクリックするとそれが活性画像になります。 しかし普段はマルチウィンドウモードなら目的の画像ウィンドウをクリック、 シングルウィンドウモードなら目的の画像タブをクリックしてその画像を活性化させる方法をいちばんよく行なうことになるでしょう。

    XDS 対応のファイルマネージャーに画像見本アイコンをドラッグしていって放つと画像の保存ができます。 XDS とは X Direct Save Protocol という X™ 用の追加機能のことです。 X は UNIX 風システムでグラフィカルユーザーインターフェースを担う X ウィンドウシステムの規格を提供しています。

[注記] 注記

At every start, GIMP selects the brush, color, pattern you used when quitting your previous session because the Save input device settings on exit in Preferences/Input Devices, is checked by default. If you uncheck it, GIMP will use use a color, a brush and a pattern by default, always the same.

[ティップ] ティップ

ツールボックス上部にはウィルバーの目玉の絵が表示されています。 この空き地は個人用 GIMP ディレクトリー内の gimprc ファイルに (toolbox-wilber no) の行を追加すると撤去できます。 この指示はツールボックスのみに適用されます。 画像ウィンドウ内にもウィルバーの目玉の絵が表示されることがありますが、 こちらは何も画像を開いていない時だけに限られています。

[ティップ] ティップ

ファイルブラウザーの画像アイコンをツールボックスまでドラッグして放つとその画像が新たな画像ウィンドウになって、 あるいは画像表示領域の新たなタブとなって開かれます。