第12章 GIMP 宇宙管理局

目次

1. GIMP の設定ダイアログ
1.1. はじめに
1.2. System Resources
1.3. カラーマネジメント (色管理)
1.4. Playground
1.5. ツールオプション
1.6. 新しい画像作成時の初期設定
1.7. グリッドの設定
1.8. ユーザーインターフェース
1.9. テーマ
1.10. テーマ
1.11. ツールボックス
1.12. Dialog Defaults
1.13. ヘルプ
1.14. ディスプレイ
1.15. ウィンドウの設定
1.16. 画像ウィンドウ
1.17. 画像ウィンドウの表示スタイル
1.18. 画像ウィンドウのタイトルとステータスバー
1.19. Image Window Snapping Behavior
1.20. 入力デバイス
1.21. 入力コントローラー
1.22. フォルダー
1.23. データフォルダー
2. グリッドとガイド
2.1. グリッド
2.2. ガイド
3. 格子線を描写
4. タイルキャッシュの設定方法
5. メニューの各機能にショートカットを作成
6. 自分流のスプラッシュスクリーン

1. GIMP の設定ダイアログ

1.1. はじめに

図12.1 設定のページ一覧

設定のページ一覧

GIMP の設定ダイアログは画像ウィンドウのメニューより 編集設定 と進んで呼び出します。 ここで GIMP の動作慣習を様々な面で変更できます。 以下の各節は個々に誂え得る設定とその効果を詳細に解説します。

ここで定義した設定情報はすべて個人用の GIMP ディレクトリーに置かれた gimprc というファイルに記入して保管されます。 グラフィカルユーザーインターフェースよりもテキストエディターで作業したいというパワーユーザーの方はこのファイルを編集して設定を変更しても構いません。 また UNIX™ システム風のシステムではそういう方のための詳しいオンラインマニュアルがあり、 このファイルの内容についての技術的情報と、 各設定項目の用途が man gimprc とすれば読めます。

1.2. System Resources

図12.2 System Resources

System Resources

このページではさまざまな用途で使うシステムのメモリー資源の割り当て量について誂えられる。 またそのほか、 保存されていない画像を閉じる際に尋ねるウィンドウを出さなくするスイッチと、 GIMP が作成し使用するサムネイル (縮小見本画像) の大きさ設定がある。


1.2.1. オプション

リソースの使い方

作業履歴の最小エントリー数

GIMP はほとんどの操作が取り消せるようにするため、 各画像ごとに作業履歴を保持していますが、 その目的で一定量のメモリーを割り当てることになります。 ただし GIMP はメモリーの総消費量を無視してでも直近の操作には最小限の取り消し手数を確保します。 その手数はここで指定します。 GIMP の作業履歴機能についてのさらなる情報が 「取り消し」 にあります。

作業履歴のメモリーサイズ

これは各画像ごとに割り当てる作業履歴のためのメモリー量の仮の上限です。 作業履歴がこの容量を越すと、 最も古い操作の記録から順に削除されることになりますが、 もし履歴の手数が上記の最小エントリー数を下回るようならば削除しません。

タイルキャッシュサイズ

これは GIMP の画像データに割り当てるシステム RAM の容量です。 この上限を越えてメモリーを要求するときは、 GIMP はディスクへスワップ[データの一時退避]を始めますので、 情況によっては劇的な減速をもたらします。 この数値は GIMP をインストールする際にも設定可能ですが、 この場でそれが変更できます。 タイルキャッシュの設定方法 に詳しい情報があります。

新しい画像の最大サイズ

これは厳しい制限ではありません。 この容量を越える大きさの画像を作成しようとすると、 本当にそうするか尋ねるようになっています。 超巨大な画像を作成すると GIMP が異常終了するか、 反応が極端に遅ーーーーくなるので、 こうして意図しない偶発的な作成を防いでいます。

使用するプロセッサーの数

初期値は 1 つです。 複数の中央演算処理装置を備えたコンピューターで指定します。 [--disable-mp としてビルドした場合はこのオプションはありません。]

Hardware acceleration

Use OpenCL

OpenCL is an acronym for Open Computing Language (see Wikipedia). This option, checked by default, improves the management of relations between the CPU and the graphic processing unit (GPU).

画像サムネイル

サムネイルのサイズ

This options allows you to set the size of the thumbnails shown in the File Open dialog (and also saved for possible use by other programs). The options are No thumbnails, Normal (128x128), and Large (256x256).

サムネイルの最大ファイルサイズ

GIMP はここで指定した最大容量を越す画像ファイルに対して縮小見本画像を作成しません。 このオプションで極端に大きな画像ファイルをサムネイル化する際に GIMP がノロノロと遅くなってしまうのを防げます。

Document History

システムの [最近開いたファイル] にも記録・反映する

これを有効にすると、 開いたファイルそれぞれの記録が文書開覧履歴に保存されます。 それらファイルの一覧は画像ウィンドウメニューの ファイル最近開いたファイル サブメニュー上の若干数のほか、 その底部にあるメニュー項目 ファイル履歴 をクリックすると開かれる 最近開いたファイル ダイアログにもあります。

1.3. カラーマネジメント (色管理)

図12.3 設定 カラーマネジメントのページ

設定 カラーマネジメントのページ

1.3.1. オプション

このページで GIMP の色管理を設定できます。

いくつかのオプションは引き出しメニューでカラープロファイルを選択できます。 メニューに目当てのプロファイルが見当らなければ、 メニュー下端の カラープロファイルをディスクから選択... をクリックして追加できます。

[ティップ] ティップ

カラープロファイルの書かれたファイルの名前には .icc という拡張子がつきますので簡単にわかります。 またこれらは特定の位置にまとまって置かれることが多くあります。 GIMPMac OS X™ でご使用の場合は、 /Library/ColorSync/Profiles//Library/Printers/[製造者名]/Profiles/ あたりを探してみてください。

Image display mode

このオプションは GIMP の色管理の方式を定めます。 つぎの 3 通りのモードがあります。

  • No color management: choosing this selection shuts down the color management in GIMP completely.

  • Color managed display: with this selection you can enable the GIMP color management to provide a fully corrected display of the images according to the given color profile for the display.

  • Soft-proofing: when choosing this option, you enable the GIMP color management not only to apply the profile for the display, but also the selected printer simulation profile. Doing so, you can preview the color results of a print with that printer.

    [注記] 注記

    GIMP の色管理は画像表示の補正と画像ファイルへのプロファイル埋め込みだけ行なうことをお断りしておきます。 とくに GIMP 経由での印刷に対してはこのダイアログで選択したオプションが全く使われません。 その理由は、 印刷は印刷専用の処理システムが必要なほど特別な仕事なので、 GIMP にそれらを組み込んでいないからです。

Color Managed Display

モニタープロファイル

  • None : GIMP uses the colorimetric profile of your monitor.

  • Select color profile from disk : if you have one.

  • Try to use the system monitor profile : If checked, GIMP will try to use the display color profile of the system windows handler. Else, the configured monitor profile is used.

Rendering intent

  • This option is about how colors are converted from the color space of your image to your display device. Four modes are available: Perceptual, Relative colorimetric, Saturation and Absolute colorimetric.

    Relative colorimetric is usually the best choice (default). Unless you use a LUT monitor profile (most monitor profile are matrix), choosing perceptual intent actually gives you relative colorimetric.

    Use black point compensation

    • This option is checked by default. Do use black point compensation unless you have a reason not to.

Optimize image display for:

  • Two options: Speed and Precision/Color fidelity. Speed is activated by default. If not, image display might be better at the cost of speed.

Soft-proofing>

Soft-proofing is a mechanism that allows you to see on your screen what printing on paper will look. More generally, it is soft-proofing from the color space of your image to another color color space (printer or other output device).

Soft-proofing profile

None is the choice by default. The drop-down list offers the possibility of Select color profile from disk....

Rendering intent As above, four modes: Perceptual, Relative colorimetric, Saturation and Absolute colorimetric. Try them all and choose what looks the best.

Use black point compensation

Try with and without black point compensation and choose what looks best.

Optimize soft-proofing for:

Two options: Speed and Precision/Color fidelity. Speed is activated by default. If not, soft-proofing might be better at the cost of speed.

Mark out of gamut colors

When this box is checked, the soft-proofing will mark color that can not be represented in the target color space. On the right, a color button, when clicked, opens a color selector to choose the wanted color.

Preferred profiles

RGB プロファイル

Default is None and the built-in RGB profile is used. You can select another RGB working space color profile from disk: it will be offered next to the built-in profile when a color profile can be chosen.

Grayscale profile

Default is None and the built-in Grayscale profile is used. You can select another Grayscale working space color profile from disk: it will be offered next to the built-in profile when a color profile can be chosen.

CMYK プロファイル

Default is None. You can select a CMYK working space color profile from disk to convert RGB to CMYK.

Policies

File Open Behavior

Default is Ask what to do. You can also select Keep embedded profile or Convert to preferred RGB color profile to indicate how to treat embedded color profiles when opening an image file.

[注記] 注記

さらに詳しい説明をお求めならば:

  • ICC プロファイルについてはウィキペディアに説明があります。 [WKPD-ICC]

  • OpenICC プロジェクト ([OPENICC]) は GIMP や infography に名を連ねた偉大な面々が貢献して運営されています。

ウェブから取得できる多くのプロファイル:

  • ICC sRGB 作業用色空間: ICCsRGB[ICCsRGB]

  • Microsoft sRGB 作業用色空間: MsRGB[MsRGB]

  • Adobe RGB98 作業用色空間: Adobe RGB (1998)[AdobeRGB]

  • ECI (European Color Initiative) プロファイル: ECI[ECI]

1.4. Playground

図12.4 Insane Options

Insane Options

This page lets you select some experimental tools.


1.5. ツールオプション

図12.5 設定 ツールオプションのページ

設定 ツールオプションのページ

このページでツールのふるまいの諸相を誂える。


1.5.1. オプション

全般

終了時にツールオプションを保存する

言葉通り

今すぐツールオプションを保存

言葉通り

ツールオプションをリセット

言葉通り

拡大または縮小

既定の補間方法

[ラスター画像に]描画されたものを拡大もしくは縮小すると、 できた結果の画素はいずれも元画像のいくつかの画素が補間計算されてつくられます。 このオプションは既定の 補間方法 を定めますが、 拡大・縮小ツールではツールオプションの 補間アルゴリズム で、 拡大・縮小ダイアログでは 補間方法 でいつでも変更可能です。

つぎの 4 つの選択肢があります。

補間しない

これは最速ですがどう見ても粗雑です。 マシンの処理速度が深刻な被害を受けるというのであるときのみ、 これを考慮する価値があります。

線形

かつてはこの方法が初期設定になっていました。 さまざまな用途に十分良い結果が出ます。

キュービック

最高なのはこの方法です (ただし実際はある種の画像においては線形に劣る) が、 処理が最も遅くなります。 GIMP 2.6 よりこの方法が既定に据えられています。

NoHalo

This method performs a high quality interpolation. Use the NoHalo method when you downscale an image to less than a half of the original size.

LoHalo

This method performs a high quality interpolation. Use the LoHalo method when you do not reduce the size much (rotate, shear).

ツール共有の描画オプション

Brush, Dynamics,Pattern, Gradient

これらは何かの描画ツールでブラシ等を選ぶと他の描画ツールでもその新たに選択された物品が使われるようにするか、 それとも個々の描画ツール (鉛筆、 絵筆、 エアブラシなどなど) それぞれが直前に選ばれた物品を記憶しておくようにするかを定めます。

移動ツール

つかんだレイヤーやパスをアクティブにする

ここでは修飾キーなしで移動ツールを使いながら他のレイヤーやパスの活性化が可能かどうかを定めます。

1.6. 新しい画像作成時の初期設定

図12.6 設定 新しい画像作成時の初期設定

設定 新しい画像作成時の初期設定

このページでは新しい画像の作成ダイアログの既定値を定めます。 それぞれの値が示す意味については 新しい画像の作成 ダイアログの説明をご覧ください。

1.7. グリッドの設定

図12.7 設定 グリッドの設定のページ

設定 グリッドの設定のページ

このページでは GIMP のグリッド (格子線) の属性の初期設定値を誂えられます。 グリッドはメニューの 表示グリッドを表示 で表示と非表示が切り替えられます。 ここにある設定内容はメニューより 画像グリッドの設定... と進むと開かれる画像のグリッドを調整ダイアログの設定内容にそっくりですが、 そのダイアログは既存の画像においてグリッドを再設定するために使われています。 各設定項目の意味についての情報は グリッドの設定 でご覧ください。

1.8. ユーザーインターフェース

図12.8 設定 ユーザーインターフェースのページ

設定 ユーザーインターフェースのページ

このページでは言語と、 レイヤーとチャンネルのプレビューとキーボードショートカットが誂えられる。


オプション

言語の設定

GIMP は初期設定の場合、 お使いのシステムと同じ言語を用います。 他の言語へはこの引き出しリストで切り替えできます。 ただしこの指定は GIMP を再起動したあとに反映されます。 「言語」 を参照してください。

プレビュー

初期設定では、 レイヤーダイアログなどいろいろな場面で画像の縮小見本が表示されます。 何らかの理由でこの機能を無効にする場合には、 レイヤーとチャンネルのプレビューを表示する のチェックを外してください。 プレビューを表示する場合には プレビューサイズの既定値ナビゲーションのプレビューサイズ のメニューでその大きさが 9 段階に調節できます。

You can also customize the Undo preview size and the Navigation preview size.

キーボードショートカット

<!--メニュー上の項目は Alt キーと個々の呼応するキーとの組み合わせにより活性化できます。 普通はそれぞれのメニュー見出しに[(丸括弧)に入った]下線つきの英数字がついていて、 これらを アクセラレーター といいます。 (その表記が煩わしいとか使うつもりもないというふうな) 何らかの理由でこの表示が不要な場合は、 メニューにニーモニック (アクセスキー) を表示 のチェックを外すとよいでしょう。-->

GIMP はキーボードショートカット (メニュー項目を活性化するキーやキーの組み合わせ) が動的に作成可能です。 対象となるメニュー項目上にマウスポインターを合わせ、 キーを押せば登録完了です。 ただしこの機能は初心者ユーザーが誤って標準のキーボードショートカットを上書きする恐れがあるため、 初期設定では無効となっています。 これを有効にするには 動的キーボードショートカットを使用する にチェックを入れてください。

キーボードショートカット設定... ボタンをクリックすると キーボードショートカット設定 ダイアログが開かれます。 ここには[あらゆるコマンドと]メニュー項目が並んでおり、 ショートカットの登録が視覚的に行えます。

If you change shortcuts, you will probably want your changes to continue to apply in future GIMP sessions. If not, uncheck Save Keyboard Shortcuts on exit. But remember that you have done this, or you may be frustrated later. If you don't want to save shortcuts on exit every session, you can save the current settings at any time using the Save Keyboard Shortcuts Now button, and they will be applied to future sessions. If you decide that you have made some bad decisions concerning shortcuts, you can reset them to their original state by pressing Reset Saved Keyboard Shortcuts to Default Values. A new possibility: Remove All Keyboard Shortcuts.

1.9. テーマ

図12.9 設定 テーマのページ

設定 テーマのページ

This page lets you select a theme, which determines many aspects of the appearance of the GIMP user interface. Clicking on a theme in the list causes it to be applied immediately, so it is easy to see the result and change your mind if you don't like it.

1.10. テーマ

図12.10 Icon Theme Preference

Icon Theme Preference

This page lets you select a theme for the icons of the GIMP user interface. Test them: you will see the result instantly in this preference dialog.

1.11. ツールボックス

図12.11 設定 ツールボックスのページ

設定 ツールボックスのページ

1.11.1. オプション

図12.12 ツールボックスの外観 (初期設定)

ツールボックスの外観 (初期設定)

このページはツールボックスの底部にある 3 つの脈絡情報区画のそれぞれについて表示するかどうかを決めて外観を誂えるものです。 その効果については 「色と標識の区画」 をご覧ください。

表示スタイル

描画色と背景色

ツールボックスの下部左側 (2) の区画に色の標識区画を置くかどうか定めます。

アクティブなブラシ・パターン・グラデーション

ツールボックスの下部中央 (3) に現在のブラシとパターンとグラデーションのアイコンを表示するかどうかを指定します。

アクティブな画像

ツールボックスの下部右側 (4) に現在活性化している画像の縮尺見本を表示するかどうか決めます。

ツールアイコンの設定

この一覧表でのしるしがついているツールだけがツールボックスに現れます。 初期設定では色ツールにのしるしがありません。 表示させたいツールの欄をクリックすればこのしるしが切り替わりツールボックスに加わります。

ツールの表示順がダイアログ底部の上下矢印ボタンで調整できます。

このオプションはもともと GIMP の以前の版でツールオプションダイアログにあった内容です。

1.12. Dialog Defaults

図12.13 Dialog Default

Dialog Default

This page lets you customize the default parameters of dialogs.


1.13. ヘルプ

図12.14 Help System Preferences

Help System Preferences

このページでは GIMP のヘルプ機構のふるまいを誂えられる。


1.13.1. オプション

全般

ツールチップを表示する

ツールチップとはボタンやアイコンのような一部のインターフェース要素の上にマウスポインターをかざしたときに短時間だけ現れる小さなふきだしのことで、 中に文章が書かれています。 その内容はときにはその要素が何であるかを述べ、 ときにはその要素の明らかには気付かれない使い方を示唆します。 でもこれが作業の集中の妨げになるというときは、 ここでオプションのチェックを外せば無効にできます。 非常に熟達したユーザーでもない限りはここに手をつけずにおくことをお勧めします。

ヘルプボタンを表示する

このオプションは、 情況適応ヘルプを利用するための ヘルプ ボタンが各ツールのダイアログの底部に表示されるかどうかを制御するものです。

使用するユーザーマニュアル

この引き出しリストで インストール版オンライン版 を選択してください。 「ヘルプ」 もご覧ください。

ヘルプブラウザー

使用するヘルプブラウザー

GIMP のヘルプは HTML ファイル即ちウェブページの形式で提供されています。 これを読むには GIMP に付いてくる特別なヘルプブラウザーと、 お好きなウェブブラウザーのどちらも使えます。 ここでどれを使うかを選択します。 これらヘルプページは GIMP 内蔵ブラウザーで正しく表示されるよう入念に検査されているのに対し、 他のウェブブラウザーはその機能の保証にばらつきがありますので、 ここは内蔵ブラウザーを選ぶ方が確実でしょう。 とはいえ実際のところ最近のウェブブラウザーはどれもちゃんと表示できています。

[注記] 注記

Note that the GIMP help browser is not available on all platforms. If it is missing, this option is hidden and the standard web browser will be used to read the help pages.

Action Search

Maximum History Size

Default value is 100 (0-1000) items in the history.

Show unavailable actions

When this check-box is enabled, a search of actions will also return inactive actions.

Clear Action History

Self-explanatory.

1.14. ディスプレイ

図12.15 設定 ディスプレイのページ

設定 ディスプレイのページ

このページは画像の透明部分の視覚化表現を選択し、 モニターの解像度を測定する。


1.14.1. オプション

透明部分の表示方法

スタイル

初期設定では GIMP は透過部分を中間調の市松模様で表現しますが、 変更可能です。 この中間調のほかに明るい市松模様と暗い市松模様があり、 単色では黒、 白、 灰色から選べます。

市松模様のサイズ

透明部分の表示方法に市松模様を選んだ場合にここでその正方形の大きさを指定できます。

図12.16 モニター解像度測定ダイアログ

モニター解像度測定ダイアログ

モニター解像度

モニター解像度とは垂直と水平それぞれの 1 インチあたりの画素数 (ピクセル数) のことです。 手掛かりを得る方法は 3 つあります。

  • ウィンドウシステムに解像度を問い合わせます。 (最も手軽にできますが不正確なおそれがあります)。

  • 手づから自ら入力します。

  • 測定 ボタンをクリックすると、 モニター解像度測定ダイアログが開かれます。 実際にモニター画面に定規を押し当て、 縦と横にそれぞれ置かれた画面上の定規の全長を読み取って入力欄に記入します。 単位は変更できます。 OK をクリックするとその結果が 手動設定 の各数値に反映されます。

1.15. ウィンドウの設定

図12.17 設定 ウィンドウの設定のページ

設定 ウィンドウの設定のページ

このページでは GIMP でどのように各ウィンドウを扱うかを設定します。 ご理解いただきたいのは GIMP は各ウィンドウを直接は操作せず、 ウィンドウマネージャーに依頼する方式をとっていることです。 (ウィンドウマネージャーとは MS Windows™ におけるウィンドウズのシステムだとか、 X11™ ウィンドウシステムで標準的に組み上げた Gnome™ 上の Metacity などです。) ウィンドウマネージャーは数多くの種類がありそのすべてが順当に作動するわけではないので、 実際はここに示した機能が説明どおりにはたらく保証はありません。 しかし最近の標準に忠実なウィンドウマネージャーをお使いならば確実でしょう。

1.15.1. オプション

ウィンドウマネージャーのヒント

ドックとツールボックスのヒント

ここで選択できるのはツールボックスとダイアログ群を纏めるドックの扱われ方です。 3 つの選択肢があります。

  • 通常のウィンドウ を選択した場合は他のウィンドウと同じように扱われます。

  • ユーティリティウィンドウ を選択した場合は、 タイトルバーから最小化ボタンが除かれドックが常時画面上に居座ります。

    図12.18 補助ウィンドウのタイトルバー

    補助ウィンドウのタイトルバー

    通常のタイトルバー

    補助ウィンドウのタイトルバー

    補助ウィンドウのタイトルバー


  • 常に前面 を選ぶと常時他のすべてのウィンドウよりも前面に居座ります。

この設定が有効になるのは次回 GIMP を起動して以降になりますことをご承知おきください。

フォーカス

フォーカスされた画像をアクティブにする

普通はどれかの画像ウィンドウをフォーカスすると (大抵はそのウィンドウ枠の色が変化するのでわかる)、 その画像は GIMP活性画像になり、 画像に関連した操作の対象となります。 ところがウィンドウにマウスポインターをかざしただけだけで自動的にフォーカスするようなウィンドウマネージャーの設定を好む人々もいます。 この設定を適用してみると画像ウィンドウにフォーカスしただけでその画像が自動的に活性化するのは不便なことがわかります。 そういった方はこのオプションのチェックを外すとよいでしょう。

ウィンドウ位置

終了時にウィンドウの位置を保存する

このオプションにチェックを入れると、 GIMP を起動したときに、 ダイアログのウィンドウやツールボックスが前回終了時点で置かれた位置と大きさのままに開かれます。

今すぐウィンドウ位置を保存

このボタンは 終了時にウィンドウの位置を保存する にチェックを入れない場合に役立ちます。 あらかじめお好みの位置にウィンドウを置いてからこのボタンをクリックすると、 GIMP を起動する度にその配置でウィンドウが開かれるようになります。

保存済ウィンドウ位置をリセット

いったん保存したウィンドウ配置が気に入らなくなったときに、 それらをいちいち再配置するよりは初期設定の配置に戻してしまいたいとお考えならばこのボタンをクリックすればよいのです。

1.16. 画像ウィンドウ

図12.19 設定 画像ウィンドウのページ

設定 画像ウィンドウのページ

このページで画像ウィンドウのふるまいの諸相を誂えられる。


1.16.1. オプション

全般

ピクセル等倍で表示

ピクセル等倍Dot for dotとも言われ、 1:1 の等倍率にズームされます。 このオプションを無効にすると、 画像の大きさは画像の X と Y の解像度で判断されます。 より詳しくは 画像の拡大・縮小 をご覧ください。

蟻の行進速度

選択範囲を作成すると、 その輪郭線は破線で囲まれ、 破線は輪郭線上を行進しているように見えます。 これには蟻の行進という冗談みたいな名前がついています。 ここで指定する数値が小さくなるにつれ、 蟻たちの行進は速く (そして騒々しく) なります。

ズームとウィンドウサイズ変更

ズーム時にウィンドウサイズを変更する

このオプションにチェックが入ると、 画像を伸縮ズーム表示する度に画像ウィンドウが自動的にその大きさに合わせてサイズ変更します。 逆に無効にすれば、 画像の表示倍率を変えても画像ウィンドウの大きさはそのままです。

キャンバスサイズ変更時にウィンドウサイズも変更する

このオプションにチェックが入ると、 切り抜きや拡大・縮小によって画像の大きさを変える度に、 画像ウィンドウもそれに合わせて大きさを変えます。 逆に無効にすれば、 画像ウィンドウの大きさはそのままです。

既定の表示倍率

画像を初めて開いたときに、 その画像がディスプレイ画面をはみ出さないように縮小表示するか、 倍率 1:1 で等倍表示するかをここで選択します。 第 2 の選択肢を選んでいて画像がディスプレイ画面より大き過ぎる場合には、 画像ウィンドウでは画像の一部だけが見えるように表示されます。 (残りの部分を見るには画像キャンバスをスクロールします。)

スペースキー

スペースキーが押されているとき
  • ビューを移動 (パン) これが初期設定です。 キャンバスをウィンドウ内で移動します。 スクロールや 「ナビゲーションダイアログ」 と同じ用途に使えます。

  • Toggle to Move Tool

  • 何もしない

マウスポインター

ブラシの輪郭を表示する

このオプションにチェックを入れると、 描画ツールを起用したときに画像上にブラシの輪郭が表示されマウスポインターとして動かせます。 低速なシステムでの GIMP でとくに大きなブラシを用いている場合に、 マウスやタブレットの動きとポインターの位置にずれが生じることがあります。 このオプションを切ればそれを避けられそうです。 でもブラシ表示は実に役に立つものではないでしょうか。

描画ツールのポインターを表示する

ここにチェックを入れると、 ポインターの表示が変更できます。 ブラシの輪郭を表示している場合は、 その姿はブラシの輪郭に重ねられます。 ポインターの形状は次のオプションで定まります。

ポインターのモード

このオプションは 描画ツールのポインターを表示する にチェックが入っていなければ何の効果もありません。 有効な場合には 3 つの選択肢があります。 ツールアイコン はポインターの側に現在起用しているツールを示す小さなアイコンが付きます。 このアイコンは次のオプションでその姿が変更できます。 十字付きツールアイコン もツールを示す小さなアイコンが付きますが、 ポインターの中心を表す照準十字も表示されます。 そのほか 十字のみ があります。

ポインターの表現方法

ここで 装飾的 を選ぶと、 ポインターの側に示されるツールアイコンはグレースケールで表示されます。 もう一方の 黒と白 は簡素な表示になります。 こちらは処理速度に問題のあるシステムでわずかに速度向上の役に立つと思われます。

1.17. 画像ウィンドウの表示スタイル

図12.20 設定 画像ウィンドウの表示スタイルのページ

設定 画像ウィンドウの表示スタイルのページ

このページでは画像ウィンドウの表示形式について、 フルスクリーンで表示をしない場合とする場合の 2 つに分けて初期設定値を誂えられる。 ここに挙げられた設定項目はいずれも表示メニューの画像特有の項目で変更できる。 各項目が示す意味とその情報については 画像ウィンドウ をご覧いただきたい。


ここでひとつだけ、 キャンバス周辺の表示 (パディング) についてもっと説明しておかなければならないでしょう。 パディングとは画像が画像ウィンドウのすべてを占めていないときに、 画像の外周不活性区域を示す色や表現のことです。 (このてびきの図はすべて明るい灰色にしてあります。) このキャンバス周辺の表示モードには 4 つの選択肢があります。 現在のテーマで指定した色を使用するもの、 画像の透過部分によく似た市松模様の明るい配色のものと暗い配色のもの、 そして キャンバス周りの表示色 で誂えた色を使用するものです。

1.18. 画像ウィンドウのタイトルとステータスバー

図12.21 設定 画像ウィンドウのタイトルとステータスバーの形式のページ

設定 画像ウィンドウのタイトルとステータスバーの形式のページ

このページでは画像ウィンドウのタイトルバーとステータスバーの 2 つの部分での文字表記の形式を誂えられる。 タイトルバーは画像ウィンドウの上部に現れるはずだが、 これはウィンドウマネージャーの助力に依存するためすべての状況で動作する保証はない。 ステータスバーは画像ウィンドウの下部右寄りにある。 より詳しくは 画像ウィンドウ を見てほしい。


1.18.1. 形式を選抜

数点のお仕着せな表現形式からひとつを選ぶか、 自分流の 形式文字列 を入力欄に書いてください。 ここで形式文字列について説明しましょう。 % 記号で始まるアルファベット (大文字と小文字の区別あり) で表せる 変数 を除き、 書き込んだ文字はそのまま表示されます。 使用可能な変数はつぎのとおりです。

変数 意味
%f 画像ファイルの素の名前、 さもなくば名称未設定
%F ファイル名をフルパスで、 さもなくば名称未設定
%p 画像の id 番号 (重複なし)
%i 表示番号。 複数のウィンドウで同じ画像を開いている場合に
%t 画像のモード (RGB カラー、 グレースケール、 インデックスカラー)
%z 表示倍率 (百分率)
%s 倍率の分母 (倍率 = %d/%s)
%d 倍率の分子 (倍率 = %d/%s)
%Dx 画像が手付き (未保存の変更あり) の場合には文字 x を表示、 手付かずならば何もしない
%Cx 画像が手付かず (未保存の変更なし) の場合には文字 x を表示、 手付きならば何もしない
%l レイヤーの層数
%L レイヤーの層数 (長い表記)
%m その画像のメモリー使用量
%n 活性化レイヤー/チャンネルの名称
%P 活性化レイヤー/チャンネルの id 番号
%w 画像の幅 (ピクセル単位)
%W 画像の幅 (実測的単位)
%h 画像の高さ (ピクセル単位)
%H 画像の高さ (実測的単位)
%u 単位表記 (ピクセルなら px)
%U 簡略化単位
%% % 記号そのもの

1.19. Image Window Snapping Behavior

図12.22 Image Window Snapping Behavior

Image Window Snapping Behavior

This page allows you to customize snapping in the image. Only Snap to Guides is activated by default. You can also check Snap to Grid, Snap to Canvas Edges and Snap to Active Path, in normal mode and fullscreen mode.

Snapping distance is the activation distance of snapping, in pixels. Default value is 8 pixels (1-255).

1.20. 入力デバイス

図12.23 設定 入力デバイスのページ

設定 入力デバイスのページ

追加入力デバイス

Share tool and tool options between input devices

When enabled, the same tool and tool options will be used for all input devices. No tool switching will occur when the input device changes.

追加された入力デバイスの設定...

この大きなボタンでタブレットや MIDI キーボードなど、 コンピューターに接続された周辺装置を設定できます。 タブレットを導入されておればつぎのようなダイアログが現れます。

図12.24 タブレットでの設定

タブレットでの設定

入力デバイスの設定を終了時に保存する

When you check this box, GIMP remembers the tool, color, pattern, and brush you were using the last time you quit.

今すぐ入力デバイス設定を保存

言葉通り

入力デバイス設定のリセット

これまでの設定を破棄し、 既定の設定に戻します。

1.21. 入力コントローラー

図12.25 設定 入力コントーラーのページ

設定 入力コントーラーのページ

This dialog has two lists of additional input controllers: Available Controllers on the left, Active Controllers on the right. It is used to enable or disable an input device and configure it.

項目をクリックして強調表示させてから、 左右の矢印ボタンをクリックすればそのコントローラーはもう一方のリストに移動できます。 アクティブなコントローラーの側の項目を利用可能なコントローラーの側に移動すると、 ダイアログが現れてそのコントローラーを削除するのか無効にするだけなのかを問われます。

一覧表 (主にアクティブなコントローラー) の項目をダブルクリックするか、 あるいはその一覧表の下側にある 選択したコントローラーの設定 アイコンをクリックすると、 そのコントローラーを設定するダイアログが開かれます。

Main Mouse Wheel

図12.26 Main Mouse Wheel

Main Mouse Wheel


全般
このコントローラーからのイベントをダンプする

このオプションは利用可能にしたコントローラーが発するイベントを標準出力 stdout に書き出したいときにチェックを入れます。 そのイベント情報を見るためには、 コマンドターミナルで GIMP を起動する必要がありますが、 得た出力はシェルのリダイレクト機能を使えばファイルに保存もできます。 このオプションの主な使い道はデバッグです。

このコントローラーを有効にする

ここでマウスホイールに新たな操作を追加する場合にはこのオプションを有効にする必要があります。

マウスホイールのイベント

このウィンドウのスクロールバーの付いた表をご欄ください。 左側にはマウスホイールと多少の修飾キーの考えうるすべての組み合わせが並び、 右側にはそれらのイベント発生のどれかに関連づけられた GIMP の操作があります。 さらにここにはボタンが 3 つあります。 イベントを横取り編集 ボタンをクリックするとコントローラーのアクションイベントを選択ダイアログが開かれますので、 ここでイベントに関連づけたい GIMP の操作を選択してください。 クリア ボタンはそのイベントに何も関連づけられていない状態にします。

操作がいくつか既にイベントに関連づけられています。

イベントに割り当てるアクションを選択

イベントを選択してから 編集 ボタンをクリックするとつぎのようなダイアログが開かれます。

図12.27 コントローラーのアクションイベントを選択

コントローラーのアクションイベントを選択

このイベントに対するアクションが既にある場合は、 ウィンドウではそのアクションが強調表示されます。 無ければウィンドウはアクションをメニューの分類で列挙します。 クリックした行が選択されます。

Main Keyboard

このダイアログの使い方はマウスホイールのときと同じです。 扱われているイベントはキーボードの矢印キーに多少の修飾キーを組み合わせたものです。

図12.28 Main Keyboard

Main Keyboard

[注記] 注記

以上のことをふまえた例が 大きさの変わるブラシの作成法 にあります。

1.22. フォルダー

図12.29 設定 基本のフォルダーのページ

設定 基本のフォルダーのページ

このページでは GIMP が一時的なファイルを置くための 2 箇所の重要なフォルダーの位置を設定できます。 このページ以降では GIMP で扱うたとえばブラシのようなファイル資材を探し出す位置を、 個別に設定できるようになっています。 それぞれの説明が次項 データフォルダー にあります。ここに示されたフォルダー以外の位置を指定する場合は、 引き出しメニューから選択するか、 その下端にある その他... をクリックしておのおののフォルダー選択ダイアログで指定してください。

フォルダー

一時フォルダー

このフォルダーは一時的に発生するファイルを置くために使われます。 これらのファイルは作業用データを暫時保存するために作成され、 その GIMP 操作の期間内に消去されます。 大きな容量も高い性能も必要ありません。 初期設定では個人用 GIMP 内の tmp というサブディレクトリーが使われますが、 ディスク残量がたいへん窮屈になっていたり重大な性能問題がある場合には、 ここで他のディレクトリーに替えましょう。 ただしそのディレクトリーが存在し、 なおかつそのディレクトリーに対する読み書きの権限が必要です。 無ければまずいことになるでしょう。

スワップ用フォルダー

このフォルダーは GIMP で開かれたすべての画像とデータの容量が使用可能な RAM の限界を越してしまった場合のメモリー貯蔵庫として使われます。 とても大きな画像やレイヤーを多数持つ画像を扱ったり、 多数の画像を同時に開いたときに GIMP は可能性として数百メガバイトものスワップ空間を要求することになりうるのですが、 ディスク容量がどこまで利用可能かという問題やその性能についてはこのフォルダーに明確にかかっています。 初期設定ではここは GIMP の個人用ディレクトリー内に置かれますが、 もっと大きな容量のディスクや、 実際的に性能がより良いディスクが他にある場合には、 そちらにスワップフォルダーを移動すれば目に見えて恩恵を得るでしょう。 もちろんそのディレクトリーが必ず存在し、 書き込み権限を持っていなくてはなりません。

1.23. データフォルダー

図12.30 設定 ブラシ用フォルダーのページ

設定 ブラシ用フォルダーのページ

GIMP が扱う資材はブラシ、 パターン、 グラデーションなど様々な種類があります。 それぞれの基本的な構成は GIMP を導入した時点で提供されますが、 さらにユーザー自身で作成したりダウンロードしてきたものを追加できます。 ここには各々の資材の種類に合わせた設定のページがあり、 サーチパス (検索対象位置) を設定できるようになっています。 各資材を探し出すパスを複数指定でき、 そのディレクトリーはすべて GIMP の起動時に読み込まれます。 いずれのページの構成も同じですので、 例としてブラシのページを上図に載せておきました。

初期設定で既に 2 つのフォルダーが検索対象に含まれています。 システム用 フォルダーは GIMP とともにインストールされた物品の置かれる場所です。 個人用 フォルダーは GIMP の個人用ディレクトリー内にあり、 ご自分で作成された資材はここに収めてください。 システム用フォルダーには書き込み可能の印が付きません。 その内容を変更しようとしないでください。 個人用フォルダーの方には書き込み可能の印が付いていなればなりません。 もし不可にすると先に置いてあった物以外に何も無い場所になり無意味だからです。

このダイアログページの上に並んでいるボタンを使えば検索対象位置を設定できます。

オプション

フォルダーを選択する

一覧表内のいずれかのフォルダーをクリックすると、 つぎに挙げる操作の対象として選択されます。

フォルダーを追加する/置き換える

入力欄にフォルダーの名前を書き込むか、 右端の 「ファイル選択」 ボタンの案内で名前を指定したなら、 つぎに左端のボタンをクリックすれば先に選択したフォルダーがここで新たに指定したフォルダーに置き換わります。 先にフォルダーを何も選択していなかった場合は、 指定したフォルダーが一覧表に追加されます。 テキスト入力欄の左側にある丸いランプが緑ではなく赤を灯している場合は、 存在しないフォルダーを指定したことを示しています。 GIMP はディレクトリーを作成しませんので、 ご自分で直ちにフォルダーを作ってください。

上げる/下げる

「上向き矢印」 ボタンや 「下向き矢印」 ボタンをクリックすると、 選択されたフォルダーが一覧表内で前後に移動します。 上から順にフォルダーが読み込まれますので、 そこに置かれた物品の読み込み優先順位がこのボタンで変更できることになります。

フォルダーを除外する

「ごみ箱」 ボタンをクリックすれば選択されたフォルダーは一覧表から削除されます。 (フォルダーそのものを削除するのではありません。 検索対象位置から除外するだけです。) システム用フォルダーを削除することもできますがおやめください。