Cap. 16. Menus

Cuprins

1. Introducere în Meniuri
1.1. Bara de meniu a imaginii
1.2. Meniuri contextuale
1.3. Meniuri de rupere
1.4. Meniuri de filă
2. Meniul Fișier
2.1. Prezentare generală
2.2. New…
2.3. Create
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. Save
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Print
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Close
2.20. Close all
2.21. Quit
3. Meniul Editare
3.1. Edit Menu Entries
3.2. Undo
3.3. Redo
3.4. Undo History
3.5. Cut
3.6. Copy
3.7. Copy Visible
3.8. Paste
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Paste as
3.13. Buffer
3.14. Clear
3.15. Fill with FG Color
3.16. Fill with BG Color
3.17. Fill with Pattern
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Stroke Selection
3.21. Stroke Path
3.22. The Preferences Command
3.23. Keyboard Shortcuts
3.24. Modules
3.25. Units
4. Meniul Selectează
4.1. Introducere în meniul Selectează
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Save to Channel
4.19. To Path
5. Meniul Vizualizare
5.1. Introduction to the View Menu
5.2. New View
5.3. Show All
5.4. Dot for Dot
5.5. Zoom
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Shrink Wrap
5.9. Full Screen
5.10. Navigation Window
5.11. Display Filters
5.12. Color Management
5.13. Show Selection
5.14. Show Layer Boundary
5.15. Show Guides
5.16. Show Grid
5.17. Show Sample Points
5.18. Snap to Guides
5.19. Snap to Grid
5.20. Snap to Canvas
5.21. Snap to Active Path
5.22. Padding Color
5.23. Show Menubar
5.24. Show Rulers
5.25. Show Scrollbars
5.26. Show Statusbar
6. Meniul Imagine
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transform
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Canvas Size
6.18. Fit Canvas to Layers
6.19. Fit Canvas to Selection
6.20. Print Size
6.21. Scale Image
6.22. Crop Image
6.23. Slice Using Guides
6.24. Zealous Crop
6.25. Merge Visible Layers
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Guides
6.29. New Guide
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Remove all guides
6.33. Configure Grid…
6.34. Image Properties
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Meniul Strat
7.1. Introduction to the Layer Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop Layer
8. Meniul Culori
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturation
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invert
8.13. Linear Invert
8.14. Value Invert
8.15. The Auto Submenu
8.16. Egalizează
8.17. Balans de alb
8.18. Întindere contrast
8.19. Întindere HSV
8.20. Îmbunătățire culoare
8.21. Îmbunătățire culoare (Moștenire)
8.22. The Components Submenu
8.23. Mixer canal
8.24. Extragere componentă
8.25. Mixer mono
8.26. Compunere
8.27. Descompune
8.28. Recompune
8.29. Color la gri
8.30. Desaturare
8.31. Sepia
8.32. The Map Submenu
8.33. Rearanjare paletă de culori
8.34. Stabilește paleta de culori
8.35. Hartă alien
8.36. Schimb de culori
8.37. Rotire culori
8.38. Hartă degrade
8.39. Hartă de paletă
8.40. Exemplu de colorare
8.41. Fattal și restul. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stres
8.45. Retinex
8.46. The Info Submenu
8.47. Histogramă
8.48. Culoarea medie a chenarului
8.49. Analiză de spațiu de culoare
8.50. Exportă histogramă
8.51. Netezește paleta
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. Meniul Unelte
9.1. Introducere în meniul Unelte
10. Meniul Filtre
10.1. Introducere în meniul Filtre
10.2. Repetă ultimul
10.3. Arată din nou ultimul
10.4. Restabilește toate filtrele
10.5. Submeniul Python-Fu
10.6. Submeniul Script-Fu
11. Meniul Ferestre
12. Meniul Ajutor
12.1. Introducere în meniul Ajutor
12.2. Ajutor
12.3. Ajutor contextual
12.4. Sfatul zilei
12.5. Despre
12.6. Navigator de module
12.7. Navigatorul de proceduri
12.8. GIMP online

1. Introducere în Meniuri

Există multe locuri în GIMP unde puteți găsi meniuri. Scopul acestui capitol este de a explica toate comenzile care sunt accesibile din bara de meniu a imaginii și din meniul imagini pe care îl puteți obține și prin clic dreapta pe canava. Toate meniurile contextuale și intrările de meniu pentru celelalte dialoguri sunt descrise în altă parte în capitolele care descriu dialogurile în sine.

1.1. Bara de meniu a imaginii

Această bară de meniu poate conține alte intrări dacă ați adăugat script-fus, python-fus sau clipuri video la GIMP.

1.2. Meniuri contextuale

Dacă dați clic dreapta pe anumite părți din interfața GIMP, se deschide un meniu contextual, ceea ce duce la o varietate de funcții. Unele locuri unde puteți accesa meniuri contextuale sunt:

  • Clic pe o fereastră a imaginii afișează meniul Imagine. Acest lucru este util când lucrați în modul ecran complet, fără o bară de meniu.

  • Clic pe un strat în dialogul Straturi sau pe un canal în dialogul Canale afișează funcții pentru stratul sau canalul selectat.

  • Clic dreapta pe bara de meniu a imaginii are același efect ca și clic stânga.

  • Clic dreapta pe bara de titlu afișează funcțiile care nu aparțin lui GIMP, ci programului de gestionare a ferestrelor de pe calculator.

1.3. Meniuri de rupere

Există o proprietate interesantă asociată cu unele dintre meniurile din GIMP. Acestea sunt oricare dintre meniurile din meniul contextual al imaginii pe care le obțineți dând clic dreapta pe canava și pe oricare dintre submeniurile sale. (Vă puteți da seama că un element de meniu conduce la un submeniu, deoarece există o iconiță lângă acesta.) Când deschideți oricare dintre aceste meniuri, există o linie punctată în partea de sus a acestora (linie de rupere). Dând clic pe această linie punctată, detașați meniul de sub el și acesta devine o fereastră separată.

Fig. 16.1. Submeniul Ferestre și submeniul său de rupere

Submeniul „ Ferestre” și submeniul său de rupere
Submeniul „ Ferestre” și submeniul său de rupere

Meniurile de rupere devin de fapt independente. Ele sunt întotdeauna vizibile, funcțiile lor se aplică întotdeauna imaginii curente, și ele persistă atunci când toate imaginile sunt închise. Puteți închide un submeniu de rupere dând clic din nou pe linia punctată sau prin închiderea ferestrei din gestionarul de ferestre de pe calculator (de multe ori dând clic pe o iconiță X în colțul din dreapta sus al ferestrei).

Aceste submeniuri de rupere sunt, de asemenea, create în modul fereastră unică, dar sunt de interes mai scăzut, deoarece acestea sunt mascate de fereastră de îndată ce dați clic pe ea.

1.4. Meniuri de filă

Următorul tip de meniuri nu este legat de bara de meniu a imaginii, dar din motive de completitudine:

Fiecare dialog andocabil conține un buton de meniu de filă, așa cum este evidențiat mai jos. Apăsând acest buton de meniu de filă deschide un meniu special de operații legate de filă, cu o intrare în partea de sus care se deschide în meniul contextual al dialogului.

Fig. 16.2. Un dialog andocabil.

Un dialog andocabil.

O fereastră de dialog cu butonul de meniu de filă evidențiat.

Un dialog andocabil.

Meniul filă.


Consultați Secțiune 2.3.2, „Meniu tab” pentru a afla mai multe despre meniurile de filă.