GIMP - GNU 图像处理程序

用户手册

法律提示

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section enphrased GNU Free Documentation License.


目录

前言
1. GIMP 用户手册作者及贡献者
I. 开始使用 GIMP
1. 简介
1. 欢迎使用 GIMP
1.1. 作者
1.2. GIMP 帮助系统
1.3. 特性和功能
2. What's new in GIMP 2.10?
2.1. Updated user interface and initial HiDPI support
2.2. GEGL port, high bit depth support, multi-threading, and more
2.3. Linear color space workflow
2.4. Color management revamped
2.5. Layers and masks
2.6. More use for CIE LAB and CIE LCH
2.7. New and improved tools
2.8. Digital painting improvements
2.9. Digital photography improvements
2.10. Effects
2.11. Usability improvements
2.12. File formats support
2.13. Metadata viewing, editing, and preservation
2.14. On-canvas interaction
2.15. Simplified bug reporting and crash recovery
2.16. API changes
2.17. Roadmap and what's next
2. Fire up the GIMP
1. Running GIMP
1.1. Known Platforms
1.2. Language
1.3. Command Line Arguments
2. Starting GIMP the first time
2.1. Finally . . .
3. First Steps with Wilber
1. Basic Concepts
2. Main Windows
2.1. The Toolbox
2.2. Image Window
2.3. Dialogs and Docking
3. Undoing
3.1. 不可撤销的操作
4. Common Tasks
4.1. Intention
4.2. Change the Size of an Image for the screen
4.3. Change the Size of an Image for print
4.4. Compressing Images
4.5. Crop An Image
4.6. Find Info About Your Image
4.7. Change the Mode
4.8. Flip An Image
4.9. Rotate An Image
4.10. Separating an Object From Its Background
5. How to Draw Straight Lines
5.1. Intention
5.2. Examples
4. Getting Unstuck
1. Getting Unstuck
1.1. Stuck!
1.2. Common Causes of GIMP Non-Responsiveness
II. How do I Become a GIMP Wizard?
5. Getting Images into GIMP
1. Image Types
2. Creating new Files
3. Opening Files
3.1. Open File
3.2. Open Location
3.3. Open Recent
3.4. Using External Programs
3.5. File Manager
3.6. Drag and Drop
3.7. Copy and Paste
3.8. Image Browser
6. Getting Images out of GIMP
1. Files
1.1. Save / Export Images
1.2. File Formats
2. Preparing your Images for the Web
2.1. Images with an Optimal Size/Quality Ratio
2.2. Reducing the File Size Even More
2.3. Saving Images with Transparency
7. Painting with GIMP
1. 选区
1.1. Feathering
1.2. Making a Selection Partially Transparent
2. Creating and Using Selections
2.1. Moving a Selection
2.2. Adding or subtracting selections
3. The QuickMask
3.1. 预览
3.2. 属性
4. Using QuickMask Mode
5. Paths
5.1. Path Creation
5.2. Path Properties
5.3. Paths and Selections
5.4. Transforming Paths
5.5. Stroking a Path
5.6. Paths and Text
5.7. Paths and SVG files
6. Brushes
7. Adding New Brushes
8. The GIH Dialog Box
9. Varying brush size
9.1. How to vary the height of a brush
9.2. Creating a brush quickly
10. Gradients
11. Patterns
12. Palettes
12.1. Colormap
13. Presets
14. Drawing Simple Objects
14.1. Drawing a Straight Line
14.2. Creating a Basic Shape
8. 合并图像
1. Introduction to Layers
1.1. Layer Properties
2. Layer Modes
3. Creating New Layers
4. Layer Groups
9. Text Management
1. Text Management
1.1. Text Area
1.2. Managing Text Layer
1.3. Text Toolbox
1.4. Text Context Menu
2. Text
2.1. Embellishing Text
2.2. Adding Fonts
2.3. Font Problems
10. Enhancing Photographs
1. Working with Digital Camera Photos
1.1. Introduction
1.2. Improving Composition
1.3. Improving Colors
1.4. Adjusting Sharpness
1.5. Removing Unwanted Objects from an Image
1.6. Saving Your Results
11. Color Management with GIMP
1. Color Management in GIMP
1.1. Problems of a non Color Managed Workflow
1.2. Introduction to a Color Managed Workflow
12. Enrich my GIMP
1. Preferences Dialog
1.1. Introduction
1.2. System Resources
1.3. Color Management
1.4. Playground
1.5. Tool Options
1.6. Default Image Preferences
1.7. Default Image Grid
1.8. Interface
1.9. Theme
1.10. Theme
1.11. Toolbox
1.12. Dialog Defaults
1.13. Help System
1.14. Display
1.15. Window Management
1.16. Image Windows
1.17. Image Window Appearance
1.18. Image Window Title and Statusbar
1.19. Image Window Snapping Behavior
1.20. Input Devices
1.21. Input Controllers
1.22. Folders
1.23. Data Folders
2. Grids and Guides
2.1. The Image Grid
2.2. Guides
3. Rendering a Grid
4. How to Set Your Tile Cache
5. Creating Shortcuts to Menu Functions
6. Customize Splash-Screen
13. Scripting
1. 插件
1.1. 简介
1.2. 使用插件
1.3. Installing New Plugins
1.4. 编写插件
2. 使用 Script-Fu 脚本
2.1. Script-Fu?
2.2. Installing Script-Fus
2.3. Do's and Don'ts
2.4. 两种不同的 Script-Fu
2.5. 独立脚本
2.6. 基于图像的脚步
3. A Script-Fu Tutorial
3.1. Getting Acquainted With Scheme
3.2. Variables And Functions
3.3. Lists, Lists And More Lists
3.4. Your First Script-Fu Script
3.5. Giving Our Script Some Guts
3.6. Extending The Text Box Script
3.7. Your script and its working
III. 函数参考
14. 工具
1. The Toolbox
1.1. Introduction
1.2. Tool Icons
1.3. Color and Indicator Area
1.4. Tool Options
2. Selection Tools
2.1. Common Features
2.2. Rectangle Selection
2.3. Ellipse Selection
2.4. Free Selection (Lasso)
2.5. Fuzzy selection (Magic wand)
2.6. Select By Color
2.7. Intelligent Scissors
2.8. 前景选择
3. Paint Tools
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. 油漆桶填充
3.5. 梯度
3.6. 铅笔
3.7. 画笔
3.8. MyPaint Brush
3.9. 橡皮
3.10. 喷枪
3.11. 墨水
3.12. 克隆
3.13. 复原
3.14. 透视克隆
3.15. Blur/Sharpen
3.16. 涂抹
3.17. 减淡/加深
4. Transform Tools
4.1. Common Features
4.2. 对齐
4.3. 移动
4.4. 剪裁
4.5. 旋转
4.6. 缩放
4.7. 切变
4.8. 透视
4.9. 翻转
4.10. The Cage Tool
4.11. Unified Transform
4.12. Warp Transform
4.13. Handle Transform
5. Other
5.1. Overview
5.2. Paths
5.3. Color Picker
5.4. Zoom
5.5. Measure
5.6. Text
5.7. GEGL Operation
15. 对话框
1. Dialog Introduction
2. Image Structure Related Dialogs
2.1. Layers Dialog
2.2. Channels Dialog
2.3. Paths Dialog
2.4. Colormap Dialog
2.5. Histogram dialog
2.6. Navigation Dialog
2.7. Undo History Dialog
3. Image-content Related Dialogs
3.1. FG/BG Color Dialog
3.2. Brushes Dialog
3.3. Patterns Dialog
3.4. Gradients Dialog
3.5. Palettes Dialog
3.6. Tagging
3.7. Fonts Dialog
4. Image Management Related Dialogs
4.1. Buffers Dialog
4.2. Images Dialog
4.3. Document History Dialog
4.4. Templates Dialog
5. Misc. Dialogs
5.1. Tool Presets Dialog
5.2. Tool Preset Editor
5.3. Device Status Dialog
5.4. Error Console
5.5. Save File
5.6. Export File
5.7. Sample Points Dialog
5.8. Pointer Dialog
5.9. Symmetry Painting dialog
16. 菜单
1. Introduction to Menus
1.1. The Image Menu Bar
1.2. Context Menus
1.3. Tear-off menus
1.4. Tab menus
2. 文件菜单
2.1. Overview
2.2. New…
2.3. Create
2.4. Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. 保存
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Print
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Close
2.20. Close all
2.21. Quit
3. 编辑菜单
3.1. Edit Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into Selection
3.11. Paste In Place
3.12. Paste Into Selection In Place
3.13. Paste as
3.14. Buffer
3.15. Clear
3.16. Fill with FG Color
3.17. Fill with BG Color
3.18. Fill with Pattern
3.19. Fill Selection Outline
3.20. Fill Path
3.21. Stroke Selection
3.22. Stroke Path
3.23. The Preferences Command
3.24. Keyboard Shortcuts
3.25. Modules
3.26. Units
4. The Select Menu
4.1. Introduction to the Select Menu
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Save to Channel
4.19. To Path
5. The View Menu
5.1. Introduction to the View Menu
5.2. New View
5.3. Dot for Dot
5.4. Zoom
5.5. Flip and Rotate (0°)
5.6. Shrink Wrap
5.7. Full Screen
5.8. Navigation Window
5.9. Display Filters
5.10. Color Management
5.11. Show Selection
5.12. Show Layer Boundary
5.13. Show Guides
5.14. Show Grid
5.15. Show Sample Points
5.16. Snap to Guides
5.17. Snap to Grid
5.18. Snap to Canvas
5.19. Snap to Active Path
5.20. Padding Color
5.21. Show Menubar
5.22. Show Rulers
5.23. Show Scrollbars
5.24. Show Statusbar
6. The Image Menu
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transform
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Guillotine
6.18. Canvas Size
6.19. Fit Canvas to Layers
6.20. Fit Canvas to Selection
6.21. Print Size
6.22. Scale Image
6.23. Crop Image
6.24. Zealous Crop
6.25. Merge Visible Layers
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Guides
6.29. New Guide
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Remove all guides
6.33. Configure Grid…
6.34. Image Properties
7. The Layer Menu
7.1. Introduction to the Layer Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop Layer
8. The Colors Menu
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturation
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invert
8.13. Linear Invert
8.14. Value Invert
8.15. The Auto Submenu
8.16. Equalize
8.17. White Balance
8.18. Color Enhance
8.19. Color Enhance (legacy)
8.20. Normalize
8.21. Stretch Contrast
8.22. Stretch HSV
8.23. The Components Submenu
8.24. Channel Mixer
8.25. 组合
8.26. Extract Component
8.27. Mono Mixer
8.28. 分解
8.29. Recompose
8.30. Color to Gray
8.31. Desaturate
8.32. Sepia
8.33. The Map Submenu
8.34. Rearrange Colormap
8.35. Set Colormap
8.36. Alien Map
8.37. Color Exchange
8.38. Rotate Colors
8.39. Gradient Map
8.40. Palette Map
8.41. Sample Colorize
8.42. Fattal et al. 2002
8.43. Mantiuk 2006
8.44. Reinhard 2005
8.45. Stress
8.46. Retinex
8.47. The Info Submenu
8.48. Histogram
8.49. Border Average
8.50. Colorcube Analysis
8.51. Export Histogram
8.52. Smooth Palette
8.53. Threshold
8.54. Colorize
8.55. Posterize
8.56. Color to Alpha…
8.57. Dither
8.58. RGB Clip
8.59. Hot…
9. The Tools Menu
9.1. Introduction to the Tools Menu
10. The Filters Menu
10.1. Introduction to the Filters Menu
10.2. 重复上次
10.3. Re-show Last
10.4. 重置所有滤镜
10.5. The Python-Fu Submenu
10.6. The Script-Fu Submenu
11. Windows Menu
12. 帮助菜单
12.1. 帮助菜单简介
12.2. 帮助
12.3. Context Help
12.4. 每日提醒
12.5. 关于
12.6. 插件浏览器
12.7. The Procedure Browser
12.8. GIMP online
17. 虑镜
1. 介绍
1.1. 预览
2. Common Features
3. 模糊滤镜
3.1. Introduction
3.2. Gaussian Blur
3.3. Pixelize
3.4. Selective Gaussian Blur
3.5. Circular Motion Blur
3.6. Linear Motion Blur
3.7. Zoom Motion Blur
3.8. Tileable Blur
4. 增强滤镜
4.1. Introduction
4.2. Antialias
4.3. Deinterlace
4.4. Despeckle
4.5. Destripe
4.6. NL Filter
4.7. Red Eye Removal
4.8. Sharpen
4.9. Unsharp Mask
5. 扭曲滤镜
5.1. Introduction
5.2. Blinds
5.3. Curve Bend
5.4. Emboss
5.5. Engrave
5.6. Erase Every Other Row
5.7. Lens Distortion
5.8. Mosaic
5.9. Newsprint
5.10. Page Curl
5.11. Polar Coords
5.12. Ripple
5.13. Shift
5.14. Value Propagate
5.15. Video
5.16. Waves
5.17. Whirl and Pinch
5.18. Wind
5.19. Apply Lens
6. 光照和阴影滤镜
6.1. Introduction
6.2. Gradient Flare
6.3. Lens Flare
6.4. Lighting Effects
6.5. Sparkle
6.6. Supernova
6.7. Drop Shadow
6.8. Perspective
6.9. Xach-Effect
6.10. Glass Tile
7. 噪音滤镜
7.1. Introduction
7.2. HSV Noise
7.3. Hurl
7.4. Pick
7.5. RGB Noise
7.6. Slur
7.7. Spread
8. 边缘侦测滤镜
8.1. Introduction
8.2. Difference of Gaussians
8.3. Edge
8.4. Laplace
8.5. Neon
8.6. Sobel
9. 通用滤镜
9.1. Introduction
9.2. Convolution Matrix
9.3. Dilate
9.4. Erode
10. 组合滤镜
10.1. Introduction
10.2. Depth Merge
10.3. Filmstrip
11. 艺术滤镜
11.1. Introduction
11.2. Apply Canvas
11.3. Cartoon
11.4. Clothify
11.5. Cubism
11.6. GIMPressionist
11.7. Oilify
11.8. Photocopy
11.9. Predator
11.10. Softglow
11.11. Van Gogh (LIC)
11.12. Weave
12. 装饰滤镜
12.1. Introduction
12.2. Add Bevel
12.3. Add Border
12.4. Coffee Stain
12.5. Fuzzy Border
12.6. Old Photo
12.7. Round Corners
12.8. Slide
12.9. Stencil Carve
12.10. Stencil Chrome
13. 映射滤镜
13.1. Introduction
13.2. Bump Map
13.3. Displace
13.4. Fractal Trace
13.5. Illusion
13.6. Tile Seamless
13.7. Map Object
13.8. Paper Tile
13.9. Small Tiles
13.10. Tile
13.11. Warp
14. 渲染滤镜
14.1. Introduction
14.2. Difference Clouds
14.3. Fog
14.4. Plasma
14.5. Solid Noise
14.6. Flame
14.7. IFS Fractal
14.8. Checkerboard
14.9. CML Explorer
14.10. Diffraction Patterns
14.11. Grid
14.12. Jigsaw
14.13. Maze
14.14. Qbist
14.15. Sinus
14.16. Circuit
14.17. Fractal Explorer
14.18. Gfig
14.19. Lava
14.20. Line Nova
14.21. Sphere Designer
14.22. Spyrogimp
15. Web 滤镜
15.1. 介绍
15.2. ImageMap
15.3. Semi-Flatten
15.4. Slice
16. 卡通滤镜
16.1. 介绍
16.2. Blend
16.3. Burn-In
16.4. Rippling
16.5. Spinning Globe
16.6. Waves
16.7. Optimize
16.8. Playback
I. 键盘鼠标操作参考
帮助 — Key reference for Help menu
工具 — Key reference for the Tools menu
文件 — Key reference for the File menu
对话框 — Key reference for Dockable Dialogs submenu
查看 — Key reference for View menu
编辑 — Key reference for Edit menu
Layer — Key reference for Layer menu
Select — Key reference for Select menu
虑镜 — Key reference for Filters menu
缩放工具 — Key reference for the Zoom tool submenu
术语表
参考文献
A. GIMP 历史
1. 最开始
2. 早期的 GIMP
3. 改变世界之一
4. 2.0 版
5. GIMP 2.2 的新功能
6. GIMP 2.4 的新功能
7. GIMP 2.6 的新特性
8. What's New in GIMP 2.8?
B. 提交错误报告和请求改进
1. 确定它的确是个 BUG
2. 提交 BUG
3. 提交 BUG 之后会发生什么
C. How to Contribute
1. Prerequisites
1.1. Join our mailing list
1.2. Create a Local Working Copy of Code
1.3. Installing your sandbox
1.4. The gimp-help-2 folder
2. Workflow
2.1. Writing
2.2. Validating
2.3. Images
2.4. Create HTML Files
2.5. Sending your files
3. Annexes
4. Working under Windows
4.1. Adapting Cygwin to use with GIMP documentation tools
D. GNU 自由文本授权
1. 导言
2. 效力与定义
3. 逐字的复制
4. 大量地复制
5. 修改
6. 组合文件
7. 文件的收集
8. 独立作品的聚集
9. 翻译
10. 终止
11. 本授权的未来改版
12. 授权附录:如何使用本授权用于你的文件
E. 哎呀!少了帮助
索引