GNU Image Manipulation Program

Підручник користувача

Юридичні зауваження

Кожен має право копіювати, розповсюджувати та вносити зміни до даного Документу на умовах GNU Free Documentation License, версії 1.2 або будь-якої наступної версії, опублікованої Free Software Foundation; даний Документ не містить Незмінних розділів; даний Документ не має Текстів передньої та задньої обкладинок. Копія даної ліцензії включена в розділ із заголовком GNU Free Documentation License.


Зміст

Передмова
1. Автори і учасники створення «Підручника користувача GIMP»
I. Початкові зауваження
1. Вступ
1. Вітаємо у GIMP
1.1. Автори
1.2. Довідкова система GIMP
1.3. Можливості
2. Що нового у GIMP 2.10.18?
2. Запаліть GIMP
1. Running GIMP
1.1. Known Platforms
1.2. Language
1.3. Command Line Arguments
2. Starting GIMP the first time
2.1. Finally . . .
3. Перші кроки з Вілбером
1. Basic Concepts
2. Main Windows
2.1. The Toolbox
2.2. Image Window
2.3. Dialogs and Docking
3. Undoing
3.1. Things That Cannot be Undone
4. Common Tasks
4.1. Intention
4.2. Change the Size of an Image for the screen
4.3. Change the Size of an Image for print
4.4. Compressing Images
4.5. Crop An Image
4.6. Find Info About Your Image
4.7. Change the Mode
4.8. Flip An Image
4.9. Rotate An Image
4.10. Separating an Object From Its Background
5. How to Draw Straight Lines
5.1. Intention
5.2. Examples
4. Що робити, якщо щось не виходить
1. Вступ
2. Common Causes of GIMP Non-Responsiveness
2.1. There is a floating selection
2.2. The selection is hidden
2.3. You are acting outside the selection
2.4. The active drawable is not visible
2.5. The active drawable is transparent
2.6. You are trying to act outside the layer
2.7. You are trying to act on a layer group
2.8. The image is in indexed color mode.
2.9. No visible effect when trying to use a brush, eraser or other tool
2.10. Eraser and brushes no longer work
2.11. Eraser does not make area transparent
2.12. Unexpected colors when trying to use a brush or eraser
3. How to fix missing windows and dialogs
3.1. All tool windows are missing
3.2. Tool options dialog is missing
3.3. Some of the tool icons are missing
II. Як стати чарівником GIMP?
5. Отримання зображень у GIMP
1. Image Types
2. Creating new Files
3. Opening Files
3.1. Open File
3.2. Open Location
3.3. Open Recent
3.4. Using External Programs
3.5. File Manager
3.6. Drag and Drop
3.7. Copy and Paste
3.8. Image Browser
6. Отримання зображень з GIMP
1. Files
1.1. Збереження/Експортування зображень
1.2. Формати файлів
2. Preparing your Images for the Web
2.1. Images with an Optimal Size/Quality Ratio
2.2. Reducing the File Size Even More
2.3. Saving Images with Transparency
7. Малювання за допомогою GIMP
1. The Selection
1.1. Feathering
1.2. Making a Selection Partially Transparent
2. Creating and Using Selections
2.1. Пересування позначеного
2.2. Adding or subtracting selections
3. The QuickMask
3.1. Overview
3.2. Properties
4. Using QuickMask Mode
5. Контури
5.1. Path Creation
5.2. Path Properties
5.3. Paths and Selections
5.4. Transforming Paths
5.5. Stroking a Path
5.6. Paths and Text
5.7. Paths and SVG files
6. Brushes
7. Adding New Brushes
8. The GIH Dialog Box
9. Changing brush size
9.1. How to change the size of a brush
9.2. Creating a brush quickly
10. Gradients
11. Patterns
12. Palettes
12.1. Colormap
13. Presets
14. Drawing Simple Objects
14.1. Drawing a Straight Line
14.2. Creating a Basic Shape
8. Поєднання зображень
1. Introduction to Layers
1.1. Layer Properties
2. Layer Modes
3. Creating New Layers
4. Layer Groups
9. Робота з текстом
1. Text Management
1.1. Text Area
1.2. Managing Text Layer
1.3. Text Toolbox
1.4. Text Context Menu
2. Текст
2.1. Embellishing Text
2.2. Adding Fonts
2.3. Font Problems
10. Удосконалення фотографій
1. Working with Digital Camera Photos
1.1. Вступ
1.2. Improving Composition
1.3. Improving Colors
1.4. Adjusting Sharpness
1.5. Removing Unwanted Objects from an Image
1.6. Saving Your Results
11. Керування кольорами у GIMP
1. Color Management in GIMP
1.1. Problems of a non Color Managed Workflow
1.2. Introduction to a Color Managed Workflow
12. Розширення можливостей GIMP
1. Preferences Dialog
1.1. Introduction
1.2. System Resources
1.3. Color Management
1.4. Image Import and Export
1.5. Tool Options
1.6. Default Image Preferences
1.7. Default Image Grid
1.8. Interface
1.9. Theme
1.10. Icon Theme
1.11. Toolbox
1.12. Dialog Defaults
1.13. Help System
1.14. Display
1.15. Window Management
1.16. Image Windows
1.17. Image Window Appearance
1.18. Image Window Title and Statusbar
1.19. Image Window Snapping Behavior
1.20. Input Devices
1.21. Input Controllers
1.22. Folders
1.23. Data Folders
2. Grids and Guides
2.1. The Image Grid
2.2. Guides
3. Rendering a Grid
4. How to Set Your Tile Cache
5. Creating Shortcuts to Menu Functions
6. Customize Splash-Screen
13. Скрипти
1. Plugins
1.1. Introduction
1.2. Using Plugins
1.3. Installing New Plugins
1.4. Writing Plugins
2. Using Script-Fu Scripts
2.1. Script-Fu?
2.2. Installing Script-Fu scripts
2.3. Do's and Don'ts
2.4. Different Kinds Of Script-Fus
2.5. Image-Dependent Scripts
3. A Script-Fu Tutorial
3.1. Getting Acquainted With Scheme
3.2. Variables And Functions
3.3. Lists, Lists And More Lists
3.4. Your First Script-Fu Script
3.5. Giving Our Script Some Guts
3.6. Extending The Text Box Script
3.7. Your script and its working
III. Довідник з функцій
14. Інструменти
1. The Toolbox
1.1. Introduction
1.2. Tool Icons
1.3. Color and Indicator Area
1.4. Tool Options
2. Selection Tools
2.1. Common Features
2.2. Rectangle Selection
2.3. Ellipse Selection
2.4. Free Selection (Lasso)
2.5. Fuzzy selection (Magic wand)
2.6. Select By Color
2.7. Intelligent Scissors
2.8. Foreground Select
3. Paint Tools
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. Bucket Fill
3.5. Gradient
3.6. Pencil
3.7. Paintbrush
3.8. MyPaint Brush
3.9. Eraser
3.10. Airbrush
3.11. Ink
3.12. Clone
3.13. Heal
3.14. Perspective Clone
3.15. Blur/Sharpen
3.16. Smudge
3.17. Dodge/Burn
4. Transform Tools
4.1. Common Features
4.2. Align
4.3. Move
4.4. Crop
4.5. Rotate
4.6. Scale
4.7. Shear
4.8. Perspective
4.9. 3D Transform
4.10. Unified Transform
4.11. Handle Transform
4.12. Flip
4.13. The Cage Tool
4.14. Warp Transform
5. Other
5.1. Overview
5.2. Paths
5.3. Color Picker
5.4. Zoom
5.5. Measure
5.6. Text
5.7. GEGL Operation
15. Діалогові вікна
1. Dialog Introduction
2. Image Structure Related Dialogs
2.1. Layers Dialog
2.2. Channels Dialog
2.3. Paths Dialog
2.4. Colormap Dialog
2.5. Histogram dialog
2.6. Navigation Dialog
2.7. Undo History Dialog
3. Image-content Related Dialogs
3.1. FG/BG Color Dialog
3.2. Brushes Dialog
3.3. Patterns Dialog
3.4. Gradients Dialog
3.5. Palettes Dialog
3.6. Tagging
3.7. Fonts Dialog
4. Image Management Related Dialogs
4.1. Buffers Dialog
4.2. Images Dialog
4.3. Document History Dialog
4.4. Templates Dialog
5. Miscellaneous Dialogs
5.1. Tool Presets Dialog
5.2. Tool Preset Editor
5.3. Device Status Dialog
5.4. Error Console
5.5. Dashboard
5.6. Save File
5.7. Export File
5.8. Sample Points Dialog
5.9. Pointer Dialog
5.10. Symmetry Painting dialog
16. Меню
1. Introduction to Menus
1.1. The Image Menu Bar
1.2. Context Menus
1.3. Tear-off menus
1.4. Tab menus
2. The «File» Menu
2.1. Overview
2.2. New…
2.3. Create
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. Save
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export… and Overwrite…
2.13. Export As…
2.14. Create Template…
2.15. Print
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Close
2.20. Close all
2.21. Quit
3. The «Edit» Menu
3.1. «Edit» Menu Entries
3.2. Undo
3.3. Redo
3.4. Undo History
3.5. Cut
3.6. Copy
3.7. Copy Visible
3.8. Paste
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Paste as
3.13. Buffer
3.14. Clear
3.15. Fill with FG Color
3.16. Fill with BG Color
3.17. Fill with Pattern
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Stroke Selection
3.21. Stroke Path
3.22. The «Preferences» Command
3.23. Keyboard Shortcuts
3.24. Modules
3.25. Units
4. The «Select» Menu
4.1. Introduction to the «Select» Menu
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Save to Channel
4.19. To Path
5. The «View» Menu
5.1. Introduction to the «View» Menu
5.2. New View
5.3. Show All
5.4. Dot for Dot
5.5. Zoom
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Shrink Wrap
5.9. Full Screen
5.10. Navigation Window
5.11. Display Filters
5.12. Color Management
5.13. Show Selection
5.14. Show Layer Boundary
5.15. Show Canvas Boundary
5.16. Show Guides
5.17. Show Grid
5.18. Show Sample Points
5.19. Snap to Guides
5.20. Snap to Grid
5.21. Snap to Canvas
5.22. Snap to Active Path
5.23. Padding Color
5.24. Show Menubar
5.25. Show Rulers
5.26. Show Scrollbars
5.27. Show Statusbar
6. The «Image» Menu
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transform
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Canvas Size
6.18. Fit Canvas to Layers
6.19. Fit Canvas to Selection
6.20. Print Size
6.21. Scale Image
6.22. Crop Image
6.23. Slice Using Guides
6.24. Zealous Crop
6.25. Merge Visible Layers
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Guides
6.29. New Guide
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Remove all guides
6.33. Configure Grid…
6.34. Image Properties
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. The «Layer» Menu
7.1. Introduction to the «Layer» Menu
7.2. New Layer
7.3. New From Visible
7.4. New Layer Group
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Merge Layer Group
7.9. Delete Layer
7.10. The Text Commands of the Layer Menu
7.11. Discard Text Information
7.12. «Stack» Submenu
7.13. Select Previous Layer
7.14. Select Next Layer
7.15. Select Top Layer
7.16. Select Bottom Layer
7.17. Raise Layer
7.18. Lower Layer
7.19. Layer to Top
7.20. Layer to Bottom
7.21. The «Reverse Layer Order» command
7.22. The «Mask» Submenu
7.23. Add Layer Mask
7.24. Apply Layer Mask
7.25. Delete Layer Mask
7.26. Show Layer Mask
7.27. Edit Layer Mask
7.28. Disable Layer Mask
7.29. Mask to Selection
7.30. Add Layer Mask to Selection
7.31. Subtract Layer Mask from Selection
7.32. Intersect Layer Mask with Selection
7.33. The «Transparency» Submenu of the «Layer» menu
7.34. Add Alpha Channel
7.35. Remove Alpha Channel
7.36. Color to Alpha
7.37. Semi-flatten
7.38. Threshold Alpha
7.39. Alpha to Selection
7.40. Add Alpha channel to Selection
7.41. Subtract from Selection
7.42. Intersect Alpha channel with Selection
7.43. The «Transform» Submenu
7.44. Flip Horizontally
7.45. Flip Vertically
7.46. Rotate 90° clockwise
7.47. Rotate 90° counter-clockwise
7.48. Rotate 180°
7.49. Arbitrary Rotation
7.50. Offset
7.51. Layer Boundary Size
7.52. Layer to Image Size
7.53. Scale Layer
7.54. Crop Layer
8. The «Colors» Menu
8.1. Introduction to the «Colors» Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturation
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invert
8.13. Linear Invert
8.14. Value Invert
8.15. The «Auto» Submenu
8.16. Вирівнювання
8.17. Баланс білого
8.18. Розтягнути контрастність
8.19. Розтягування HSV
8.20. Підсилення кольорів
8.21. Підсилити кольори (старий)
8.22. The «Components» Submenu
8.23. Channel Mixer
8.24. Extract Component
8.25. Mono Mixer
8.26. Compose
8.27. Decompose
8.28. Recompose
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. The «Map» Submenu
8.33. Rearrange Colormap
8.34. Set Colormap
8.35. Alien Map
8.36. Color Exchange
8.37. Rotate Colors
8.38. Gradient Map
8.39. Palette Map
8.40. Sample Colorize
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. The «Info» Submenu
8.47. Histogram
8.48. Border Average
8.49. Colorcube Analysis
8.50. Export Histogram
8.51. Smooth Palette
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. The «Tools» Menu
9.1. Introduction to the «Tools» Menu
10. The «Filters» Menu
10.1. Introduction to the «Filters» Menu
10.2. Repeat Last
10.3. Re-show Last
10.4. Reset All Filters
10.5. The «Python-Fu» Submenu
10.6. The «Script-Fu» Submenu
11. «Windows» Menu
12. The «Help» Menu
12.1. Introduction to the «Help» Menu
12.2. Help
12.3. Context Help
12.4. Tip of the Day
12.5. About
12.6. Plug-In Browser
12.7. The Procedure Browser
12.8. GIMP online
17. Фільтри
1. Introduction
2. Common Features
3. Blur Filters
3.1. Introduction
3.2. Focus Blur
3.3. Gaussian Blur
3.4. Lens Blur
3.5. Mean Curvature Blur
3.6. Median Blur
3.7. Pixelize
3.8. Selective Gaussian Blur
3.9. Variable Blur
3.10. Circular Motion Blur
3.11. Linear Motion Blur
3.12. Zoom Motion Blur
3.13. Tileable Blur
4. Enhance Filters
4.1. Introduction
4.2. Antialias
4.3. Deinterlace
4.4. High Pass
4.5. Noise Reduction
4.6. Red Eye Removal
4.7. Symmetric Nearest Neighbor
4.8. Sharpen (Unsharp Mask)
4.9. Despeckle
4.10. Destripe
4.11. NL Filter
4.12. Wavelet Decompose
5. Distort Filters
5.1. Introduction
5.2. Apply Lens
5.3. Emboss
5.4. Engrave
5.5. Lens Distortion
5.6. Kaleidoscope
5.7. Mosaic
5.8. Newsprint
5.9. Polar Coordinates
5.10. Ripple
5.11. Shift
5.12. Spherize
5.13. Value Propagate
5.14. Video
5.15. Waves
5.16. Whirl and Pinch
5.17. Wind
5.18. Curve Bend
5.19. Emboss (legacy)
5.20. Page Curl
6. Light and Shadow Filters
6.1. Introduction
6.2. Bloom
6.3. Supernova
6.4. Lens Flare
6.5. Gradient Flare
6.6. Lighting Effects
6.7. Sparkle
6.8. Drop Shadow
6.9. Long Shadow
6.10. Vignette
6.11. Drop Shadow (legacy)
6.12. Perspective
6.13. Xach-Effect
7. Noise Filters
7.1. Introduction
7.2. CIE lch Noise
7.3. HSV Noise
7.4. Hurl
7.5. Pick
7.6. RGB Noise
7.7. Slur
7.8. Spread
8. Edge-Detect Filters
8.1. Introduction
8.2. Difference of Gaussians
8.3. Edge
8.4. Laplace
8.5. Neon
8.6. Sobel
8.7. Image Gradient
9. Generic Filters
9.1. Introduction
9.2. Convolution Matrix
9.3. Distance Map
9.4. GEGL graph
9.5. Normal Map
9.6. Dilate
9.7. Erode
10. Combine Filters
10.1. Introduction
10.2. Depth Merge
10.3. Filmstrip
11. Artistic Filters
11.1. Introduction
11.2. Apply Canvas
11.3. Cartoon
11.4. Cubism
11.5. Glass Tile
11.6. Oilify
11.7. Photocopy
11.8. Simple Linear Iterative Clustering (SLIC)
11.9. Softglow
11.10. Waterpixels
11.11. Cartoon (legacy)
11.12. Clothify
11.13. GIMPressionist
11.14. Oilify (legacy)
11.15. Predator
11.16. Softglow (legacy)
11.17. Van Gogh (LIC)
11.18. Weave
12. Decor Filters
12.1. Introduction
12.2. Add Bevel
12.3. Add Border
12.4. Coffee Stain
12.5. Fog
12.6. Fuzzy Border
12.7. Old Photo
12.8. Round Corners
12.9. Slide
12.10. Stencil Carve
12.11. Stencil Chrome
13. Map Filters
13.1. Introduction
13.2. Bump Map
13.3. Displace
13.4. Fractal Trace
13.5. Illusion
13.6. Little Planet
13.7. Panorama Projection
13.8. Recursive Transform
13.9. Paper Tile
13.10. Tile Seamless
13.11. Fractal Trace (legacy)
13.12. Map Object
13.13. Tile
14. Rendering Filters
14.1. Introduction
14.2. Flame
14.3. Fractal Explorer
14.4. IFS Fractal
14.5. Cell Noise
14.6. Perlin Noise
14.7. Plasma
14.8. Simplex Noise
14.9. Solid Noise
14.10. Difference Clouds
14.11. Bayer Matrix
14.12. Checkerboard
14.13. Diffraction Patterns
14.14. Grid
14.15. Linear Sinusoid
14.16. Maze
14.17. Sinus
14.18. Spiral
14.19. Checkerboard (legacy)
14.20. CML Explorer
14.21. Grid (legacy)
14.22. Jigsaw
14.23. Qbist
14.24. Spyrogimp
14.25. Circuit
14.26. Gfig
14.27. Lava
14.28. Line Nova
14.29. Sphere Designer
15. Web Filters
15.1. Introduction
15.2. ImageMap
15.3. Semi-Flatten
15.4. Slice
16. Animation Filters
16.1. Introduction
16.2. Blend
16.3. Burn-In
16.4. Rippling
16.5. Spinning Globe
16.6. Waves
16.7. Optimize
16.8. Playback
I. Довідка з використання клавіатури та миші
Файл — Довідник із клавіатурних комбінацій для меню Файл
Зміни — Довідник із клавіатурних комбінацій для меню Зміни
Позначити — Довідник із клавіатурних комбінацій для меню Вибір
Перегляд — Довідник із клавіатурних комбінацій для меню Перегляд
Зображення — Довідник із клавіатурних комбінацій для меню Зображення
Шари — Довідник із клавіатурних комбінацій для меню Шар
Інструменти — Довідник із клавіатурних комбінацій для меню Засоби
Фільтри — Довідник із клавіатурних комбінацій для меню Фільтри
Вікна — Довідник із клавіатурних комбінацій для меню Вікна
Довідка — Довідник із клавіатурних комбінацій для меню Довідка
Засіб масштабування — Довідник із клавіатурних комбінацій для засобу масштабування
Глосарій
Бібліографія
A. GIMP History
1. The Very Beginning
2. The Early Days of GIMP
3. The One to Change the World
4. Версія 2.0
5. Що нового у GIMP 2.2?
6. Що нового у GIMP 2.4?
7. Що нового у GIMP 2.6?
8. Що нового у GIMP 2.8?
9. Що нового у GIMP 2.10?
B. Reporting Bugs and Requesting Enhancements
1. Making sure it's a Bug
2. Reporting the Bug
C. Як взяти участь?
1. Prerequisites
1.1. Join our mailing list
1.2. Create a Local Working Copy of Code
1.3. Installing your sandbox
1.4. The gimp-help folder
2. Процес
2.1. Написання
2.2. Перевірка
2.3. Зображення
2.4. Create HTML Files
2.5. Sending your files
3. Annexes
4. Working under Windows
4.1. Adapting Cygwin to use with GIMP documentation tools
D. Tone Mapping and Shadow Recovery Using GIMP’s ‘Colors/Exposure’
1. High bit depth GIMP’s floating point “Colors/Exposure”: much better than Curves for lightening the shadows and midtones of an image without blowing the highlights
2. A step-by-step example showing how to recover shadow information using high bit depth GIMP’s floating point “Colors/Exposure”
3. Use Notes
4. Висновки
E. GNU Free Documentation License
1. ПЕРЕДМОВА
2. СФЕРА ЗАСТОСУВАННЯ, ТЕРМІНИ ТА ЇХ ВИЗНАЧЕННЯ
3. КОПІЮВАННЯ БЕЗ ЗМІН
4. ТИРАЖУВАННЯ
5. ЗМІНИ
6. ОБ'ЄДНАННЯ ДОКУМЕНТІВ
7. ЗБІРНИКИ ДОКУМЕНТІВ
8. ПОЄДНАННЯ З НЕЗАЛЕЖНИМИ ПРАЦЯМИ
9. ПЕРЕКЛАД
10. ВТРАТА ЛІЦЕНЗІЇ
11. ПЕРЕГЛЯД ЛІЦЕНЗІЙНИХ УМОВ
12. ДОДАТОК: Як користуватися цими умовами ліцензування для ваших документів
F. Ой! Довідки немає
Покажчик