Capítulo 10. Melhorando fotografias

Índice

1. Trabalhando com fotos de câmeras digitais
1.1. Introdução
1.2. Melhorando a composição
1.3. Melhorando as cores
1.4. Ajustando a nitidez
1.5. Removendo objetos indesejados de uma imagem
1.6. Salvando seus resultados

1. Trabalhando com fotos de câmeras digitais

1.1. Introdução

Um dos usos mais comuns do GIMP é arrumar fotos de câmeras digitais que, por alguma razão, não ficaram perfeitas. Talvez a imagem tenha ficado sobre-exposta ou sub-exposta, talvez um pouco inclinada, ou fora de foco: todos esses são problemas comuns para os quais o GIMP possui boas ferramentas. O propósito deste capítulo é propiciar uma visão geral do que são essas ferramentas e das situações em que as mesmas são úteis. Você não vai encontrar tutoriais detalhados aqui: na maioria dos casos é mais fácil entender como as ferramentas funcionam experimentando com as ferramentas do que lendo sobre elas. (E também, cada ferramenta é descrita de forma mais abrangente na sessão de Ajuda devotada à mesma); Você também não vai encontrar nada neste capítulo sobre a quantidade enorme de efeitos especiais que você pode aplicar em uma imagem usando o GIMP. Você deve estar familiarizado com os conceitos básicos do GIMP antes de ler este capítulo, mas certamente você não precisa ser um expert — se você é, você provavelmente já sabe da maior parte do que está aqui de qualquer forma. E não hesite em experimentar: o poderoso sistema de desfazer do GIMP permite que você se recupere de praticamente qualquer erro com um simples Ctrl+Z

As coisas que você mais comumente quer arrumar numa foto imperfeita são de quatro tipos: Melhorar a composição; melhorar as cores; melhorar a nitidez e remover defeitos ou outros elementos indesejados da imagem.

1.2. Melhorando a composição

1.2.1. Rotacionando uma imagem

É fácil, ao tirar uma foto, segurar a câmera de modo que não fique bem alinhada com a vertical, resultando em uma foto em que todas as coisas estão inclinadas em um ângulo. No GIMP, a forma de arrumar isso é usando a ferramenta de Rotacionar. Ative-a clicando em seu ícone na caixa de ferramentas, ou pressionando a combinação Shift+R dentro da imagem. Certifique-se de que as opções da ferramenta estão visíveis, e, no topo, assegure-se de que em Transformar, o botão da direita (Transformar camada) esteja selecionado. Se você clicar com mouse dentro da imagem e arrasta-la, você verá uma grade que aparece conforme você arrasta. Quando a grade parecer estar na posição certa clique em Rotacionar ou pressione Enter, e a imagem será girada.

Agora, na verdade, não é tão fácil assim arrumar as coisas com esse método: com frequência você vai perceber que as coisas melhoraram, mas ainda não estão perfeitas. Uma solução é rotacionar mais um pouquinho, mas há uma desvantagem nesse método. Cada vez que você rotaciona uma imagem, pelo fato dos pixels da imagem rotacionada não se alinharem perfeitamente com os pixels originais, a imagem inevitavelmente se torna um pouco desfocada. Para uma única rotação, esse desfoque é bem pequeno, mas duas rotações desfocam o dobro, e não há razões para deixar as coias mais desfocadas do que você precisa. Uma alternativa melhor é desfazer a rotação e fazer uma outra, ajustando o ângulo.

Felizmente, o GIMP provê uma forma de fazer isso que é consideravelmente mais fácil de usar: nas opções da ferramenta Rotacionar, na Direção, você pode selecionar Corretivo (Para trás). Ao fazer isso, em vez de rotacionar a grade para compensar o erro, você rotaciona a grade para se alinhar com o erro. A descrição pode parecer confusa, mas tente e você vai ver que é algo bem simples.

[Nota] Nota

Desde o GIMP 2.2 há uma opção para pré-visualizar o resultado das transformações, em vez de haver apenas uma grade visível. Isso torna bem mais fácil acertar as coisas na primeira tentativa.

Depois que você rotacionar uma imagem, haverá desagradáveis buracos triangulares nas bordas. Uma forma de arruma-los é preenche-los com alguma cor de fundo que não seja intrusiva, mas normalmente a melhor solução será cortar (guilhotinar) a imagem. Quanto maior a rotação, maior a área que será cortada, então o melhor mesmo é ter a máquina tão alinhada quanto possível quando você tira a foto.

1.2.2. Cortando

Quando você tira uma foto com uma câmera digital, você tem controle sobre o que vai aparecer na imagem, mas com frequência não tanto quanto você gostaria: o resultado final poderia ficar melhor com algum recorte. Além disso, normalmente é possível aumentar o impacto de uma imagem recortando-a de forma que os elementos mais importantes fiquem em pontos chave. Como uma regra geral, que não deve se seguida sempre, mas é boa de se ter em mente é a regra dos terços, que diz que uma foto tem maior impacto se o objeto de interesse está em localizado numa posição localizada a um terço da imagem, tanto na largura, quanto na altura.

Para cortar uma imagem, ative a ferramenta de Cortar na caixa de ferramentas, ou pressionando a tecla C (maiúscula) enquanto estiver na imagem. Com a ferramenta ativa, clicar e arrastar na imagem irá criar um retângulo - e você poderá ajusta-lo com o mouse, ou digitar as dimensões desejadas direto no diálogo de opções de ferramenta. Você pode mover o retângulo em incrementos de um pixel mantendo o cursor dentro das alças de redimensionamento, nos cantos, e usando as setas do teclado na direção desejada. (shift + seta para ir de 10 em 10 pixels). Quando tudo estiver perfeito, pressione Enter, ou simplesmente clique com o botão esquerdo dentro do retângulo (fora das alças de redimensionamento).

1.3. Melhorando as cores

1.3.1. Ferramentas automáticas

Apesar de sistemas de controle de exposição sofisticados, fotografias tiradas com câmeras digitais algumas vezes ficam super ou sub-expostas, ou com desvios de cor devido a imperfeições na iluminação. O GIMP lhe traz várias ferramentas para corrigir cores em uma imagem, indo de ferramentas automáticas que funcionam com um simples clique, até ferramentas altamente sofisticadas que lhe dão muitos parâmetros de controle. Vamos começar com as mais simples primeiro.

O GIMP tem varias ferramentas de correção de cor automáticas. Infelizmente, elas normalmente não resultam exatamente no que você pode querer. Por outro lado, você gasta só um instante para testa-las, e se você não ganhar mais nada com isso, pelo menos elas lhe darão uma ideia de algumas das possibilidades que existem para a imagem. Exceto por Níveis automáticos, você encontrará todas essas ferramentas no seguinte lugar no menu da janela de imagem: CoresAutomático

Aqui estão eles, com umas poucas palavras sobre cada uma:

Normalizar

Esta ferramenta (na verdade é um plug-in) é útil para imagens sub-expostas. Ela ajusta a imagem uniformemente até que o ponto mais claro esteja no limite de saturação, e o ponto mais escuro seja preto. O lado negativo é que a quantidade de clareamento é determinada inteiramente pelos pontos mais claro e mais escuro da imagem, de forma que um único pixel branco e/ou um único pixel preto tornarão a normalização inefetiva.

Equalizar

Este é um ajuste muito poderoso que tenta espalhar as cores na imagem de forma uniforme em toda a faixa de intensidades possíveis. Em alguns casos o efeito é espetacular, fazendo aparecer contrastes que são bem difíceis de se obter de qualquer outra forma; mas geralmente, ele só faz a imagem parecer estranha. Bem, é só um instante para tentar, e se não ficar bom, desfazer!

Realce de cor...

Esse comando aumenta a saturação das cores na camada, sem alterar o brilho ou o matiz. Portanto, ele não funciona em imagens em tons de cinza.

Esticar contraste

Funciona quase como Normalizar, exceto que ele opera nos canais vermelho, verde e azul de forma independente. Em geral é útil para reduzir desvios para uma cor.

Esticar HSV

faz o mesmo que Esticar contraste, mas funciona no espaço de cores HSV, em vez do RGB. Ele preserva o matiz.

Equilíbrio de branco

Pode melhorar as imagens com pontos ruins de branco ou de preto removendo cores pouco usadas, e esticando a faixa das outras tanto quanto possível.

Níveis automáticos

Isso é feito ativando-se a ferramenta de Níveis (FerramentasFerramentas de corNíveis ou CoresNíveis no menu da janela de imagens), e então pressionando o botão Automático próximo ao centro da janela de diálogo. Você verá um resultado em pré-visualização, e deve apertar o botão Ok para o mesmo fazer efeito. Pressionar Cancelar faz a imagem retornar ao estado anterior.

Se você puder encontrar um ponto na imagem que deveria ser 100% branco, e um segundo ponto que deveria ser totalmente preto, então você pode usar a ferramenta de níveis para fazer um ajuste semi-automático, que em muitos casos faz um trabalho muito bom arrumando tanto o brilho quanto as cores na imagem. Primeiro, ative a ferramenta de Níveis como descrito anteriormente. Agora olhe perto da parte de baixo do diálogo da ferramenta, e veja três botões com símbolos que lembram conta-gotas. O da esquerda, se você passar o mouse sobre ele, mostra que sua função é Selecione ponto negro. Clique nele, então clique num ponto na imagem que deveria ser preto, realmente preto, não só muito escuro, e veja a imagem mudar. Em seguida, pegue o conta-gotas mais a direita (Selecione ponto branco), e clique num ponto da imagem que deveria ser branco, e, novamente, observe a imagem mudar. Se você gostou do resultado, clique o botão de Ok, senão, Cancelar.

Esses são ajustes automáticos de cores. Se você achar que nenhum deles faz o trabalho por você, é hora de tentar alguma das ferramentas de cor mais interativas. Todas essas, exceto uma, podem ser acessadas em Ferramentas>Ferramentas de cor, no menu da janela de imagens. Depois de selecionar uma ferramenta de cor, clique na imagem (em qualquer ponto) para ativa-la e trazer seu diálogo.

1.3.2. Problemas de exposição

A ferramenta mais simples de se usar é a de Brilho e contraste. Também é a menos poderosa, mas em muitos casos, faz tudo o que você precisa. Esta ferramenta é usada com frequência para imagens que ficaram sub-expostas ou sobre-expostas. Não serve para corrigir desvios de cor. Esta ferramenta tem dois controles deslizantes para serem ajustados, um para o Brilho e um para o Contraste Se a opção de Pré-visualização estiver ligada (em geral está), você verá seus ajustes serem refletidos na imagem em tempo real. Quando estiver feliz com os resultados, pressione Ok e eles serão consolidados. Se você não conseguir chegar nos resultados que deseja, pressione Cancelar, ou vá direto para outra ferramenta, clicando emEditar essas configurações como níveis. Isso abrirá a ferramenta de Níveis, mas mantendo os ajustes que você já fez em Brilho/contraste, embora sem torna-los permanentes ainda, de forma que você possa refinar os parâmetros.

Uma ferramenta mais sofisticada, mas um pouco mais complexa, para usar é a ferramenta de Níveis. O diálogo para essa ferramenta parece bastante complicado, mas para os usos básicos que temos em mente aqui, a única coisa com que você vai precisar lidar é a área dos Níveis de entrada, especificamente os três controles triangulares deslizantes que aparecem abaixo do histograma. Nós vamos direcionar você para a ajuda da ferramenta de Níveis para instruções, mas na verdade, a forma mais fácil de de aprender a usa-la é movendo esses três controles e vendo que acontece na pré-visualização da imagem. (Certifique-se de que a opção de Pré-visualização esteja ligada). Como no caso anterior, se você achar que está chegando no caminho certo, mas precisa de um pouco mais de controle sobre o resultado final, pode clicar em Editar essas configurações como curvas.

E por fim, uma ferramenta muito poderosa para corrigir problemas de exposição, é a ferramenta de Curvas. Essa ferramenta permite que você clique e arraste em pontos de controle sobre uma curva, de forma a criar uma função que mapeia níveis de brilho de entrada para níveis de brilho de saída. A ferramenta de curvas pode replicar qualquer efeito que você consiga com a ferramenta de Brilho/Contraste ou com a ferramenta de Níveis, então ela é mais poderosa que ambas — e na verdade não há nenhum motivo para você não começar direto pela ferramenta de Curvas para os ajustes, sem nem passar pelas demais. Novamente, nós referimos você para a ajuda da ferramenta de Curvas para ver instruções detalhadas, mas a forma mais fácil de entender como usa-la é experimentando.

A forma mais poderosa de ajustar brilho e contraste de uma imagem, para usuários mais avançados do GIMP, é criar uma camada acima da atual, e deixar o modo de combinação para essa nova camada em Multiplicar, no diálogo de Camadas. A nova camada passa a servir como uma camada de controle de ganho para a camada abaixo dela, com branco resultando no ganho máximo, e preto resultando em zero (preto). Então, ao pintar na nova camada, você pode ajustar seletivamente o ganho de cada área da imagem, tendo um controle muito fino. Você deve tentar pintar degradês bem suaves, por que mudanças bruscas vão levar a cantos espúrios no resultado (experimente a ferramenta de Aerógrafo). Pinte apenas com tons de cinza, não com cores, a não ser que você queira mudanças de cor na sua imagem.

Na verdade, o modo de Multiplicar não é o único que é útil para controle de ganho. De fato, o modo Multiplicar só pode escurecer partes de uma imagem, nunca clareá-las. Então é mais útil se algumas partes foram super-expostas. Usar o modo de Dividir tem o efeito oposto: ele pode clarear partes de uma imagem, mas nunca escurece-las. Então aqui segue um truque que frequentemente é útil para ter o máximo de detalhe em todas as áreas de uma imagem:

  1. Duplique a camada (produzindo uma nova camada sobre a mesma).

  2. Tire a saturação dessa cópia (Cores->dessaturar).

  3. Aplique uma desfocagem gaussiana sobre o resultado, com um raio grande (100 ou mais).

  4. Configure o Modo no diálogo de camadas para Dividir.

  5. Controle a quantidade de correção ajustando a opacidade no diálogo de camadas, ou usando uma das ferramentas de Brilho e contraste, Níveis ou de Curvas, nessa nova camada.

  6. Quando você estiver feliz como resultado, você pode usar a opção de Combinar abaixo do menu de Camadas, para combinar ambas as camadas em uma.

Além dos modos de Multiplicar e Dividir, você pode obter efeitos úteis com outros modos de combinação de camadas, tais como Sub-exposição, Super-exposição, ou Luz suave. É bem fácil, no entanto, depois que você começa a brincar com essas coisas, tirar os olhos do computador por um momento e descobrir que você acabou de gastar uma hora inteira mexendo nos parâmetros. Fique avisado: quanto mais opções você tiver, mais difícil é tomar uma decisão. De repente, o melhor é usar a ferramenta de Curvas, que pode permitir um bom ajuste em segundos.

1.3.3. Ajustando o Matiz e a Saturação

Na nossa experiência, se sua imagem tem um desvio da cor—muito vermelho, muito azul, etc— a forma mais simples de ajusta-la é com a ferramenta de Níveis (ou a de Curvas), ajustando os níveis separadamente nos canais de vermelho, verde e azul. Se isso não funcionar para você, pode tentar usar a ferramenta de Equilíbrio de Cores, mas ela é bem mais difícil de se usar efetivamente (tanto ela quanto a ferramenta de Curvas são boas para criar certos tipos de efeitos especiais, no entanto)

Algumas vezes é difícil de dizer se você ajustou as cores adequadamente. Uma boa técnica, bem objetiva, é encontrar um ponto na imagem que você saiba que deveria ser ou branco, ou um tom de cinza. Ative a ferramenta Seletor de cores (o simbolo de conta-gotas na caixa de ferramentas), e clique nesse ponto. Se as cores estão ajustadas corretamente, os componentes vermelho, verde e azul deste ponto devem toso ser bem próximos. Se não forem, então você pode perceber que tipo de ajuste você precisa. Esta técnica, quando bem usada, permite até mesmo que pessoas daltônicas corrigirem as cores de uma imagem.

Se a sua imagem estiver com aspecto de lavada, desbotada — o que pode acontecer facilmente se você tira fotos na luz muito clara — tente usar a ferramenta de Matiz e saturação, que apresenta três controles para serem manipulados, para Matiz, Luminosidade e Saturação. Aumentar a saturação provavelmente fará a imagem parecer melhor. Em alguns casos é bem útil ajustar a luminosidade ao mesmo tempo (Luminosidade aqui é bem parecida com o controle de Brilho na ferramenta de Brilho e contraste, exceto que cada um é formado de diferentes proporções dos canais vermelho, verde e azul). A ferramenta de Matiz e saturação também dá opção de alterar sub-faixas específicas das cores (usando os botões no alto do diálogo), mas se você quiser cores que pareçam naturais é melhor evitar fazer isso na maioria dos casos, e usar seleções para alterar partes específicas da imagem com esta ferramenta.

[Dica] Dica

Mesmo se uma imagem não parecer estar desbotada, muitas vezes você pode aumentar seu impacto aumentando um pouco a saturação. Veteranos da era da fotografia em filmes, algumas vezes chamam essa técnica de Fujificar, devido ao filme Fujichrome, que era notório por produzir fotografias bastante saturadas.

Quando você tira fotos em condições de pouca luz, em alguns casos você tem o problema oposto: muita saturação. Nesse caso, a ferramenta de Matiz e saturação é uma boa opção, só que para reduzir a saturação, em vez de aumenta-la.

1.4. Ajustando a nitidez

1.4.1. Tornando nítida

Se o foco da câmera não estiver ajustado perfeitamente, ou se a câmera estive se movendo quando a foto for tirada, o resultado será uma imagem desfocada. Se estiver muito embaçada, provavelmente não há muita coisa a fazer, com qualquer técnica, mas se for só um tanto moderado, pode ser que você consiga melhorar a imagem.

The most generally useful technique for sharpening a fuzzy image is called the Sharpen (Unsharp Mask. In spite of the rather confusing name, which derives from its origins as a technique used by film developers, its result is to make the image sharper, not unsharp. It is a plug-in, and you can access it as Filters->Enhance->Sharpen (Unsharp Mask) in the image menu. There are two parameters, Radius and Amount. The default values often work pretty well, so you should try them first. Increasing either the radius or the amount increases the strength of the effect. Don't get carried away, though: if you make the unsharp mask too strong, it will amplify noise in the image and also give rise to visible artifacts where there are sharp edges.

[Dica] Dica

Sometimes using Sharpen (Unsharp Mask) can cause color distortion where there are strong contrasts in an image. When this happens, you can often get better results by decomposing the image into separate Hue-Saturation-Value (HSV) layers, and running Sharpen (Unsharp Mask) on the Value layer only, then recomposing. This works because the human eye has much finer resolution for brightness than for color. See the sections on Decompose and Compose for more information.

Em algumas ocasiões, você pode conseguir resultados úteis tornando nítidas partes específicas de uma imagem, usando a ferramenta de Desfocar / deixar nítido da caixa de ferramentas, no modo de Deixar nítido. Isso permite que você aumente a nitidez de áreas da imagem pintando sobre as mesmas com o pincel. Você deve se conter, no entanto, ou os resultados não parecerão muito naturais. Aumentar a nitidez melhora as definições de contornos em uma imagem, mas também amplifica o ruído.

1.4.2. Reduzindo a granulosidade

When you take pictures in low-light conditions or with a very fast exposure time, the camera does not get enough data to make good estimates of the true color at each pixel, and consequently the resulting image looks grainy. You can smooth out the graininess by blurring the image, but then you will also lose sharpness. There are a couple of approaches that may give better results. Probably the best, if the graininess is not too bad, is to use the filter called Selective Blur, setting the blurring radius to 1 or 2 pixels. The other approach is to use the Despeckle filter. This has a nice preview, so you can play with the settings and try to find some that give good results. When graininess is really bad, though, it is often very difficult to fix by anything except heroic measures (i.e., retouching with paint tools).

1.4.3. Suavizando

De vez em quando você tem o problema oposto: uma imagem está com muita ênfase nos detalhes. A solução é desfoca-la um pouquinho. Felizmente desfocar uma imagem é muito mais fácil do que torna-la nítida. Uma vez que dificilmente você vai querer desfocar demais, o método mais simples é usar o plug-in Desfocar, acessível em Filtros->Desfocar->Desfocar no menu da janela de imagem. Isso vai suavizar um tanto o foco da imagem. Se você quiser uma suavização maior, simplesmente repita a aplicação do filtro até chegar ao resultado desejado.

1.5. Removendo objetos indesejados de uma imagem

Há dois tipos de objetos que você pode querer remover de uma imagem: defeitos causados por coisas como poeira ou cabelo na lente; ou coisas que estavam de fato presentes na imagem, mas atrapalham a qualidade da mesma, tais como fios e postes telefônicos atravessando uma linda fotografia de paisagem das montanhas.

1.5.1. Suprimindo manchas

Uma boa ferramenta para suprimir poeira e outros tipos de sujeira da lente, é o filtro de Suprimir Manchas, que pode ser acessado em Filtros->Realçar->Suprimir manchas do menu da janela de imagens. Uma coisa muito importante: para usar este filtro efetivamente, você começa por fazer uma pequena seleção contendo a mancha e uma pequena área ao redor da mesma. A seleção deve ser pequena o suficiente de tal forma que as manchas sejam distinguíveis estatisticamente dos outros pixels dentro da seleção. Se você tentar executar Suprimir manchas na imagem toda, dificilmente você vai ter qualquer resultado útil (a não ser ao tentar reduzir a granulação - veja seção anterior). Uma vez que você tenha chegado a uma seleção razoável,a tive o Suprimir manchas, e veja a pré-visualização enquanto ajusta os parâmetros. Com sorte, você achará alguma configuração que pode remover a sujeira afetando minimamente a área ao redor. Quanto mais a mancha for distinta da área ao redor da mesma, melhores resultados você deve ter. Se não estiver funcionando, você pode tentar cancelar o filtro, criar uma outra seleção, e tentar de novo.

Se você tem mais de uma mancha em uma imagem, você precisa aplicar o filtro Suprimir manchas em cada uma delas, individualmente.

1.5.2. Remoção de objetos

O método mais efetivo para remover tralhas indesejadas de uma imagem é a ferramenta Clonar - , que permite que você pinte sobre uma parte da imagem copiando pixels diretamente de outra parte, ou mesmo de uma imagem diferente. O truque para usar a ferramenta de Clonar de forma eficaz é encontrar uma parte da imagem que possa ser usada para copiar por cima da parte indesejada. Se a área ao redor de um objeto indesejado for muito diferente do restante da imagem, você pode não ter tanta sorte. Por exemplo, se numa adorável cena de praia, aparece um terrível ser humano andando na areia, e você fica com aquele sentimento de que você gostaria de teleporta-lo pra longe, é bem provável que você encontre uma área vazia da praia parecida com área que a pessoa está, e usa-la para clonar por cima dele. É impressionante como os resultados desta ferramenta parecem naturais quando ela funciona bem.

Consulte a ajuda da ferramenta de Clonar para instruções mais detalhadas. Clonar é tanto uma ciência quanto uma arte, e quanto mais você pratica-la, melhor você fica. No começo pode parecer impossível chegar a qualquer resultado exceto algumas manchas horríveis, mas a persistência compensa.

Uma outra ferramenta que é bem parecida com a ferramenta de clonar, mas mais esperta, é a ferramenta de Restauração, que também leva em conta a área ao redor do destino ao clonar. Um uso típico é a remoção de rugas ou outros erros menores em imagens.

Em alguns casos, você pode conseguir bons resultados simplesmente cortando o objeto ofensor pra fora da imagem (com editar->cortar) e então usar um plug-in chamado Resynthesizer para preencher o espaço vazio. Este plug-in não vem junto com o GIMP padrão, mas pode ser obtido do site do autor [PLUGIN-RESYNTH]. Como sempre, a efetividade dos resultados que você obtém podem variar.

1.5.3. Remoção de olhos vermelhos

Quando você tira uma foto com flash de alguém que está olhando diretamente para a câmera, a iris pode refletir a luz do flash de volta para câmera de forma que o olho pode aparecer em um vermelho brilhante: este efeito é chamado de olho vermelho e fica muito estranho. Muitas câmeras modernas tem modos especiais de flash que diminuem esse efeito, mas isso só funciona se esses modos estiverem ligados, e mesmo assim, nem sempre eles são perfeitos. É interessante que o mesmo efeito acontece com fotos de animais, mas os olhos deles podem aparecer de outras cores, tais como verde.

From version 2.4, GIMP incorporated a special remove red eye filter. Make a selection with one of the selection tools of the red part of the eye and then choose the Remove Red Eye filter. Perhaps you have to fiddle around a bit with the threshold slider to get the right color.

1.6. Salvando seus resultados

1.6.1. Arquivos

Qual formato de arquivo você deve usar para salvar ou exportar seus resultados, e, será que você deve redimensiona-lo? As respostas dependem do que você pretende fazer com a imagem.

  • Se você pretende abrir a imagem no GIMP novamente para trabalhar mais, você deve salva-la no formato XCF nativo do GIMP (isso é, colocar .xcf na extensão de arquivo). Porque esse é único formato que garante que nenhuma informação da imagem é perdida.

  • Se você pretende imprimir a imagem em papel, você deve evitar reduzir o seu tamanho, exceto cortando partes dela (guilhotinando, com a ferramenta Cortar). A razão para isso é que impressoras tem resoluções muito maiores do que monitores de vídeo — 600 até 3000 dpi Pontos por polegada (dots per inch), a densidade física — o que vai equivaler a cerca de 300 pixels por polegada — você precisa de muitos pontos de tinta para criar o equivalente a um pixel, que pode ser de qualquer intensidade de cor. Monitores por outro lado costumam estar na faixa de 75-120 pixels por polegada. Uma imagem de 3000 x 5000-pixels pode parecer gigante num monitor, mas vai ficar do tamanho de uma folha de papel ao ser impressa com qualidade altíssima numa impressora. Em geral, não há razão para aumentar o tamanho de uma imagem também: você não pode aumentar a resolução real desta forma , uma vez que detalhes novos não podem ser criados, e você sempre pode configurar o tamanho para impressão para o aumento de tamanho acontecer durante a impressão, automaticamente. Quanto ao formato de arquivo, para fotografias em geral está ok usar o formato JPEG com qualidade entre 75 e 90. No caso de imagens criadas no computador, ou com texto inserido, ou capturas de tela, o melhor é usar um formato sem perda como o PNG.

  • Se você pretende exibir a imagem somente na tela, ou usa-la com um projetor de vídeo, tenham em mente que as maiores resoluções que existem estão na faixa de 1920x1080 (HD) - então você não vai ganhar muito se mantiver sua exportação final maior que isso.

  • Se você pretende colocar a imagem numa página web ou envia-la por e-mail, pode ser uma boa ideia manter o tamanho do arquivo tão pequeno quanto possível. Primeiro, reduza a imagem até o menor tamanho confortável, em que seja possível ver os detalhes relevantes (tenha em mente que outras pessoas vão estar usando monitores e configurações de resolução diferentes). Segundo, exporte a imagem como um arquivo JPEG. No diálogo de exportação para JPEG, marque a opção de Exibir pré-visualização na janela de imagem, e então ajuste a configuração de qualidade para o nível mais baixo que deixe a qualidade aceitável. (Você verá os efeitos de cada alteração na imagem). Certifique-se de que a imagem esteja no nível de zoom de 100% ao fazer isso, de forma que você não se engane por conta dos efeitos do zoom.

Veja a seção de Formatos de arquivo para ter maiores informações.

1.6.2. Imprimindo suas fotos

As in most applications, in GIMP, printing needs to go to main menu FilePrint. However it is very useful to keep in mind some elementary concepts to prevent some unpleasant surprises when looking at result, or to cure them if that occurs. You must always remember:

  • que a imagem exibida na sua tela está no modo RGB, e a impressão acontece no modo CMYK; Em consequência, as cores que você obtém na impressão podem não ser exatamente as que você está esperando. Isso depende de usar as tabelas corretas. Para os curiosos, algumas explicações esclarecedoras podem ser vistas nesses links da Wikipedia:

  • que a resolução do monitor está sempre entre 72 e 120 pixels por polegada, que a resolução da impressora, em pontos por polegada, pode ser até 10 vezes maior (ainda que você precise de muitos pontos para ter a cópia exata de um pixel) que a de uma tela, então o tamanho da impressão não corresponde ao tamanho da imagem como é vista na tela, ou ao tamanho da folha de papel.

Consequentemente, antes de qualquer impressão, é importante você ir até ImagemTamanho para impressão e escolher o tamanho de saída mais conveniente na caixa de Tamanho de impressão, ajustando-a diretamente ou ajustando a resolução. O símbolo mostra que ambos os valores estão vinculados. Você pode desassociar a resolução horizontal da vertical clicando neste símbolo, mas é arriscado. No passado, com o usuário tendo controle direto de impressoras com resolução X e Y diferentes isso até podia ser útil para impressão. Hoje, os drivers de impressão abstraem essa parte - portanto essa mudança só é útil para criar efeitos especiais, ou para outros usos da resolução da imagem.

Uma última recomendação: verifique o tamanho das margens e centralização da imagem. Seria uma pena se uma margem muito grande ou centralização inapropriada danificasse seu trabalho - principalmente se você estiver usando algum papel fotográfico especial.

1.6.3. Dados EXIF

Câmeras digitais modernas, quando batem uma foto, adicionam informações ao arquivo de dados que contém a imagem. Essas informações incluem o modo da câmera, configurações da mesma, e algumas das circunstâncias em que a foto foi tirada. Esses dados são incluídos em arquivos JPEG, TIFF ou RAW em uma estrutura chamada de EXIF. Para arquivos JPEG, o GIMP pode conservar os dados EXIF se tiver sido compilado adequadamente. Ele depende de uma biblioteca chamada libexif (e partir da versão 2.10, da biblioteca gexiv2), que pode não estar disponível em todos os sistmas. Se o GIMP está com o suporte a EXIF habilitado, então importar uma imagem JPEG com dados de EXIF e exporta-la de volta para JPEG fará com que esses dados sejam preservados sem modificações. Esta não é a melhor forma para um editor de imagens lidar com dados EXIF, mas é melhor do que simplesmente remove-lo, o que era o que algumas versões iniciais do GIMP faziam.

Se você quiser ver o conteúdo dos dados de EXIF, você pode baixar do registro de plug-ins do GIMP o Exif browser plug-in [PLUGIN-EXIF]. Após instala-lo, haverá uma opção em Filtros->Genéricos>Exif browser a partir do menu de imagens. (Veja Instalando novos plug-ins para ajuda)