第8章 画像の組み合わせ

目次

1. レイヤーのあらまし
1.1. レイヤーの諸特性
2. レイヤーのモード
3. 新しいレイヤーの作成
4. レイヤーグループ

1. レイヤーのあらまし

You can think of layers as a stack of slides. Using layers, you can construct an image of several conceptual parts, each of which can be manipulated without affecting any other part of the image. Layers are stacked on top of each other. The bottom layer is the background of the image, and the components in the foreground of the image come above it.

図8.1 An image with layers

An image with layers

Layers of the image

An image with layers

Resulting image


There is no limit, in principle, to the number of layers an image can have: only the amount of memory available on the system. It is not uncommon for advanced users to work with images containing dozens of layers. You can group layers to make your work easier, and you have many commands to handle layers.

レイヤーが画像上で重ね合わされている様子はレイヤーダイアログで見られます。 レイヤーダイアログは GIMP にとってはツールボックスに次いで重要なダイアログです。 そのはたらきは レイヤーダイアログ の節で詳しく説明してありますが、 レイヤーの属性表示の機能についてはここでも触れることにします。

画像は開かれるとそれぞれに 活性描画対象 (active drawable) をひとつ持ちます。 レイヤーは描画対象のひとつですが、 他にもチャンネルやレイヤーマスク、 選択マスクもこれに含まれます。 (基本的には、 描画対象とは描画ツールで書き込めるもの全般を表しています。) 現在活性化しているレイヤーはレイヤーダイアログで強調表示され、 画像ウィンドウ下部の状態情報の区画でその名前が表示されます。 不活性レイヤーはレイヤーダイアログ上でクリックすると活性化します。 いずれのレイヤーも強調表示されていない場合は、 レイヤー以外の描画対象が活性化していることになります。

In the menu bar above an image window, you can find a menu called Layer, containing a number of commands that affect the active layer of the image. The same menu can be accessed by right-clicking in the Layers dialog.

1.1. レイヤーの諸特性

画像上のレイヤーはそれぞれが数々の重要な属性を有しています。

レイヤー名

レイヤーはそれぞれ名前がつきます。 レイヤーが作られるときに自動的に名付けられることもありますが、 変更もできます。 レイヤー名はレイヤーダイアログ上で名前を変えたいレイヤーの名前をダブルクリックすればその場で書き換えられます。 あるいはレイヤーダイアログでレイヤー名をマウスの 第2ボタン でクリックして出てくるメニューの最上部にある レイヤー名の変更... をクリックすると、 ダイアログが現れますのでここで現在活性化しているレイヤーの名前を変更できます。

アルファチャンネルの追加と削除

アルファチャンネルは各レイヤーの画素ごとの透過程度の情報を符号化します。 チャンネルダイアログ上で可視化されています。 白は完全不透明、 黒は完全透過を表し、 灰色は各段階の不完全透過を表しています。

背景レイヤーはこの件で独特です。 新しい画像を作成した直後の段階では、 画像のレイヤーは背景レイヤーの 1 層だけです。 作成の際に塗りつぶし色に透明以外を指定した場合はその画像にアルファチャンネルはありません。 しかし新しくレイヤーを追加すれば、 不透明な塗りつぶし色で作成された画像であっても自動的にアルファチャンネルがつくられ、 背景レイヤーを別として新たなレイヤーにはすべて適用されます。 背景レイヤーにも透過効果が欲しいときは、 新しい画像の作成の際に塗りつぶし色に透明を選ぶか、 既にある画像の背景レイヤーに対し アルファチャンネルを追加 します。

レイヤーは最背面のレイヤーを除きいずれも自動的にアルファチャンネルがある状態になりますが、 アルファ値をグレースケール化して見ることはできません。 詳しい説明が用語集の アルファ の項目にあります。

アルファチャンネルの例. 

図8.2 アルファチャンネルの例: 基本の画像

アルファチャンネルの例: 基本の画像

この画像では 3 層のレイヤーがそれぞれ純赤、 純緑、 純青で 100% 不透明に塗られている。 チャンネルダイアログではこの画像にアルファチャンネルが加わっていることがわかる。 白く描かれているのは、 100% 不透明なレイヤーしかないので画像が全く透過しないためである。 いま赤のレイヤーを活性化している。 純赤で塗られているので緑や青は片鱗もなく、 それぞれのチャンネルは黒くなっている。


図8.3 アルファチャンネルの例: 透過レイヤーが 1 層

アルファチャンネルの例: 透過レイヤーが 1 層

最前面のレイヤーの左半分が透明になった (矩形選択してから 編集消去 (Delete) )。 第 2 のレイヤーの緑が透けて見える。 アルファチャンネルがまだ白いままなのは、 画像にはこの区画で不透明なレイヤーがあるためである。


図8.4 アルファチャンネルの例: 透過レイヤーが 2 層

アルファチャンネルの例: 透過レイヤーが 2 層

第 2 のレイヤーの左側を透過させた。 第 3 のレイヤーの青が第 1 と第 2 のレイヤーを通して見えている。 アルファチャンネルがいまだ白いのは、 画像にはこの区画で不透明なレイヤーがあるためである。


図8.5 アルファチャンネルの例: 透過レイヤーが 3 層

アルファチャンネルの例: 透過レイヤーが 3 層

第 3 のレイヤーの左半分を透過させ[ようとし]た。 アルファチャンネルは白いままで、 このレイヤーの左半分も白く不透明だ。 背景レイヤーにアルファチャンネルがない。 つまりこれは、 消去コマンドが消しゴムツールのように動作するため、 ツールボックスの色の区画に示されている背景色が塗られたことになる。


図8.6 アルファチャンネルの例: 背景レイヤーにアルファチャンネルを追加

アルファチャンネルの例: 背景レイヤーにアルファチャンネルを追加

レイヤー透明部分アルファチャンネルを追加 コマンドを背景レイヤーに対して使った。 とうとうこの画像の左半分は完全に透過し、 画像が置かれたページの色が出ている。 アルファチャンネルの左部分は透明になり、 チャンネルダイアログ上では黒く表示された。


レイヤーの形式

レイヤーの種類とは画像のモード (前節を参照) とアルファチャンネルの有無により決まっています。 6 種類が考えられます。

  • 赤・緑・青 (RGB)

  • 赤・緑・青・アルファつき (RGBA)

  • グレースケール (Gray)

  • アルファつきグレースケール (GrayA)

  • インデックス化カラー (Indexed)

  • アルファつきインデックス化カラー (IndexedA)

レイヤーの種類を問うものの代表がフィルター (フィルター メニューにある) です。 その多くが扱える種類を限定しており、 使えないフィルターはメニュー上で灰色無効になっています。 画像のモードを変更したりアルファチャンネルを追加もしくは削除すると大抵の問題は対処できます。

可視性

レイヤーを破棄せずに画像から除外したいときは、 レイヤーダイアログ上でのしるしをクリックします。 これをレイヤーの可視性の切り替えといいます。 画像に対する操作のほとんどは不可視にされたレイヤーをまるで存在しないかのように扱います。 不透明度が一様でない複数のレイヤーを有する画像を扱うとき、 他のレイヤーをいくつか隠せば作業対象のレイヤーの内容がよく見えます。

[ティップ] ティップ

Shift キーを押しながら目のしるしをクリックするとクリックしたレイヤー 以外の すべてのレイヤーが不可視になります。 再び同じ操作をするとすべてのレイヤーが可視性有りに切り替わります。

Active layer

Usually, you activate a layer, to work on it, clicking it in the layer list. When you have a lot of layers, finding which layer an element of the image belongs to is not easy: then, press Alt and click with Mouse wheel on this element to activate its layer. The available layers will be looped through (starting from the upper one) while the Alt is held and the picked layer will be temporarily displayed in the status bar.

レイヤーの連結

レイヤーの見本と目のしるしの間をクリックすると、 複数のレイヤーを纏める鎖のアイコンが表示されます。 こうして連結されたレイヤーはたとえば移動ツールをはじめとする変形ツールで一斉に操作できます。 連結は パスダイアログ にもあって、 連結されたレイヤーとともに操作できます。

図8.7 レイヤーダイアログ

レイヤーダイアログ

黄: 可視性。 赤: レイヤー同士の連結。


大きさと境界線

GIMP ではレイヤーの境界線がその画像の境界線と一致する必要がありません。 たとえばテキストを置く場合、 それぞれのテキストは別個のレイヤーとなって画像に重なり、 その大きさはぴったり文字の大きさが収まるだけの幅と高さになります。 また、 切り取って貼り付けられた新たなレイヤーは、 貼り付けられた形象が収まるちょうどの大きさになります。 画像ウィンドウ上では、 活性レイヤーの境界線は黒と黄の点滅破線で縁取られて表示されます。

レイヤーの境界線に気を付けなければならない理由は、 領域外では何も操作ができないからです。 何もないところでは作業できません。 これでは困るときはレイヤーの大きさを変更しても構いません。 レイヤー メニューの下のほうにいくつか関係するコマンドがあります。

[注記] 注記

レイヤーが消費するメモリー量はそこに描かれた内容を問わずただその大きさで決まります。 ですから多数のレイヤーを有する画像や巨大な画像を扱うときには、 それぞれのレイヤーの大きさをできるだけ小さくするとメモリーの消費を節約できます。

不透明度

レイヤーの不透明度は積み重なったレイヤーを上から見て下層のレイヤーの色がどの程度見えるかを定めます。 不透明度の範囲は 0 から 100 にあり、 0 は完全透過を、 100 は完全不透明を表します。

モード

レイヤーのモードはこのレイヤーの色が背面側のレイヤーの色とどのように合成され視覚的効果を及ぼすかを定めます。 とても複雑ですがとても重要ですので、 その件だけの節を設けるのに十分な内容があります。 次節 「レイヤーのモード」 をお読みください。

レイヤーマスク

アルファチャンネルとは別に、 レイヤーに透過効果をかけるもう一つの方法があります。 レイヤーマスク はレイヤーに追加するとそのレイヤーに対してグレースケールの描画対象が付加されます。 レイヤーは作られた当初はレイヤーマスクがありませんので、 必要なときに追加することになります。 レイヤーマスクとその操作方法については レイヤーマスク でさらに踏み込んで説明しています。