Kapitel 10. Fotos verbessern

Inhaltsverzeichnis

1. Mit digitalen Fotos arbeiten
1.1. Einführung
1.2. Die Komposition verbessern
1.3. Farben verbessern
1.4. Die Bildschärfe regulieren
1.5. Unerwünschte Objekte aus einem Bild entfernen
1.6. Ihre Ergebnisse sichern

1. Mit digitalen Fotos arbeiten

1.1. Einführung

Eine der häufigsten Anwendungen für GIMP ist das Korrigieren digitaler Fotos, die aus irgendeinem Grund nicht ganz perfekt geworden sind. Das Bild ist vielleicht über- oder unterbelichtet, vielleicht etwas gedreht, möglicherweise unscharf. Das sind alles typische Probleme, für die GIMP geeignete Werkzeuge hat. Das Anliegen dieses Kapitels ist es, Ihnen einen Überblick über diese Werkzeuge und die Situationen, in denen sie sinnvoll eingesetzt werden können, zu verschaffen. Sie werden hier allerdings keine detaillierten Anleitungen finden. In den meisten Fällen erlernt man die Benutzung dieser Werkzeuge leichter, indem man sie einfach ausprobiert und damit experimentiert, statt darüber zu lesen. (Außerdem ist jedes Werkzeug in der betreffenden Hilfeseite ausführlicher beschrieben.) Sie werden hier auch nichts über die Vielzahl der »Spezialeffekte« finden, die Sie mit GIMP auf ein Bild anwenden können. Sie sollten mit den grundlegenden Konzepten von GIMP vertraut sein, bevor Sie dieses Kapitel lesen, aber Sie müssen ganz bestimmt kein Experte sein; falls Sie einer sind, kennen Sie das meiste sowieso schon. Und schrecken Sie nicht vor Experimenten zurück: GIMPs leistungsfähiges »Journal« erlaubt es Ihnen, fast jeden Arbeitsschritt durch ein einfaches Strg+Z wieder rückgängig zu machen.

Meistens fällt das, was Sie zur Verbesserung eines unvollkommenen Fotos machen wollen, in die folgenden Kategorien: Verbesserung der Komposition, Verbesserung der Farben, Verbesserung der Schärfe, Entfernung von Artefakten oder anderen unerwünschten Elementen aus dem Bild.

1.2. Die Komposition verbessern

1.2.1. Ein Bild drehen

Es passiert sehr leicht, die Kamera beim Fotografieren nicht ganz waagerecht zu halten, so dass die Objekte im Bild etwas geneigt sind. In GIMP verwendet man das Drehen-Werkzeug, um das zu korrigieren. Sie aktivieren es durch einen Klick auf das Symbol im Werkzeugfenster oder, während Sie im Bildfenster sind, durch die Taste Umschalt+R (großes »R«). Vergewissern Sie sich, dass die Werkzeugoptionen sichtbar sind und dass oben für Wirkt auf der linke Knopf (»Ebene transformieren«) aktiviert ist. Wenn Sie dann auf das Bild klicken und den Mauszeiger ziehen, sehen Sie einen Umriss, der sich beim Ziehen dreht. Wenn dieser Umriss richtig liegt, klicken Sie auf Rotieren oder drücken die Enter-Taste, und das Bild wird gedreht.

In der Praxis ist es allerdings nicht ganz so leicht, mit dieser Methode alles richtig zu machen. Oft werden Sie feststellen, dass es zwar besser geworden ist, aber noch nicht perfekt. Eine Lösung wäre jetzt, noch ein bisschen mehr zu drehen, aber dieser Ansatz hat einen Nachteil: Jedesmal, wenn Sie ein Bild drehen, wird es zwangsläufig etwas undeutlicher, da die Pixel nach der Drehung nicht exakt wie die Originale ausgerichtet sind. Für eine einzige Drehung ist diese Unschärfe nur gering, aber zwei Drehungen machen das Bild zweimal so unscharf wie eine, und es gibt keinen Grund, das Bild undeutlicher als nötig zu machen. Ein bessere Alternative ist es, die Drehung rückgängig zu machen und dann eine andere Drehung mit angepasstem Winkel zu versuchen.

Glücklicherweise stellt GIMP eine erheblich leichtere Methode bereit: bei den Optionen des Drehwerkzeuges können Sie als Transformationsrichtung »Rückwärts (Korrigierend)« wählen. Statt den Umriss zu drehen, um den Fehler zu kompensieren, können Sie ihn nun zum Fehler ausgerichtet drehen. Wenn das jetzt zu verwirrend war, probieren Sie es einfach aus, Sie werden sehen, es ist eigentlich ganz einfach.

[Anmerkung] Anmerkung

Seit GIMP 2.2 gibt es die Option, eine Vorschau des transformierten Bildes anstelle nur des Umrisses anzuzeigen. Das erleichtert es, die Arbeit gleich beim ersten Versuch richtig zu machen.

Nachdem Sie ein Bild gedreht haben, sind an den Ecken unangenehme dreieckige »Löcher«. Ein Weg, das zu beheben, besteht darin, einen Hintergrund zu erstellen, der die Löcher mit einer unauffälligen oder neutralen Farbe füllt, aber normalerweise ist es besser, etwas vom Bild abzuschneiden. Je größer die Drehung, desto mehr muss abgeschnitten werden, daher ist es am besten, die Kamera beim Fotografieren so gerade wie möglich zu halten.

1.2.2. Zuschneiden

Wenn Sie ein Bild mit einer digitalen Kamera aufnehmen, haben Sie eine gewisse Kontrolle darüber, was im Bild enthalten ist, aber oftmals nicht in dem Ausmaß, wie Sie es vielleicht wünschten, mit der Folge, dass die Bilder nachgeschnitten werden sollten. Darüber hinaus ist es oft möglich, den Eindruck des Bildes zu verbessern, indem man es nachträglich so zuschneidet, dass wichtige Elemente auf Schlüsselpositionen platziert werden. Eine gute, wenn auch nicht allgemein gültige Regel, die man im Kopf haben sollte, ist die »Drittelregel«. Danach erreicht man den besten Eindruck, wenn man Höhe und Breite des Bildes gedanklich in Drittel aufteilt und das Hauptmotiv an den gedachten Drittellinien beziehungsweise an deren Schnittpunkten platziert.

Um ein Bild zuzuschneiden, aktivieren Sie das Werkzeug Zuschneiden / Größe ändern im Werkzeugfenster oder durch die Taste Umschalt+C, während der Mauszeiger auf dem Bild ist. Klicken und Ziehen im Bild wird nun ein Rechteck freimachen. Außerdem öffnet sich ein Dialogfenster, in dem Sie die Größe der ausgeschnittenen Region anpassen können, falls sie nicht ganz genau stimmt. Wenn alles perfekt ist, drücken Sie den Knopf Zuschneiden im Dialog.

1.3. Farben verbessern

1.3.1. Automatisierte Werkzeuge

Trotz ausgeklügelter Belichtungssyteme sind Bilder digitaler Kameras oft über- oder unterbelichtet, oder sie weisen Farbstiche aufgrund ungenügender Beleuchtung auf. GIMP gibt Ihnen eine Vielzahl von Werkzeugen an die Hand, mit denen Sie Farben in einem Bild korrigieren können, von automatisierten Tools, die auf einen simplen Mausklick hin laufen, bis hoch entwickelten Werkzeugen, die Ihnen viele Parameter zur Steuerung anbieten. Wir fangen mit den einfachsten an.

GIMP bietet Ihnen einige automatisierte Korrekturwerkzeuge. Unglücklicherweise liefern sie meistens nicht ganz genau die Ergebnisse, die Sie haben wollen, aber sie lassen sich in Sekundenschnelle ausprobieren und geben Ihnen oftmals zumindest eine Idee einiger Möglichkeiten, die in dem Bild stecken. Mit Ausnahme von »Automatische Farbwerte« finden Sie sie unter FarbenAutomatisch im Menü des Bildfensters.

Hier sind sie, jeweils mit ein paar Anmerkungen:

Normalisieren

Dieses Werkzeug (tatsächlich ist es ein Plugin) ist für unterbelichtetet Bilder nützlich: es passt das ganze Bild gleichförmig solange an, bis der hellste Punkt genau am Sättigungslimit liegt und der dunkelste Punkt schwarz ist. Der Nachteil ist, dass der Helligkeitsgrad einzig durch den hellsten beziehungsweise dunkelsten Punkt des Bildes festgelegt wird, d.h. nur ein einziges weißes und/oder schwarzes Pixel macht die Normalisierung untauglich.

Egalisieren

Dies ist eine sehr wirkungsvolle Anpassung, die versucht, die Bildfarben gleichmäßig auf den Bereich aller möglichen Intensitäten zu verteilen. In manchen Fällen ist der Effekt wirklich erstaunlich und bringt Kontraste zum Vorschein, die man auf andere Art und Weise nur sehr schwer erreichen kann. Aber gewöhnlich bewirkt sie einfach nur, dass das Bild sehr seltsam aussieht. Ach ja, sie kann in nur einem Augenblick ausprobiert werden.

Farbverbesserung

Hiermit wird die Farbsättigung der aktiven Ebenen erhöht, ohne den Farbton oder die Helligkeit zu verändern. Daher funktioniert dieses Werkzeug auch nicht bei Graustufenbildern.

Kontrastspreizung

Das ist wie »Normalisierung«, außer dass es unabhängig auf dem Rot-, Grün- und Blaukanal arbeitet. Oft hat es den nützlichen Effekt, Farbstiche zu reduzieren.

HSV strecken

Wie »Kontrastspreizung«, arbeitet aber im HSV-Farbmodell und erhält den Farbton.

Weißabgleich

Dieses Kommando kann Bilder mit schlechtem Weiß oder Schwarz verbessern, indem es nur wenig vorkommende Farben entfernt und den übrigen Farbbereich weitestmöglich streckt.

Automatische Farbwerte

Dies aktiviert man über WerkzeugeFarbenWerte oder FarbenWerte im Menü des Bildfensters, dann den Knopf Automatisch in der Mitte des Dialogfensters drücken. Sie sehen eine Vorschau des Ergebnisses. Drücken Sie OK, um es anzuwenden, oder Abbrechen, damit das Bild wieder in den vorigen Zustand zurückkehrt.

Falls Sie im Bild einen Punkt finden, der weiß sein sollte, und einen zweiten, der schwarz sein sollte, dann können Sie mit diesem Werkzeug eine halbautomatische Anpassung durchführen, die oftmals sowohl die Helligkeit als auch die Farben erfolgreich im gesamten Bild korrigiert. Aktivieren Sie zuerst das Werkzeug wie oben beschrieben. Suchen Sie nun unten im Dialogfenster die drei Knöpfen mit den Symbolen, die wie Pipetten aussehen (beziehungsweise aussehen sollten ...). Wenn Sie den Mauszeiger auf den linken Schalter bewegen, wird die Funktion angezeigt: »Schwarz-Punkt wählen«. Klicken Sie darauf, dann klicken Sie auf einen Punkt im Bild, der schwarz sein sollte - tatsächlich vollkommen schwarz, und nicht nur irgendwie dunkel. Achten Sie darauf, wie sich das Bild verändert. Als nächstes klicken Sie auf den rechten der drei Schalter (»Weiß-Punkt wählen«) und dann auf einen Bildpunkt, der weiß sein sollte. Beachten Sie wieder, wie sich das Bild verändert. Wenn Sie mit dem Ergebnis zufrieden sind, klicken Sie auf OK, andernfalls auf Abbrechen.

Das waren die automatisierten Farbeinstellungen. Falls Sie feststellen, dass Ihnen keine davon weiterhilft, dann ist es an der Zeit, eines der interaktiven Werkzeuge auszuprobieren. Mit einer Ausnahme können Sie auf diese über WerkzeugeFarben im Menü des Bildfensters zugreifen. Nachdem Sie ein Farbwerkzeug ausgewählt haben, klicken Sie irgendwo auf das Bild, um das Werkzeug zu aktivieren und das Dialogfenster zu öffnen.

1.3.2. Belichtungsprobleme

Das am einfachsten zu benutzende Werkzeug ist Helligkeit / Kontrast. Es ist allerdings auch nicht sehr leistungsfähig, aber in vielen Fällen macht es schon alles, was Sie brauchen. Dieses Werkzeug ist häufig für über- oder unterbelichtete Bilder nützlich, nicht aber, um Farbstiche zu korrigieren. Mittels zweier Schieberegler können Sie Helligkeit und Kontrast einstellen. Wenn Sie die Option »Vorschau« aktiviert haben (und das sollten Sie praktisch immer), sehen Sie, wie sich die Anpassungen im Bild niederschlagen. Wenn Sie mit dem Ergebnis zufrieden sind, drücken Sie OK, und Ihre Einstellungen werden übernommen. Ansonsten können Sie mit dem Knopf Abbrechen das Bild in seinen vorigen Zustand zurücksetzen.

Eine anspruchsvollere und kaum schwierigere Möglichkeit, Probleme mit der Belichtung zu korrigieren, ist das bereits erwähnte Werkzeug »Werte«. Dessen Dialog sieht sehr kompliziert aus, aber für die einfache Nutzung, die wir hier im Sinn haben, müssen Sie sich nur mit dem Bereich »Quellwerte« beschäftigen, insbesondere mit den drei dreieckigen Schiebereglern unterhalb des Diagramms. Für die Benutzung verweisen wir Sie auf Abschnitt 8.10, „Levels“, aber tatsächlich ist der einfachste Weg, die Benutzung zu erlernen, mit den Reglern zu experimentieren und sie zu bewegen, während Sie beobachten, wie sich das Bild verändert. (Stellen Sie sicher, dass Vorschau unten im Dialogfenster aktiviert ist.)

Eine sehr leistungsfähige Methode zur Korrektur von Belichtungsproblemen ist die Verwendung des Werkzeuges Kurven. Es erlaubt Ihnen, Kontrollpunkte auf einer Kurve anzuklicken und zu verschieben, um so eine Funktion zu erstellen, die Helligkeitswerten der Eingabe Helligkeiten der Ausgabe zuordnet. Das Kurvenwerkzeug kann alle Effekte reproduzieren, die Sie mit den Werkzeugen »Helligkeit / Kontrast« oder »Werte« erreichen können. Für eine detaillierte Beschreibung verweisen wir Sie nochmals auf das entsprechende Kapitel der Hilfeseiten (Abschnitt 8.11, „Curves“), aber am leichtesten lernen Sie die Benutzung wieder durch Ausprobieren.

Der vielseitigste Ansatz, Helligkeit und Kontrast im Bild anzupassen, insbesondere für fortgeschrittenere GIMP-Benutzer, besteht darin, eine neue Ebene oberhalb der zu bearbeitenden zu erstellen und dann im Ebenendialog den Modus für die obere Ebene auf Multiplikation zu setzen. Die neue Ebene dient dann als »Intensitätsregler« für die darunter liegende, mit Weiß für maximale Intensität und Schwarz für Intensität Null. Das heißt, indem Sie auf der neuen Ebene malen, können Sie selektiv die Intensität für jeden Bereich des Bildes anpassen, was Ihnen eine ausgezeichnete Kontrolle ermöglicht. Sie sollten versuchen, nur mit weichen Farbverläufen zu malen, da sprunghafte Änderungen der Intensität zu falschen Rändern führt. Malen Sie nur mit Grautönen, nicht mit Farben, es sei denn, Sie wollen im Bild Farbänderungen erzeugen.

»Multiplikation« ist nicht der einzige Modus, der für eine Intensitätsregelung nützlich ist. Tatsächlich kann der »Multiplikations«-Modus nur Teile des Bildes verdunkeln, aber sie niemals aufhellen, er hilft also nur, wenn Teile des Bildes überbelichtet sind. »Division« hat genau den gegenteiligen Effekt: er hellt Teile des Bildes auf. Hier ein kleiner Trick, der oftmals ein Maximum an Details auf dem gesamten Bild zum Vorschein bringt:

  1. Duplizieren Sie die Ebene (das erstellt eine neue Ebene darüber).

  2. Entfernen Sie die Sättigung der neuen Ebene.

  3. Wenden Sie einen Gaußschen Weichzeichner auf das Resultat an, mit einem großen Radius (100 oder mehr).

  4. Schalten Sie den Modus im Ebenendialog auf »Division«.

  5. Regulieren Sie den Grad der Korrektur, indem Sie die Deckkraft im Ebenendialog anpassen oder mit einem der Werkzeuge »Helligkeit / Kontrast«, »Werte« oder »Kurven« auf der neuen Ebene.

  6. Wenn Sie mit dem Ergebnis zufrieden sind, können Sie mit Nach unten vereinen die Steuerungsebene mit der ursprünglichen Ebene zu einer einzigen Ebene vereinen.

Außer mit »Multiplikation« und »Division« können Sie hin und wieder auch mit anderen Ebenenmodi nützliche Effekte erzielen, etwa mit »Abwedeln«, »Nachbelichten« oder »Weiche Kanten«. Allerdings kann es nur allzuleicht passieren, dass man eine Stunde damit verbringt, mit den Parametern herumzuspielen, ohne auf die Zeit zu achten. Seien Sie also gewarnt: je mehr Möglichkeiten Sie haben, desto schwerer fällt die Entscheidung.

1.3.3. Farbton und Sättigung regulieren

Wenn Ihr Bild einen Farbstich hat, etwa zu rot oder zu blau, kann man das nach unserer Erfahrung am einfachsten mit dem Werkzeug »Werte« korrigieren, indem man die Werte für den roten, grünen und blauen Kanal jeweils einzeln anpasst. Wenn das nicht zum Erfolg führt, dann sind die Werkzeuge »Farbabgleich« oder »Farben« einen Versuch wert, aber diese sind, um sie effektiv einsetzen zu können, auch sehr viel komplizierter. (Sie sind aber sehr gut geeignet, um bestimmte Typen von Spezialeffekten zu erzeugen.)

Manchmal ist es schwer zu sagen, ob die Farbanpassungen ausreichend waren. Eine gute, objektive Methode ist, einen Punkt im Bild zu finden, von dem Sie wissen, dass er entweder weiß oder grau sein sollte. Aktivieren Sie dann die Farbpipette (das Pipettensymbol im Werkzeugfenster) und klicken Sie auf den oben erwähnten Punkt: das öffnet das Farbpipetten-Dialogfenster. Wenn die Farben korrekt angepasst wurden, dann sollte die drei Farbkomponenten Rot, Grün und Blau der angezeigten Farbe den gleichen Wert haben. Falls nicht, dann sollten Sie erkennen können, welche Anpassung Sie vorzunehmen haben. Diese Technik, wenn sie richtig benutzt wird, erlaubt es sogar Farbenblinden, die Farben eines Bildes zu korrigieren.

Wenn Ihr Bild verblasst ist, was leicht bei Aufnahmen im hellen Licht passieren kann, versuchen Sie das Werkzeug Farbton / Sättigung, welches Ihnen drei Schieberegler anbietet, um Farbton, Helligkeit und Sättigung zu verändern. Eine Erhöhung der Sättigung wird das Bild vermutlich besser erscheinen lassen. Manchmal ist es sinnvoll, gleichzeitig die Helligkeit anzupassen. (»Helligkeit« hier entspricht in etwa der »Helligkeit« im Werkzeug Helligkeit / Kontrast, außer dass beide aus unterschiedlichen Kombinationen der drei Farbkanäle gebildet werden.) »Farbton / Sättigung« bietet Ihnen die Möglichkeit, die Einstellungen auf bestimmte Farben zu beschränken (mit den Schaltern oben im Dialog), aber wenn Sie natürlich aussehende Farben erhalten wollen, sollten Sie das in der Regel vermeiden.

[Tipp] Tipp

Auch wenn ein Bild nicht verblasst zu sein scheint, können Sie den Eindruck oftmals dadurch verbessern, dass Sie die Sättigung ein klein wenig erhöhen. Veteranen der Filmära nennen diesen Trick manchmal »Fujifying«, nach dem Fujichrome-Film, der der dafür bekannt ist, Abzüge mit sehr hoher Farbsättigung zu produzieren.

Wenn Sie Bilder bei wenig Licht aufnehmen, haben Sie manchmal das entgegengesetzte Problem: zu hohe Sättigung. Auch in diesem Fall ist das Werkzeug »Farbton / Sättigung« eine gute Wahl, diesmal, um die Sättigung zu verringern statt zu erhöhen.

1.4. Die Bildschärfe regulieren

1.4.1. Bildschärfe erhöhen

Wenn das Objektiv nicht perfekt eingestellt ist oder die Kamera sich während der Bildaufnahme bewegt, ist das Ergebnis ein unscharfes Bild. Bei sehr viel Unschärfe können Sie vermutlich mit keiner Technik viel machen, aber wenn es nur ein bisschen unscharf ist, sollten Sie in der Lage sein, das Bild zu verbessern.

Meistens ist die beste Methode, um ein Bild schärfer zu machen, das Filter Schärfen (Unscharf maskieren). Trotz dieses ziemlich verwirrenden Namens, der sich von einer bei Filmentwicklern verwendeten Technik herleitet, macht er das Bild keineswegs »unscharf«, sondern schärfer. Es handelt sich hier um ein Plugin, auf das Sie über FilterVerbessernSchärfen (Unscharf maskieren) im Bildmenü zugreifen können. Es gibt zwei Parameter, »Radius« und »Menge«. Die Vorgabewerte funktionieren oftmals sehr gut, daher sollten Sie es zuerst damit probieren. Erhöhung des Radius oder der Menge erhöht die Wirkung. Aber lassen Sie sich nicht hinreißen: wenn Sie die unscharfe Maske zu stark einstellen, wird sie das Rauschen im Bild erhöhen und sichtbare Artefakte an scharfen Kanten erzeugen.

[Tipp] Tipp

Manchmal kann »Schärfen (Unscharf maskieren)« an Stellen mit starkem Kontrast die Farben verzerren. Wenn das passiert, können Sie oft bessere Resultate erzielen, indem Sie das Bild nach Farbton / Sättigung / Wert (HSV, Hue-Saturation-Value) in einzelne Ebenen zerlegen, »Schärfen (Unscharf maskieren)« auf die Ebene »Wert« (Helligkeit) anwenden und dann die Ebenen wieder zusammensetzen. Das funktioniert deshalb, weil das menschliche Auge Helligkeit sehr viel feiner auflösen kann als Farben. Mehr dazu finden Sie in Abschnitt 8.27, „ Zerlegen und Abschnitt 8.24, „Zusammenfügen“.

In einigen Situationen können Sie gute Ergebnisse erzielen, wenn Sie bestimmte Teile des Bildes mit Verknüpfen (Weichzeichnen / Schärfen) aus dem Werkzeugfenster im Modus »Schärfen« bearbeiten. Es ermöglicht Ihnen, die Schärfe in bestimmten Bereichen zu erhöhen, indem Sie sie mit irgendeinem Pinsel bemalen. Sie sollten damit allerdings zurückhaltend umgehen, denn sonst werden die Resultate nicht sehr natürlich aussehen. Schärfen erhöht nicht nur die Schärfe von offensichtlichen Kanten, sondern auch das Rauschen.

1.4.2. Körnigkeit reduzieren

Wenn Sie ein Foto bei schlechten Lichtbedingungen oder mit einer sehr kurzen Belichtungszeit aufnehmen, erhält die Kamera nicht genügend Daten, um gute Schätzungen für die tatsächliche Farbe jedes einzelnen Pixels vornehmen zu können. Folglich sehen die Ergebnisse grobkörnig aus. Sie können die Körnigkeit durch Weichzeichnen »glätten«, aber dann verlieren Sie auch die Bildschärfe. Es gibt ein paar Ansätze, die möglicherweise bessere Ergebnisse liefern. Der vermutlich beste, falls die Körnigkeit nicht zu stark ist, ist ein Filter namens Selektiver Gaußscher Weichzeichner mit einem Radius von 1 oder 2 Pixel. Ein anderer Weg ist das Filter Flecken entfernen. Dieser hat eine nette Vorschau, so dass Sie mit den Einstellungen herumspielen und so eine Kombination finden können, die gute Resultate liefert. Wenn die Körnigkeit allerdings wirklich grob ist, dann ist es gewöhnlich sehr schwer, irgend etwas zu korrigieren, es sei denn, man greift zu wirklich heroischen Maßnahmen (z.B. Retuschieren mit den Malwerkzeugen).

1.4.3. Bildschärfe herabsetzen

Gelegentlich haben Sie genau das entgegengesetzte Problem: ein Bild ist zu scharf. Die Lösung ist, es etwas zu verwischen. Glücklicherweise ist das sehr viel leichter, als das Bild schärfer zu machen. Da Sie das Bild vermutlich nicht sehr stark verwischen wollen, ist die einfachste Methode, das Plugin Weichzeichnen zu verwenden, das Sie im Bildfenster unter FilterWeichzeichnenWeichzeichnen finden. Es wird das Bild ein klein wenig verschmieren. Falls das nicht ausreicht, wiederholen Sie es einfach so lange, bis Sie das gewünschte Ergebnis haben.

1.5. Unerwünschte Objekte aus einem Bild entfernen

Es gibt zwei Arten von Objekten, die Sie vielleicht aus einem Bild entfernen möchten: künstliche Erscheinungen, die z.B. durch Staub oder Haare auf der Linse entstanden, und Dinge, die tatsächlich vorhanden waren, die aber die Qualität des Bildes vermindern, wie etwa Stromleitungen, die entlang einer wunderschönen Berglandschaft verlaufen.

1.5.1. Flecken entfernen

Ein gutes Werkzeug, um Staub und andere Verschmutzungen der Linse zu entfernen, ist das Filter Flecken entfernen, auf den Sie über FilterVerbessernFlecken entfernen im Bildfenster zugreifen können. Sehr wichtig: um den Filter effizient nutzen zu können, müssen Sie mit einer kleinen Auswahl beginnen, die den Fleck und einen schmalen Bereich darum enthält. Die Auswahl muss klein genug sein, um die Pixel des Fleckes statistisch von den anderen Pixeln innerhalb der Auswahl unterscheiden zu können. Wenn Sie versuchen, »Flecken entfernen« auf das gesamte Bild anzuwenden, werden kaum jemals etwas Sinnvolles erhalten. Wenn Sie eine vernünftige Auswahl erstellt haben, aktivieren Sie das Filter und beobachten dann die Vorschau, wenn Sie die Parameter anpassen. Mit etwas Glück finden Sie eine Einstellung, die die Verunreinigungen entfernt und dabei den angrenzenden Bereich nur minimal verändert. Je besser sich der Schmutz von der Umgebung unterscheidet, desto besser sollten Ihre Ergebnisse sein. Falls es gar nicht funktioniert, lohnt es sich vermutlich, das Filter abzubrechen, eine andere Auswahl zu erstellen und dann wieder von vorne anzufangen.

Wenn Sie mehrere Flecken auf dem Bild haben, müssen Sie das Filter auf jeden einzeln anwenden.

1.5.2. Störende Objekte entfernen

Das Werkzeug der Wahl, wenn es gilt, ungewollte Objekte aus dem Bild zu entfernen, ist das Klonen-Werkzeug mit dem Symbol ,welches es Ihnen ermöglicht, Teile eines Bildes mit Pixeldaten von einem anderen Teil des Bildes (oder sogar aus einem anderen Bild) zu übermalen. Der Trick besteht nun darin, einen anderen Bereich des Bildes zu finden, den man als »Flicken« für den unerwünschten Teil verwenden kann. Falls sich der Bereich um das störende Objekt sehr vom Rest des Bildes unterscheidet, werden Sie wohl kein Glück haben. Aber wenn Sie beispielsweise eine herrliche Strandszene haben mit einer hässlichen Person, die über den Strand läuft und die Sie gerne »wegbeamen« würden, dann werden Sie sicher einen leeren Teil des Strandes finden, der dem mit der Person ähnelt und den Sie über die Person kopieren können. Es ist wirklich erstaunlich, wie natürlich die Ergebnisse aussehen können, wenn die Technik gut angewendet wird.

Detaillierte Anweisungen finden Sie in Abschnitt 3.12, „Klonen“. Klonen ist mehr eine Kunst als eine Wissenschaft, und je mehr Sie sich darin üben, desto besser werden Sie. Am Anfang mag es noch unmöglich erscheinen, etwas anderes als häßliche Flecken zu produzieren, aber bleiben Sie dran: Hartnäckigkeit wird sich auszahlen.

Ähnlich wie Klonen, allerdings etwas trickreicher, ist das Werkzeug Heilen, das beim Klonen zusätzlich den Bereich um das Ziel herum betrachtet. Eine typische Anwendung ist das Entfernen von Falten und anderen kleineren Bildfehlern.

In einigen Fällen können Sie auch gute Resultate erzielen, indem Sie das Objekt einfach aus dem Bild schneiden und dann die Lücke mit einem Plugin namens »Resynthesizer«[PLUGIN-RESYNTH] füllen. Dieses Plugin ist nicht standardmäßig installiert, aber Sie können es von der Webseite des Autors herunterladen: [PLUGIN-RESYNTH].

1.5.3. Rote Augen entfernen

Wenn Sie eine Blitzlichtaufnahme von jemandem machen, der direkt in die Kamera schaut, kann die Iris des Auges das Blitzlicht so zur Kamera zurückwerfen, dass das Auge hellrot erscheint. Dies wird »Rote-Augen-Effekt« genannt und sieht sehr bizarr aus. Viele moderne Kameras haben spezielle Blitzmodi, die den Effekt minimieren, aber Sie müssen sie natürlich auch benutzen, und selbst dann funktionieren sie nicht immer perfekt. Bei Tieren tritt derselbe Effekt auf, aber interessanterweise können die Augen auch in anderen Farben erscheinen, etwa in Grün.

Mit GIMP-2.4 wurde ein besonderes Filter zum Entfernen der roten Augen eingeführt. Erstellen Sie eine Auswahl mit dem roten Teil des Auges und wählen Sie dann das Filter »Rote Augen entfernen«. Unter Umständen müssen Sie dann noch ein wenig den Schwellwert regulieren, um die korrekte Farbe zu erhalten.

1.6. Ihre Ergebnisse sichern

1.6.1. Bilddateien

Welches Dateiformat sollten Sie zum Speichern Ihrer Arbeit wählen, und sollten Sie die Bildgröße ändern? Die Antwort hängt davon ab, was Sie mit dem Bild machen wollen:

  • Wenn Sie vorhaben, das Bild noch einmal mit GIMP zu bearbeiten, sollten Sie es im GIMP-eigenen XCF-Format (d.h. mit Endung .xcf) speichern, da nur mit diesem Format garantiert keine Bildinformationen verloren gehen.

  • Falls Sie das Bild auf Papier ausdrucken wollen, sollten Sie vermeiden, das Bild zu verkleinern (außer durch Zuschneiden). Der Grund ist, dass Drucker eine sehr viel höhere Auflösung als Bildschirme erreichen: 600 bis 1400dpi (Punkte je Zoll« die physische Dichte) für typische Drucker gegenüber 72 bis 100dpi für Bildschirme. Ein 3000 x 5000 Pixel großes Bild sieht auf dem Bildschirm riesig aus, ergibt auf dem Papier aber nur ein Bild von etwa 13cm x 21cm bei 600dpi. Normalerweise gibt es auch keinen vernünftigen Grund, ein Bild zu vergrößern. Die tatsächliche Auflösung können Sie so nicht erhöhen, und es kann sowieso entsprechend normiert werden, wenn es gedruckt wird. Zum Dateiformat: Im allgemeinen ist es in Ordnung, das JPEG-Format mit einem Qualitätsniveau von 75 bis 85 zu verwenden. In seltenen Fällen, bei Bildern mit langen, nahezu einfarbige Streifen, müssen Sie sogar ein noch höheres Niveau wählen oder statt dessen ein verlustfreies Format wie TIFF nehmen.

  • Wenn Sie das Bild auf dem Bildschirm darstellen oder es mit einem Videoprojektor vorführen wollen, denken Sie daran, dass die höchste Bildschirmauflösung bei den gebräuchlichsten Systemen 1600 x 1200 beträgt, es bringt also nichts, das Bild größer zu lassen. Daher ist das JPEG-Format für diese Zwecke fast immer eine gute Wahl.

  • Soll das Bild auf eine Webseite oder per E-Mail verschickt werden, ist es eine gut Idee, die Dateigröße so gering wie möglich zu halten. Verkleinern Sie daher das Bild so weit, bis die relevanten Details gerade eben noch sichtbar sind (denken Sie daran, dass andere Monitoren einer anderen Größe oder andere Bildschirmauflösungen verwenden könnten). Als nächstes speichern Sie das Bild als JPEG-Datei. Dabei aktivieren Sie die Option »Vorschau im Bildfenster anzeigen« im JPEG-Dialogfenster und stellen mit dem Regler die Qualität auf das geringstmögliche Niveau ein, das noch eine akzeptable Bildqualität liefert. (Im Bild sehen Sie dann den Effekt der jeweiligen Änderung.) Passen Sie auf, dass das Bild dabei mit Zoomfaktor 1:1 dargestellt wird, um nicht durch Zoomeffekte in die Irre geleitet zu werden.

Weitere Informationen finden Sie unter Abschnitt 1, „Bilddateien“.

1.6.2. Ihre Fotos drucken

Um Fotos zu drucken, wählen Sie DateiDrucken im Menü des Bildfensters. Dabei ist es sehr hilfreich, wenn man einige grundlegende Konzepte im Kopf hat, um sich vor unliebsamen Überraschungen zu schützen oder um sich helfen zu können, falls doch etwas schiefgegangen ist. Denken Sie immer an folgendes:

  • Auf dem Bildschirm wird das Bild im RGB-Modus dargestellt, beim Drucken hingegen im CMYK-Modus. Folglich werden die Farbeigenschaften des gedruckten Bildes nicht ganz genau Ihren Erwartungen entsprechen. Abhängig ist das von der entsprechenden Tabelle für die Übertragung. Die Interessierten finden in diesen Wikipedia-Artikeln weitergehende Erklärungen dazu:

  • Wie bereits weiter oben beschrieben, liegt die Bildschirmauflösung typischerweise im Bereich von 75 bis 100 dpi, während die Auflösung des Druckers mindestens zehnmal so hoch. ist. Die Größe des gedruckten Bildes hängt von der Anzahl der Pixel und der (Druck-)Auflösung ab, entspricht also nicht zwangsläufig der Größe auf dem Bildschirm oder der Papiergröße.

Bevor Sie drucken, gehen Sie also unbedingt zu: BildDruckgröße im Menü des Bildfensters und legen hier eine für Ihre Zwecke sinnvolle Größe des Ausdrucks fest. Sie können dazu entweder die Größe oder die Auflösung einstellen, wobei beide unmittelbar voneinander abhängen. Ferner können Sie an dem Symbol erkennen, dass Sie die X- und Y-Auflösung voneinander trennen können, allerdings ist das nicht ohne Risiko. Vermutlich existiert diese Möglichkeit, da es Drucker mit unterschiedlicher X- und Y-Auflösung gibt. Wie auch immer, Sie werden jedenfalls Ihre Überraschung erleben, wenn Sie diese Verbindung auflösen. Aber vielleicht wollen Sie ja einmal etwas Besonderes ausprobieren?

Ein letzter Rat: Überprüfen Sie noch einmal die Randeinstellung und die Zentrierung. Gegebenenfalls stellen Sie sie bei den Druckereinstellungen unter DateiDrucken... neu ein. Es wäre doch jammerschade, wenn ein zu großer Rand einen Teil Ihres Bildes abschneidet oder eine falsche Zentrierung Ihre Arbeit verdirbt, insbesondere, wenn Sie spezielles Fotopapier verwenden.

1.6.3. EXIF-Daten

Wenn Sie ein Foto aufnehmen, fügen moderne Digitalkameras der Datei Informationen über die Kameraeinstellungen und die Umstände, unter denen das Bild gemacht wurde, hinzu. Diese Daten sind in einem strukturierten Format namens »EXIF« in den JPEG- oder TIFF-Dateien enthalten. Bei JPEG-Dateien kann GIMP EXIF-Daten pflegen, wenn es entsprechend kompiliert wurde und die Programmbibliothek libexif vorhanden ist, was nicht auf jedem System der Fall ist. Falls GIMP EXIF unterstützt, dann bleiben die EXIF-Daten unverändert, wenn eine JPEG-Datei geladen und wieder im JPEG-Format gespeichert wird. Genau genommen sollte ein Bildbearbeitungsprogramm EXIF-Daten nicht so behandeln, aber es ist besser, als die Daten einfach zu löschen, was vorherige GIMP-Version machten.

Falls Sie sich den Inhalt der EXIF-Daten ansehen wollen, können Sie vom Plugin-Register ein Exif-Browser-Plugin [PLUGIN-EXIF] herunterladen. Wenn Sie dieses auf Ihrem System übersetzen und installieren, können Sie über FilterGenerischExif Browser im Menü des Bildfensters darauf zugreifen. (Siehe auch Abschnitt 1.3, „Neue Plugins installieren“.)