Poglavje 16. Meniji

Kazalo

1. Predstavitev menijev
1.1. The Image Menu Bar
1.2. Kontekstni meniji
1.3. Tear-off menus
1.4. Tab menus
2. Meni Datoteka
2.1. Pregled
2.2. New…
2.3. Ustvari
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Odpri nedavne
2.8. Shrani
2.9. Save as…
2.10. Save a Copy…
2.11. Povrni
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Natisni
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Zapri
2.20. Zapri vse
2.21. Izhod
3. Meni Uredi
3.1. Edit Menu Entries
3.2. Razveljavi
3.3. Ponovi
3.4. Zgodovina razveljavitev
3.5. Izreži
3.6. Kopiraj
3.7. Kopiraj vidno
3.8. Prilepi
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Prilepi kot
3.13. Medpomnilnik
3.14. Počisti
3.15. Napolni z barvo ozadja
3.16. Napolni z barvo ozadja
3.17. Napolni z vzorcem
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Vleci poteze po izboru
3.21. Vleci poteze po poti
3.22. The Preferences Command
3.23. Keyboard Shortcuts
3.24. Gradniki
3.25. Enote
4. The Select Menu
4.1. Introduction to the Select Menu
4.2. Izberi vse
4.3. Brez
4.4. Preobrni
4.5. Plavajoče
4.6. Po barvi
4.7. Iz poti
4.8. Urejevalnik izbora
4.9. Operjeno
4.10. Izostri
4.11. Skrči
4.12. Povečaj
4.13. Rob
4.14. Remove Holes
4.15. Popači
4.16. Zaobljen pravokotnik
4.17. Vključi/izključi hitro masko
4.18. Shrani v kanal
4.19. V pot
5. Meni Pogled
5.1. Introduction to the View Menu
5.2. Nov pogled
5.3. Show All
5.4. Točka za točko
5.5. Zoom
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Skrči z ovijanjem
5.9. Celozaslonsko
5.10. Okno krmarja
5.11. Pokaži filtre
5.12. Upravljanje z barvami
5.13. Pokaži izbor
5.14. Pokaži meje plasti
5.15. Pokaži vodila
5.16. Pokaži mrežo
5.17. Pokaži vzorčne točke
5.18. Pripni na vodila
5.19. Pripni na mrežo
5.20. Pripni na rob platna
5.21. Pripni na aktivno pot
5.22. Padding Color
5.23. Pokaži menijsko vrstico
5.24. Pokaži ravnila
5.25. Pokaži drsnika
5.26. Pokaži vrstico stanja
6. Meni Slika
6.1. Pregled
6.2. Podvoji
6.3. Način
6.4. Način RGB
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Preoblikuj
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Velikost platna
6.18. Prilagodi platno plastem
6.19. Prilagodi platno izboru
6.20. Velikost tiskanja
6.21. Spremeni merilo slike
6.22. Crop Image
6.23. Slice Using Guides
6.24. Obreži pristrano
6.25. Spoji vidne plasti
6.26. Splošči sliko
6.27. Align Visible Layers…
6.28. Vodila
6.29. Novo vodilo
6.30. Novo vodilo (v odstotkih)
6.31. Nova vodila iz izbora
6.32. Odstrani vsa vodila
6.33. Configure Grid…
6.34. Lastnosti slike
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Meni Plast
7.1. Introduction to the Layer Menu
7.2. Nova plast
7.3. New Layer Group
7.4. Novo iz vidnega
7.5. Podvoji plast
7.6. Zasidraj plast
7.7. Merge Down
7.8. Izbriši plast
7.9. The Text Commands of the Layer Menu
7.10. Zavrži besedilne podatke
7.11. Podmeni Sklad
7.12. Izberi prejšnjo plast
7.13. Izberi naslednjo plast
7.14. Izberi vrhnjo plast
7.15. Izberi plast na dnu
7.16. Dvigni plast
7.17. Spusti plast
7.18. Plast na vrh
7.19. Plast na dno
7.20. The Reverse Layer Order command
7.21. Podmeni Maska
7.22. Dodaj masko plasti
7.23. Uporabi masko plasti
7.24. Izbriši masko plasti
7.25. Pokaži masko plasti
7.26. Uredi masko plasti
7.27. Onemogoči masko plasti
7.28. Maska v izbor
7.29. Dodaj masko plasti izboru
7.30. Odštej masko plasti od izbora
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Dodaj kanal alfa
7.34. Odstrani kanal alfa
7.35. Barva v alfo
7.36. Delno splošči
7.37. Prag alfa
7.38. Alfa v izbor
7.39. Add Alpha channel to Selection
7.40. Odštej od izbora
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Prezrcali vodoravno
7.44. Prezrcali navpično
7.45. Zasukaj za 90° v SUK
7.46. Zasukaj za 90° v NSUK
7.47. Zasukaj za 180°
7.48. Poljubni zasuk
7.49. Offset
7.50. Layer Boundary Size
7.51. Plast na velikost slike
7.52. Spremeni merilo plasti
7.53. Obreži plast
8. Meni Barve
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Nasičenost
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Preobrni
8.13. Linear Invert
8.14. Preobrni vrednosti
8.15. The Auto Submenu
8.16. Izenači
8.17. Nastavitev beline
8.18. Raztegni kontrast
8.19. Razširi HSV
8.20. Color Enhance
8.21. Color Enhance (legacy)
8.22. The Components Submenu
8.23. Mešalec kanalov
8.24. Extract Component
8.25. Mono Mixer
8.26. Skladaj
8.27. Razstavi
8.28. Ponovno sestavi
8.29. Color to Gray
8.30. Desaturate
8.31. Sepia
8.32. The Map Submenu
8.33. Prerazporedi katalog barv
8.34. Nastavi katalog barv
8.35. Poslikaj napis
8.36. Izmenjava barv
8.37. Zasukaj barve
8.38. Zemljevid preliva ...
8.39. Zemljevid palete
8.40. Prebarvaj z vzorcem
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Stress
8.45. Retinex
8.46. The Info Submenu
8.47. Histogram
8.48. Povprečje robu
8.49. Analiza barvne kocke
8.50. Export Histogram
8.51. Zgladi paleto
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. Meni Orodja
9.1. Introduction to the Tools Menu
10. Meni Filtri
10.1. Uvod v meni Filtri
10.2. Ponovi zadnjega
10.3. Ponovno pokaži zadnjega
10.4. Ponastavi vse filtre
10.5. Podmeni Python-Fu
10.6. Podmeni Skript-Fu
11. Windows Menu
12. Meni Pomoč
12.1. Introduction to the Help Menu
12.2. Pomoč
12.3. Kontekstna pomoč
12.4. Nasvet dneva
12.5. O programu
12.6. Brskalnik vstavkov
12.7. Brskalnik procedur
12.8. GIMP na spletu

1. Predstavitev menijev

There are many places in GIMP where you can find menus. The aim of this chapter is to explain all the commands that are accessible from the image menu bar and the image menu you can get by right clicking in the canvas. All the context menus and the menu entries for the other dialogs are described elsewhere in the chapters that describe the dialogs themselves.

1.1. The Image Menu Bar

This menu bar may contain other entries if you have added script-fus, python-fus or videos to your GIMP.

1.2. Kontekstni meniji

If you right-click on certain parts of the GIMP interface, a context menu opens, which leads to a variety of functions. Some places where you can access context menus are:

  • Clicking on an image window displays the Image menu. This is useful when you are working in full-screen mode, without a menubar.

  • Clicking on a layer in the Layers Dialog or on a channel in the Channels Dialog displays functions for the selected layer or channel.

  • Right-clicking on the image menubar has the same effect as left-clicking.

  • Right-clicking on the title bar displays functions which do not belong to GIMP, but to the window manager program on your computer.

1.3. Tear-off menus

There is an interesting property associated with some of the menus in GIMP. These are any of the menus from the Image context menu you get by right-clicking on the canvas and any of its submenus. (You can tell that a menu item leads to a submenu because there is an icon next to it.) When you bring up any of these menus, there is a dotted line at the top of it (tear-off line). By clicking on this dotted line, you detach the menu under it and it becomes a separate window.

Slika 16.1. The windows submenu and its tear-off submenu

The “windows” submenu and its tear-off submenu
The “windows” submenu and its tear-off submenu

Tear-off menus are actually independent. They are always visible, their functions always apply to the current image, and they persist when all of the images are closed. You can close a tear-off submenu by clicking on the dotted line again or closing the window from the window manager on your computer (often by clicking on an X icon in the upper right corner of the window).

These tear-off submenus are also created in single-window mode, but are of less interest since they are masked by the window as soon as you click on it.

1.4. Tab menus

The following type of menus is not related to the image menu bar, but for the sake of completeness:

Every dockable dialog contains a Tab Menu button, as highlighted below. Pressing this Tab Menu button opens a special menu of tab-related operations, with an entry at the top that opens into the dialog's context menu.

Slika 16.2. A dockable dialog.

A dockable dialog.

A dialog window with the Tab menu button highlighted.

A dockable dialog.

The Tab menu.


See Razdelek 2.3.2, “Tab Menu” to learn more about Tab menus.