Capitolo 8. Combinare le immagini con GIMP

Indice

1. Livelli
1.1. Proprietà del livello
2. Modalità del livello
3. Creazione di nuovi livelli
4. Gruppi di livelli

1. Livelli

Si può pensare ai livelli come una pila di diapositive. Usando i livelli, si può creare un'immagine formandola concettualmente di diverse parti, ognuna delle quali può essere elaborata senza influire su altre. I livelli sono impilati uno sopra l'altro. Il livello inferiore è lo sfondo dell'immagine, mentre i componenti in primo piano dell'immagine vengono sopra di esso.

Figura 8.1. Un'immagine con livelli

Un'immagine con livelli

Livelli dell'immagine

Un'immagine con livelli

L'immagine risultante


Non ci sono limiti, in linea di principio, al numero di livelli che un'immagine può avere: solo la quantità di memoria disponibile sul sistema può esserlo. Non è raro che gli utenti avanzati lavorino con immagini contenenti dozzine di livelli. È possibile raggruppare i livelli per semplificare il tuo lavoro e sono a disposizione molti comandi per la gestione dei livelli.

L'organizzazione dei livelli di un'immagine viene mostrata dalla finestra livelli, che è la seconda più importante finestra di dialogo di GIMP dopo quella principale degli strumenti. Un illustrazione della finestra di dialogo dei livelli e la descrizione in dettaglio di come essa lavora viene descritto nella sezione Finestra livelli, ma ne discuteremo qui solo alcuni aspetti in relazione alle proprietà dei livelli essa che mostra.

Ogni immagine aperta ha sempre un singolo piano disegnabile attivo. Un «piano disegnabile» è un concetto di GIMP che include i livelli, ma anche diversi altri oggetti come i canali, le maschere di livello e la maschera di selezione (un «piano disegnabile» è, in pratica, qualsiasi cosa possa essere tratteggiata con gli strumenti di disegno). Se un livello è attivo, viene mostrato evidenziato nella finestra dei livelli ed il suo nome viene mostrato nell'area di stato della finestra immagine. Se non è attivo, per renderlo tale basta fare clic su di esso. Se nessun livello è evidenziato, significa che il piano disegnabile attivo è qualcosa che non è un livello.

Nella barra dei menu sopra la finestra immagine, è possibile trovare il menu Livello, contenente un gruppo di comandi che riguardano il livello attivo di un'immagine. Lo stesso menu è accessibile facendo clic con il tasto destro del mouse nella finestra di dialogo dei livelli.

1.1. Proprietà del livello

Ogni livello in un'immagine possiede un certo numero di importanti attributi:

Nome

Ogni livello possiede un nome. Il nome viene assegnato automaticamente quando questo viene creato ma è possibile cambiarlo in seguito. È possibile cambiare il nome al livello sia facendo doppio clic su di esso nella finestra di dialogo dei livelli che facendo clic con il tasto destro del mouse sempre nella finestra dei livelli e poi selezionando la voce che appare per prima in cima, cioè Modifica attributi di livello.

Presenza o assenza di un canale alfa

Un canale alfa codifica le informazioni sulla trasparenza per ogni pixel di un livello. È visibile nella finestra di dialogo canali: bianco è completamente opaco e nero è completamente trasparente mentre i livelli di grigio rappresentano diversi valori di parziali trasparenze.

Il livello di sfondo è particolare. Se un'immagine è stata appena creata essa ha un unico livello che è di sfondo. Se l'immagine è stata creata con un riempimento opaco questo livello non è dotato di canale alfa. Se si aggiunge un nuovo livello anche con un riempimento opaco, viene creato automaticamente un canale alfa che si applica a tutti i livelli tranne che allo sfondo. Per avere un livello di sfondo con un canale alfa si deve creare una immagine con un riempimento trasparente oppure si utilizza il comando Aggiungi canale alfa.

Ogni livello diverso dallo sfondo di un'immagine deve avere un canale alfa. Per lo sfondo è opzionale. Molte operazioni non possono essere eseguite su livelli che mancano del canale alfa. Lo spostamento di un livello su una posizione differente nella pila dei livelli è un ovvio esempio (dato che solo il livello di sfondo può essere sprovvisto di canale alfa), ma ogni operazione che riguarda le trasparenze ha questa caratteristica. Puoi aggiungere un canale alfa ad un livello a cui manca usando il comando da menu LivelloTrasparenzaAggiungi canale alfa, o facendo clic con il tasto destro nella finestra di dialogo dei livelli e selezionando Aggiungi canale alfa dal menu a tendina che appare di conseguenza.

Esempio per il Canale alfa. 

Figura 8.2. Esempio canale alfa: immagine di base

Esempio canale alfa: immagine di base

Questa immagine ha tre livelli riempiti con rosso, verde e blu opachi al 100%. Nella finestra dei canali si può notare come sia stato aggiunto un canale alfa. È di colore bianco perché l'immagine non è trasparente in quanto vi è almeno un livello opaco al 100%. Il livello corrente è quello rosso, poiché è riempito di rosso pieno non si vedono aree blu o verdi e i canali corrispondenti sono neri.


Figura 8.3. Esempio canale alfa: un livello trasparente

Esempio canale alfa: un livello trasparente

La parte a sinistra del primo livello è stata resa trasparente (selezione rettangolare quindi Modifica/Pulisci). Il secondo livello, quello verde, è visibile. Il canale alfa è ancora bianco poiché vi è un livello opaco in questa parte dell'immagine.


Figura 8.4. Esempio canale alfa: due livelli trasparenti

Esempio canale alfa: due livelli trasparenti

La parte a sinistra del secondo livello è stata resa trasparente. Il terzo livello, quello blu, è ora visibile attraverso il primo e il secondo. Il canale alfa è ancora bianco poiché vi è un livello opaco in questa parte dell'immagine.


Figura 8.5. Esempio canale alfa: tre livelli trasparenti

Esempio canale alfa: tre livelli trasparenti

La parte a sinistra del terzo livello è stata resa trasparente. Il canale alfa è ancora bianco e la parte a sinistra è bianca opaca. Il livello di sfondo non è dotato di canale alfa. In questo caso il comando Pulisci funziona come lo strumento Gomma e utilizza il colore di sfondo della casella strumenti.


Figura 8.6. Esempio canale alfa: aggiunta di un canale alfa allo sfondo

Esempio canale alfa: aggiunta di un canale alfa allo sfondo

Dopo aver utilizzato il comando LivelloTrasparenzaAggiungi canale alfa che è disponibile solo sul livello di sfondo. La parte a sinistra dell'immagine è completamente trasparente ed ha il colore della pagina su cui è posta l'immagine. La parte a sinistra della miniatura del canale alfa nella finestra dei canali è nera (trasparente).


Tipo di livello

Il tipo di livello è determinato dal tipo dell'immagine (vedere le sezioni precedenti) e dalla presenza o assenza del canale alfa. Questi sono i tipi possibili di livelli:

  • RGB

  • RGBA

  • Grigio

  • Grigio A

  • Indicizzato

  • Indicizzato A

La ragione è che molti filtri (nel menu Filtri ) accettano solo un sottoinsieme di tipi di livello, e quindi appaiono disabilitati nel menu se il livello attivo non è di tipo compatibile. Solitamente è possibile risolvere il problema cambiando modalità dell'immagine oppure aggiungendo o rimuovendo un canale alfa.

Visibilità

È possibile rimuovere un livello da un'immagine, senza distruggerlo, facendo clic sul simbolo dell'"occhio aperto" nella finestra di dialogo dei livelli. Quest'operazione viene chiamata "abilitazione della visibilità" del livello. Molte operazioni sull'immagine trattano il livelli disabilitati come se non esistessero. Quando si lavora con immagini che contengono molti livelli con varie opacità spesso è utile, per avere un'idea più precisa del contenuto del livello su cui si vuole lavorare, nascondere alcuni o tutti gli altri livelli.

[Suggerimento] Suggerimento

Se si fa clic con il tasto Maiusc sul simbolo dell'occhio, ciò comporterà la disabilitazione di tutti i livelli eccetto quello su cui si è fatto clic.

Livello attivo

Solitamente, si attiva un livello per lavorarvi sopra, facendoci clic sopra nell'elenco dei livelli. Quando ci sono molti livelli, trovare il livello a cui appartiene un elemento dell'immagine non è cosa facile: allora, premere Alt e fare clic (Maiusc+Alt sotto Linux): verranno disabilitati tutti i livelli a parte quello selezionato.

Concatenamento ad altri livelli

Se si fa clic tra le icone occhio e le miniature del livello, si ottiene la visualizzazione di un'icona a forma di catene, che abilita un gruppo di operazioni su insiemi multipli di livelli (per esempio con lo strumento Sposta o con uno strumento di trasformazione).

Figura 8.7. La finestra di dialogo livelli

La finestra di dialogo livelli

Rosso: collegamento con altri livelli. Verde: visibilità.


Dimensione e limiti

In GIMP, i limiti di un livello non corrispondono necessariamente ai limiti dell'immagine che li contiene. Quando si crea del testo per esempio, ogni unità di testo finisce nel proprio livello separato, ed il livello ha precisamente le dimensioni necessarie per contenere i testo e nulla più. Anche quando si crea un nuovo livello utilizzando i comandi copia e incolla, il nuovo livello ha la dimensione dell'elemento incollato. Nella finestra immagine, i limiti del livello attivo sono mostrati con una linea tratteggiata giallo-nera.

La ragione principale per cui tutto ciò è importante è che è impossibile fare qualsiasi operazione su di un livello al di fuori dei suoi confini: è chiaramente impossibile modificare ciò che non esiste! Se ciò vi disturba, basta modificare le dimensioni del livello quel tanto che serve, utilizzando i molti comandi che potete trovare in fondo al menu Livello.

[Nota] Nota

La dimensione della memoria che un livello consuma è determinata dalle sue dimensioni e non dai suoi contenuti. Perciò se si sta lavorando con immagini molto grandi o immagini con molti livelli è un'efficace strategia, in termini di risparmio di risorse, la precisa definizione delle dimensioni dei livelli al minimo necessario.

Opacità

L'opacità di un livello determina l'ammontare di quanto colore presente nei livelli sottostanti possa apparire attraverso la pila. L'opacità varia da 0 a 100; con 0 si intende completa trasparenza mentre 100 significa completa opacità.

Modalità

La modalità di un livello determina come i colori del livello vengono combinati con i colori dei livelli sottostanti per produrre il risultato visibile. Quest'argomento è sufficientemente importante e complesso da meritare una intera sezione, la prossima, dedicata completamente ad esso. Vedere Modalità di livello.

Maschera di livello

In aggiunta al canale alfa, esiste un altro metodo per controllare la trasparenza di un livello: aggiungendo una maschera di livello, che è un piano disegnabile extra in scala di grigi associato con il livello. Un livello non possiede in maniera predefinita una maschera di livello; è necessario aggiungerla successivamente. Le maschere di livello e come lavorare con esse è un argomento descritto in maniera dettagliata in una sezione successiva di questo capitolo.