5.2. パス

図14.168 ツールボックス上のパスツールアイコン

ツールボックス上のパスツールアイコン

パスツールはベジエ曲線と呼ばれる複合した選択をつくるのに使用でき、 なげなわツールにいくぶん似てはいますがこちらはベクトル式曲線を作成・操作する能力のすべてがあります。 このツールで曲線が描けるとともに、 その曲線に基づいて描画が行なえますし、 保存はもちろん他形式への/からの転換もできます。 パスを使って幾何学図形を作ることもできます。 パスのために パスダイアログ が用意されています。

5.2.1. 呼び出し方

このツールを起用する方法はつぎのいずれかです。

  • 画像ウィンドウのメニューより ツールパス

  • ツールボックスのツールアイコン

  • キーボードショートカット B

5.2.2. キー修飾 (初期設定)

[注記] 注記

これらのキー修飾についてはヘルプメッセージが画像ウィンドウの底部にあるステータスバー (状態表示区画) に随時表示されます。

Shift

このキーには脈絡に沿ってさまざまな機能が付与されます。 詳細はツールオプションをご覧ください。

Ctrl ; Alt

パスツールの作業モードは 作成編集移動 の 3 種類に分かれます。 Ctrl キーを押すと作成モードから編集モードに切り替わります。 Alt (あるいは Ctrl+Alt ) を押すと作成モードから移動モードに切り替わります。

5.2.3. オプション

図14.169 パスツールのツールオプション

パスツールのツールオプション

一般的にはこのツールを起用すると、 そのツールオプションがツールボックスの下に繋げられたウィンドウ上に現れます。 そのようなウィンドウが見あたらないときは、 画像ウィンドウのメニューより ウィンドウドッキング可能なダイアログツールオプション と辿れば今使っているツールのツールオプションウィンドウが開きます。

作成モード

このツールの既定モードは 作成 です。 つぎつぎと画像上をクリックしてパスを描いてゆきます。 置かれたコントロールポイントはクリックしてドラッグすれば移動できます。 各コントロールポイントの間にあるのが分節です。

打たれた番号は 2 つの分節からなる直線パスを描く順序である。

曲がった分節を作るにはただその分節をドラッグするか新たなアンカーをドラッグすればよい。 青の矢印で曲がるところを指し示した。 2 つの小さなハンドルが出現したので、 あとはそれをドラッグしても曲線を曲げ直せる。

[ティップ] ティップ

曲線を手早く閉じるには Ctrl キーを押しながら最初に置いたアンカーをクリックします。 旧版の GIMP では閉じたパスの内側をクリックすると選択範囲に変換されてしまいましたが、 今ではツールオプションの パスを選択範囲に ボタンや パスダイアログ ボタンが使えます。

[ティップ] ティップ

初期設定ではハンドルを 2 つもつと対称的に動作します。 ハンドルを個別に操作するときは一旦マウスボタンを放します。 Shift キーを押しながらの操作なら再びハンドルは点対称に動きます。

このモードでできる操作がいくつかあります。

Inserting a new node: When you press Ctrl and hover the mouse pointer over the existing path, the mouse pointer changes to the '+' sign. Clicking will create a new path node in the hovered point of the path.

Moving one or several nodes: On a node, the mouse pointer becomes a 4-arrows cross. You can click and drag it. You can select several nodes by Shift and click and move them by click and drag. Pressing Ctrl+Alt allows to move all the path, as a selection.

Modifying handles: You have to Edit a node before. A handle appears. Drag it to bend the curve. Pressing Shift toggles to symmetric handles.

Modify segment: When the mouse pointer goes over a segment, it turns to a 4-arrows cross. Click and drag it to bend the segment. As soon as you move it, handles appear at both ends of the segment. Pressing the Shift key toggles to symmetric handles.

Adding a new subpath: When you press Ctrl and hover the mouse pointer outside the existing path, the mouse pointer starts displaying a square. Clicking will start a subpath that isn't connected to other curves, but is considered a part of the path.

編集モード

編集 モードは 作成 モードではできなかった処理をする機能があります。 このモードは既にあるパスに対してのみ操作が可能です。 パス上から離れたマウスポインターは小さな斜線入りの円がついた姿になり、 このときは何の操作もできません。

2 つの終端アンカーを繋ぐ分節を追加 - パスの終端アンカーをクリックして活性化します。 マウスポインターには小さな連結のしるし (重なった 2 つの円) がつきます。 もう一方の終端アンカーをクリックすると両者は連結されます。 閉じていない成分を繋ぎ合わせる用途に向いています。

パスから分節を削除 - Shift+Ctrl の組み合わせを押しながらマウスポインターを分節にかざすと、 その姿に小さなマイナス記号がつきます。 その分節はクリックすれば削除できます。

パスにアンカーを追加 - 分節にマウスポインターをかざすとその姿に小さなプラス記号がつきます。 その分節上の任意の位置でクリックするとそこに新たなアンカーが置かれます。

アンカーを削除 - Shift+Ctrl の組み合わせを押しながらマウスポインターをアンカーにかざすと、 その姿に小さなマイナス記号がつきます。 そのアンカーはクリックすれば削除できます。

アンカーにハンドルを追加 - アンカーの上ではマウスポインターの右上に小さな四方矢印がつきます。 アンカーをクリックすると、 ハンドルが (削除されていなければ) 現れます。 もしひとつだけだったり全く無かった場合はアンカーをドラッグすればハンドルが現れます。アンカーには 2 つまでハンドルがつけられます。 ハンドルがひとつだけの場合には Shift キーを押しながらそのハンドルをドラッグすればもう一方のハンドルが点対称の位置に現れます。

アンカーからハンドルを削除 - Shift+Ctrl の組み合わせを押しながらハンドルにマウスポインターをかざしてもその姿に変化はありません。 そしてハンドルはクリックすれば削除されます。

[注意] 注意

アンカーや分節やハンドルを削除する際には何の警告もありません。 もちろんこれらの処理の取り消しに関しても同様です。

移動モード

移動 モードでは 1 面のパスのひとつもしくは複数の成分を移動できます。 そのままパスをクリックしてドラッグしてください。

パスに複数の成分があるときは、 選択して活性化した成分だけが移動します。 ただしパス上でない場所でクリックしてドラッグするとすべての成分が移動します。 Shift キーを押しながらドラッグしてもすべての成分を移動できます。

[注記] 注記

複数の面のパスを同時に移動したい場合は、 パスダイアログでそれらの パスの連結をしてから、 移動ツール を用いて、 その移動対象にパスを選んで移動してください。

多角形

このオプションを指定すると描ける分節は直線のみになります。 ハンドルは使えません。 分節をドラッグすると変形しないで移動をします。

パスを選択範囲に

このボタンを押すとパスの現在の状態に基づいて選択範囲が作成されます。 その選択範囲はおなじみの蟻の行進で表されます。 ちなみにパスはまだ残っていますから、 パスツールをひきつづき用いてこのパスを加工できますし、 作られた選択範囲は独立していますから連られて変形することはありません。 別のツールを呼び出したときはパスが見えなくなることがありますが、 パスダイアログを見れば消えず残っていることがわかります。 後で再び活性化できます。

閉じていないパスを変換した場合は、 各成分ごとに始点と終点が直線で結ばれて閉じられます。

画像ウィンドウ下部でヘルプメッセージが示すとおり、 Shift キーを押しながらこのボタンを押せばそれまでの選択範囲へこの新たに作られた選択範囲が加えられます。 Ctrl キーを押しながらならばそれまでの選択範囲からこの選択範囲が除外されます。 Shift+Ctrl の組み合わせとならば両選択範囲の共通部分のみ残ります。

パスの境界線を描画

GIMP の旧版では画像ウィンドウのメニューの編集サブメニューを通してしかこのコマンドを呼び出せませんでしたが、 今ではこのボタンも使えます。 「パスの境界線を描画...」パス もご覧ください。

パス についての概念もお読みください。