3.2. ブラシダイアログ

図15.33 ブラシダイアログ

ブラシダイアログ

ブラシダイアログは描画ツールで使用するブラシを選ぶのに使われます。 ブラシについての情報と GIMP での利用方法については ブラシ の節をご覧ください。 またこのダイアログはブラシを管理する機能をいくつか呼び出せるようにもなっています。 ブラシを拾うには一覧表でそのアイコンをクリックしてください。 掴んだブラシはツールボックスの ブラシ/パターン/グラデーション の区画にその姿のアイコンで表示されます。 今回から GIMP の同梱ブラシは形が違うもので 56 種類となりました。 というのもブラシの大きさや割合や角度がツールオプションでそれぞれ設定可能になったからです。 これに加えて、 ブラシエディターを使ったり画像をブラシ専用の特別なファイル形式で保存すればお手製のブラシも作れます。

3.2.1. ダイアログの呼び出し方

ブラシダイアログはドッキング可能です。 その扱い方については 「ダイアログとその合体」 の節をご覧ください。

呼び出し方はつぎのとおりです。

  • from the Toolbox, by clicking on the brush symbol in the Brush/Pattern/Gradient area (if you have checked the Show active brush, pattern and gradient option in the toolbox preferences).

  • 画像ウィンドウのメニューより ウィンドウドッキング可能なダイアログブラシ

  • 任意のドッキング可能なダイアログのボタンアイコン をクリックすると出てくるタブメニューより タブの追加ブラシ

  • あらゆる描画ツールのツールオプションダイアログにブラシアイコンボタンがあって、 これをクリックすればよく似た一覧表が現れて手早くブラシを選べるようになっています。 一覧表の下側の 5 つのボタンのうち右端のブラシのアイコンボタンをクリックすれば本物のブラシダイアログが開きます。

    簡約ブラシダイアログ

    このウィンドウには 5 つのアイコンボタンがあります。 その意味はツールチップで明瞭に説明されています。

    • 小さなプレビュー

    • 大きなプレビュー

    • リストで表示

    • グリッドで表示

    • ブラシ選択ダイアログを開く

    ちなみに設定によっては、 この飛び出し一覧表から選んだブラシは現在起用しているツールにのみ適用し、 他のツールで用いるブラシは変更しない設定も可能です。 より詳しくは 設定 ダイアログのツールオプションのページをご覧ください。

3.2.2. ブラシダイアログの利用法

3.2.2.1. 升目表示と列挙表示

ブラシダイアログのタブメニューで 並べて表示一覧で表示 を切り替えられます。 並べて表示を選ぶと一度にたくさんのブラシ見本が探せるように各ブラシアイコンは升目状に並べられます。 一覧で表示の場合はブラシ見本とその名前が一覧表に列挙されます。

タブメニューの プレビューサイズ サブメニューでダイアログに表示されるブラシ見本をお好みの大きさに調節できます。

図15.34 升目表示と列挙表示

升目表示と列挙表示

グリッドで表示

升目表示と列挙表示

並べて表示


並べて表示

ダイアログの上部に現在選択されているブラシの名前と大きさ (ピクセル単位) が表示されます。

利用可能なブラシの見本が升目状に並べられていて、 現在選択されたブラシは枠線で囲まれます。

一覧表に列挙して表示

基本的には並べて表示と使い方に大差ありませんが、 次の点が異なります。

ブラシの名前はダブルクリックすると編集ができます。 ただし名前を変更できるのは自作のブラシや自前でインストールしたものに限られ、 GIMP 同梱でインストールされたブラシは対象外です。 仮に同梱版のブラシの名前を変えてみれば確かに編集はできますが、 確定しようとして Enter キーを押したりどこか他のところをクリックするとたちまち名前は元に戻されてしまいます。 GIMP と同時にインストールされるブラシ、 パターン、 グラデーションなどの資源は原則として変更不可です。 変更できるのは自作のものや自前のものだけです。

3.2.2.2. ブラシの見本

図15.35 ブラシダイアログ

ブラシダイアログ

ブラシの見本をクリックするとそのブラシが現在のブラシに選ばれ、 ツールボックスのブラシの標識や描画ツールのブラシオプションはそのブラシに替わります。 ブラシの見本をダブルクリックすると (後述の) ブラシエディター が起用されます。 ブラシダイアログの底部に並ぶアイコンボタンにはさまざまなはたらきがあります。

各ブラシ見本の右下についている小さな印の意味はつぎのとおりです。

  • 右下に青い三角がついたブラシは見本と同じ大きさです。 複製できます。

  • 右下の十字は見本が縮小されたものであることを表しています。 見本をクリックしたまま待つと一時的に本来の大きさで表示されます。

  • 右下に赤い三角がついたブラシはアニメーションするブラシです。 見本をクリックしたまま待つとブラシが動画表示されます。

3.2.2.3. タグづけ

タグはブラシの一覧表示を再構成するのに使えます。 「タグづけ」 をご覧ください。

3.2.2.4. ダイアログ底部に並ぶアイコンボタン

ダイアログの底部にはスライダーと 5 つのアイコンボタンがあります。

間隔

マウスポインターがなぞった線上に並ぶブラシの刻印の互いの間隔をこのスライダーで調節します。 間隔の値はブラシの幅の百分率で指定します。

ブラシを編集

このボタンは (後述する) ブラシエディター を呼び出します。 どんなブラシを選んでいてもブラシエディターを開けますが、 媒介変数つきブラシだけしか扱えないため、 他の種類のブラシを開いたときは読み込み専用と表示されて何も変更できません。

新しいブラシを作成

このボタンをクリックすると新しい媒介変数つきブラシが境界にぼかしが入った丸い形に作られ、 これを編集できるようブラシエディターが開かれます。 この新しいブラシは自動的に個人用 GIMP ディレクトリー内の brushes フォルダーに保存されます。

ブラシの複製

このボタンは現在選ばれているブラシが媒介変数つきであるときのみ利用できます。 ブラシの複製をとるとブラシエディターが開かれてその複製の加工ができるようになっています。 作成が済むと自動的にそのブラシファイルは個人用 GIMP ディレクトリーの brushes フォルダーに保存されます。

ブラシの削除

このオプションはパラメーターつきブラシにのみ有効です。 現在選ばれているブラシを削除できる権限をお持ちでしたら、 このボタンをクリックすればダイアログ上のみならず保存されていたブラシファイルまで跡形もなく消し去れます。 実行に移すまえに確認が求められます。

ブラシの更新

ブラシエディターで作成されたブラシファイルが自動的に保存される個人用 GIMP ディレクトリーの brushes フォルダーをはじめ、 ブラシ検索パスに登録されたフォルダーに何かブラシファイルを新たに収めたら、 このボタンをクリックすればダイアログの一覧表は読み込み直され、 新しく追加されたブラシがダイアログで利用できるようになります。

Open brush as image

New option in GIMP-2.10.10: you can edit this image, copy it and Edit>Paste as>New brush. This is different from 「ブラシエディター」 that allows to modify an existing brush.

以上 5 つのボタンでできる機能は、 ブラシダイアログの一覧表 (升目並びと名前表示つき列挙のいずれも) 内の標的のブラシをマウスの 第2ボタン でクリックすると出てくるポップアップメニューや、 ダイアログのタブメニューの ブラシ サブメニューからも呼び出せます。

3.2.2.5. ブラシダイアログの脈絡メニュー

図15.36 ブラシダイアログの脈絡メニュー

ブラシダイアログの脈絡メニュー


ダイアログのブラシ一覧表上をマウスの 第2ボタン でクリックすると脈絡メニューが出てきます。 このメニューには楕円形や矩形のブラシが作成できるオプションも並んでいます。 これらのブラシには、 ぼかし効果が加えられたものもありますがいずれも媒介変数つきではありません。

その他のメニュー項目はそのほとんどがアイコンボタンの説明で述べたものばかりですが、 ブラシの場所をコピー はまだでした。 これはブラシのパス (保管場所までの位置名) をクリップボードに書き出します。 直後に画像ウィンドウのメニューより ファイル場所を開く... と進んでブラシを画像として開く使い方があります。

3.2.3. ブラシエディター

図15.37 ブラシエディターダイアログ

ブラシエディターダイアログ

ブラシエディター。 新しいブラシの作成で呼び出したところ。


ブラシエディターでは GIMP とともに提供されたブラシの媒介変数を見られます (ただしそれらの変更は不可)。 ブラシの自作もできます。 新しいブラシを作成ボタン をクリックするとブラシの編集機能がはたらきはじめます。 そこで円形、 正方形、 菱形のような幾何学図形が選べます。 このエディターの各部品を順に見てゆきましょう。

ダイアログバー: どんなダイアログウィンドウにも共通するタブメニューボタンがあります。 ブラシ編集の脈絡メニューは 現在のブラシを編集 の 1 項目だけです。 これを無効にしているなら、 ブラシエディターに読み込まれるブラシを切り替えるには目的のブラシを選択してからブラシダイアログのブラシを編集のアイコンボタンをクリックします。

ブラシの名称欄: ブラシの名前が表示されており編集できます。

ブラシのプレビュー領域: ブラシの諸元を調整するたび即座にその変更が反映されます。

形状

円形、 正方形、 菱形があります。 この原型をこのあとのオプションで調整してゆきます。

半径

ブラシの中心から外縁までの横方向の距離です。 仮に半径が 10 ピクセルとすれば形状が正方形ならその各辺は 20 ピクセルです。 半径が 5 ピクセルな菱形ならその各辺はおよそ 7 ピクセルになります。

とがり

この数は正方形と菱形に対してのみ効果があります。 正方形の場合は数を増やすと形状の角が増え多角形になります。 菱形の場合は星型です。

強度

この値はブラシの境界のぼかし具合を制御します。 最大値 1.00 にするとぼかしはありません。 値のとれる範囲は 0.00 から 1.00 です。

縦横比

この値はブラシの幅と高さの比を制御します。 たとえば菱形で半径 5 ピクセル、 縦横比 2.0 とすれば、 幅 10 ピクセル高さ 5 ピクセルの扁平なブラシができます。 値のとれる範囲は 1.0 から 20.0 です。

角度

角度とは水平方向とブラシの幅の方向との反時計回りの角度を表しています。 ブラシの幅の方向は標準的には水平方向なのでこの値は 0 度です。 この値を増すにつれブラシは反時計回りに傾きます。 値のとれる範囲は 0 度から 180 度です。

間隔

ブラシは線を描くとき実際はそのブラシの刻印を線上に並べます。 ブラシの刻印がよく重なって密着しておれば均質な線の印象が得られます。 その場合の間隔は 1.00 です。 値のとれる範囲は 1.00 から 200.0 です。

3.2.4. クリップボードブラシ

画像の選択範囲や全体像を取り込んだり切り取ったりすると、 その写しがブラシダイアログの左上の区画に新たなブラシとして現れます。 このブラシは再び何かの画像や選択範囲を取り込むまでその内容が保たれます。 GIMP を終了すると消えます。

図15.38 クリップボードブラシの登場

クリップボードブラシの登場

[注記] 注記

こうしてできたクリップボードブラシはブラシダイアログに現れたときにすぐさま 編集クリップボードから生成新しいブラシ... とすれば保存できます。 (「クリップボードから生成 → 新しいブラシ...」 もご覧ください。)