12장. 나만의 김프 만들기

차례

1. 기본 설정 대화상자
1.1. 소개
1.2. System Resources
1.3. 색상 관리
1.4. Playground
1.5. 도구 옵션
1.6. 기본 이미지 설정
1.7. 기본 이미지 격자
1.8. 인터페이스
1.9. 테마
1.10. 테마
1.11. 도구상자
1.12. Dialog Defaults
1.13. 도움말 시스템
1.14. 화면
1.15. 창 관리
1.16. 이미지 창
1.17. 이미지 창 모양
1.18. 이미지 창 제목표시줄과 상태표시줄
1.19. Image Window Snapping Behavior
1.20. 입력 장치
1.21. 입력 제어기
1.22. 폴더
1.23. 데이터 폴더
2. 모눈과 안내선
2.1. 이미지 모눈
2.2. 안내선
3. 모눈 만들기
4. 타일 캐쉬 설정하는 방법
5. 메뉴 단축키 만들기
6. 초기 화면 변경하기

1. 기본 설정 대화상자

1.1. 소개

그림 12.1. 기본 설정 페이지 목록

기본 설정 페이지 목록

The preferences dialog can be accessed from the image menu-bar, through EditPreferences. It lets you customize many aspects of the way GIMP works. The following sections detail the settings that you can customize, and what they affect.

기본 설정에서 설정한 모든 내용은 김프 사용자 디렉토리의 gimprc 파일에 저장됩니다. 따라서 이 파일을 텍스트 에디터로 직접 수정할 수도 있습니다. 그리고 만약 리눅스를 사용하고 있다면 man gimprc 명령을 통해 파일 내용과 쓰임새에 대한 많은 정보를 얻을 수 있습니다.

1.2. System Resources

그림 12.2. System Resources

System Resources

이 페이지에서는 다양한 목적에 따라 할당된 시스템 메모리량을 조정할 수 있습니다. 그리고 저장안한 이미지를 닫을 때 확인창의 표시여부나 미리보기 크기 등을 설정할 수 있습니다.


1.2.1. 옵션

자원 소비량

실행 취소 최소 횟수

김프에서는 메모리의 한계 내에서 대부분의 작업을 취소할 수 있습니다. 이는 각 이미지의 실행 취소 기록에서 관리합니다. 여기서는 실행 취소를 보장할 최소한의 갯수를 설정할 수 있습니다. 김프의 실행 취소에 대한 자세한 사항은 3절. “실행 취소하기” 을 참조하십시오.

실행 취소 최대 메모리

각 이미지의 실행 취소에 할당된 메모리양입니다. 실행 취소 이력의 메모리 크기가 이를 넘으면, 오래된 기록부터 삭제됩니다. 단 삭제될 지점이 실행 취소 최소 횟수보다 작은 지점이라면 삭제되지 않습니다.

타일 캐쉬 크기

김프 이미지 데이터에 할당된 시스템 메모리 양입니다. 김프에서 이 이상의 메모리를 사용하면, 디스크 스왑으로 대체하게 됩니다. 이럴 경우 일부 시스템에서는 순간적인 다운현상이 있을 수도 있습니다. 이는 김프 설치시에 설정할 수 있고, 여기서 변경할 수도 있습니다. 더 자세한 사항은 타일 캐쉬 설정하는 방법을 참고하세요.

새 이미지 최대 크기

여기서 설정한 값보다 큰 이미지를 생성하려고 할 경우, 확인창이 뜹니다. 이는 실수로 큰 이미지를 만들어서 김프가 종료되거나 굉장히 느려지는 것을 막기 위한 것입니다.

Number of processors to use

Default is one. Your computer may have more than one processor.

Hardware acceleration

Use OpenCL

OpenCL is an acronym for Open Computing Language (see Wikipedia). This option, checked by default, improves the management of relations between the CPU and the graphic processing unit (GPU).

이미지 미리보기

미리보기 크기

This options allows you to set the size of the thumbnails shown in the File Open dialog (and also saved for possible use by other programs). The options are No thumbnails, Normal (128x128), and Large (256x256).

미리보기를 만들 최대 파일 크기

이미지 파일의 크기가 설정한 값보다 크면, 미리보기를 만들지 않습니다. 이는 지나치게 큰 이미지의 미리보기를 만들지 않음으로써 김프가 느려지는 것을 방지합니다.

Document History

Keep record of used files in the Recent Documents list

When checked, files you have opened will be saved in the Document history. You can access the list of files with the Document history dialog from the image menu-bar : FileOpen RecentDocument History.

1.3. 색상 관리

그림 12.3. 색상 관리 설정

색상 관리 설정

1.3.1. 옵션

이 페이지에서는 김프 색상 관리에 대한 설정을 할 수 있습니다.

일부 옵션은 메뉴에서 색상 프로필을 선택할 수 있습니다. 메뉴에 원하는 프로필이 없을 겅우에는 디스크에서 색상 프로필 선택... 항목을 클릭하여 원하는 프로필을 추가합니다.

[작은 정보] 작은 정보

색상 프로필 파일은 .icc 확장자를 가지고 있습니다. 그리고 대부분은 특정 디렉토리에 저장되어 있습니다. MaC OS X 을 쓰고 있다면 /Library/ColorSync/Profiles/ 이나 Library/Printers/[manufacturer]/Profiles 에 있을 것입니다.

Image display mode

이 옵션을 이용해 김프 색상 관리가 동작하는 방식을 결정할 수 있습니다. 여기에는 세 가지 모드가 있습니다.

  • No color management: choosing this selection shuts down the color management in GIMP completely.

  • Color managed display: with this selection you can enable the GIMP color management to provide a fully corrected display of the images according to the given color profile for the display.

  • Soft-proofing: when choosing this option, you enable the GIMP color management not only to apply the profile for the display, but also the selected printer simulation profile. Doing so, you can preview the color results of a print with that printer.

    [참고] 참고

    김프 색상 관리는 화면에서의 이미지의 색상 표현과 이미지에 색상 프로필을 추가하는 것만 할 수 있습니다. 즉, 김프로 인쇄하는 것에는 영향을 주지 못합니다. 이는 인쇄 작업은 김프와는 별개의 인쇄 엔진에 의해 동작하기 때문입니다.

Color Managed Display

모니터 프로필

  • None : GIMP uses the colorimetric profile of your monitor.

  • Select color profile from disk : if you have one.

  • Try to use the system monitor profile : If checked, GIMP will try to use the display color profile of the system windows handler. Else, the configured monitor profile is used.

Rendering intent

  • This option is about how colors are converted from the color space of your image to your display device. Four modes are available: Perceptual, Relative colorimetric, Saturation and Absolute colorimetric.

    Relative colorimetric is usually the best choice (default). Unless you use a LUT monitor profile (most monitor profile are matrix), choosing perceptual intent actually gives you relative colorimetric.

    Use black point compensation

    • This option is checked by default. Do use black point compensation unless you have a reason not to.

Optimize image display for:

  • Two options: Speed and Precision/Color fidelity. Speed is activated by default. If not, image display might be better at the cost of speed.

Soft-proofing>

Soft-proofing is a mechanism that allows you to see on your screen what printing on paper will look. More generally, it is soft-proofing from the color space of your image to another color color space (printer or other output device).

Soft-proofing profile

None is the choice by default. The drop-down list offers the possibility of Select color profile from disk....

Rendering intent As above, four modes: Perceptual, Relative colorimetric, Saturation and Absolute colorimetric. Try them all and choose what looks the best.

Use black point compensation

Try with and without black point compensation and choose what looks best.

Optimize soft-proofing for:

Two options: Speed and Precision/Color fidelity. Speed is activated by default. If not, soft-proofing might be better at the cost of speed.

Mark out of gamut colors

When this box is checked, the soft-proofing will mark color that can not be represented in the target color space. On the right, a color button, when clicked, opens a color selector to choose the wanted color.

Preferred profiles

RGB 프로필

Default is None and the built-in RGB profile is used. You can select another RGB working space color profile from disk: it will be offered next to the built-in profile when a color profile can be chosen.

Grayscale profile

Default is None and the built-in Grayscale profile is used. You can select another Grayscale working space color profile from disk: it will be offered next to the built-in profile when a color profile can be chosen.

CMYK 프로필

Default is None. You can select a CMYK working space color profile from disk to convert RGB to CMYK.

Policies

File Open Behavior

Default is Ask what to do. You can also select Keep embedded profile or Convert to preferred RGB color profile to indicate how to treat embedded color profiles when opening an image file.

[참고] 참고

추가 설명:

  • ICC 프로필에 대한 설명은 위키백과를 참고하십시오. [WKPD-ICC]

  • 김프를 비롯해 많은 자유 프로그램들에 기여를 하고 있는 OpenICC 프로젝트에 대한 내용은 다음을 참고하십시오 ([OPENICC]).

웹에서 많은 프로필을 가져올 수 있습니다.:

  • ICC sRGB 작업공간: ICCsRGB[ICCsRGB]

  • Microsoft sRGB 작업공간: MsRGB[MsRGB]

  • Adobe RGB98 작업공간 : Adobe RGB (1998)[AdobeRGB]

  • ECI (European Color Initiative) 프로필: ECI[ECI]

1.4. Playground

그림 12.4. Insane Options

Insane Options

This page lets you select some experimental tools.


1.5. 도구 옵션

그림 12.5. 도구 옵션 설정

도구 옵션 설정

이 페이지에서는 도구의 동작에 관한 설정들을 변경할 수 있습니다.


1.5.1. 옵션

일반

마칠 때 도구 옵션 저장

이 옵션을 체크하면, 김프를 종료할 때 도구 옵션의 설정을 저장합니다.

도구 옵션 저장

이 옵션을 체크하면, 김프를 종료할 때 도구 옵션의 설정을 저장합니다.

저장된 도구 옵션을 기본값으로 초기화

이 옵션을 체크하면, 김프를 종료할 때 도구 옵션의 설정을 저장합니다.

비율 조정

기본 보간법

When you scale something, each pixel in the result is calculated by interpolating several pixels in the source. This option determines the default interpolation method: it can always be changed, though, in the Tool Options dialog.

There are four choices:

None

This is the fastest method, but it's quite crude: you should only consider using it if your machine is very seriously speed-impaired.

Linear

This used to be the default, and is good enough for most purposes.

Cubic

This is the best choice (although it can actually look worse than Linear for some types of images), but also the slowest. Since GIMP 2.6, this method is the default.

NoHalo

This method performs a high quality interpolation. Use the NoHalo method when you downscale an image to less than a half of the original size.

LoHalo

This method performs a high quality interpolation. Use the LoHalo method when you do not reduce the size much (rotate, shear).

그리기 도구 공통 옵션

Brush, Dynamics,Pattern, Gradient

여기에 있는 항목들을 활성화시키면, 선택한 붓이나 무늬, 그라디언트 등을 모든 도구에서 같이 사용하게 됩니다. 반대로 비활성시키면 각 도구들은 각기 마지막으로 사용한 항목들을 기억하여 각 도구별로 다른 붓이나 무늬, 그라디언트를 사용하게 됩니다.

이동 도구

Set layer or path as active

현재 레이어나 경로를 다른 키를 누르지 않고도 이동시킬 수 있도록 할 것인지 여부를 결정할 수 있습니다.

1.6. 기본 이미지 설정

그림 12.6. 새 이미지의 기본값 설정

새 이미지의 기본값 설정

이 페이지에서는 새 이미지 대화상자의 기본 설정을 변경할 수 있습니다. 각 항목에 대한 설명은 새 이미지 대화상자 섹션을 참고하십시오.

1.7. 기본 이미지 격자

그림 12.7. 기본 격자 설정

기본 격자 설정

이 페이지에서는 김프 격자의 기본 속성을 변경할 수 있습니다. 격자는 이미지 메뉴의 보기격자 표시 를 통해 표시 여부를 결정할 수 있습니다. 여기서 설정한 것들은 이미지 메뉴의 이미지격자 설정 에서 변경할 수 있는데, 이는 현재 이미지에만 적용이 됩니다. 각 항목에 대한 설명은 격자 대화상자 설정을 참조하십시오.

1.8. 인터페이스

그림 12.8. 인터페이스 설정

인터페이스 설정

This page lets you customize language, layer/channel previews and keyboard shortcuts.


옵션

Language

The GIMP's default language is that of your system. You can select another language in the drop-down list. You have to start GIMP again to make this change effective. Please refer to 1.2절. “지원하는 언어”.

미리보기

By default, GIMP shows miniature previews of the contents of layers and channels in several places, including the Layers dialog. If for some reason you would prefer to disable these, you can do it by unchecking Enable layer and channel previews. If you do want previews to be shown, you can customize their sizes using the menus for Default layer and channel preview size and Navigation preview size.

You can also customize the Undo preview size and the Navigation preview size.

키보드 단축키

Any menu item can be activated by holding down Alt and pressing a sequence of keys. Normally, the key associated with each menu entry is shown as an underlined letter in the text, called accelerator. If for some reason you would prefer the underlines to go away (maybe because you think they're ugly and you don't use them anyway), then you can make this happen by unchecking Show menu mnemonics.

GIMP can give you the ability to create keyboard shortcuts (key combinations that activate a menu entry) dynamically, by pressing the keys while the pointer hovers over the desired menu entry. However, this capability is disabled by default, because it might lead novice users to accidentally overwrite the standard keyboard shortcuts. If you want to enable it, check Use dynamics keyboard shortcuts here.

Pressing the button for Configure Keyboard Shortcuts brings up the Shortcut Editor, which gives you a graphical interface to select menu items and assign shortcuts to them.

If you change shortcuts, you will probably want your changes to continue to apply in future GIMP sessions. If not, uncheck Save Keyboard Shortcuts on exit. But remember that you have done this, or you may be frustrated later. If you don't want to save shortcuts on exit every session, you can save the current settings at any time using the Save Keyboard Shortcuts Now button, and they will be applied to future sessions. If you decide that you have made some bad decisions concerning shortcuts, you can reset them to their original state by pressing Reset Saved Keyboard Shortcuts to Default Values. A new possibility: Remove All Keyboard Shortcuts.

1.9. 테마

그림 12.9. 테마 설정

테마 설정

This page lets you select a theme, which determines many aspects of the appearance of the GIMP user interface. Clicking on a theme in the list causes it to be applied immediately, so it is easy to see the result and change your mind if you don't like it.

1.10. 테마

그림 12.10. Icon Theme Preference

Icon Theme Preference

This page lets you select a theme for the icons of the GIMP user interface. Test them: you will see the result instantly in this preference dialog.

1.11. 도구상자

그림 12.11. 도구상자 기본 설정

도구상자 기본 설정

1.11.1. 옵션

그림 12.12. 기본 도구상자 모양

기본 도구상자 모양

This page lets you customize the appearance of the Toolbox, by deciding whether the three context information areas should be shown at the bottom.

모양

전경색 및 배경색 표시

Controls whether the color area on the left (2) appears in the Toolbox.

현재 붓, 무늬, 그라디언트 표시

Controls whether the area in the center (3), with the brush, pattern, and gradient icons, appears in the Toolbox.

현재 이미지 표시

Controls whether a preview of the currently active image appears on the right (4).

Tools configuration

In this list, tools with an eye are present in the Toolbox. By default, color tools have no eye: you can add them to the Toolbox by clicking the corresponding checkbox.

You can also sort tools by priority using the arrow up and down buttons at the bottom of the dialog.

This option replaces the Tools Dialog of former GIMP versions.

1.12. Dialog Defaults

그림 12.13. Dialog Default

Dialog Default

This page lets you customize the default parameters of dialogs.


1.13. 도움말 시스템

그림 12.14. Help System Preferences

Help System Preferences

이 페이지에서는 김프 도움말 시스템에 대한 설정을 할 수 있습니다.


1.13.1. 옵션

일반

풍선 도움말 표시

Tool tips are small help pop-ups that appear when the pointer hovers for a moment over some element of the interface, such as a button or icon. Sometimes they explain what the element does; sometimes they give you hints about non-obvious ways to use it. If you find them too distracting, you can disable them here by unchecking this option. We recommend that you leave them enabled unless you are a very advanced user.

도움말 버튼 표시

This option controls whether the help buttons are shown on every tool dialog, which may be used alternatively to invoke the help system.

User manual

This drop-down list lets you select between Use a locally installed copy and Use the online version. See 12.2절. “도움말”.

도움말 브라우저

사용할 도움말 브라우저

김프 도움말은 웹페이지와 같은 HTML 파일로 되어 있습니다. 따라서 김프에 있는 도움말 전용 브라우저나 다른 일반 웹브라우저로 불 수 있습니다. 하지만 일부 브라우저에서는 도움말이 잘 보이지 않을 수도 있으니 가급적이면 김프 브라우저로 설정하는 것이 좋습니다. 하지만 최근의 브라우저들은 특별한 문제가 없습니다.

[참고] 참고

Note that the GIMP help browser is not available on all platforms. If it is missing, this option is hidden and the standard web browser will be used to read the help pages.

Action Search

Maximum History Size

Default value is 100 (0-1000) items in the history.

Show unavailable actions

When this check-box is enabled, a search of actions will also return inactive actions.

Clear Action History

Self-explanatory.

1.14. 화면

그림 12.15. 화면 설정

화면 설정

이 페이지에서는 이미지의 투명부분을 표현하는 방법에 대한 설정을 할 수 있습니다. 그리고 모니터의 해상도를 재확인할 수 있습니다.


1.14.1. 옵션

투명 표현

투명 표현 유형

기본값으로 김프는 투명한 영역을 중간색의 격자무늬로 표현합니다. 하지만 이 설정을 다른 유형의 격자무늬나 색상(검정색, 흰색, 회색)으로 바꿀 수 있습니다.

격자 크기

투명한 영역을 표시하는 격자무늬의 사각형 크기를 설정할 수 있습니다.

그림 12.16. 측정 대화상자

측정 대화상자

모니터 해상도

모니터 해상도는 가로, 세로별 인치당 픽셀 비율입니다. 이를 지정하는 방법은 세 가지가 있습니다.

  • 데스크탑 시스템의 해상도 가져오기(가장 쉽지만 부정확할 수도 있습니다.)

  • 수동으로 설정하기

  • 측정 버튼 누르기

측정 대화상자

My monitor was impressively off when I tried the Calibrate Dialog. The Calibrate Game is fun to play. You will need a soft ruler.

1.15. 창 관리

그림 12.17. 창 관리 설정

창 관리 설정

이 페이지에서는 김프의 창들을 관리하는 방법을 설정할 수 있습니다. 여기서 주의해야 할 점은 김프는 창들을 직접 관리하지 않고, 창 관리자를 통해 한다라는 것입니다(예: MS Windows 에서는 Windows, Linux 의 Gnome 에서는 Metacity 등). 많은 창 관리자가 존재하기 때문에 일부 창 관리자에서는 여기서 설명한 기능들 중 일부가 동작하지 않을 수도 있습니다. 하지만 표준을 준수하는 최신 창 관리자일 경우에는 대부분 동작을 합니다.

1.15.1. 옵션

창 관리자 설정

창 유형별 도구상자와 독(dock) 설정

The choices you make here determine how the Toolbox, and the docks that hold dialogs, will be treated. You have three possibilities for them:

  • If you choose Normal Window, they will be treated like any other windows.

  • If you choose Utility Window, the reduce button in the title bar is absent and the docks will remain permanently on your screen.

    그림 12.18. Utility window title bar

    Utility window title bar

    Normal title bar

    Utility window title bar

    The title bar in a utility window


  • If you choose Keep above, they will be kept in front of every other window at all times.

Note that changes you make here will not take effect until the next time you start GIMP.

포커스

포커스된 이미지 활성화시키기

Normally, when you focus an image window (usually indicated by a change in the color of the frame), it becomes the active image for GIMP, and therefore the target for any image-related actions you perform. Some people, though, prefer to set up their window managers such that any window entered by the pointer is automatically focused. If you do this, you may find that it is inconvenient for focused images to automatically become active, and may be happier if you uncheck this option.

창 위치

마칠 때 창 위치 저장하기

이 옵션을 체크하면 김프 창의 위치가 저장되어 김프를 재시작해도 동일한 위치로 열립니다.

창 위치를 지금 저장하기

이 버튼은 "마칠 때 창 위치 저장하기" 기능을 사용하지 않을 때 유용합니다. 김프 창을 원하는 위치로 배치한 뒤 이 버튼을 눌러 위치를 저장하면 김프가 항상 그 자리로 실행됩니다.

저장된 창 위치를 기본값으로 초기화

저장한 창의 위치가 마음에 들지 않을 경우 재조정하지 않고 이 버튼을 눌러 초기 위치로 되돌릴 수 있습니다.

1.16. 이미지 창

그림 12.19. 일반 이미지창 설정

일반 이미지창 설정

이 페이지에서는 이미지창의 동작과 모양에 관한 설정을 할 수 있습니다.


1.16.1. 옵션

일반

Use Dot for dot by default

Using Dot for dot means that at 1:1 zoom, each pixel is the image is scaled to one pixel on the display. If Dot for dot is not used, then the displayed image size is determined by the X and Y resolution of the image. See the Scale Image section for more information.

선택의 점선이 움직이는 속도

When you create a selection, the edge of it is shown as a dashed line with dashes that appear to move, marching slowly along the boundary: they are jokingly called marching ants. The smaller the value entered here, the faster the ants march (and consequently the more distracting they are!).

확대와 크기 조정시 동작

확대시 창 크기 조정

이 옵션을 체크하면 이미지를 확대/축소 할때마다 이미지에 맞게 이미지 창의 크기가 변경됩니다.

이미지 크기 변경시 창 크기 조정

이 옵션을 체크하면 잘라내기나 크기 조정으로 이미지의 크기를 변경할 경우, 그 크기에 맞춰 창의 크기가 조절됩니다.

초기 확대 비율

이미지를 열었을 때 창 크기에 맞게 축소하여 보여줄 것인지, 아니면 원래 크기대로 보여줄 것인지 결정합니다. 1:1 비율로 보여주기를 선택하면, 이미지가 클 경우 이미지의 일부만 표시되고 창에 스크롤바가 생깁니다.

스페이스 바

스페이스 바를 누르고 있을 경우
  • 화면 이동(Pan view) (기본값) 나

  • Toggle to Move Tool

  • 동작 없음

마우스 커서

붓 윤곽 표시

이 옵션을 활성화시키면, 그리기 도구를 사용할 경우 이미지 위에 붓의 윤곽이 보여집니다. 이는 컴퓨터 성능이 낮거나 붓의 크기가 클 경우 김프 사용에 문제를 일으킬 수도 있습니다. 따라서 꼭 필요한 경우가 아니라면 사용하지 않는 것이 좋습니다.

그리기 도구의 커서 표시

이 옵션을 활성화시키면 커서가 표시됩니다. 이는 붓 윤곽에 추가되는 것으로 붓 윤곽 표시가 활성화되어야 표시됩니다. 커서의 종류는 다음 옵션에서 설정됩니다.

커서 모드

이 옵션은 그리기 도구의 커서 표시가 체크되어야만 적용이 됩니다. 여기에는 세 가지 모드가 있습니다. 도구 아이콘은 커서 옆에 현재 사용중인 도구의 아이콘이 표시됩니다. 십자선과 도구 아이콘은 중앙에 십자선이 표시되고 그 옆에 도구 아이콘이 표시됩니다. 그리고 십자선만은 중앙에 십자선만 표시됩니다.

커서 렌더링

예쁘게는 커서가 회색으로 표현되고, 흑백은 단순 흑백으로 표시되어 속도감이 필요할 때 유용합니다.

1.17. 이미지 창 모양

그림 12.20. 이미지 창 기본 모양

이미지 창 기본 모양

이 페이지에서는 이미지 창의 일반 모드와 전체 화면 모드에서의 기본 모양을 설정할 수 있습니다. 여기서 설정한 값들은 이미지 창의 보기 메뉴에서 각 창에 맞게 변경할 수 있습니다. 각 항목에 대한 더 자세한 내용은 이미지 창 섹션에서 확인할 수 있습니다.


여기서 설명이 좀 더 필요한 항목은 여백입니다. 여백는 이미지의 가장자리 주변에 표시되는 색상으로 모든 화면에서 볼 수 있지는 않습니다(여기서 사용된 모든 이미지에서는 회색으로 표시됩니다). 여백 색상은 현재 테마에서 지정된 색상, 이미지의 투명한 부분 등에 표시되는 격자의 밝은 색상이나 어두운 색상, 혹은 사용자가 선택한 색상 등으로 채울 수 있습니다. 사용자 정의 색상은 사용자 정의 색상에서 선택할 수 있습니다.

1.18. 이미지 창 제목표시줄과 상태표시줄

그림 12.21. 이미지 창 제목표시줄과 상태표시줄 형식

이미지 창 제목표시줄과 상태표시줄 형식

이 페이지에서는 이미지 창의 제목 표시줄과 상태 표시줄에 표시되는 정보의 종류를 설정할 수 있습니다. 제목 표시줄은 이미지 창의 상단에 표시되지만, 창 관리자에 따라 다를 수 있습니다. 상태 표시줄은 이미지 창의 우측 아래쪽에 표시됩니다. 이에 대한 더 자세한 사항은 이미지 창 섹션을 참고하십시오.


1.18.1. 표시 형식 선택하기

You can choose among several predesigned formats, or you can create one of your own, by writing a format string in the entry area. Here is how to understand a format string: anything you type is shown exactly as you type it, with the exception of variables, whose names all begin with %. Here is a list of the variables you can use:

변수 Meaning
%f Bare filename of the image, or Untitled
%F Full path to file, or Untitled
%p 이미지 id 번호(유일함)
%i 보기 번호, 이미지가 여러 창에 표시될 때.
%t 이미지 유형 (RGB, grayscale, indexed)
%z 확대/축소 비율(퍼센트)
%s 원본에 대한 대상의 비율 (확대/축소 단계 = %d/%s)
%d 대상에 대한 원본의 비율 (확대/축소 단계 = %d/%s)
%Dx 이미지가 수정되었을 경우 x 를 표시합니다.
%Cx 이미지가 수정되지 않았을 경우 x 를 표시합니다.
%l 레이어 수
%L 레이어 수 (자세히)
%m 이미지의 메모리 사용량
%n 활성화된 레이어/채널명
%P 활성화된 레이어/채널 id
%w 이미지 너비(픽셀)
%W 이미지 너비(실생활에서 쓰는 단위)
%h 이미지 높이(픽셀)
%H 이미지 높이(실생활에서 쓰는 단위)
%u 단위 기호 (예. Pixel 은 px)
%U 단위 약호
%% A literal % symbol

1.19. Image Window Snapping Behavior

그림 12.22. Image Window Snapping Behavior

Image Window Snapping Behavior

This page allows you to customize snapping in the image. Only Snap to Guides is activated by default. You can also check Snap to Grid, Snap to Canvas Edges and Snap to Active Path, in normal mode and fullscreen mode.

Snapping distance is the activation distance of snapping, in pixels. Default value is 8 pixels (1-255).

1.20. 입력 장치

그림 12.23. 입력 장치 설정

입력 장치 설정

확장 입력 장치

Share tool and tool options between input devices

When enabled, the same tool and tool options will be used for all input devices. No tool switching will occur when the input device changes.

확장 입력 장치 설정

컴퓨터에 연결된 타블렛이나 미디 키보드 등의 추가 장치를 설정할 수 있습니다. 만약 타블렛이 연결되어 있다면 다음과 같은 대화상자가 표시될 것입니다.

그림 12.24. 타블렛 설정

타블렛 설정

마칠 때 장치 상태 저장

When you check this box, GIMP remembers the tool, color, pattern, and brush you were using the last time you quit.

입력 장치 상태 지금 저장

입력 장치의 상태를 지금 저장하는 버튼입니다.

저장된 장치 설정을 기본값으로 초기화하기

사용자가 저장한 설정을 삭제하고, 기본 설정값을 복원합니다.

1.21. 입력 제어기

그림 12.25. 입력 제어기 설정

입력 제어기 설정

This dialog has two lists of additional input controllers: Available Controllers on the left, Active Controllers on the right. It is used to enable or disable an input device and configure it.

A click on an item will highlight it and you can move the controller from one list to the other by clicking on the respective arrow key. When you try to move a controller from the list of active controllers to the available controllers, a dialog pops up and you will have the choice of removing the controller or just disabling it.

When you double click on a (typically active) controller or alternatively click on the Edit button at the bottom of the list, you can configure this controller in a dialog window:

메인 마우스 휠

그림 12.26. 메인 마우스 휠

메인 마우스 휠


일반
Dump events from this controller

This option must be checked if you want a print on the stdout of the events generated by the enabled controllers. If you want to see those event you should start GIMP from a terminal or making it to print the stdout to file by the shell redirection. The main use of this option is for debug.

Enable this controller

This option must be checked if you want to add a new actions to the mouse wheel.

마우스 휠 이벤트

이 창에는 스크롤바가 있습니다. 왼쪽에는 마우스 휠에 할당할 수 있는 이벤트 목록이 있고, 오른쪽에는 각각의 이벤트에 대한 동작 목록이 있습니다. 그리고 편집 버튼과 비우기 버튼이 있습니다.

일부 동작은 이미 할당되어 있는데, 이는 예제같은 것으로 정상적으로 동작하지 않을 수도 있습니다.

이벤트에 할당될 동작 선택하기

이벤트를 선택한 다음, 편집 버튼을 누르면 다음과 같은 대화상자가 나타납니다.

그림 12.27. 제어기 이벤트 동작 선택하기

제어기 이벤트 동작 선택하기

이벤트에 동작이 할당되어 있으면, 해당 동작에 대한 창이 뜨고, 아닌 경우에는 새로운 동작을 선택할 수 있는 창이 뜹니다. 여기서 동작을 선택합니다.

메인 키보드

마우스 휠과 동일한 방법으로 키보드의 화살키와 기능 키들을 조합하여 동작을 할당할 수 있습니다.

그림 12.28. 메인 키보드

메인 키보드

[참고] 참고

이러한 개념의 예는 다양한 크기의 붓 만들기 에서 찾아볼 수 있습니다.

1.22. 폴더

그림 12.29. 기본 폴더 설정

기본 폴더 설정

이 페이지에서는 김프 임시 파일을 저장하기 위한 두 개의 중요한 폴더의 위치를 설정할 수 있습니다. 그리고 붓과 같은 자원의 위치를 저장하는 폴더를 설정할 수 있는 하위 페이지들이 있습니다. 이러한 데이터 폴더들에 대한 설명은 데이터 폴더 페이지에 있습니다. 임시 파일 폴더는 직접 주소를 입력하거나 오른쪽의 버튼을 눌러 파일 찾기 창을 이용해 지정할 수 있습니다.

폴더

임시 폴더

이 폴더에는 작업 데이터의 임시 저장을 위한 파일 등의 임시 파일을 저장하기 위한 폴더입니다. 이 폴더의 파일들은 김프 세션이 종료되면 삭제됩니다. 이 폴더는 크기가 클 필요도 없고, 고성능이 필요하지도 않습니다. 기본 위치는 김프 사용자 디렉토리 아래에 tmp 폴더입니다. 만약 디스크가 상당히 작다면 다른 위치로 변경할 수도 있습니다. 하지만 해당 디렉토리는 반드시 있어야하며 쓰기 가능해야 합니다.

스왑 폴더

This is the folder used as a memory bank when the total size of images and data open in GIMP exceeds the available RAM. If you work with very large images, or images with many layers, or have many images open at once, GIMP can potentially require hundreds of megabytes of swap space, so available disk space and performance are definitely things to think about for this folder. By default, it is set to your personal GIMP directory, but if you have another disk with more free space, or substantially better performance, you may see a significant benefit from moving your swap folder there. The directory must exist and be writable by you.

1.23. 데이터 폴더

그림 12.30. 기본 설정: 붓 폴더

기본 설정: 붓 폴더

김프는 붓, 무늬, 그라디언트 등 몇 가지 유형의 자원을 사용합니다. 이들은 기본적으로 김프와 함께 설치되며, 사용자가 직접 만들거나 다운로드받아 설치할 수도 있습니다. 각 자원들은 기본 설정 페이지에서 검색 경로를 설정할 수 있으며, 김프 시작시에 설정된 각 폴더의 자원들을 불러옵니다. 각 페이지들은 예제인 붓 페이지와 거의 흡사합니다.

검색 폴더에는 기본값으로 두 개의 폴더가 설정되어 있습니다. 김프가 설치된 시스템 폴더와 사용자가 추가된 항목들이 저장되는 김프 사용자 디렉토리 내부의 사용자 폴더입니다. 시스템 폴더는 쓰기 가능 표시를 하지 말고, 그 안의 파일들도 수정하지 않는 것이 좋습니다. 사용자 폴더는 쓰기 가능으로 표시되어 있어야 하나, 실은 아무 의미가 없습니다. 사용자 폴더에는 사용자가 직접 추가한 항목들만 들어가기 때문입니다.

대화상자 상단의 버튼을 눌러 검색 경로를 설정할 수 있습니다.

옵션

폴더 선택하기

목록에 있는 폴더중 하나를 클릭하여 선택합니다.

폴더 추가/교체 하기

If you type the name of a folder in the entry space, or navigate to it using the file chooser button on the right, and then click the left button, this will replace the selected folder with the one you have specified. If nothing in the list is selected, the folder you specify will be added to the list. If the light-symbol to the left of the text entry area is red instead of green, it means that the folder you have specified does not exist. GIMP will not create it for you, so you should do this immediately.

위/아래로 옮기기

위 화살버튼이나 아래 화살버튼을 누르면 선택한 폴더의 위치가 변경됩니다. 이 순서는 폴더를 읽어오는 순서입니다. 이를 이용해 목록에 있는 폴더들의 읽어오기 순서를 변경할 수 있습니다.

폴더 삭제하기

휴지통 버튼을 클릭하면 선택한 폴더를 목록에서 제거합니다(폴더 자체를 삭제하지는 않습니다). 시스템 폴더는 가능한 삭제하지 않는 것이 좋습니다.