2. 김프의 주요 화면

김프 사용자 인터페이스는 다음 두 가지 모드를 지원합니다.

When you open GIMP for the first time, it opens in single-window mode by default. You can enable multi-window mode unchecking Windows>Single-Window Mode) option in the image menu bar. After quitting GIMP, GIMP will start in the mode you have selected next time.

다중창 모드

그림 3.2. 다중창 모드 스크린샷

다중창 모드 스크린샷

위 스크린샷은 효과적으로 사용할 수 있도록 배치된 김프 기본 창의 모습입니다.

You can notice two panels, left and right, and an image window in middle. A second image is partially masked. The left panel collects Toolbox and Tool Options dialog together. The right panel collects Layers, Channels, Paths, Undo History dialogs together in a multi-tab dock, and Brushes, Patterns, Gradients, Fonts, History, Paint dynamics editor, Palette editor dialogs together in another multi-tab dock.

  1. 기본 도구 상자: 여러 가지 도구들을 선택할 수 있는 아이콘들이 모아져 있습니다. 그리고 전경색/배경색이 표시됩니다. 붓, 패턴, 그라디언트, 현재 이미지의 아이콘 등을 추가할 수도 있습니다. 편집기본 설정도구 상자 메뉴를 이용하여 추가로 표시할 수 있는 항목들을 표시하거나 숨길 수 있습니다.

  2. 도구 옵션: 도구 옵션 대화 상자는 기본 도구 상자 아래에 연결되어 있으며, 현재 선택된 도구의 옵션을 표시합니다.(스크린샷에는 이동 도구의 옵션이 표시되고 있습니다)

  3. 이미지 창: 김프에서는 이미지들이 각각의 독립된 창으로 열립니다. 그리고 시스템 리소스가 허용하는 한 많은 이미지를 동시에 열수 있습니다. 김프를 이용하여 이미지를 편집하려면, 우선 이 이미지 창을 이용해 그림을 불러와야 합니다. 이미지 창의 한쪽 구석에는 메뉴 모음(파일, 편집, 선택 등..)이 있으며, 이 메뉴 모음은 마우스 버튼 우클릭으로도 사용할 수 있습니다.

    이미지를 불러올 때 이미지가 이미지 창의 크기보다 큰 경우, 이미지를 축소시켜 창에 전체 이미지가 표시되도록 합니다. 확대/축소 비율을 100%로 만들면, 이미지 창에 스크롤바가 표시됩니다.

  4. 레이어, 채널, 경로 독(dock): 독(dock) 안에 포함된 각 대화 상자가 탭으로 구분됩니다. 레이어 탭에는 현재 활성화된 이미지의 레이어 구조가 표시되며, 이를 이용해 다양한 방법으로 이미지를 편집할 수 있습니다. 레이어 대화 상자를 이용하지 않고도 몇 가지 기본적인 기능을 사용할 수는 있지만, 어느 정도 김프에 익숙해진 사용자라면 레이어 대화 상자가 늘 필요하다고 느낄 것입니다.

  5. 붓/무늬/그라디언트: 붓, 무늬, 그라디언트 등의 관리를 위한 대화 상자들로 레이어 대화 상자 아래에 연결되어 있습니다.

대화 상자와 독(dock) 관리에 대해서는 2.3절. “대화 상자와 도킹”에 설명이 되어 있습니다.

단일창 모드

그림 3.3. 단일창 모드 스크린샷

단일창 모드 스크린샷

다중창과 같은 요소들을 포함하고 있지만, 사용법은 다소 다릅니다.

  • Left and right panels are fixed; you can't move them. But you can decrease or increase their width by dragging the moving pointer that appears when the mouse pointer overflies the right border of the left pane. If you want to keep the left pane narrow, please use the slider at the bottom of the tool options to pan across the options display.

    If you reduce the width of a multi-tab dock, there may be not enough place for all tabs;then arrow-heads appear allowing you to scroll through tabs.

    다중창 모드에서는 키를 이용해 각종 창들을 숨기거나 표시할 수 있습니다.

  • 이미지는 두 패널 사이에 가득차게 표시됩니다.

    When several images are open, a new bar appears above the image window, with a tab for every image. You can navigate between images by clicking on tabs or either using Ctrl+Page Up or Page Down or Alt+Number. Number is tab number; you must use the number keys of the upper line of your keyboard, not that of keypad (Alt-shift necessary for some national keyboards).

위 내용은 가장 기본적인 대화 상자들입니다. 이외에 목적에 따라 수많은 대화 상자들이 있지만, 대부분은 필요에 따라 그때그때 열어 쓰고 닫아두게 됩니다. 일반적으로 도구 옵션을 포함한 도구 상자와 레이어 대화 상자는 항상 열어두는 편이 좋습니다. 도구 상자는 많은 김프 의 핵심이며, 도구 옵션 상자는 독립된 대화 상자로 위 스크린샷처럼 기본 도구 상자에 연결되어 있습니다. 도구 옵션 상자 역시 항상 필요한 것으로 여기에 표시되는 도구의 설정 상태를 보지 않고 도구들을 효과적으로 사용하는 것은 다소 어려운 일입니다. 따라서 많은 사용자들이 스크린샷과 같은 형태로 사용합니다. 레이어 대화 상자는 복수의 레이어를 가진 이미지를 편집할 때 사용됩니다. 김프를 전문으로 사용하려면 거의 필수적으로 사용하게 됩니다. 그리고 레이어 대화 상자는 작업중인 이미지를 보는데에도 사용합니다. 작업 후 저장을 하지 않고 이미지 창을 닫으면, 이미지 창을 닫을 것인지를 묻는 창이 표시됩니다.

[참고] 참고

실수로 김프의 대화 상자를 닫아도 최근 닫은 독(dock) 메뉴를 이용하면 스크린샷과 같은 모습으로 쉽게 복구시킬 수 있습니다. 창 메뉴는 열려 있는 이미지가 있을 때에만 사용이 가능합니다. 독(dock)에 탭을 추가하거나, 닫기, 떼어내기를 하려면 대화 상자의 오른쪽 상단에 있는 를 클릭합니다. 이 버튼을 누르면 탭 메뉴가 표시됩니다. 메뉴에서 탭 추가,탭 닫기, or 탭 떼어내기 중 필요한 메뉴를 선택합니다.

다음 절에서는 스크린샷에 있는 각 창의 구성 요소들과 그것들의 기능에 대해 이야기할 것입니다. 다음 절과 김프 이미지의 기본 구조에 대한 절을 통해 김프를 이용한 기본적인 이미지 편집의 다양한 방법을 배울 수 있습니다. 또 시간이 허락한다면 메뉴얼의 나머지 부분을 통해 수많은 정교한 방법들을 배우고, 활용할 수 있게 될 것입니다. Have fun!

2.1. 기본 도구 상자

그림 3.4. 도구 상자의 모습

도구 상자의 모습

다음에 설명할 기본 도구 상자는 김프의 핵심적인 부분입니다.

[작은 정보] 작은 정보

김프의 다른 부분과 마찬가지로 도구 상자의 특정 부분에 마우스 커서를 올려놓고 잠시 기다리면, 해당 부분에 대한 간단한 설명과 사용법이 도구 설명으로 표시됩니다. 도구 설명에는 키보드 단축키도 표시됩니다. 또 원하는 부분에 마우스 커서를 올려놓고 F1 키를 누르면 조금 더 상세한 도움말을 볼 수 있습니다.

기본값으로 전경색 아이콘만 표시되며, 편집기본 설정도구 상자 메뉴를 이용해 붓-패턴-그라디언트 아이콘과 활성화된 이미지 아이콘을 추가할 수 있습니다. Tools configuration.

  1. 도구 아이콘: 이 아이콘들은 그림의 일부를 선택하거나, 칠하거나 변형시키는 등의 다양한 목적을 위한 도구들을 사용하기 위한 것입니다. 도구들의 간단한 사용법은 도구 상자 소개 섹션에 있고, 각 도구들에 대해서는 도구 장에 상세히 소개되어 있습니다.

  2. 전경색/배경색: 이 부분에는 김프의 현재 전경색과 배경색이 표시됩니다. 각 부분을 클릭하면 색상 선택 대화 상자가 나타나고 그곳에서 다른 색상으로 변경할 수 있습니다. 그리고 양방향 화살표를 클릭하면 두 색상을 맞바꿀 수 있으며, 왼쪽 하단의 조그만 심볼을 클릭하면 기본값인 검정색과 흰색으로 초기화할 수 있습니다.

  3. Brush/Pattern/Gradient: The symbols here show you GIMP's current selections for: the Paintbrush, used by all tools that allow you to paint on the image (painting includes operations like erasing and smudging, by the way); for the Pattern, which is used in filling selected areas of an image; and for the Gradient, which comes into play whenever an operation requires a smoothly varying range of colors. Clicking on any of these symbols brings up a dialog window that allows you to change it.

  4. 활성화된 이미지: 김프에서는 한번에 여러 이미지들을 열어 두고 작업을 할 수 있습니다. 하지만 그러할지라도 어느 한 순간에는 한 이미지만 작업을 하게 되는데, 그 이미지의 미리 보기가 이 영역에 표시됩니다. 이것을 클릭하면, 현재 열린 이미지의 목록이 담긴 대화 상자가 호출됩니다. 대화 상자에 있는 이미지 중 하나를 선택하면 해당 이미지가 활성화됩니다. 다중 창 모드에서는 이미지 창을 클릭하거나 싱글창 모드에서는 이미지 탭을 클릭해서 원하는 이미지를 활성화시킬 수도 있습니다.

    활성화된 이미지 아이콘을 XDS 파일 관리자로 드래그앤 드랍하여 이미지를 저장할 수도 있습니다.

[참고] 참고

At every start, GIMP selects the brush, color, pattern you used when quitting your previous session because the Save input device settings on exit in Preferences/Input Devices, is checked by default. If you uncheck it, GIMP will use use a color, a brush and a pattern by default, always the same.

[작은 정보] 작은 정보

도구 상자의 윗 부분에 있는 윌버의 눈을 도구 상자에서 없앨 수 있습니다. 이를 없애려면 gimprc 파일에 (toolbox-wilber no) 을 추가합니다. 이는 도구 상자에만 영향을 주며 빈 이미지 창에 표시되는 윌버의 눈에는 영향을 주지 않습니다.

[작은 정보] 작은 정보

파일 브라우저에서 도구 상자 창으로 이미지 파일을 드래그앤 드랍하면 이미지창이나 탭으로 해당 이미지가 열립니다.