7. GIMP 2.6 の新機能

GIMP 2.6 は開発者にとっても重要な公開版です。 これまでに何度も寄せられた要望をもとにユーザーインターフェースの改善を行なったことに加え、 試験的に GEGL の導入も行いました。 GEGL はグラフ形式のデータ構造からなる画像処理ライブラリーであり、 結果的に高いビット深度と非破壊編集を GIMP にもたらすものとなるはずです。

ユーザーインターフェース

ツールボックスのメニューバーを撤去

ツールボックスのメニューバーが撤去されその内容は画像ウィンドウのメニューバーに統合されました。 このために無画像ウィンドウというものが導入されました。 画像が何も開かれていない場合にもメニューバーを表示するとともにアプリケーションそのものの存在を保持する役目があります。 またここはドラッグして放つ動作の目的地にもなります。 最初に開いた画像は無画像ウィンドウが通常の画像ウィンドウに変化して表示します。 最後の画像を閉じた後のウィンドウが無画像ウィンドウになります。

図A.5 新しい GIMP 2.6 の画像ウィンドウの外観

新しい GIMP 2.6 の画像ウィンドウの外観

ツールボックスとドックは補助ウィンドウに

無画像ウィンドウが自然にメインウィンドウとなったことで、 ツールボックスとドックはメインウィンドウではなく補助ウィンドウとなりました。 ウィンドウマネージャーにとってはこの変更により、 ツールボックスやドックをタスクバーから除外できるので、 常に画像ウィンドウ上にツールバーやドックが存在することが明確になったため、 より GIMP のウィンドウを正しく管理することが可能になりました。

画像の外にまでスクロールが可能に

ナビゲーションダイアログは画像の境界を過ぎても繰り寄せられるようになりました。 これでもう画像が画像ウィンドウいっぱいに広がっていて境界線付近で描画ブラシが使いづらかった問題はなくなりました。 さらに、 補助ウィンドウが画像にかぶっていても、 画像の方を移動すれば簡単に隠れた部分を見たり編集したりできるようになります。

図A.6 画像の外へスクロール

画像の外へスクロール

小規模な変更
  • ダイアログ メニューは ウィンドウ メニューに名前が変更されました。

  • 最近閉じたドックのリストが保持され、 再び開くのが容易になりました。

  • Windows™ 環境で画像を開く際に、 既に GIMP を実行していた場合の動作が改善されました。

  • 画像ウィンドウのステータスバーで、 ズーム倍率を直接入力できるようになりました。

  • GIMP ヘルプシステムはインストール版のヘルプパッケージだけでなく、 オンライン版も利用できるようになりました。

  • ドック上でタブ化したダイアログを誤って消してしまわないためのロック機能が付きました。

ツールとフィルターとプラグイン

自由選択ツールの改良

これまでの手書き選択ツールが多角形選択が可能なツールに進化しました。 手書き曲線と線分を繋ぎあわせたり、 線分を編集したり、 限定方角で線分を引いたりできるようになりましたが、 もちろん一般的な選択ツールとしての操作 (選択範囲の加減など) もできます。 これはつまり自由選択ツールが極めて柔軟かつ強力な、 しかも使い易い選択ツールに発展したことを意味します。

図A.7 多角形選択

多角形選択

ブラシ感度の調整(現ブラシの動的特性)

ブラシ感度の調整オプションにより、 圧力や筆速や不規則変化のような絶えず変化する入力情報を使って不透明度や硬さや大きさや色のようなブラシにまつわる変数を操作できます。 すべてのブラシが大きさと不透明度をサポートしていますし、 ほかの変数も多数のブラシがサポートしています。 筆速や不規則変化はマウスにも有効です。 インクツールは以前から筆速対応ができていましたが、 筆速に依存する描画をもっとうまくこなせるように全面改修を行ないました。

図A.8 ブラシ感度の調整(現ブラシの動的特性)

ブラシ感度の調整(現ブラシの動的特性)

ブラシ感度の調整の機能がパスの境界線の描画に新機能として生かされています。 ダイアログでは描画ツールのオプションの下にブラシ感度の調整を模倣するチェックボックスが加わり、 描画ツールを使用した境界線の描画に活用できます。 つまり境界線の描画を実行すると GIMP はあたかも筆圧や筆速が輪郭線の伸びに合わせて変化しているようにブラシに伝えます。 筆圧は圧力無しから開始し、 最大圧力まで駆け上がって再び圧力無しまで減圧してゆきます。 筆速は 0 から加速を始め、 描線の終端で最大速となります。

小規模な変更
  • テキストツールには囲み枠が加わり、 枠内の文字を自動改行させることが可能になりました。

    図A.9 テキストツールの囲み枠

    テキストツールの囲み枠

  • 矩形の枠が基本になっている切り抜きツールや矩形選択ツールと同じように、 枠が小さいときは加工ハンドルが枠外に現れる。

    図A.10 矩形枠のハンドル

    矩形枠のハンドル

  • 移動ツールに限定動作のオプションを追加。

  • 描画ツールでのイベント平滑化改善。

  • 矩形枠の中央点が移動時に図示され、 ガイドや定規に近づくと吸着。

  • にじみツールでブラシの拡大・縮小が可能に。

  • 色ツールによく使う色調整が保存できるプリセット機能を追加。

  • 明るさ-コントラスト ツールから レベル ツールへ、 あるいは レベル ツールから トーンカーブ ツールへの設定内容の受け渡しが可能になりました。

  • 変換ツールのプレビュー機能の透明度が変更可能に。

  • スクリーンショットプラグインが新たにマウスカーソルを含めた取り込みも可能に (Xfixes が必要です)。

  • 切り抜きツールや矩形選択ツールの矩形枠の縦横比をステータスバーに表示。

  • 脱色ツールにプレビュー機能を追加。 キャンバス上で見られる。

  • 炎プラグインが 22 の変種に発展。

  • ブラシフォルダーなどのデータディレクトリー内を再帰的にファイル検索。

  • PSD 形式のファイル転換読み込みプラグインは書き直された新版を採用し、 新たに ICC 色プロファイルが読み込めるようになるなどいくつかの機能が増えた。

  • いくつかの画像表示に Cairo ライブラリーを使用。

    図A.11 2.6 と 2.4 の表示の比較

    2.6 と 2.4 の表示の比較

手の内

GEGL

Important progress towards high bit-depth and non-destructive editing in GIMP has been made. Most color operations in GIMP are now ported to the powerful graph based image processing framework GEGL [GEGL], meaning that the internal processing is done in 32bit floating point linear light RGBA. By default the legacy 8bit code paths are still used, but a curious user can turn on the use of GEGL for the color operations with Colors / Use GEGL.

GEGL に色操作を移植したことに加え、 試験的に GEGL 操作ツールが作られ、 ツールメニュー上に加わりました。 画像に GEGL による処理が適用でき、 その結果をキャンバス上でプレビューする機能もあります。 下図はガウスぼかしをかけたときのスクリーンショットです。

図A.12 GEGL 操作

GEGL 操作

小規模な変更

多くのウィジェットが Cairo [CAIRO] という 2 次元画像ライブラリーを使った描画方式に移植されました。 見た目にどんな変化が起きたかを上図の 比較例 でご覧ください。

雑載

プラグイン開発

プラグイン開発を楽しくするための新しいものがあります。 たとえばエラーが起きたときにプロシージャーが示すエラーの説明はより詳しくなりました。 またそのエラーをユーザーに伝えることも可能です。

GIMP 2.6 はスクリプト機能も更に強化されました。 特にテキストレイヤーの操作と作成の API は格段に豊富なものとなりました。 GIMP 2.6 で新しくなったシンボルのリストがあります [GIMP-NEWSYM26]

後方互換性

古いスクリプトの一部が GIMP 2.4 で使用できませんでした。 この問題は GIMP 2.6 で改善され 2.0 や 2.2 用のスクリプトも動作します。

既知の問題
  • 補助ウィンドウのヒント機構は現在[2.6.0]のところ LinuxGNOME デスクトップ環境でのみ動作することがわかっており、 Windows™ 対応は GIMP 2.6.1 からになります。

  • テキストツールの使い勝手はまだ最適化への運用が足りません。 より良くなる時期は GIMP 2.8 を目標にしています。

  • GVfs のサポートがないシステムで GIMP を自己ビルドされるときは configure--without-gvfs を明示する必要があります。 これがないと遠隔ファイルを開く動作が適切に行なわれません。