GNU Image Manipulation Program

Manuale utente

Note legali

È garantito il permesso di copiare, distribuire e/o modificare questo documento seguendo i termini della Licenza per Documentazione Libera GNU, Versione 1.2 o qualsiasi versione successiva pubblicata dalla Free Software Foundation; senza sezioni non modificabili, senza testi di copertina, e senza testi di retro copertina. Una copia della licenza è acclusa nella sezione intitolata Licenza di Documentazione Libera del progetto GNU.


Indice

Prefazione
1. Autori e collaboratori del manuale utente di GIMP
I. Introduzione
1. Introduzione
1. Benvenuti a GIMP
1.1. Autori
1.2. Il sistema d'aiuto di GIMP
1.3. Caratteristiche e funzionalità
2. Cosa c'è di nuovo in GIMP 2.8?
2. Esecuzione di GIMP
1. Eseguire GIMP
1.1. Piattaforme conosciute
1.2. Lingua
1.3. Argomenti della riga di comando
2. Prima esecuzionde di GIMP
2.1. Infine . . .
3. Primi passi con Wilber
1. Concetti base di GIMP
2. Le finestre principali in GIMP
2.1. Il pannello strumenti
2.2. Finestra immagine
2.3. Pannelli e finestre agganciabili
3. Annullamenti
3.1. Operazioni che non possono essere annullate
4. Utilizzi frequenti
4.1. Obiettivi
4.2. Cambiare le dimensioni di un'immagine per lo schermo
4.3. Cambiare le dimensioni di un'immagine per la stampa
4.4. Compressione delle immagini
4.5. Ritagliare un'immagine
4.6. Ottenere informazioni sulle immagini
4.7. Cambio di modalità
4.8. Riflettere un'immagine
4.9. Ruotare un'immagine
4.10. Separazione di un oggetto dal suo sfondo
5. Come disegnare linee dritte
5.1. Obiettivi
5.2. Esempi
4. Sbloccarsi in GIMP
1. Sbloccare la situazione
1.1. Bloccato!
1.2. Cause frequenti di blocco con GIMP
II. Come diventare un mago di GIMP?
5. Inserire le immagini in GIMP
1. Tipi di immagine
2. Creazione di nuovi file
3. Aprire file esistenti
3.1. File apri
3.2. Apri posizione
3.3. Apri recenti
3.4. Uso di programmi esterni
3.5. Gestione file
3.6. Trascinamento
3.7. Copia e incolla
3.8. Navigatore immagini
6. Estrarre le immagini da GIMP
1. File
1.1. Salvataggio / esportazione delle immagini
1.2. Formati di file
2. Preparare immagini per Internet
2.1. Immagini con un rapporto ottimale dimensione/qualità
2.2. Riduzione ulteriore della dimensione dei file
2.3. Salvataggio di immagini con trasparenza
7. Dipingere con GIMP
1. La selezione
1.1. Sfumatura
1.2. Rendere una selezione parzialmente trasparente
2. Creazione e uso delle selezioni
2.1. Spostamento di una selezione
2.2. Aggiunta o sottrazione di selezioni
3. La maschera veloce
3.1. Panoramica
3.2. Proprietà
4. Uso della modalità maschera veloce
5. Tracciati
5.1. Creazione di tracciati
5.2. Proprietà dei tracciati
5.3. Tracciati e selezioni
5.4. Trasformazione dei tracciati
5.5. Delineare un tracciato
5.6. Tracciati e testo
5.7. Tracciati e file SVG
6. Pennelli
7. Aggiunta di nuovi pennelli
8. La finestra di dialogo GIH
9. Creazione di un pennello a dimensione variabile
9.1. Come variare l'altezza di un pennello
9.2. Creazione veloce di un pennello
10. Gradienti
11. Motivi
12. Tavolozze
12.1. Mappa colore
13. Preimpostazioni
14. Disegno di oggetti semplici
14.1. Disegno di una linea retta
14.2. Creazione di una forma semplice
8. Combinare le immagini con GIMP
1. Livelli
1.1. Proprietà del livello
2. Modalità del livello
3. Creazione di nuovi livelli
4. Gruppi di livelli
9. Gestione del testo
1. Gestione del testo
2. Pannello strumenti di testo
2.1. Menu contestuale del pannello degli strumenti di testo
3. Testo
3.1. Abbellimento del testo
3.2. Aggiungere font
3.3. Problemi con i caratteri
10. Migliorare le foto con GIMP
1. Al lavoro con le fotografie digitali
1.1. Introduzione
1.2. Miglioramento della composizione
1.3. Miglioramento colori
1.4. Regolazione della nitidezza
1.5. Rimozione degli oggetti indesiderati da un'immagine
1.6. Salvataggio dei risultati
11. Gestione del colore con GIMP
1. Gestione del colore in GIMP
1.1. Problemi di un flusso di produzione senza gestione del colore
1.2. Flusso di produzione con gestione del colore
12. Adattare GIMP ai propri gusti
1. Finestra preferenze
1.1. Introduzione
1.2. Ambiente
1.3. Interfaccia
1.4. Temi
1.5. Sistema d'aiuto
1.6. Opzioni strumenti
1.7. Strumenti
1.8. Preferenze immagine predefinita
1.9. Griglia immagine predefinita
1.10. Finestre immagine
1.11. Aspetto della finestra immagine
1.12. Titolo finestra immagine e barra di stato
1.13. Visualizzazione
1.14. Gestione del colore
1.15. Dispositivi di ingresso
1.16. Controllori di ingresso
1.17. Gestione finestre
1.18. Cartelle
1.19. Cartelle dati
2. Griglie e Guide
2.1. La griglia immagine
2.2. Guide
3. Disegnare una griglia
4. Come impostare la cache tile
5. Creazione di scorciatoie alle funzioni nei menu
6. Personalizza l'immagine d'avvio
13. Programmare GIMP
1. Plugin
1.1. Introduzione
1.2. Uso dei plugin
1.3. Installazione di nuovi Plugin
1.4. Scrittura dei plugin
2. Uso degli script Script-Fu
2.1. Script-Fu?
2.2. Installazione degli Script-Fu
2.3. Cose che si possono e che non si possono fare
2.4. Tipi differenti di Script-Fu
2.5. Script autonomi
2.6. Script immagine dipendenti
3. Una guida sugli Script-Fu
3.1. Introduzione a Scheme
3.2. Variabili e funzioni
3.3. Liste, liste e ancora liste
3.4. Il primo script Script-Fu
3.5. Dare un corpo allo script
3.6. Estendere lo script Text Box
3.7. Lo script e il suo funzionamento
III. Guida di riferimento di GIMP
14. Strumenti
1. La barra degli strumenti
1.1. Introduzione
1.2. Icone strumenti
1.3. Area dei colori e degli indicatori
1.4. Opzioni dello strumento
2. Strumenti di selezione
2.1. Funzioni comuni
2.2. Strumento di selezione rettangolare
2.3. Strumento di selezione ellittica
2.4. Selezione a mano libera (lazo)
2.5. Selezione fuzzy (bacchetta magica)
2.6. Strumento di selezione per colore
2.7. Forbici intelligenti
2.8. Strumento di selezione primo piano
3. Strumenti di disegno
3.1. Funzioni comuni
3.2. Dinamiche
3.3. Strumenti di disegno (matita, pennello, aerografo)
3.4. Riempimento colore
3.5. Sfumatura
3.6. La matita
3.7. Il pennello
3.8. La gomma
3.9. Aerografo
3.10. Stilo
3.11. Strumento clona
3.12. Cerotto
3.13. Clona in prospettiva
3.14. Sfoca/Contrasta
3.15. Strumento sfumino
3.16. Scherma/Brucia
4. Strumenti di trasformazione
4.1. Funzioni comuni
4.2. Strumento di allineamento
4.3. Spostamento
4.4. Taglierino
4.5. Rotazione
4.6. Scala
4.7. Inclina
4.8. Prospettiva
4.9. Riflessione
4.10. Lo strumento gabbia
5. Strumenti di colore
5.1. Panoramica
5.2. Bilanciamento del colore
5.3. Tonalità-saturazione
5.4. Colorazione
5.5. Luminosità-Contrasto
5.6. Soglia
5.7. Livelli
5.8. Curve
5.9. Posterizzazione
5.10. Desatura
6. Altri
6.1. Panoramica
6.2. Tracciati
6.3. Prelievo colore
6.4. Zoom
6.5. Misurino
6.6. Testo
6.7. Operazione GEGL
15. Finestre di dialogo
1. Introduzione alle finestre
2. Finestre relative alla struttura dell'immagine
2.1. Finestra livelli
2.2. Finestra di dialogo canali
2.3. Finestra di dialogo tracciati
2.4. Finestra mappa colori
2.5. Finestra dell'istogramma
2.6. Finestra di navigazione
2.7. Finestra cronologia annullamenti
3. Finestre relative al contenuto dell'immagine
3.1. La finestra di dialogo «Colore PP/SF»
3.2. Finestra di dialogo pennelli
3.3. Finestra motivi
3.4. Finestra di dialogo gradienti
3.5. Finestra di dialogo tavolozze
3.6. Marcatura
3.7. La finestra di dialogo caratteri
4. Finestre relative alla gestione delle immagini
4.1. Finestra di dialogo buffer
4.2. La finestra di dialogo immagini
4.3. Finestra cronologia documenti
4.4. La finestra di dialogo modelli
5. Finestre varie
5.1. Finestra di dialogo preimpostazioni strumenti
5.2. L'editor delle preimpostazioni degli strumenti
5.3. Finestra stato dispositivi
5.4. Console errori
5.5. Salva il file
5.6. Esporta file
5.7. Finestra «punti di campionamento»
5.8. Finestra «puntatore»
16. Menu
1. Introduzione ai menu
1.1. La barra del menu dell'immagine
1.2. I menu contestuali
1.3. Menu staccabili
1.4. Menu scheda
2. Il menu «File»
2.1. Panoramica
2.2. Nuovo
2.3. Crea
2.4. Apri
2.5. Apri come livelli
2.6. Apri posizione
2.7. Apri recenti
2.8. Salva
2.9. Salva come
2.10. Salva una copia
2.11. Ricarica
2.12. Esporta
2.13. Esporta come...
2.14. Crea un modello
2.15. Stampa
2.16. Chiudi
2.17. Chiudi tutto
2.18. Esci
3. Il menu «Modifica»
3.1. Le voci del menu «modifica»
3.2. Annulla
3.3. Ripeti
3.4. Sfuma
3.5. Cronologia annullamenti
3.6. Taglia
3.7. Copia
3.8. Copia il visibile
3.9. Incolla
3.10. Incolla dentro
3.11. Incolla come
3.12. Buffer
3.13. Cancella
3.14. Riempi con il colore di primopiano
3.15. Riempi con il colore di sfondo
3.16. Riempi con il motivo
3.17. Delinea selezione
3.18. Delinea tracciato
3.19. Il comando «preferenze»
3.20. Tasti scorciatoia
3.21. Moduli
3.22. Unità
4. Il menu «Seleziona»
4.1. Introduzione al menu «Seleziona»
4.2. Tutto
4.3. Niente
4.4. Inverti
4.5. Fluttuante
4.6. Per colore
4.7. Dal tracciato
4.8. Editor della selezione
4.9. Sfumata
4.10. Definita
4.11. Riduci
4.12. Allarga
4.13. Bordo
4.14. Distorci
4.15. Rettangolo arrotondato
4.16. Commuta maschera veloce
4.17. Salva nel canale
4.18. A tracciato
5. Il menu «Visualizza»
5.1. Introduzione al menu«Visualizza»
5.2. Nuova vista
5.3. Punto per punto
5.4. Zoom
5.5. Adatta la finestra all'immagine
5.6. A tutto schermo
5.7. Finestra di navigazione
5.8. Mostra filtri
5.9. Selezione
5.10. Limiti del livello
5.11. Mostra le guide
5.12. Mostra la griglia
5.13. Punti di campionamento
5.14. Guide magnetiche
5.15. Griglia magnetica
5.16. Superficie magnetica
5.17. Tracciato attivo magnetico
5.18. Colore di riempimento
5.19. Barra dei menu
5.20. Righelli
5.21. Mostra le barre di scorrimento
5.22. Barra di stato
6. Il menu «Immagine»
6.1. Panoramica
6.2. Duplica
6.3. Modalità
6.4. Modalità RGB
6.5. Modalità a scala di grigi
6.6. Modalità indicizzata
6.7. Trasforma
6.8. Rifletti orizzontalmente; Rifletti verticalmente
6.9. Rotazione
6.10. Ghigliottina
6.11. Dimensione superficie
6.12. Imposta la superficie ai livelli
6.13. Imposta la superficie alla selezione
6.14. Dimensione di stampa
6.15. Scala immagine
6.16. Ritaglia immagine
6.17. Autoritaglio immagine
6.18. Ritaglio preciso
6.19. Fondi livelli visibili
6.20. Appiattisci immagine
6.21. Allinea livelli visibili
6.22. Guide
6.23. Nuova guida
6.24. Nuova guida (in percentuale)
6.25. Nuove guide dalla selezione
6.26. Rimuovi tutte le guide
6.27. Configura griglia
6.28. Proprietà dell'immagine
7. Il menu «Livello»
7.1. Introduzione al menu «Livello»
7.2. Nuovo livello
7.3. Nuovo gruppo di livelli
7.4. Nuovo dal visibile
7.5. Duplica livello
7.6. Àncora livello
7.7. Fondi in basso
7.8. Elimina livello
7.9. I comandi testo del menu Livelli
7.10. Abbandona informazioni sul testo
7.11. Sottomenu «Pila»
7.12. Seleziona il livello precedente
7.13. Seleziona il livello successivo
7.14. Seleziona il livello in cima
7.15. Seleziona il livello di fondo
7.16. Alza il livello
7.17. Abbassa il livello
7.18. Alza il livello fino in cima
7.19. Abbassa il livello fino in fondo
7.20. Il comando «inverti l'ordine dei livelli»
7.21. Il sottomenu «maschera»
7.22. Aggiungi maschera di livello
7.23. Applica maschera di livello
7.24. Elimina maschera di livello
7.25. Mostra maschera di livello
7.26. Modifica maschera di livello
7.27. Disabilita maschera di livello
7.28. Maschera a selezione
7.29. Aggiungi la maschera di livello alla selezione
7.30. Sottrai la maschera di livello dalla selezione
7.31. Interseca la maschera di livello con la selezione
7.32. Il sottomenu «Trasparenza» del menu «Livello»
7.33. Aggiungi canale alfa
7.34. Rimuovi canale alfa
7.35. Colore ad alfa
7.36. Semi-appiattisci
7.37. Soglia alfa
7.38. Alfa a selezione
7.39. Aggiungi il canale alfa alla selezione
7.40. Sottrai dalla selezione
7.41. Interseca il canale alfa con la selezione
7.42. Il sottomenu «Trasforma»
7.43. Rifletti orizzontalmente
7.44. Rifletti verticalmente
7.45. Ruota di 90° in senso orario
7.46. Ruota di 90° in senso antioriario
7.47. Ruota di 180°
7.48. Rotazione arbitraria
7.49. Scostamento
7.50. Dimensione margini del livello
7.51. Livello a dimensione immagine
7.52. Scala livello
7.53. Ritaglia livello
7.54. Autoritaglio livello
8. Il menu «Colori»
8.1. Introduzione al menu «Colori»
8.2. Strumenti di colore
8.3. Inverti
8.4. Inverti valore
8.5. Usa GEGL
8.6. Il sottomenu «Auto»
8.7. Equalizza
8.8. Bilanciamento del bianco
8.9. Aumento del colore
8.10. Normalizza
8.11. Ampliamento contrasto
8.12. Ampliamento HSV
8.13. Il sottomenu «Componenti»
8.14. Mixer canali
8.15. Componi
8.16. Scomponi
8.17. Ricomponi
8.18. Il sottomenu «mappa»
8.19. Reimposta la mappa colori
8.20. Imposta mappa colori
8.21. Mappa aliena
8.22. Scambio colore
8.23. Mappa gradiente
8.24. Mappa tavolozza
8.25. Ruota colori
8.26. Colorazione a campione
8.27. Il sottomenu «Info»
8.28. Istogramma
8.29. Media del bordo
8.30. Analisi cubocolori
8.31. Sfuma tavolozza
8.32. I filtri colore
8.33. Colorazione
8.34. Colore ad alfa
8.35. Blocco filtri
8.36. Bollenti
8.37. RGB massimo
8.38. Retinex
9. Il menu «Strumenti»
9.1. Introduzione al menu «Strumenti»
10. Il menu «Filtri»
10.1. Introduzione al menu «Filtri»
10.2. Ripeti l'ultimo
10.3. Ri-mostra l'ultima
10.4. Reimposta tutti i filtri
10.5. Il sottomenu «Python-Fu»
10.6. Il sottomenu «Script-Fu»
11. Il menu «Finestre»
12. Il menu «Aiuto»
12.1. Introduzione al menu «Aiuto»
12.2. Aiuto
12.3. Contenuti dell'aiuto
12.4. Suggerimenti del giorno
12.5. Informazioni
12.6. Navigatore Plug-In
12.7. Il navigatore delle procedure
12.8. GIMP online
17. Filtri
1. Introduzione
1.1. Anteprima
2. Filtri di sfocatura
2.1. Introduzione ai filtri di sfocatura
2.2. Sfocatura
2.3. Sfocatura gaussiana
2.4. Sfocatura gaussiana selettiva
2.5. Sfumatura movimento
2.6. Effetto pixel
2.7. Sfocatura piastrellabile
3. Filtri di miglioramento
3.1. Introduzione
3.2. Antialias
3.3. Deinterlaccia
3.4. Smacchiatura
3.5. Destriscia
3.6. Filtro NL
3.7. Rimozione occhi rossi
3.8. Affilatura
3.9. Maschera di contrasto
4. Filtri di distorsione
4.1. Introduzione ai filtri di distorsione
4.2. Strisce
4.3. Piega curva
4.4. Rilievo
4.5. Incisione
4.6. Cancella ogni altra riga
4.7. IWarping
4.8. Distorsione lente
4.9. Mosaico
4.10. Effetto giornale
4.11. Pagina arricciata
4.12. Coordinate polari
4.13. Increspature
4.14. Spostamento
4.15. Propagazione valore
4.16. Video
4.17. Onde
4.18. Vortice e pizzico
4.19. Vento
5. Filtri luce e ombra
5.1. Introduzione
5.2. Chiarore a gradiente
5.3. Riflesso lenti
5.4. Effetti luce
5.5. Scintillio
5.6. Supernova
5.7. Proietta ombra
5.8. Prospettiva
5.9. Effetto xach
5.10. Applica lente
5.11. Piastrelle di vetro
6. Filtri di disturbo
6.1. Introduzione ai filtri di disturbo
6.2. Disturbo HSV
6.3. Casuale
6.4. Prelievo
6.5. Disturbo RGB
6.6. Macchia
6.7. Diffusione
7. Filtri di rilevamento contorni
7.1. Introduzione
7.2. Differenza di gaussiane
7.3. Contorni
7.4. Laplace
7.5. Neon
7.6. Sobel
8. Filtri generici
8.1. Introduzione
8.2. Matrice di convoluzione
8.3. Dilata
8.4. Erodi
9. Filtri di combinazione
9.1. Introduzione
9.2. Fusione profonda
9.3. Pellicola
10. Filtri artistici
10.1. Introduzione
10.2. Applica tela
10.3. Fumetto
10.4. Drappeggia
10.5. Cubismo
10.6. GIMPressionista
10.7. Pittura ad olio
10.8. Fotocopia
10.9. Predator
10.10. Chiarore sfumato
10.11. Van Gogh (LIC)
10.12. Onda
11. Decorazioni
11.1. Introduzione
11.2. Porta in rilievo
11.3. Aggiungi bordo
11.4. Macchie di caffè
11.5. Bordo frastagliato
11.6. Vecchia foto
11.7. Angoli arrotondati
11.8. Diapositive
11.9. Scolpitura
11.10. Cromatura scolpita
12. Filtri mappa
12.1. Introduzione ai filtri mappa
12.2. Mappa a sbalzo
12.3. Sposta
12.4. Traccia frattale
12.5. Illusione
12.6. Rendi senza giunzioni
12.7. Mappa su oggetto
12.8. Fogli di carta
12.9. Piastrelle piccole
12.10. Piastrella
12.11. Warp
13. Filtri Render
13.1. Introduzione
13.2. Nuvole a differenza
13.3. Nebbia
13.4. Plasma
13.5. Disturbo pieno
13.6. Fiamme
13.7. Frattale IFS
13.8. Scacchiera
13.9. Esploratore CML
13.10. Motivi di diffrazione
13.11. Griglia
13.12. Puzzle
13.13. Labirinto
13.14. QBista
13.15. Seno
13.16. Circuito
13.17. Esploratore frattali
13.18. Gfig
13.19. Lava
13.20. Linea Nova
13.21. Designer sfera
13.22. Spirografo
14. Filtri Web
14.1. Introduzione
14.2. Mappaimmagine
14.3. Semi-appiattisci
14.4. Affetta
15. Filtri di animazione
15.1. Introduzione
15.2. Sfuma
15.3. Burn-In
15.4. Ondine
15.5. Globo che gira
15.6. Onde
15.7. Ottimizza
15.8. Esecuzione
16. Filtri alfa a logotipo
16.1. Introduzione
16.2. Profilo 3D
16.3. Bagliore alieno
16.4. Neon alieno
16.5. Di base I & II
16.6. Sfumato
16.7. Bovinazione
16.8. Gesso
16.9. Scheggia
16.10. Cromato
16.11. Fumetto
16.12. Metallo freddo
16.13. Congelato
16.14. Lucida
16.15. Incandescenza
16.16. Gradiente sfumato
16.17. Neon
16.18. Traccia di particella
16.19. Tessuto
I. Indice di riferimento tasti
Aiuto — Elenco tasti per il menu Aiuto
Strumenti — Elenco tasti per il menu Strumenti
File — Elenco tasti per il menu File
Finestre di dialogo — Elenco tasti per il sottomenu Pannelli agganciabili
Visualizza — Elenco tasti per il menu Visualizza
Modifica — Elenco tasti per il menu Modifica
Livello — Elenco tasti per il menu Livello
Seleziona — Elenco tasti per il menu Seleziona
Filtri — Elenco tasti per il menu Filtri
Strumento Zoom — Elenco tasti per il sottomenu Zoom
Glossario
Bibliografia
A. La storia di GIMP
1. I primordi
2. I primi giorni di GIMP
3. L'uno per cambiare il mondo
4. La versione 2.0
5. Cosa c'è di nuovo in GIMP 2.2?
6. Cosa c'è di nuovo in GIMP 2.4?
7. Cosa c'è di nuovo in GIMP 2.6?
B. Segnalazione difetti e richieste di miglioramenti
1. Accertarsi che sia un difetto
2. Segnalare un difetto
3. Cosa succede alla segnalazione dopo la spedizione
C. Licenza di documentazione libera del progetto GNU
1. PREAMBOLO
2. APPLICABILITÀ E DEFINIZIONI
3. COPIE LETTERALI
4. COPIARE IN NOTEVOLI QUANTITÀ
5. MODIFICHE
6. COMBINAZIONE DI DOCUMENTI
7. RACCOLTE DI DOCUMENTI
8. AGGREGAZIONE A LAVORI INDIPENDENTI
9. TRADUZIONE
10. CESSAZIONE DELLA LICENZA
11. REVISIONI FUTURE DI QUESTA LICENZA
12. APPENDICE: Come usare questa licenza per i vostri documenti
D. Oops! Manca un file di aiuto!
Indice analitico