GIMP - GNU 图像处理程序

用户手册

法律提示

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section enphrased GNU Free Documentation License.


目录

前言
1. GIMP 用户手册作者及贡献者
I. 开始使用 GIMP
1. 简介
1. 欢迎使用 GIMP
1.1. 作者
1.2. GIMP 帮助系统
1.3. 特性和功能
2. What's New in GIMP 2.8?
2. Fire up the GIMP
1. Running GIMP
1.1. Known Platforms
1.2. Language
1.3. Command Line Arguments
2. Starting GIMP the first time
2.1. Finally . . .
3. First Steps with Wilber
1. Basic Concepts
2. Main Windows
2.1. The Toolbox
2.2. Image Window
2.3. Dialogs and Docking
3. Undoing
3.1. 不可撤销的操作
4. Common Tasks
4.1. Intention
4.2. Change the Size of an Image for the screen
4.3. Change the Size of an Image for print
4.4. Compressing Images
4.5. Crop An Image
4.6. Find Info About Your Image
4.7. Change the Mode
4.8. Flip An Image
4.9. Rotate An Image
4.10. Separating an Object From Its Background
5. How to Draw Straight Lines
5.1. Intention
5.2. Examples
4. Getting Unstuck
1. Getting Unstuck
1.1. Stuck!
1.2. Common Causes of GIMP Non-Responsiveness
II. How do I Become a GIMP Wizard?
5. Getting Images into GIMP
1. Image Types
2. Creating new Files
3. Opening Files
3.1. Open File
3.2. Open Location
3.3. Open Recent
3.4. Using External Programs
3.5. File Manager
3.6. Drag and Drop
3.7. Copy and Paste
3.8. Image Browser
6. Getting Images out of GIMP
1. Files
1.1. Save / Export Images
1.2. File Formats
2. Preparing your Images for the Web
2.1. Images with an Optimal Size/Quality Ratio
2.2. Reducing the File Size Even More
2.3. Saving Images with Transparency
7. Painting with GIMP
1. 选区
1.1. Feathering
1.2. Making a Selection Partially Transparent
2. Creating and Using Selections
2.1. Moving a Selection
2.2. Adding or subtracting selections
3. The QuickMask
3.1. 预览
3.2. 属性
4. Using QuickMask Mode
5. Paths
5.1. Path Creation
5.2. Path Properties
5.3. Paths and Selections
5.4. Transforming Paths
5.5. Stroking a Path
5.6. Paths and Text
5.7. Paths and SVG files
6. Brushes
7. Adding New Brushes
8. The GIH Dialog Box
9. Varying brush size
9.1. How to vary the height of a brush
9.2. Creating a brush quickly
10. Gradients
11. Patterns
12. Palettes
12.1. Colormap
13. Presets
14. Drawing Simple Objects
14.1. Drawing a Straight Line
14.2. Creating a Basic Shape
8. 合并图像
1. Introduction to Layers
1.1. Layer Properties
2. Layer Modes
3. Creating New Layers
4. Layer Groups
9. Text Management
1. Text Management
2. Text Tool Box
2.1. Text Tool Box Context menu
3. Text
3.1. Embellishing Text
3.2. Adding Fonts
3.3. Font Problems
10. Enhancing Photographs
1. Working with Digital Camera Photos
1.1. Introduction
1.2. Improving Composition
1.3. Improving Colors
1.4. Adjusting Sharpness
1.5. Removing Unwanted Objects from an Image
1.6. Saving Your Results
11. Color Management with GIMP
1. Color Management in GIMP
1.1. Problems of a non Color Managed Workflow
1.2. Introduction to a Color Managed Workflow
12. Enrich my GIMP
1. Preferences Dialog
1.1. Introduction
1.2. Environment
1.3. Interface
1.4. Theme
1.5. Help System
1.6. Tool Options
1.7. Toolbox
1.8. Default Image Preferences
1.9. Default Image Grid
1.10. Image Windows
1.11. Image Window Appearance
1.12. Image Window Title and Statusbar
1.13. Display
1.14. Color Management
1.15. Input Devices
1.16. Input Controllers
1.17. Window Management
1.18. Folders
1.19. Data Folders
2. Grids and Guides
2.1. The Image Grid
2.2. Guides
3. Rendering a Grid
4. How to Set Your Tile Cache
5. Creating Shortcuts to Menu Functions
6. Customize Splash-Screen
13. Scripting
1. 插件
1.1. 简介
1.2. 使用插件
1.3. Installing New Plugins
1.4. 编写插件
2. 使用 Script-Fu 脚本
2.1. Script-Fu?
2.2. Installing Script-Fus
2.3. Do's and Don'ts
2.4. 两种不同的 Script-Fu
2.5. 独立脚本
2.6. 基于图像的脚步
3. A Script-Fu Tutorial
3.1. Getting Acquainted With Scheme
3.2. Variables And Functions
3.3. Lists, Lists And More Lists
3.4. Your First Script-Fu Script
3.5. Giving Our Script Some Guts
3.6. Extending The Text Box Script
3.7. Your script and its working
III. 函数参考
14. 工具
1. The Toolbox
1.1. Introduction
1.2. Tool Icons
1.3. Color and Indicator Area
1.4. Tool Options
2. Selection Tools
2.1. Common Features
2.2. Rectangle Selection
2.3. Ellipse Selection
2.4. Free Selection (Lasso)
2.5. Fuzzy selection (Magic wand)
2.6. Select By Color
2.7. Intelligent Scissors
2.8. 前景选择
3. Paint Tools
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. 油漆桶填充
3.5. 混合填充
3.6. 铅笔
3.7. 画笔
3.8. 橡皮
3.9. 喷枪
3.10. 墨水
3.11. 克隆
3.12. 复原
3.13. 透视克隆
3.14. Blur/Sharpen
3.15. 涂抹
3.16. 减淡/加深
4. Transform Tools
4.1. Common Features
4.2. 对齐
4.3. 移动
4.4. 剪裁
4.5. 旋转
4.6. 缩放
4.7. 切变
4.8. 透视
4.9. 翻转
4.10. The Cage Tool
5. Color Tools
5.1. Overview
5.2. 色彩平衡
5.3. 色调-饱和度
5.4. 单色化
5.5. 亮度-对比度
5.6. 阈值
5.7. 色阶
5.8. 曲线
5.9. 色调分离
5.10. 去色
6. Other
6.1. Overview
6.2. Paths
6.3. Color Picker
6.4. Zoom
6.5. Measure
6.6. Text
6.7. GEGL Operation
15. 对话框
1. Dialog Introduction
2. Image Structure Related Dialogs
2.1. Layers Dialog
2.2. Channels Dialog
2.3. Paths Dialog
2.4. Colormap Dialog
2.5. Histogram dialog
2.6. Navigation Dialog
2.7. Undo History Dialog
3. Image-content Related Dialogs
3.1. FG/BG Color Dialog
3.2. Brushes Dialog
3.3. Patterns Dialog
3.4. Gradients Dialog
3.5. Palettes Dialog
3.6. Tagging
3.7. Fonts Dialog
4. Image Management Related Dialogs
4.1. Buffers Dialog
4.2. Images Dialog
4.3. Document History Dialog
4.4. Templates Dialog
5. Misc. Dialogs
5.1. Tool Presets Dialog
5.2. Tool Preset Editor
5.3. Device Status Dialog
5.4. Error Console
5.5. Save File
5.6. Export File
5.7. Sample Points Dialog
5.8. Pointer Dialog
16. 菜单
1. Introduction to Menus
1.1. The Image Menu Bar
1.2. Context Menus
1.3. Tear-off menus
1.4. Tab menus
2. 文件菜单
2.1. Overview
2.2. New
2.3. Create
2.4. Open
2.5. Open as Layers
2.6. Open Location
2.7. Open Recent
2.8. 保存
2.9. Save as
2.10. Save a Copy
2.11. Revert
2.12. Export
2.13. Export As...
2.14. Create Template
2.15. Print
2.16. Close
2.17. Close all
2.18. Quit
3. 编辑菜单
3.1. Edit Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into
3.11. Paste as
3.12. Buffer
3.13. Clear
3.14. Fill with FG Color
3.15. Fill with BG Color
3.16. Fill with Pattern
3.17. Stroke Selection
3.18. Stroke Path
3.19. The Preferences Command
3.20. Keyboard Shortcuts
3.21. Modules
3.22. Units
4. The Select Menu
4.1. Introduction to the Select Menu
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Distort
4.15. Rounded Rectangle
4.16. Toggle QuickMask
4.17. Save to Channel
4.18. To Path
5. The View Menu
5.1. Introduction to the View Menu
5.2. New View
5.3. Dot for Dot
5.4. Zoom
5.5. Shrink Wrap
5.6. Full Screen
5.7. Navigation Window
5.8. Display Filters
5.9. Show Selection
5.10. Show Layer Boundary
5.11. Show Guides
5.12. Show Grid
5.13. Show Sample Points
5.14. Snap to Guides
5.15. Snap to Grid
5.16. Snap to Canvas
5.17. Snap to Active Path
5.18. Padding Color
5.19. Show Menubar
5.20. Show Rulers
5.21. Show Scrollbars
5.22. Show Statusbar
6. The Image Menu
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Transform
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Guillotine
6.11. Canvas Size
6.12. Fit Canvas to Layers
6.13. Fit Canvas to Selection
6.14. Print Size
6.15. Scale Image
6.16. Crop to Selection
6.17. Autocrop Image
6.18. Zealous Crop
6.19. Merge Visible Layers
6.20. Flatten Image
6.21. Align Visible Layers
6.22. Guides
6.23. New Guide
6.24. New Guide (by Percent)
6.25. New Guides from Selection
6.26. Remove all guides
6.27. Configure Grid
6.28. Image Properties
7. The Layer Menu
7.1. Introduction to the Layer Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop to Selection
7.54. Autocrop Layer
8. The Colors Menu
8.1. Introduction to the Colors Menu
8.2. Colors Tools
8.3. Invert
8.4. Value Invert
8.5. Use GEGL
8.6. The Auto Submenu
8.7. Equalize
8.8. White Balance
8.9. Color Enhance
8.10. Normalize
8.11. Stretch Contrast
8.12. Stretch HSV
8.13. The Components Submenu
8.14. Channel Mixer
8.15. 组合
8.16. 分解
8.17. Recompose
8.18. The Map Submenu
8.19. Rearrange Colormap
8.20. Set Colormap
8.21. Alien Map
8.22. Color Exchange
8.23. Gradient Map
8.24. Palette Map
8.25. Rotate Colors
8.26. Sample Colorize
8.27. The Info Submenu
8.28. Histogram
8.29. Border Average
8.30. Colorcube Analysis
8.31. Smooth Palette
8.32. The Color Filters
8.33. Colorify
8.34. Color to Alpha
8.35. Filter Pack
8.36. Hot
8.37. Max RGB
8.38. Retinex
9. The Tools Menu
9.1. Introduction to the Tools Menu
10. The Filters Menu
10.1. Introduction to the Filters Menu
10.2. 重复上次
10.3. Re-show Last
10.4. 重置所有滤镜
10.5. The Python-Fu Submenu
10.6. The Script-Fu Submenu
11. Windows Menu
12. 帮助菜单
12.1. 帮助菜单简介
12.2. 帮助
12.3. Context Help
12.4. 每日提醒
12.5. 关于
12.6. 插件浏览器
12.7. The Procedure Browser
12.8. GIMP online
17. 虑镜
1. 介绍
1.1. 预览
2. 模糊滤镜
2.1. Introduction
2.2. Blur
2.3. Gaussian Blur
2.4. Selective Gaussian Blur
2.5. Motion Blur
2.6. Pixelise
2.7. Tileable Blur
3. 增强滤镜
3.1. Introduction
3.2. Antialias
3.3. Deinterlace
3.4. Despeckle
3.5. Destripe
3.6. NL Filter
3.7. Red Eye Removal
3.8. Sharpen
3.9. Unsharp Mask
4. 扭曲滤镜
4.1. Introduction
4.2. Blinds
4.3. Curve Bend
4.4. Emboss
4.5. Engrave
4.6. Erase Every Other Row
4.7. IWarp
4.8. Lens Distortion
4.9. Mosaic
4.10. Newsprint
4.11. Page Curl
4.12. Polar Coords
4.13. Ripple
4.14. Shift
4.15. Value Propagate
4.16. Video
4.17. Waves
4.18. Whirl and Pinch
4.19. Wind
5. 光照和阴影滤镜
5.1. Introduction
5.2. Gradient Flare
5.3. Lens Flare
5.4. Lighting Effects
5.5. Sparkle
5.6. Supernova
5.7. Drop Shadow
5.8. Perspective
5.9. Xach-Effect
5.10. Apply Lens
5.11. Glass Tile
6. 噪音滤镜
6.1. Introduction
6.2. HSV Noise
6.3. Hurl
6.4. Pick
6.5. RGB Noise
6.6. Slur
6.7. Spread
7. 边缘侦测滤镜
7.1. Introduction
7.2. Difference of Gaussians
7.3. Edge
7.4. Laplace
7.5. Neon
7.6. Sobel
8. 通用滤镜
8.1. Introduction
8.2. Convolution Matrix
8.3. Dilate
8.4. Erode
9. 组合滤镜
9.1. Introduction
9.2. Depth Merge
9.3. Film
10. 艺术滤镜
10.1. Introduction
10.2. Apply Canvas
10.3. Cartoon
10.4. Clothify
10.5. Cubism
10.6. GIMPressionist
10.7. Oilify
10.8. Photocopy
10.9. Predator
10.10. Softglow
10.11. Van Gogh (LIC)
10.12. Weave
11. 装饰滤镜
11.1. Introduction
11.2. Add Bevel
11.3. Add Border
11.4. Coffee Stain
11.5. Fuzzy Border
11.6. Old Photo
11.7. Round Corners
11.8. Slide
11.9. Stencil Carve
11.10. Stencil Chrome
12. 映射滤镜
12.1. Introduction
12.2. Bump Map
12.3. Displace
12.4. Fractal Trace
12.5. Illusion
12.6. Make Seamless
12.7. Map Object
12.8. Paper Tile
12.9. Small Tiles
12.10. Tile
12.11. Warp
13. 渲染滤镜
13.1. Introduction
13.2. Difference Clouds
13.3. Fog
13.4. Plasma
13.5. Solid Noise
13.6. Flame
13.7. IFS Fractal
13.8. Checkerboard
13.9. CML Explorer
13.10. Diffraction Patterns
13.11. Grid
13.12. Jigsaw
13.13. Maze
13.14. Qbist
13.15. Sinus
13.16. Circuit
13.17. Fractal Explorer
13.18. Gfig
13.19. Lava
13.20. Line Nova
13.21. Sphere Designer
13.22. Spyrogimp
14. Web 滤镜
14.1. 介绍
14.2. ImageMap
14.3. Semi-Flatten
14.4. Slice
15. 卡通滤镜
15.1. 介绍
15.2. Blend
15.3. Burn-In
15.4. Rippling
15.5. Spinning Globe
15.6. Waves
15.7. Optimize
15.8. Playback
16. 对 Alpha 应用 Logo
16.1. Introduction
16.2. 3D Outline
16.3. Alien Glow
16.4. Alien Neon
16.5. Basic I & II
16.6. Blended
16.7. Bovination
16.8. Chalk
16.9. Chip Away
16.10. Chrome
16.11. Comic Book
16.12. Cool Metal
16.13. Frosty
16.14. Glossy
16.15. Glowing Hot
16.16. Gradient Bevel
16.17. Neon
16.18. Particle Trace
16.19. Textured
I. 键盘鼠标操作参考
帮助 — Key reference for Help menu
工具 — Key reference for the Tools menu
文件 — Key reference for the File menu
对话框 — Key reference for Dockable Dialogs submenu
查看 — Key reference for View menu
编辑 — Key reference for Edit menu
Layer — Key reference for Layer menu
Select — Key reference for Select menu
虑镜 — Key reference for Filters menu
缩放工具 — Key reference for the Zoom tool submenu
术语表
参考文献
A. GIMP 历史
1. 最开始
2. 早期的 GIMP
3. 改变世界之一
4. 2.0 版
5. GIMP 2.2 的新功能
6. GIMP 2.4 的新功能
7. GIMP 2.6 的新特性
B. 提交错误报告和请求改进
1. 确定它的确是个 BUG
2. 提交 BUG
3. 提交 BUG 之后会发生什么
C. GNU 自由文本授权
1. 导言
2. 效力与定义
3. 逐字的复制
4. 大量地复制
5. 修改
6. 组合文件
7. 文件的收集
8. 独立作品的聚集
9. 翻译
10. 终止
11. 本授权的未来改版
12. 授权附录:如何使用本授权用于你的文件
D. 哎呀!少了帮助
索引