2.5. Zauberstab

Abbildung 14.22. Der Zauberstab im Werkzeugfenster

Der Zauberstab im Werkzeugfenster

Das Werkzeug »Zauberstab« (»unscharfe« Auswahl) ermöglicht es Ihnen, eine Auswahl auf der Basis von Bereichen eines Bildes oder der aktuellen Ebene mit ähnlichen Farbwerten zu erstellen.

Wenn Sie den Zauberstab verwenden, ist es besonders wichtig, den richtigen Anfangspunkt zu wählen. Andernfalls können Sie leicht etwas ganz anderes (möglicherweise sogar genau das Gegenteil) als gewünscht erhalten.

Der Zauberstab ist sehr gut geeignet, um eine Auswahl aus Bildteilen zu erstellen, welche durch starke Kanten von ihrer Umgebung abgegrenzt sind. Es macht Spaß, den Zauberstab zu benutzen, daher arbeiten gerade GIMP-Einsteiger sehr viel mit ihm. Wenn Sie eine Weile den Zauberstab verwendet haben, kann es allerdings passieren, dass Sie es als eher schwierig empfinden, damit exakt den Bereich auszuwählen, den Sie wollen – weder mehr, noch weniger. Erfahrenere Anwender empfinden daher die Arbeit mit den Werkzeugen Pfad oder Nach Farbe auswählen als wesentlich effizienter und verwenden den Zauberstab deutlich seltener. Trotzdem ist der Zauberstab sehr nützlich, wenn es darum geht, einen Bereich des Bildes auszuwählen, der von einer Kontur begrenzt wird. Er funktioniert auch sehr gut, um einen (nahezu) einfarbigen Hintergrund auszuwählen.

Bitte beachten Sie, dass der ausgewählte Bereich nicht nur Pixel umfasst, die direkt mit dem Startpunkt verbunden sind. Der Zauberstab ist auch in der Lage, kleine Lücken zu überspringen. Die Größe dieser Lücken lässt sich mit der Eigenschaft Schwellwert anpassen. Um den Schwellwert bei der Verwendung des Zauberstabs zu vergrößern oder verkleinern, ziehen Sie nach dem ersten Mausklick den Mauszeiger nach unten oder rechts, beziehungsweise nach oben oder links.

2.5.1. Werkzeugaufruf

Sie haben verschiedene Möglichkeiten, das Werkzeug »Zauberstab« zu aktivieren:

  • Über das Menü WerkzeugeAuswahlwerkzeugeZauberstab im Bildfenster,

  • mit einem Mausklick auf das Symbol im Werkzeugfenster,

  • über das Tastenkürzel U.

2.5.2. Zusatztasten (Voreinstellungen)

Der Zauberstab hat keine speziellen Tastenkombinationen. Die allgemeinen Tastenkombinationen für Auswahlwerkzeuge stehen Ihnen aber zur Verfügung.

2.5.3. Das Werkzeug benutzen

Abbildung 14.23. Den Zauberstab benutzen: Die ausgewählten Pixel sind zusammenhängend

Den Zauberstab benutzen: Die ausgewählten Pixel sind zusammenhängend

Eine Auswahl wird erstellt, sobald Sie einen Bereich des Bildes anklicken. Sie vergrößert sich ausgehend von dem von Ihnen gewählten Punkt, als würden Sie Wasser ausschütten, welches über alle Bereiche mit gleicher oder ähnlicher Farbe des Startpixels läuft. Sie können den Ähnlichkeits-Schwellwert durch Ziehen der Maus beeinflussen: Je weiter Sie die Maus nach unten oder rechts ziehen, desto größer wird der ausgewählte Bereich. Auf die gleiche Weise können Sie durch Ziehen nach oben oder links den ausgewählten Bereich verkleinern.

Sie können den Umriss der Auswahl über Alt + Pfeiltasten verschieben.

2.5.4. Eigenschaften

Abbildung 14.24. Eigenschaften des Werkzeugs »Zauberstab«

Eigenschaften des Werkzeugs »Zauberstab«

Normalerweise werden die aktuellen Einstellungen eines Werkzeugs unterhalb des Werkzeugkastens angezeigt, sobald Sie ein Werkzeug aktivieren. Falls das nicht der Fall ist, können Sie sie jederzeit über FensterAndockbare DialogeWerkzeugeinstellungen im Bildfenster aktivieren.

[Anmerkung] Anmerkung

Schauen sie bitte unter Auswahlwerkzeuge nach, falls Sie Hilfe zu den allgemeinen Eigenschaften der Auswahlwerkzeuge benötigen.

Modus; Kanten glätten; Kanten ausblenden

Allgemeine Auswahleigenschaften.

Ähnliche Farben finden

Diese Eigenschaften beeinflussen die Art und Weise, wie der Zauberstab ausgehend vom Startpunkt die Auswahl erzeugt.

Transparente Bereiche auswählen

Wenn Sie diese Eigenschaft aktivieren, lassen sich mit dem Zauberstab auch transparente Bereiche auswählen. Andernfalls lassen sich transparente Bereiche mit dem Zauberstab nicht auswählen.

Vereinigung prüfen

Diese Eigenschaft wird wichtig, wenn das Bild mehrere Ebenen hat und die aktiven Ebene entweder halb durchsichtig ist oder einen anderen Modus hat als »Normal«. In einem solchen Fall unterscheiden sich die Farben in der aktiven Eben von denen des Gesamtbildes. Wenn die Eigenschaft Vereinigung prüfen ausgeschaltet ist, reagiert der Zauberstab ausschließlich auf die Farben in der aktiven Ebene. Wenn Sie eingeschaltet ist, werden in die Erstellung der Auswahl die Farben aller sichtbaren Ebenen einbezogen. Weitere Informationen finden Sie unter Sample Merged .

Diagonale Nachbarn

Wenn eingeschaltet, betrachtet das Werkzeug bei der Auswahlerstellung auch diagonal benachbarte Pixel als zusammenhängend. Mit anderen Worten sieht es sich nicht nur die vier senkrechten Nachbarn eines Pixels an, sondern alle acht Pixel.

Abbildung 14.25. Beispiel für diagonale Nachbarn

Beispiel für diagonale Nachbarn

Ein Pixel mit 4 senkrechten Nachbarn

Beispiel für diagonale Nachbarn

Ein Pixel mit 4 diagonalen Nachbarn

Beispiel für diagonale Nachbarn

Ein Pixel mit 8 Nachbarn


Abbildung 14.26. Beispiel für die Verwendung der Eigenschaft »Diagonale Nachbarn«

Beispiel für die Verwendung der Eigenschaft »Diagonale Nachbarn«

»Diagonale Nachbarn« ausgeschaltet

Beispiel für die Verwendung der Eigenschaft »Diagonale Nachbarn«

»Diagonale Nachbarn« eingeschaltet


Schwellwert

Mit diesem Schieberegler lässt sich die Empfindlichkeit des Zauberstabs zum Zeitpunkt steuern, wenn Sie auf den Startpunkt klicken: Je höher der Schwellwert, desto größer ist die Auswahl. Nach dem ersten Mausklick können Sie den Mauszeiger nach unten oder rechts ziehen, um den Schwellwert zu erhöhen, und nach oben oder links ziehen, um ihn zu verringern. Dadurch können Sie also die gleichen Ergebnisse unabhängig von der Schwellwert-Einstellung erhöhen. Allerdings müssen Sie unter Umständen weniger ziehen, um das gewünschte Ergebnis zu erhalten.

Auswahl nach

Mit dieser Eigenschaft legen Sie fest, welche Komponente des Bildes von GIMP zur Berechnung der Ähnlichkeit verwendet wird.

Die Komponenten, welche hier zur Auswahl stehen, umfassen Rot, Grün, Blau, Farbton, Sättigung und Wert.

Maske zeichnen

Diese Eigenschaft ist nur eine Hilfe zur Auswahl. Mit »marschierenden Ameisen« gekennzeichnete Auswahlen sind unter Umständen nicht erkennbar, wenn Sie die Werkzeuge »Freie Auswahl« oder »Zauberstab« verwenden. Wenn diese Eigenschaft eingeschaltet ist, werden ausgewählte Bereiche mit einer Magenta-Farbe gefüllt, solange Sie die linke Maustaste gedrückt halten. Sobald Sie die Maustaste loslassen, verschwindet die Maske.

Abbildung 14.27. Beispiel für die Verwendung der Eigenschaft »Maske zeichnen«

Beispiel für die Verwendung der Eigenschaft »Maske zeichnen«

Zauberstab-Auswahl ohne »Maske zeichnen«

Beispiel für die Verwendung der Eigenschaft »Maske zeichnen«

Zauberstab-Auswahl mit »Maske zeichnen«. Die linke Maustaste wurde noch nicht losgelassen.